[SOLVED] Updated to Mint 14; some indicators missing

[SOLVED] Updated to Mint 14; some indicators missing

Postby giant-speck on Sun Nov 25, 2012 10:23 pm

I updated to Linux Mint 14 (MATE) this morning. I added Indicator Applet Complete to MATE Panel, but only the network and sound indicators appear.

Apparently, the indicator-datetime-gtk2, indicator-session-gtk2, and indicator-messages-gtk2 packages required to make it work completely correctly have been dropped from the Universe repository in Quantal. I find it kind of strange that those were dropped, but indicator-application-gtk2 and indicator-sound-gtk2 remained in the repository.

Do you think reporting this as a bug for mate-indicator-applet would be appropriate? I know they don't maintain the above packages, but mate-indicator-applet uses those packages, so perhaps they could add them to the main MATE repository? :?
Last edited by giant-speck on Sat Dec 08, 2012 11:55 pm, edited 1 time in total.
giant-speck
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 14, 2008 12:41 am

Linux Mint is funded by ads and donations.
 

Re: Updated to Mint 14; some indicators missing

Postby giant-speck on Sat Dec 08, 2012 11:55 pm

I managed to solve this by finding all of the required packages on the [url="http://pkgs.org/search/?keyword=indicator"]Linux Packages Search[/url] website. It's a bit of a sloppy method, as it involves downloading and installing several DEBs. I don't know have the know-how, time, or patience to set up and maintain a repository, so if you are just as desperate as I was to get this working again, you can use this method.

CLICK HERE TO DOWNLOAD ALL OF THE REQUIRED PACKAGES (TAR.GZ / DROPBOX)

HIERARCHY OF DEPENDENCIES

Code: Select all
indicator-messages-gtk2 (=0.6.0)

    ↳ depends indicator-messages (=0.6.0)

        ↳ depends libindicator-messages-status-provider1 (>=0.4.92)

indicator-session-gtk2 (=0.3.96)

    ↳ depends indicator-session (=0.3.96)

indicator-datetime-gtk2 (=0.3.94)

    ↳ depends indicator-datetime (=0.3.94)

        ↳ depends libecal-1.2-10 (>=3.2.3)

            ↳ depends libedataserver-1.2-15 (=3.2.3)

        ↳ depends libedataserverui-3.0-1 (>=3.2.3)

            ↳ depends libcamel-1.2-33 (>=3.4)

            ↳ depends libebook-1.2-13 (>=3.4.4)

                ↳ depends libedataserver-1.2-16 (>=3.4.4)

            ↳ depends libecal-1.2-11 (>=3.4.4)

INSTALLING THE MESSAGES INDICATOR

Install the packages in the following order: libindicator-messages-status-provider1 ⇨ indicator-messages ⇨ indicator-messages-gtk2

INSTALLING THE SESSIONS INDICATOR

Install the packages in the following order: indicator-session ⇨ indicator-session-gtk2

INSTALLING THE DATETIME INDICATOR

Install the packages in the following order: libedataserver-1.2-16 ⇨ libebook-1.2-13
⇨ libecal-1.2-11 ⇨ libcamel-1.2-33 ⇨ libedataserverui-3.0-1 ⇨ libedataserver-1.2-15
⇨ libecal-1.2-10 ⇨ indicator-datetime ⇨ indicator-datetime-gtk2
.

Once all the required packages are installed, kill mate-panel. When it restarts, all of the indicators should be visible.

EDIT: Don't forget to lock the versions for indicator-session, indicator-datetime, and indicator-messages.
giant-speck
Level 1
Level 1
 
Posts: 3
Joined: Mon Jan 14, 2008 12:41 am


Return to MATE

Who is online

Users browsing this forum: No registered users and 6 guests