[Solved?] wireless no longer work after upgrading to Mint 14

Questions about WIFI networks and devices
Forum rules
Before you post please read this

[Solved?] wireless no longer work after upgrading to Mint 14

Postby N2PY.net on Sun Nov 25, 2012 10:41 pm

I was running Mint 13, and everything worked out of the box, total bliss.

I made a fresh install of Mint 14, and now everything works *except* wireless. I'm using a 5 year old MacBook (core 2 duo) with Mint 14/Cinnamon/64-bit. Mint 14 is the only thing on this laptop (it's not a bual boot). Here's the part of the inxi output that pertains to the Network. Additional diagnostic output in the first reply below.

Network: Card-1: Marvell 88E8058 PCI-E Gigabit Ethernet Controller driver: sky2
IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1b:63:b2:0d:17
Card-2: Broadcom BCM4321 802.11a/b/g/n driver: b43-pci-bridge
IF: N/A state: N/A mac: N/A

Wired networking seems to be functioning without any problems. For wireless, the system seems not to "see" my wireless card... I am unable to add networks, detect networks or otherwise configure any wireless settings (dialog boxes are all grayed out so that I am unable to put the curser in any of the fields to add data/save).

I'm seeing other folks mentioning wireless problems, but on a readthrough, they seem to have a different problem than I do.

Any ideas? Thanks in advance.

Brent
Last edited by N2PY.net on Tue Nov 27, 2012 1:52 pm, edited 3 times in total.
N2PY.net
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 12, 2012 9:46 pm

Linux Mint is funded by ads and donations.
 

Re: wireless no longer working after upgrading to Mint 14

Postby N2PY.net on Sun Nov 25, 2012 10:44 pm

brent@brent-macbook ~ $ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py

-------------------------
* I. scanning WIFI PCI devices...
-- Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)
==> PCI ID = 14e4:4328 (rev 03)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
eth0 no wireless extensions.

lo no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr 00:1b:63:b2:0d:17
inet addr:192.168.1.81 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21b:63ff:feb2:d17/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11265 errors:0 dropped:0 overruns:0 frame:0
TX packets:6356 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10050628 (10.0 MB) TX bytes:814454 (814.4 KB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:404 errors:0 dropped:0 overruns:0 frame:0
TX packets:404 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:41860 (41.8 KB) TX bytes:41860 (41.8 KB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
-------------------------
* VI. querying nslookup google.com...
Server: 192.168.1.254
Address: 192.168.1.254#53

Non-authoritative answer:
Name: google.com
Address: 74.125.140.102
Name: google.com
Address: 74.125.140.113
Name: google.com
Address: 74.125.140.138
Name: google.com
Address: 74.125.140.139
Name: google.com
Address: 74.125.140.100
Name: google.com
Address: 74.125.140.101
N2PY.net
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 12, 2012 9:46 pm

Re: wireless no longer working after upgrading to Mint 14

Postby fohrums on Mon Nov 26, 2012 8:27 pm

N2PY.net wrote:I was running Mint 13, and everything worked out of the box, total bliss.

I made a fresh install of Mint 14, and now everything works *except* wireless.

Mint 14 is the only thing on this laptop (it's not a bual boot).


I can confirm that there is no wireless connection with Linux Mint 14 Cinnamon with fresh install & Live Medium (USB Live).

My previous installation of Linux Mint 13 MATE had wireless connection right off the bat flawlessly.

Could this be a Cinnamon bug? Perhaps I'll report my results after a Linux Mint 14 MATE installation instead.

NOTE: So far the update problem was fixed with Linux Mint 14. No more manual fix for that :wink:
fohrums
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 19, 2012 2:32 am

Re: wireless no longer working after upgrading to Mint 14

Postby wimstock on Mon Nov 26, 2012 9:18 pm

On your wireless or internet icon right click and make sure wireless is enabled. If it is take a look a connection info and see if that gives any direction for you. Did you run the install disk or usb live and did it show any wireless connection then.
wimstock
Level 1
Level 1
 
Posts: 3
Joined: Wed Jan 11, 2012 9:38 pm

Re: wireless no longer working after upgrading to Mint 14

Postby fohrums on Mon Nov 26, 2012 9:25 pm

wimstock wrote:On your wireless or internet icon right click and make sure wireless is enabled.

Did you run the install disk or usb live and did it show any wireless connection then.


There is no option to enable it. I'm pretty sure it's 'enabled' due to the fact that when I'm on the Network Manager's window, the Wireless tab is accessible and not grayed out (not sure if it even can be grayed out if anything). If it helps.. my bluetooth is working and enabled by default.

As I mentioned wireless did not work/connect/identify with a fresh install and on a Live Medium (USB Live).

Just to mention i'm running Linux Mint 14 Cinnamon. Wireless worked fine on Linux Mint 13 MATE.
fohrums
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 19, 2012 2:32 am

Re: wireless no longer working after upgrading to Mint 14

Postby dineshtalla on Tue Nov 27, 2012 11:25 am

Even I face the same issue.
There are no option to enable the Wireless from Network Manger from panel.

Looks the drivers are not installed for wireless.

I installed Mint 14 on Dell Latitude E6400, Mint 13 has no issues with wireless..!
dineshtalla
Level 1
Level 1
 
Posts: 1
Joined: Tue Nov 27, 2012 10:54 am

Re: wireless no longer working after upgrading to Mint 14

Postby DartrhAndy on Tue Nov 27, 2012 12:31 pm

Hi,

I believe i had the same problem.The thing is that propietary drivers dnt come with the installation, for some law blabla pretty much someone wants a profit somewhere i guess, anyway.....
1) click on control center from the menu button.
2) go to Other (last option)
3) There Ull see Software Sources click on it...
4)Click on Additional Drivers (Top right last tab)
5)Select using Broadcom 802.11 Linux STA wireless driver source from bcmwl blabla
6) Enter, let it do his thing and voilà
7) Enjoy and look up in you tube The summerian scripts documentary Very Interesting....
8) God Bless.

Peace!!! (drops mic)
DartrhAndy
Level 1
Level 1
 
Posts: 2
Joined: Tue Nov 27, 2012 11:58 am

Re: wireless no longer working after upgrading to Mint 14

Postby N2PY.net on Tue Nov 27, 2012 1:50 pm

After working on this for many hours, it occurs to me that I can get my wireless running again by reverting to Mint 13. Once I did that, the problem was fixed right-out-of-the-box. Unfortunately, none of the good suggestions above were the solution to my particular problem. But I would like to thank everyone that posted, I appreciate the effort.

So I guess we can call this one "solved... sort of.... :roll:"
N2PY.net
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 12, 2012 9:46 pm

Re: [Solved?] wireless no longer work after upgrading to Min

Postby fohrums on Wed Nov 28, 2012 12:54 am

DartrhAndy wrote:Hi,
for some law blabla pretty much someone wants a profit somewhere i guess, anyway.....


I did notice that the item menu "Additional Drivers" were removed from previous Linux Mint 13.

I tested to see if wireless works on Linux Mint 14 Cinnamon & MATE and wireless is removed for this "LAW" reason.

Not to fear though as the Software Sources > Additional Drivers tab option helped out and fixed the problem. It's more of just finding out where they placed the item in the menu this time-around. :D
fohrums
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 19, 2012 2:32 am

Re: [Solved?] wireless no longer work after upgrading to Min

Postby cyberdragon on Sat Dec 01, 2012 11:49 pm

hi guys!
i have linux mint 14 mate, and am also suffering the same problem.
i also tried that "software sources" option, but didn't work.
any ideas or suggestions??? will be grateful for that................ :wink:
cyberdragon
Level 1
Level 1
 
Posts: 1
Joined: Sat Dec 01, 2012 8:38 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: ashtonford and 6 guests