"Software Sources" will not open

Questions about applications and software
Forum rules
Before you post please read this

"Software Sources" will not open

Postby jswhite on Fri Nov 23, 2012 9:21 pm

Okay, so I've got a very weird issue.

Installed Nadia the other day, totally fresh install. Post-install, I added Google apps (Earth/video talk/Chrome) to get the Google software repos added to apt, no problems there. Then I tried adding the Medibuntu repo using the following command (copied/pasted exactly from the Medibuntu site):

Code: Select all
sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update


I've done this across several installs and never had a problem, but this time I got a 404 error and it aborted. Afterwards, I have not been able to open "Software Sources" at all. Going through Synaptic (Settings -> Repositories), nothing happens. It's like it attempts to open something, then immediately goes back to Synaptic. Going through the Software Manager (Edit -> Software Sources) I get the same result. Oddly, there also seems to be a "not found" icon next to Software Sources in the manager (black icon with a red circle/slash through it).

Now I don't know for certain that this was caused by the borked up Medibuntu repository install, because I didn't actually try to open Software Sources before that. But, since that time, it's not working at all. I can manually edit repositories (/etc/apt/sources.list), I can use any package managers (or apt-get) and they appear to work exactly as they would be expected to. But trying to open "Software Sources" just straight up fails.

Anyone else see this issue and/or have an idea of how to fix it?
jswhite
Level 1
Level 1
 
Posts: 4
Joined: Thu May 24, 2012 12:23 am

Linux Mint is funded by ads and donations.
 

Re: "Software Sources" will not open

Postby ripley on Sun Nov 25, 2012 5:40 am

Yep, same problem here. I did make some changes to the system since installing and haven't tried it before that but I think the problem is in a python script.
When trying to open 'software-properties-gtk' via teminal I get:
--------------------------------------------------------------------
gpg: /tmp/tmp836sj8/trustdb.gpg: trustdb created
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 162, in packages_for_modalias
cache_map = packages_for_modalias.cache_maps[apt_cache_hash]
KeyError: -1063479186

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/software-properties-gtk", line 103, in <module>
app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)
File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 178, in __init__
self.init_drivers()
File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 1097, in init_drivers
self.devices = detect.system_device_drivers()
File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 415, in system_device_drivers
for pkg, pkginfo in system_driver_packages(apt_cache).items():
File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 319, in system_driver_packages
for p in packages_for_modalias(apt_cache, alias):
File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 164, in packages_for_modalias
cache_map = _apt_cache_modalias_map(apt_cache)
File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 129, in _apt_cache_modalias_map
m = package.candidate.record['Modaliases']
File "/usr/lib/python3/dist-packages/apt/package.py", line 429, in record
return Record(self._records.record)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xeb in position 121: invalid continuation byte
---------------------------------------------------
After that I checked the processes and 'software-properties-gtk' is in 'zombie' state.
Anyone a solution?
ripley
Level 1
Level 1
 
Posts: 4
Joined: Sun Nov 25, 2012 5:31 am

Re: "Software Sources" will not open

Postby GeneC on Sun Nov 25, 2012 9:01 am

This may be totally unrelated to both of your problems, but you both have 'tweaked' your systems some.
I noticed this same problem after un-installing Mint Update Manager= mintinstall (-- I use Synaptic), Software Sources worked properly again after a re-install of mintinstall. Might check to see if you still have it?
If not that, it may be something you recently removed that prevents Software Sources (software-properties-gtk) from opening.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: "Software Sources" will not open

Postby ripley on Sun Nov 25, 2012 12:15 pm

uninstalled an reinstalled mintinstall but no change...
ripley
Level 1
Level 1
 
Posts: 4
Joined: Sun Nov 25, 2012 5:31 am

Re: "Software Sources" will not open

Postby areynaldos on Mon Nov 26, 2012 6:31 pm

Same here... I installed Nadia on Friday, and today I can't open the software sources, same error code.

The only thing that I've done was to install some of the updates that were being pushed from the Update Manager.

Any help would be greatly appreciated.

I should say that I didn't try to uninstall mintinstall, since Synaptic wants to remove the whole mint-meta-package.
areynaldos
Level 1
Level 1
 
Posts: 15
Joined: Mon Jan 24, 2011 2:46 pm

Re: "Software Sources" will not open

Postby areynaldos on Mon Nov 26, 2012 6:45 pm

SOLVED!


Seems to be a confirmed bug in Ubuntu https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1062793 and https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/1053749

In order to fix it, you have to edit /var/lib/dpkg/status looking for the "incorrect" characters. In my case (as in the bug report) it was related to the strings for Caldav.

sudo gedit /var/lib/dpkg/status

Then look for "caldav"... The name of the maintainer is "Mickal Guessant"... note the strange characters in Mickael.... I just changed it to "Mickal" and now it works.

Follow the Launchpad thread if you want more information.

Cheers,
Last edited by areynaldos on Mon Nov 26, 2012 6:56 pm, edited 1 time in total.
areynaldos
Level 1
Level 1
 
Posts: 15
Joined: Mon Jan 24, 2011 2:46 pm

Re: "Software Sources" will not open

Postby GeneC on Mon Nov 26, 2012 6:54 pm

I did not mean to suggest UN-installing/RE-installing mintupdate.
I merely mentioned that I noticed software-sources did not work, after I had removed mintupdate from LMDE. I dont use it.
This does not appear to be related to the OP's problem...., please ignore :wink:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: "Software Sources" will not open

Postby areynaldos on Mon Nov 26, 2012 6:57 pm

Thanks GeneC... I just edited my comment above to explain the fix that worked for me.

Cheers,
areynaldos
Level 1
Level 1
 
Posts: 15
Joined: Mon Jan 24, 2011 2:46 pm

Re: "Software Sources" will not open

Postby GeneC on Mon Nov 26, 2012 6:58 pm

Glad you got it sorted out.. :)
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: "Software Sources" will not open

Postby jswhite on Mon Nov 26, 2012 8:49 pm

Sadly, this did nothing for me, because I don't have the davmail installed and I don't offhand notice another package with similar problems. I guess I'll just have to troll through the status file line by line and see if I can uncover something. If I find the issue, I'll report back.
jswhite
Level 1
Level 1
 
Posts: 4
Joined: Thu May 24, 2012 12:23 am

Re: "Software Sources" will not open

Postby ripley on Thu Dec 06, 2012 9:28 am

FIXED it!
I don't have davmail installed either but I noticed that trying to open with "sudo gedit /var/lib/dpkg/status" it had a problem reading the character code.
After setting it to "western" I could read it. Then I copied the content to a new textfile in pluma on my Desktop directory calling it "status".
Opened a terminal and:
cd /var/lib/dpkg/
sudo mv status statusold
sudo cp /home/user/Desktop/status status
and that was it, it works!
Reading the other mentioned forums, the problem has to do with the character encoding...
ripley
Level 1
Level 1
 
Posts: 4
Joined: Sun Nov 25, 2012 5:31 am

Re: "Software Sources" will not open

Postby cygnus on Thu Dec 13, 2012 7:00 pm

areynaldos wrote:SOLVED!


Seems to be a confirmed bug in Ubuntu https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1062793 and https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/1053749

In order to fix it, you have to edit /var/lib/dpkg/status looking for the "incorrect" characters. In my case (as in the bug report) it was related to the strings for Caldav.

sudo gedit /var/lib/dpkg/status

Then look for "caldav"... The name of the maintainer is "Mickal Guessant"... note the strange characters in Mickael.... I just changed it to "Mickal" and now it works.

Follow the Launchpad thread if you want more information.

Cheers,


Dude, you nailed it. Had the same problem, fixed the bad character, now it works.
cygnus
Level 1
Level 1
 
Posts: 11
Joined: Thu Nov 15, 2012 11:34 am

Re: "Software Sources" will not open

Postby viperman on Fri Dec 14, 2012 1:31 pm

ripley wrote:FIXED it!
I don't have davmail installed either but I noticed that trying to open with "sudo gedit /var/lib/dpkg/status" it had a problem reading the character code.
After setting it to "western" I could read it. Then I copied the content to a new textfile in pluma on my Desktop directory calling it "status".
Opened a terminal and:
cd /var/lib/dpkg/
sudo mv status statusold
sudo cp /home/user/Desktop/status status
and that was it, it works!
Reading the other mentioned forums, the problem has to do with the character encoding...

This worked for me! This was an obscure fix. I would never thought about the character code being messed up. Thanks so much.
viperman
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 14, 2012 12:26 pm

Re: "Software Sources" will not open

Postby pablomusa on Tue Oct 15, 2013 10:12 am

Actually in my case there were several erros in both:
/var/lib/dpkg/status & /var/lib/dpkg/available

The fix as mentioned by others is just fixing the strange chars all over the files.
I chose to ignore them and fixed as follow:

# become root, "sudo su -" is an option
su -
cd /var/lib/dpkg/

# create backup
cp available available_bkp
cp status status_bkp

# generate new files ignoring strange chars
iconv -f utf-8 -t utf-8 -c available_bkp > /tmp/available
iconv -f utf-8 -t utf-8 -c status_bkp > /tmp/status

# move generated files back to main folder
mv /tmp/available available
mv /tmp/status status

# check if things are ok
iconv available > /dev/null
iconv status > /dev/null

# if nothing is printed, then remove backup files
rm available_bkp
rm status_bkp

Abs
pablomusa
Level 1
Level 1
 
Posts: 1
Joined: Tue Oct 15, 2013 10:04 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: rotanibod and 12 guests