Keyboard shortcuts not working ( mint 14 cinnamon )

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Keyboard shortcuts not working ( mint 14 cinnamon )

Postby terin on Thu Nov 22, 2012 3:59 pm

I designated ctrl and z for command 'xkill' but theres ' nothing '... I have tried other commands for other applications also with different keyboard shortcuts ' nothing works ' and im stumped because ive never had any issues like this on any other version of linux mint or linux for that matter. Its really weird; the shortcuts work for everything else, but when it comes to custom shortcuts nothing works and ive doubled checked the commands were spelled correctly etc..
User avatar
terin
Level 1
Level 1
 
Posts: 3
Joined: Thu Nov 22, 2012 2:06 pm

Linux Mint is funded by ads and donations.
 

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby frank_claessen on Fri Nov 23, 2012 1:40 am

Could you be a bit more specific?
Which commands are you trying to evoke?
Cheers Frank

Success is a journey, not a destination!
frank_claessen
Level 1
Level 1
 
Posts: 42
Joined: Mon Nov 23, 2009 1:55 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby ilansh on Fri Nov 23, 2012 8:58 am

frank_claessen wrote:Could you be a bit more specific?
Which commands are you trying to evoke?


For me it doesn't work too!
I've tried to make several new custom keyboard shortcuts that didn't work at all.
For example:
The command: 'xkill'
The keyboard shortcut: Ctrl+Alt+Esc

The predefined keyboard shortcuts works well and I even update it successfully (I've mapped Ctrl+Alt+Down to vol down),
but, as I wrote, the custom keyboard shortcut doesn't work :(
ilansh
Level 1
Level 1
 
Posts: 5
Joined: Wed Sep 28, 2011 7:30 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby kufii on Fri Nov 23, 2012 10:11 am

Same issue here. The default custom keyboard shortcut to open a terminal works, but I can't add new ones.
kufii
Level 1
Level 1
 
Posts: 6
Joined: Sun Oct 07, 2012 7:03 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby mati2 on Fri Nov 23, 2012 10:15 am

I'm confirming this.

https://bugs.launchpad.net/linuxmint/+bug/1077930

Probably that's the bug - I hope it'll get fixed.
mati2
Level 1
Level 1
 
Posts: 1
Joined: Fri Nov 23, 2012 10:05 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby terin on Fri Nov 23, 2012 2:11 pm

Pretty serious bug at that, although the rest of the operating seems to be perfect and a lot more stable in comparison with the last version imo.

Hopefully it'll get sorted soon.
User avatar
terin
Level 1
Level 1
 
Posts: 3
Joined: Thu Nov 22, 2012 2:06 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby horizonbreakk on Sun Nov 25, 2012 4:37 am

Verifying. Tried the same with "gnome-system-monitor" and nothing.
I thought maybe I was doing something wrong so I tried testing it with different things...no customs work. :(
horizonbreakk
Level 1
Level 1
 
Posts: 2
Joined: Mon Dec 17, 2007 12:32 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby papl00 on Sun Nov 25, 2012 6:49 am

Confirming confirming..
Even if i change the existing terminal custom shortcut to start for example terminator instead, nothing happens, it remains unchanged.
User avatar
papl00
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 25, 2012 6:39 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby frank_claessen on Mon Nov 26, 2012 6:09 pm

Hi all,

I have done some heavy searching. I am working with Mint Maya but upgraded to Cinnamon 1.6.7 through the back-port repository.
Right away my keyboard shortcuts stopped working.

I think that all this relates back to Ubuntu - found a lot of information on a bug description dealing with just that.

See: https://bugs.launchpad.net/ubuntu/+sour ... bug/965921

Furthermore, there is a lot of information to be found at

https://wiki.ubuntu.com/Keybindings

that shows where and how all the information is stored

Tried gconf-editor and dconf-editor - all to no avail.

Finally went through preferences-keyboard-shortcuts and added a custom shortcut for my terminal (wasn't working anymore).

The command to run is /usr/bin/gnome-terminal

As soon as I assigned CTRL-ALT-T to it, I got a warning that these keys had to be reassigned to my custom shortcut.
I confirmed and had a working shortcut again.

Let me know if this helps (at least partly?)
Cheers Frank

Success is a journey, not a destination!
frank_claessen
Level 1
Level 1
 
Posts: 42
Joined: Mon Nov 23, 2009 1:55 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby elemenophee on Mon Nov 26, 2012 7:17 pm

frank_claessen wrote:Hi all,

I have done some heavy searching. I am working with Mint Maya but upgraded to Cinnamon 1.6.7 through the back-port repository.
Right away my keyboard shortcuts stopped working.

I think that all this relates back to Ubuntu - found a lot of information on a bug description dealing with just that.

See: https://bugs.launchpad.net/ubuntu/+sour ... bug/965921

Furthermore, there is a lot of information to be found at

https://wiki.ubuntu.com/Keybindings

that shows where and how all the information is stored

Tried gconf-editor and dconf-editor - all to no avail.

Finally went through preferences-keyboard-shortcuts and added a custom shortcut for my terminal (wasn't working anymore).

The command to run is /usr/bin/gnome-terminal

As soon as I assigned CTRL-ALT-T to it, I got a warning that these keys had to be reassigned to my custom shortcut.
I confirmed and had a working shortcut again.

Let me know if this helps (at least partly?)

do you know what are the commands for hide all windows and for move window to another desktop? Those are the shortcuts I'm missing (I use SUPER+D and SUPER+arrows)
elemenophee
Level 1
Level 1
 
Posts: 25
Joined: Tue Oct 16, 2012 4:23 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby Garvan on Mon Nov 26, 2012 9:36 pm

xkb has a cache, and it does not like to clean it. Try deleting everything in this folder.

Code: Select all
/var/lib/xkb


Garvan
Desktop: Dell, Intel Core 2 Duo E7500 @ 2.93Ghz, 2GiB RAM, Linux Mint 13 Maya.
Net-book: SAMSUNG N148-Plus, 2x Intel Atom CPU N450 @1.66Ghz, 1GB RAM, lubuntu 12.04.
User avatar
Garvan
Level 4
Level 4
 
Posts: 273
Joined: Sun May 29, 2011 3:26 am
Location: Cambodia

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby Garvan on Mon Nov 26, 2012 9:45 pm

elemenophee wrote:do you know what are the commands for hide all windows and for move window to another desktop? Those are the shortcuts I'm missing (I use SUPER+D and SUPER+arrows)


hide all windows == Ctrl+Super+D
move window to another desktop == Shift+Ctrl+Alt+Left

Look them up in the Menu->Preferences->Keyboard applet.

Garvan
Desktop: Dell, Intel Core 2 Duo E7500 @ 2.93Ghz, 2GiB RAM, Linux Mint 13 Maya.
Net-book: SAMSUNG N148-Plus, 2x Intel Atom CPU N450 @1.66Ghz, 1GB RAM, lubuntu 12.04.
User avatar
Garvan
Level 4
Level 4
 
Posts: 273
Joined: Sun May 29, 2011 3:26 am
Location: Cambodia

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby elemenophee on Tue Nov 27, 2012 4:56 am

Garvan wrote:
elemenophee wrote:do you know what are the commands for hide all windows and for move window to another desktop? Those are the shortcuts I'm missing (I use SUPER+D and SUPER+arrows)


hide all windows == Ctrl+Super+D
move window to another desktop == Shift+Ctrl+Alt+Left

Look them up in the Menu->Preferences->Keyboard applet.

Garvan

I mean for do what he said. I know that that those are the default shortcuts (for hide all windows is CTRL+ALT+D btw).

Just tested a thing and it's curious... When I installed my system, my main DE was Gnome. Yesterday I switched to Cinnamon and noticed that shortcuts with SUPER don't work (they do in Gnome). Now I installed a Mint 14 Cinnamon in VirtualBox and there THEY WORK! But with RIGHT WINDOWS key instead of LEFT. So confused? Why they don't work in my system?
elemenophee
Level 1
Level 1
 
Posts: 25
Joined: Tue Oct 16, 2012 4:23 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby viking777 on Tue Nov 27, 2012 10:30 am

I just got my first look at Mint 14 Cinnamon. Overall it is pretty impressive, but like everyone else I am affected by the inability to create custom keyboard shortcuts or delete/change the built-in ones. This is a pretty basic and necessary function I would say and needs to be addressed fairly urgently, in most other respects it is a nice piece of work.

I also run Ubuntu 12.10 on which Mint 14 is based and there are no problems with keyboard shortcuts on that distro.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby Garvan on Wed Nov 28, 2012 4:16 am

elemenophee wrote:
Garvan wrote:
elemenophee wrote:do you know what are the commands for hide all windows and for move window to another desktop? Those are the shortcuts I'm missing (I use SUPER+D and SUPER+arrows)


hide all windows == Ctrl+Super+D
move window to another desktop == Shift+Ctrl+Alt+Left

Look them up in the Menu->Preferences->Keyboard applet.

Garvan

I mean for do what he said. I know that that those are the default shortcuts (for hide all windows is CTRL+ALT+D btw).

Just tested a thing and it's curious... When I installed my system, my main DE was Gnome. Yesterday I switched to Cinnamon and noticed that shortcuts with SUPER don't work (they do in Gnome). Now I installed a Mint 14 Cinnamon in VirtualBox and there THEY WORK! But with RIGHT WINDOWS key instead of LEFT. So confused? Why they don't work in my system?


elemenophee,

You can set the key to hide all windows yourself, so it may be different on many distributions, or it could have been changed on my system or yours without us remembering. But they shortcut keys I posted do work on my system. The left and right super keys can be set individually.

But note the problems of the other posters in this thread. The changes you make setting custom key shortcuts have no effect until the kbd cache is deleted (rebooting does not work).

Garvan
Desktop: Dell, Intel Core 2 Duo E7500 @ 2.93Ghz, 2GiB RAM, Linux Mint 13 Maya.
Net-book: SAMSUNG N148-Plus, 2x Intel Atom CPU N450 @1.66Ghz, 1GB RAM, lubuntu 12.04.
User avatar
Garvan
Level 4
Level 4
 
Posts: 273
Joined: Sun May 29, 2011 3:26 am
Location: Cambodia

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby norumaru on Wed Nov 28, 2012 10:23 am

You seem to misunderstand the problem, no offence intended. The problem is that changing - or even using - the keys (pre)set to trigger the keyboard shortcuts in the keyboard menu does nothing and the only working way to set them is to define custom shortcuts under the menu point "custom shortcuts". That, in turn, involves knowing the shell command you want to bind to the combination of keys in question. Elemenophee is looking for the CLI command that would do what she wants, so that she can set up a trigger under "custom shortcuts". Clearing the xkb cache does nothing, at least for me.

And since I am posting here already, I have the same problem. I used to be able to switch between workspaces with Super+[number of workspace] and to put windows on another workspace with Ctrl+Super+[number of workspace], and since I use each workspace for a different purpose and have different applications devilspie'd to each of them, going to expo for these functions every other minute gets really annoying. So if anyone knows the CLI commands for these things, I would be overjoyed.
norumaru
Level 1
Level 1
 
Posts: 21
Joined: Tue Aug 24, 2010 4:08 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby aelfinn on Wed Nov 28, 2012 1:51 pm

Has someone brought this to the attention of Clem or whoever and got a reply?
LM15 C64
Acer Aspire 1810TZ
aelfinn
Level 3
Level 3
 
Posts: 188
Joined: Thu Dec 11, 2008 2:11 pm

Re: shortcut keys?

Postby ceccobeppe on Fri Nov 30, 2012 4:34 am

Talking about shortcut keys....

I want to disable the print screen key (or reassign to another function).

I can't find the corresponding entry in the keyboard shortcuts tab of MINT 14.

In previous version of MINT it was easy. There was a "screenshot" to customize.

Moved here by moderator - suggest you read the topic.
ceccobeppe
Level 1
Level 1
 
Posts: 10
Joined: Fri Dec 02, 2011 9:46 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby Garvan on Fri Nov 30, 2012 8:23 pm

norumaru wrote:You seem to misunderstand the problem, no offence intended. ...

Thanks for the correction. Garvan
Desktop: Dell, Intel Core 2 Duo E7500 @ 2.93Ghz, 2GiB RAM, Linux Mint 13 Maya.
Net-book: SAMSUNG N148-Plus, 2x Intel Atom CPU N450 @1.66Ghz, 1GB RAM, lubuntu 12.04.
User avatar
Garvan
Level 4
Level 4
 
Posts: 273
Joined: Sun May 29, 2011 3:26 am
Location: Cambodia

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby ScottyD on Sat Dec 01, 2012 12:09 pm

I'm amazed this is still a problem??? Custom Keyboard shortcuts are FUBAR.
ScottyD
Level 1
Level 1
 
Posts: 40
Joined: Thu Oct 20, 2011 5:16 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Cinnamon

Who is online

Users browsing this forum: wakata and 13 guests