Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby clem on Tue Nov 27, 2012 6:00 am

I've been running an "updated" MDM here since last night and I haven't experienced a single boot with llvmpipe.. of course, it's hard to say for sure since the problem didn't happen all the time in the first place, but it looks good. Basically, the fix consists in mdm checking if plymouth is running and asking it to quit.

We'll do a bit more testing and hopefully we'll have a package update for MDM very soon.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Linux Mint is funded by ads and donations.
 

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby clem on Tue Nov 27, 2012 11:33 am

This issue is now fixed in mdm 1.0.8.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby kmb42vt on Tue Nov 27, 2012 12:55 pm

clem wrote:This issue is now fixed in mdm 1.0.8.


Excellent! Since the manual fix works for now, I'll wait until the 1.0.8 is pushed through updates. Thanks Clem. :D
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)
User avatar
kmb42vt
Level 5
Level 5
 
Posts: 931
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby exploder on Tue Nov 27, 2012 5:26 pm

Very impressive! Thanks Clem! :D :) :D
exploder
Level 15
Level 15
 
Posts: 5913
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby Bali on Tue Dec 11, 2012 4:58 am

clem wrote:This issue is now fixed in mdm 1.0.8.



Hi Clem,

Is it fixed for Mint 13? Because until now my computer is slow: time to launch everything after login, also for openind locations (folders, My Computers) and files.
With a fresh install, Mint 13 is ok. But as soon as i do the first big update, everything becaome slow.
For info, I don't have this problem with Mint 9 on the exactlly same Computer/Components.
Also, when I made a Top, I can see Xorg appearing on top of the list; After 10 yearsof using Linux, this is the first time I see it on this rank of Top.

Thanks in advance for help.
User avatar
Bali
Level 1
Level 1
 
Posts: 45
Joined: Mon Jul 28, 2008 11:41 pm
Location: Indonesia (Java and Bali)

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby esteban1uy on Tue Dec 11, 2012 5:32 am

Bali wrote:
clem wrote:This issue is now fixed in mdm 1.0.8.



Hi Clem,

Is it fixed for Mint 13? Because until now my computer is slow: time to launch everything after login, also for openind locations (folders, My Computers) and files.
With a fresh install, Mint 13 is ok. But as soon as i do the first big update, everything becaome slow.
For info, I don't have this problem with Mint 9 on the exactlly same Computer/Components.
Also, when I made a Top, I can see Xorg appearing on top of the list; After 10 yearsof using Linux, this is the first time I see it on this rank of Top.

Thanks in advance for help.


Wich flavor of Mint 13 are you using?
KDE, Cinnamon, Mate... ?
Please, open a terminal, execute this command and paste the results here in the forum:
Code: Select all
inxi -Fc 0
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby AlbertP on Tue Dec 11, 2012 8:58 am

Please open a new topic. Xorg's CPU usage has nothing to do with this.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby Bali on Tue Dec 11, 2012 9:39 am

esteban1uy wrote:
Bali wrote:
clem wrote:This issue is now fixed in mdm 1.0.8.




Hi Clem,

Is it fixed for Mint 13? Because until now my computer is slow: time to launch everything after login, also for openind locations (folders, My Computers) and files.
With a fresh install, Mint 13 is ok. But as soon as i do the first big update, everything becaome slow.
For info, I don't have this problem with Mint 9 on the exactlly same Computer/Components.
Also, when I made a Top, I can see Xorg appearing on top of the list; After 10 yearsof using Linux, this is the first time I see it on this rank of Top.

Thanks in advance for help.


Wich flavor of Mint 13 are you using?
KDE, Cinnamon, Mate... ?
Please, open a terminal, execute this command and paste the results here in the forum:
Code: Select all
inxi -Fc 0


HI,

Here it is. I use Mint 13 Mate 64 Bits.

Code: Select all
System:    Host: Bali Kernel: 3.2.0-23-generic x86_64 (64 bit) Desktop: N/A Distro: Linux Mint 13 Maya
Machine:   Mobo: Gigabyte model: G41M-ES2L Bios: Award version: F9 date: 06/21/2010
CPU:       Dual core Intel Core2 Duo CPU E8200 (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx)
           Clock Speeds: 1: 2000.00 MHz 2: 2000.00 MHz
Graphics:  Card: Intel 4 Series Chipset Integrated Graphics Controller
           X.Org: 1.11.3 drivers: intel (unloaded: vesa,fbdev) Resolution: 1280x1024@75.0hz
           GLX Renderer: Mesa DRI Intel G41 GLX Version: 2.1 Mesa 8.0.4
Audio:     Card-1: Intel N10/ICH 7 Family High Definition Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.24
           Card-2: Yealink Network VoIP Phone driver: USB Audio
Network:   Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
           IF: eth0 state: down mac: 00:24:1d:bf:cb:09
           Card-2: Linksys WUSBF54G v1.1 802.11bg driver: zd1211rw
           IF: wlan0 state: up mac: 00:14:bf:be:a0:91
Drives:    HDD Total Size: 400.1GB (74.7% used) 1: /dev/sda ST380811AS 80.0GB
           2: /dev/sdb WDC_WD3200AAKS 320.1GB
Partition: ID: / size: 14G used: 5.2G (39%) fs: ext4 ID: /home size: 61G used: 7.5G (14%) fs: ext4
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 168 Uptime: 2:31 Memory: 957.4/3919.7MB Client: Shell inxi


Thanks
User avatar
Bali
Level 1
Level 1
 
Posts: 45
Joined: Mon Jul 28, 2008 11:41 pm
Location: Indonesia (Java and Bali)

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby Phyrexus on Tue Dec 18, 2012 3:28 am

I've been having a similar issue on my laptop tonight. I've been compiling the mesa drivers in the Intel Linux Graphics stack for Intel HD graphics for about a week now with no problems, but today I rebooted my computer and encountered the LLVMPIPE switching. I tried the manual fix above, but it didn't seem to help. I also tried reinstalling all of the mesa and xorg video packages to no avail. I'm running Linux Mint 14, 64 bit with Cinnamon, kernel 3.7.0-7-generic, and graphics drivers from the xorg-edgers PPA.

Please let me know if there's any other information you might need for this. Below is the output from inxi -G when I run it.

Code: Select all
~ $ inxi -G
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           X.Org: 1.13.0.902 driver: FAILED: intel Resolution: 1366x768@60.0hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.1, 256 bits) GLX Version: 2.1 Mesa 9.1-devel
Phyrexus
Level 1
Level 1
 
Posts: 4
Joined: Sat Dec 08, 2012 5:44 am

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby clem on Tue Dec 18, 2012 5:43 am

Phyrexus wrote:I've been having a similar issue on my laptop tonight. I've been compiling the mesa drivers in the Intel Linux Graphics stack for Intel HD graphics for about a week now with no problems, but today I rebooted my computer and encountered the LLVMPIPE switching. I tried the manual fix above, but it didn't seem to help. I also tried reinstalling all of the mesa and xorg video packages to no avail. I'm running Linux Mint 14, 64 bit with Cinnamon, kernel 3.7.0-7-generic, and graphics drivers from the xorg-edgers PPA.

Please let me know if there's any other information you might need for this. Below is the output from inxi -G when I run it.

Code: Select all
~ $ inxi -G
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           X.Org: 1.13.0.902 driver: FAILED: intel Resolution: 1366x768@60.0hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.1, 256 bits) GLX Version: 2.1 Mesa 9.1-devel


Make sure MDM is at version 1.0.8.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby Phyrexus on Tue Dec 18, 2012 5:09 pm

MDM is at version 1.0.8 and I am still experiencing the llvmpipe switch.
Phyrexus
Level 1
Level 1
 
Posts: 4
Joined: Sat Dec 08, 2012 5:44 am

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby AlbertP on Wed Dec 19, 2012 10:33 am

Make sure you aren't logged in into Cinnamon 2D.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby Phyrexus on Wed Dec 19, 2012 7:09 pm

When I log into Cinnamon (not the 2D option), it boots me back to Gnome Classic. The inxi -G command yields a similar output:

Code: Select all
~ $ inxi -G
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           X.Org: 1.13.0.902 driver: FAILED: intel Resolution: 1366x768@60.0hz
           GLX Renderer: N/A GLX Version: N/A
Phyrexus
Level 1
Level 1
 
Posts: 4
Joined: Sat Dec 08, 2012 5:44 am

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby clem on Thu Dec 20, 2012 5:26 am

Maybe that chipset doesn't have any acceleration?
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Re: Load correct MESA DRI Intel drivers for Linux Mint 14 RC

Postby AlbertP on Thu Dec 20, 2012 11:21 am

@ Clem: This is Intel Sandy Bridge. It's pretty recent. GLX Renderer N/A is quite a different problem indeed, so I think Phyrexus could better open a new topic.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 
Previous

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 9 guests