Setting AM/PM in Cinnamon

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Setting AM/PM in Cinnamon

Postby 7vn11vn on Thu Nov 29, 2012 6:01 pm

I installed Mate first, then Cinammon. The time in the taskbar is fine in Mate and even Ubuntu, but in Cinnamon it displays as a 24 hour clock, not am/pm. I went into the Menu and went into Preferences - Date and Time and changed it from 24-hour to AM/PM, but it stays at 24 hour. Re-booting after setting it didn't work and like I said, it's okay in Mate and Ubuntu, so I'm not sure what I'm doing wrong, or how to fix it. Can anyone help? Thanks.
7vn11vn
Level 1
Level 1
 
Posts: 9
Joined: Tue Nov 27, 2012 3:31 pm

Linux Mint is funded by ads and donations.
 

Re: Setting AM/PM in Cinnamon

Postby BoscoBearbank on Thu Nov 29, 2012 7:19 pm

Currently have Ubuntu LXDE loaded, do can't verify for Cinnamon, but right-clicking on the clock and setting the format to
Code: Select all
%a %d-%b  %I:%M:%S %p
gives me Thu 29-Nov 05:20:06 PM
User avatar
BoscoBearbank
Level 2
Level 2
 
Posts: 52
Joined: Sat Nov 14, 2009 8:13 pm

Re: Setting AM/PM in Cinnamon

Postby caboose2099 on Fri Nov 30, 2012 1:05 am

BoscoBearbank wrote:Currently have Ubuntu LXDE loaded, do can't verify for Cinnamon, but right-clicking on the clock and setting the format to
Code: Select all
%a %d-%b  %I:%M:%S %p
gives me Thu 29-Nov 05:20:06 PM


Worked for me! Mint 13 Cinnamon 64bit. Thanks! :D
caboose2099
Level 1
Level 1
 
Posts: 2
Joined: Thu Nov 29, 2012 9:22 am

Re: Setting AM/PM in Cinnamon

Postby twodogs on Fri Nov 30, 2012 12:04 pm

This is my clock. It removes the zero (06:30 PM becomes 6:30 PM) and no seconds.

Code: Select all
%a %d-%b  %_I:%M %p
--
Image
Lenovo laptop B575 8 gigs memory, 750 hard drive, and Linux Mint 17 Qiana Cinnamon 64-bit
User avatar
twodogs
Level 4
Level 4
 
Posts: 264
Joined: Sat Jun 09, 2007 9:18 pm

Re: Setting AM/PM in Cinnamon

Postby 7vn11vn on Fri Nov 30, 2012 5:03 pm

Thank you guys so much for the help. Once I found out what to do I was able to experiment and get it just the way I want it. I used this one:

%a %b %e, %_I:%M %p

Looks like this: Fri Nov 30, 1:05 PM

Thanks again. I really appreciate your help!!!
7vn11vn
Level 1
Level 1
 
Posts: 9
Joined: Tue Nov 27, 2012 3:31 pm

Re: Setting AM/PM in Cinnamon

Postby caboose2099 on Fri Nov 30, 2012 5:27 pm

7vn11vn wrote:%a %b %e, %_I:%M %p

Looks like this: Fri Nov 30, 1:05 PM


Think I may use that one when I get home from work. 8)
caboose2099
Level 1
Level 1
 
Posts: 2
Joined: Thu Nov 29, 2012 9:22 am

Re: Setting AM/PM in Cinnamon

Postby GabeA on Sun Jun 09, 2013 6:01 am

Still no way to remove military (24hr) time from the clock desklet? A few reviewers pointed out the same thing and were disappointed.

I'm not disappointed. I would just like this essential AM/PM functionality added to the clock. :)
GabeA
Level 1
Level 1
 
Posts: 3
Joined: Sun Jun 09, 2013 5:58 am

Re: Setting AM/PM in Cinnamon

Postby Nightflame on Thu Jun 20, 2013 11:08 am

GabeA wrote:Still no way to remove military (24hr) time from the clock desklet? A few reviewers pointed out the same thing and were disappointed.

I'm not disappointed. I would just like this essential AM/PM functionality added to the clock. :)


You can try another clock desklet called "Time And Date". Just refresh your Desklets from the Internet to get this.

From inside the desklet select "Edit Config"

Change the timeFormat to be:

"timeFormat": "%I:%M %p",

Save the file, remove and re-add the Desklet. You should now see the time in 12 hour with am/pm.

-S.
Nightflame
Level 1
Level 1
 
Posts: 15
Joined: Thu Feb 21, 2013 4:06 am

Re: Setting AM/PM in Cinnamon

Postby sujitnag on Thu Jun 20, 2013 11:33 am

on net connect.
left click (on date & time applets -> date time setting->generate your own date formats )
or go to
http://www.foragoodstrftime.com/

select formate.
write in date format for the panel.
User avatar
sujitnag
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 10, 2012 12:25 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Mint2be and 40 guests