[SOLVED] CD drive reads media...sometimes (or not)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[SOLVED] CD drive reads media...sometimes (or not)

Postby Frederator on Tue Nov 27, 2012 9:49 pm

I'm completely new to linux so bear with me if this has been asked a lot. I've searched and found similar problems but I don't want to hijack anybody else's thread so I'm posting a new one here.

My DVD drive works in Windows and about half the time in Mint 14. I can boot into Mint and sometimes the CD drive lists the media contents right off the bat. Other times, it will read the disc title but not show me the contents. Currently I see the drive is mounted but can't read the disc. I've tried reading the Mint Live CD that I used to install the OS, nothing. I've tried a commercial software disc, nothing.

The CD drive works fine in Windows and yesterday I burned Clonezilla using Kb3 software from Mint and was able to boot to it and make a successful clone of the partition. Go figure.

Any words of wisdom would be greatly appreciated. Please include any commands I need to enter at the terminal so I can cut and paste. Thanks in advance.
Frederator
Last edited by Frederator on Mon Dec 10, 2012 1:03 am, edited 2 times in total.
I think, therefore I am (a thought).
Frederator
Level 1
Level 1
 
Posts: 19
Joined: Tue Nov 20, 2012 6:06 pm

Linux Mint is funded by ads and donations.
 

Re: CD drive reads media...sometimes

Postby Frederator on Thu Nov 29, 2012 11:19 am

Update...
When I boot to Mint 14, the CD drive is not mounted. When I run "sudo mount /dev/sr0", it shows up and will read the CD.
Then, when I switch CDs, the drive will always read the current disc label, but then three things can happen:
1. The disc contents are read and accessible normally, or
2. The previous contents are still displayed and return an error when accessed, or
3. The disc will not show any contents at all.

How can I simply have the CD drive mount automatically and show the disc contents every time? (It does this in Windows).
TIA,
Frederator
I think, therefore I am (a thought).
Frederator
Level 1
Level 1
 
Posts: 19
Joined: Tue Nov 20, 2012 6:06 pm

Re: CD drive reads media...sometimes

Postby daveinuk on Thu Nov 29, 2012 12:46 pm

Hi Fred,

Don't know if this is what you're looking for but I came across your post and found this browsing around . . . . . . .

http://www.techsupportalert.com/content/tips-and-tricks-mint-after-installation-mint-13-cinnamon-edition.htm#Auto-Mount-Drives-at-System-Startup
Lenovo ThinkPad T61 LM16-64 bit Intel T7500/2.2GHz/Cinammon 1.8 Intel GM965. Toshiba Satellite M70: LM16-32bit. Desktop:LM13 Maya 64 bit, on new Intel 3.2ghz proc/asus MB/8gb RAM
User avatar
daveinuk
Level 6
Level 6
 
Posts: 1016
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.

Re: CD drive reads media...sometimes (or not)

Postby Frederator on Fri Nov 30, 2012 12:37 pm

Thanks, dave, but I think my problem runs deeper than that.
During the boot process today, I noticed the screen output showing trouble with the drive so when the desktop opened (with no CD drive in file manager), I ran:

sudo mount /dev/sr0
mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab

then, if I put a disc in the drive and run the command again, I get this:

sudo mount /dev/sr0
mount: /dev/sr0 already mounted or /media/brianf/2012-11-23 1050 busy
mount: according to mtab, /dev/sr0 is already mounted on /media/brianf/2012-11-23 1050

Does this help any wizards out there to figure out what's wrong and how to fix it?
TIA
Fred
I think, therefore I am (a thought).
Frederator
Level 1
Level 1
 
Posts: 19
Joined: Tue Nov 20, 2012 6:06 pm

Re: CD drive reads media...sometimes (or not)

Postby Frederator on Mon Dec 03, 2012 12:05 pm

After a fresh boot, the CD drive is not found. There is no fstab or blkid entry.

After: sudo mount /dev/sr0 /media/cdrom
I get...

Code: Select all
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: /dev/sr0: can't read superblock


However, if I open the drive, then issue the mount command and close the drive, it works fine.

Following Google searches have located many posts but so far none have guided me to the fix for my problem.
Any help for a noob?
Frederator
I think, therefore I am (a thought).
Frederator
Level 1
Level 1
 
Posts: 19
Joined: Tue Nov 20, 2012 6:06 pm

Re: CD drive reads media...sometimes (or not)

Postby Frederator on Mon Dec 10, 2012 1:02 am

I guess the CD drive doesn't need to put in an appearance until I need it and I can get it to respond by entering commands by hand.
Since this is good enough for me, I'm marking the thread [SOLVED]
Frederator
I think, therefore I am (a thought).
Frederator
Level 1
Level 1
 
Posts: 19
Joined: Tue Nov 20, 2012 6:06 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Australis Rico, coffee412, Google [Bot], Google Adsense [Bot] and 28 guests