Openvpn doesn't automatically connect on boot

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Openvpn doesn't automatically connect on boot

Postby Nanix on Fri Nov 30, 2012 12:26 pm

Yes, I've checked "autoconnect" in network manager, but it still doesn't work. It wouldn't be much of a problem but since I'm also trying to mount a folder with fstab that depends on being connected to vpn this rainbows up my whole configuration. I'd be happy for your ideas, thanks :)

edit: Oh and it's openvpn by the way in case that makes any difference.
Nanix
Level 1
Level 1
 
Posts: 14
Joined: Sun Nov 25, 2012 7:57 pm

Linux Mint is funded by ads and donations.
 

Re: Openvpn doesn't automatically connect on boot

Postby remoulder on Fri Nov 30, 2012 4:18 pm

Details, details, see how to get help
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Openvpn doesn't automatically connect on boot

Postby Nanix on Fri Nov 30, 2012 10:31 pm

My bad, sorry.

Inxi gave me:

System: Host: LillaMint Kernel: 3.5.0-18-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: System: ASUSTeK product: 1015PN version: x.x
Mobo: ASUSTeK model: 1015PN version: x.xx Bios: American Megatrends version: 0701 date: 04/18/2011
CPU: Dual core Intel Atom CPU N570 (-HT-MCP-) cache: 512 KB flags: (lm nx sse sse2 sse3 ssse3 vmx)
Clock Speeds: 1: 1000.00 MHz 2: 1000.00 MHz 3: 1000.00 MHz 4: 1667.00 MHz
Graphics: Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
X.Org: 1.13.0 driver: intel Resolution: 1024x600@60.0hz
GLX Renderer: Mesa DRI Intel IGD GLX Version: 1.4 Mesa 9.0
Audio: Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.25
Network: Card: Broadcom BCM4313 802.11b/g/n Wireless LAN Controller driver: bcma-pci-bridge
IF: wlan0 state: up mac: 74:2f:68:00:36:92
Drives: HDD Total Size: 500.1GB (2.1% used) 1: id: /dev/sda model: ST9500325AS size: 500.1GB
Partition: ID: / size: 46G used: 6.5G (15%) fs: ext4 ID: /home size: 409G used: 3.6G (1%) fs: ext4
ID: swap-1 size: 5.00GB used: 0.01GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 53.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 160 Uptime: 10:13 Memory: 1059.7/1993.6MB Client: Shell inxi: 1.8.4

Version is cinnamon, 64 bit, nadia.
Nanix
Level 1
Level 1
 
Posts: 14
Joined: Sun Nov 25, 2012 7:57 pm

Re: Openvpn doesn't automatically connect on boot

Postby remoulder on Sat Dec 01, 2012 7:38 am

Nanix wrote:trying to mount a folder with fstab that depends on being connected to vpn

Sorry but this is not going to work. Mount via fstab is done at boot but the network connection would not be established until you login. To do what you want you would have to use manually configured networking, i.e. not using Network Manager, but I don't know how you would connect to a vpn this way.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Openvpn doesn't automatically connect on boot

Postby Nanix on Sat Dec 01, 2012 8:37 am

Mh, that's bad news. Mounting the folder was the only option I saw that would allow me to achieve playing my music. You don't happen to know any music player that would just allow me to play it via smb do you?
Nanix
Level 1
Level 1
 
Posts: 14
Joined: Sun Nov 25, 2012 7:57 pm


Return to Other networking topics

Who is online

Users browsing this forum: Mint2be and 4 guests