Cinnamon with XRDP Remote Desktop

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Cinnamon with XRDP Remote Desktop

Postby AE2100A on Sat Dec 01, 2012 11:13 am

I have upgraded to Linux Mint 14. I have installed the xrdp package. I can connected remotely from a windows RDP client.

However, when I connect, I get something different. So, not when remote, I get what looks like the full Cinnamon interface gui. When I connect remotely, I get something else, probably it is Cinnamon 2d.

I want to remotely use the FULL version of Cinnamon, even when remote.

Any tips?

Is there any command I can run to confirm that I am using Cinnamon 2d or something else?

Does the startwm.sh or Xsessions need to be revised? Can you send me the proper code for FULL version?
AE2100A
Level 1
Level 1
 
Posts: 26
Joined: Sat Dec 01, 2012 10:45 am

Linux Mint is funded by ads and donations.
 

Re: Cinnamon with XRDP Remote Desktop

Postby AE2100A on Sun Dec 02, 2012 8:57 am

Is anyone else experiencing this issue?
AE2100A
Level 1
Level 1
 
Posts: 26
Joined: Sat Dec 01, 2012 10:45 am

Re: Cinnamon with XRDP Remote Desktop

Postby aa2k on Fri Dec 07, 2012 2:31 pm

Hi,
Did you find a solution for this?? I have the same problem..

If you use Vino (Shared desktop built in) using vnc to connect you get cinnamon 2d which looks the same as full cinnamon.. this is ok and its the closest to get a nice desktop (but it tents to be a bit slower), the problem is that you need to be already logged in to be able to connect which defeats the purpose of remote connection...
I use nxnomachine as well and have the same problem - it drops to the classic desktop with a 'lot' of missing icons...
I think if this is fixed them Mint would be a 'perfect' 100% solution...
aa2k
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 09, 2011 10:41 am

Re: Cinnamon with XRDP Remote Desktop

Postby unRheal on Wed Feb 27, 2013 2:37 am

Yes, I had the same problem... I was using the live boot CD.

I used the built in Desktop Sharing utility and when I connected with the windows RDP client, it gave me a new desktop that didn't have all the stuff my regular desktop did, so it was like I was logged in twice, not actually sharing the desktop, also I had to use my account id and password to connect, not the password I'd set with the Desktop Sharing utility.

When I connected with RDP, it gave me a login prompt that had "Module" "username" and "password"

After much trial and error with various other things, I finally found that if I changed the "Module" from the default "sesman-Xvnc" to "console" (or "vnc-any" it seems) then it changed and only asked for "password" - which was then the password I entered in the Desktop Sharing utility - and also connected to my actual desktop as a standard window-windows RDP type connection would do, which is what I wanted.

Hope that helps...
unRheal
Level 1
Level 1
 
Posts: 1
Joined: Wed Feb 27, 2013 2:21 am

Re: Cinnamon with XRDP Remote Desktop

Postby mattslay on Tue Mar 19, 2013 11:07 am

@unRheal - Yes that will allow you to long in as you desire, however... It still does not give you the *Cinnamon* desktop experience. It's some other fallback mode of graphics because apprarently the XRDP host service running on the remote Linux machine can't/doesn't support the full graphics stack required for th Cinammon service.
mattslay
Level 1
Level 1
 
Posts: 1
Joined: Tue Mar 19, 2013 11:01 am

Re: Cinnamon with XRDP Remote Desktop

Postby AE2100A on Mon Jun 24, 2013 3:07 am

Still have the same original problem. Haven't had time to upgrade to Linux Mint 15. Has anyone confirmed the problem is still there on Linux Mint 15?
AE2100A
Level 1
Level 1
 
Posts: 26
Joined: Sat Dec 01, 2012 10:45 am

Re: Cinnamon with XRDP Remote Desktop

Postby Tim-int on Thu Jul 18, 2013 4:46 am

Yes. The same problem in Mint 15.
Using sesman-Xvnc module, I get "Cinnamon crashed" and "running in Fallback mode". This is the only module which works, although not with Cinnamon as we'd wanted.
Rdp-any gives a blank screen. Using freerdp-any module, I get "error loading libxrdpfreerdp1.so". Using sesman-X11rdp I get connected and then immediately disconnected.
Tim-int
Level 1
Level 1
 
Posts: 38
Joined: Tue Nov 29, 2011 2:30 pm

Re: Cinnamon with XRDP Remote Desktop

Postby linuxmint-j on Mon Jul 22, 2013 4:00 pm

I'm getting the same error. If it's any help, below is a copy of the .xsession-errors file (should I be looking at a different log file) when I try to make the RDP connection. I'm not worried about most of it (warnings), but am not sure how to resolve the error that starts with:

Code: Select all
(cinnamon:3020): Gdk-ERROR **: The program 'cinnamon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 113 error_code 1 request_code 149 minor_code 8)


Relevant environment info:

Code: Select all
Kernel: 3.8.0-26-generic x86_64 (64 bit, gcc: 4.7.3) Desktop: Gnome Distro: Linux Mint 15 Olivia
System: VMware product: VMware Virtual Platform
Mobo: Intel model: 440BX Desktop Reference Platform Bios: Phoenix version 6.00 date: 07/09/2012

Graphics: Card: VMware SVGA II Adapter bus-ID: 00:0f.0
          XFree86: 4.3.0 drivers: vmware (unloaded: fbdev,vesa) Resolution: 1280x1024
          GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A


Complete error log is:
Code: Select all
Xsession: X session started for  at Mon Jul 22 14:17:37 EDT 2013
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  109 (X_ChangeHosts)
  Value in failed request:  0x5
  Serial number of failed request:  6
  Current serial number in output stream:  8
localuser:user1 being added to access control list
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  109 (X_ChangeHosts)
  Value in failed request:  0x5
  Serial number of failed request:  6
  Current serial number in output stream:  8
Script for cjkv started at run_im.
Script for default started at run_im.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Script for cjkv started at run_im.
Script for default started at run_im.
gnome-session[2947]: WARNING: GSIdleMonitor: IDLETIME counter not found
GNOME_KEYRING_CONTROL=/run/user/user1/keyring-bABN2W
SSH_AUTH_SOCK=/run/user/user1/keyring-bABN2W/ssh
GNOME_KEYRING_PID=2980
GNOME_KEYRING_CONTROL=/run/user/user1/keyring-bABN2W
SSH_AUTH_SOCK=/run/user/user1/keyring-bABN2W/ssh
GNOME_KEYRING_CONTROL=/run/user/user1/keyring-bABN2W
SSH_AUTH_SOCK=/run/user/user1/keyring-bABN2W/ssh
GPG_AGENT_INFO=/run/user/user1/keyring-bABN2W/gpg:0:1

(gnome-settings-daemon:2978): color-plugin-WARNING **: Unable to start color manager: RANDR extension is too old (must be at least 1.2)

(gnome-settings-daemon:2978): power-plugin-WARNING **: Unable to start power manager: RANDR extension is too old (must be at least 1.2)
GNOME_KEYRING_CONTROL=/run/user/user1/keyring-bABN2W
SSH_AUTH_SOCK=/run/user/user1/keyring-bABN2W/ssh
GPG_AGENT_INFO=/run/user/user1/keyring-bABN2W/gpg:0:1
Failure: Module initialization failed

(gnome-settings-daemon:2978): xrandr-plugin-WARNING **: Unable to start xrandr manager: RANDR extension is too old (must be at least 1.2)

(gnome-settings-daemon:2978): keyboard-plugin-WARNING **: Neither XKeyboard not Xfree86's keyboard extensions are available,
no way to support keyboard autorepeat rate settings

(gnome-settings-daemon:2978): keyboard-plugin-WARNING **: XKB extension not available

(gnome-settings-daemon:2978): keyboard-plugin-WARNING **: Neither XKeyboard not Xfree86's keyboard extensions are available,
no way to support keyboard autorepeat rate settings

(gnome-settings-daemon:2978): keyboard-plugin-WARNING **: Failed to set the keyboard layouts: GDBus.Error:org.freedesktop.Accounts.Error.PermissionDenied: Not authorized

(cinnamon:3020): Gdk-ERROR **: The program 'cinnamon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 113 error_code 1 request_code 149 minor_code 8)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
access control disabled, clients can connect from any host

(gnome-panel:3024): Gtk-CRITICAL **: gtk_accelerator_parse_with_keycode: assertion `accelerator != NULL' failed

** (gnome-panel:3024): WARNING **: Unable to parse mouse modifier '(null)'

XKB extension not present on :10.0
Window manager warning: Log level 32: could not find XKB extension.

** (nm-applet:3027): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Rejected send message, 2 matched rules; type="method_call", sender=":1.64" (uid=1000 pid=3027 comm="nm-applet ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination="org.freedesktop.NetworkManager" (uid=0 pid=894 comm="NetworkManager ")

(bluetooth-applet:3051): Bluetooth-WARNING **: Could not open RFKILL control device, please verify your installation
** Message: applet now removed from the notification area
** Message: using fallback from indicator to GtkStatusIcon

(gnome-panel:3024): Gtk-CRITICAL **: gtk_accelerator_parse_with_keycode: assertion `accelerator != NULL' failed

** (gnome-panel:3024): WARNING **: Unable to parse mouse modifier '(null)'
linuxmint-j
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 22, 2013 10:52 am

Re: Cinnamon with XRDP Remote Desktop

Postby linuxmint-j on Wed Jul 31, 2013 4:36 pm

So I believe that the windows manager that's being run in 'FALLBACK' mode here is metacity (the command shows up as 'metacity --replace' in /usr/bin/cinnamon-launcher).

If we can't fix Cinnamon in XRDP, then how at least do we fix the 'd' key (in metacity?) from minimizing/restoring all the windows. All the solutions I can find talking about using gconf-editor or gconftool-2 to set /apps/metacity/global_keybindings/show_desktop to be "<Super>d" don't work.
linuxmint-j
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 22, 2013 10:52 am

Re: Cinnamon with XRDP Remote Desktop

Postby Tim-int on Tue Aug 27, 2013 6:06 am

I work in a company where only Windows desktops are used. Users are accustomed to it and some large scale replacement is not an option. But, we would like to offer Linux to some mind-open users.
We have prepared a system for Linux desktops and we'd like to promote it now. Our idea was to offer everyone an access to Linux via RDP. This problem with Cinnamon prevents us from doing so.
I'd really like to see this solved.
Tim-int
Level 1
Level 1
 
Posts: 38
Joined: Tue Nov 29, 2011 2:30 pm

Re: Cinnamon with XRDP Remote Desktop

Postby hagerbomb on Wed Oct 02, 2013 12:01 am

Logging into Mint 15 from Windows 7 using XRDP crashed Cinnamon and it runs in fallback mode if I chosse not to restart cinnamon. Restarting cinnamon results in no panels. Either way, no cinnamon desktop and the "D" key closes all windows and this will not do at all. CCSM changes for show desktop to disabled availed nothing. Can't use this distro at work until we have a fix!
hagerbomb
Level 1
Level 1
 
Posts: 2
Joined: Tue Oct 01, 2013 11:13 pm

Re: Cinnamon with XRDP Remote Desktop

Postby kroonweb on Sun May 11, 2014 10:13 am

Same here, Mint 16 Cinnamon crashed on remote desktop session, both from Windows 7 and from Mint 15 Mate. Searched for more info: http://www.reddit.com/r/linuxmint/comme ... rdp_issue/ I will try the XCFE solution and get back here
kroonweb
Level 1
Level 1
 
Posts: 2
Joined: Sun May 11, 2014 10:11 am

Re: Cinnamon with XRDP Remote Desktop

Postby kroonweb on Sun May 11, 2014 11:36 am

XCFE, Cinnamon does not work for me, Mate is showing a nice desktop

sudo nano /etc/xrdp/startwm.sh
~
#. /etc/X11/Xsession
#startxcfe
#cinnamon
mate-session
~
sudo /etc/init.d/xrdp restart

But i want to login to my own user session! with current running apps!! This is not an option and very unprofessional, makes Cinnamon unusable
kroonweb
Level 1
Level 1
 
Posts: 2
Joined: Sun May 11, 2014 10:11 am

Re: Cinnamon with XRDP Remote Desktop

Postby phill1978 on Mon May 12, 2014 8:49 am

Has anyone logged a bug or Tried to get in touch with either the mint team or clem on segfault ?

forums are only for users, very rare for a dev to pop in here and try fix an issue or raise a flag


thanks
phill1978
Level 3
Level 3
 
Posts: 170
Joined: Fri Apr 22, 2011 5:19 am

Re: Cinnamon with XRDP Remote Desktop

Postby linuxmint-j on Mon May 12, 2014 10:33 pm

Excuse the ignorance, but how does one log a bug for Cinnamon (or try to get in touch with either the mint team or clem on segfault)?
linuxmint-j
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 22, 2013 10:52 am

Re: Cinnamon with XRDP Remote Desktop

Postby treuben on Sun May 18, 2014 11:28 pm

As far as I can tell (and that isn't all that far but hey) modern remote sessions shouldn't be running with vnc servers anywhere in the software stack - because they're outdated and slow. rdp or xrdp or nx is prefereable but I get blank screens upon connecting (I get the "just connecting" logo with the atom picture and sesman-X11rdp) but after logging in to that only black screen with mouse cursor.. happy to provide any error messages should anyone feel like helping me sort it out but my .xsession-errors seems empty. A lot of people would probably use mint as a home server and contribute to the community too if there was a nice nx or rdp guide for mint. Has anyone had any success (without vnc!)?

-using mint 17RC
treuben
Level 1
Level 1
 
Posts: 4
Joined: Thu May 15, 2014 7:29 pm

Re: Cinnamon with XRDP Remote Desktop

Postby treuben on Mon May 19, 2014 12:01 am

below is the contents of my .xsessions-errors..I notice that this mentions this problem with Cinnamon too..

https://code.google.com/p/chromium/issu ... ?id=222732

I used "cinnamon2d" in my .xsession

Xsession: X session started for at Mon May 19 13:19:21 CST 2014
localuser:User being added to access control list
Script for none started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Script for none started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
Window manager warning: Software rendering detected: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
Window manager warning: Missing composite extension required for compositing
treuben
Level 1
Level 1
 
Posts: 4
Joined: Thu May 15, 2014 7:29 pm

Re: Cinnamon with XRDP Remote Desktop

Postby vrkalak on Mon May 19, 2014 12:48 am

** Please, don't "resurrect" an old Topic Thread (this topic is almost 2 years old)

Start another Topic Thread if it is needed. :)

......... vrkalak (Forum Admin)
Image
:: LinuxMint-Debian-Edition (Fluxbox) :: Manjaro/Arch (Xfce) ::
Registered Linux User: #497031 :: DeviantART Page
User avatar
vrkalak
Level 10
Level 10
 
Posts: 3236
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: Cinnamon with XRDP Remote Desktop

Postby Tim-int on Mon Jul 21, 2014 9:58 am

I really don't see the point in starting a new thread with the exact same problem that has never been solved, just because it's few years old.
If that would help, all the posters here could open a new thread, but I doubt it.

BUT, I opened a new one at viewtopic.php?f=208&t=173739. I suggest it be for NEW xrdp versions (it's 0.9.0 now) and that this thread remains for OLD xrdp versions (0.6.0 in Mkint 17).

Related problem with remote session with X2GO: viewtopic.php?f=208&t=119355
Bug reports: https://bugs.launchpad.net/linuxmint.
There is this old bug: https://bugs.launchpad.net/linuxmint/+bug/890042
Tim-int
Level 1
Level 1
 
Posts: 38
Joined: Tue Nov 29, 2011 2:30 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 2 guests