libcairo2 not configured?! [SOLVED - self-corrected(!)]

Questions about applications and software
Forum rules
Before you post please read this

libcairo2 not configured?! [SOLVED - self-corrected(!)]

Postby Xheralt on Sun Dec 02, 2012 4:45 pm

Near-virgin install of Nadia, edit: 32-bit, Cinnamon desktop, from the 14.0 iso, fully updated as of this date.

According to my Synaptic listing, "libcairo2 1.12.2-1ubuntu2.1" is installed, but when I invoke GDebi to install google-chrome-stable_current_i386.deb, the installation does not complete, with the following message:

Code: Select all
Preparing to replace google-chrome-stable 23.0.1271.95-r169798 (using .../google-chrome-stable_current_i386.deb) ...
Unpacking replacement google-chrome-stable ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libcairo2 (>= 1.6.0); however:
  Package libcairo2:i386 is not configured yet.

dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured


So, why is this lib not configured, as installed, and how does one configure it?

The "why" may remain a mystery, but here's what fixed it: I went to install the chromium broswer, figuring that with it being a close cousin of chrome, installing it might straighten out their common resources (if any). This trick has worked in other distros. "Applying" the 3 files for chromium generated a bit of a surprise....there was a backlog of other files, possibly incomplete/broken installs....including libcairo...that Synaptic then dealt with! Once the two dozen other files installed/configured, Google Chrome was installed and ready to go.
Xheralt
Level 1
Level 1
 
Posts: 9
Joined: Sat Jul 14, 2007 5:11 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 21 guests