Wow. LM 14 Nadia just won't boot to save my life.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Wow. LM 14 Nadia just won't boot to save my life.

Postby jdabbott51 on Sun Dec 02, 2012 10:54 pm

Hey all, I'm a firm supporter of open source software and while I've spent a great deal of reading on Linux, it's history and it's subsequent future, I've always been reluctant to install it. I use fedora in a virtual box environment to mess around with the gedit program trying to teach myself programming. Then one fine day on Reddit I saw someone post some screen shots of Linux Mint 14 and was absolutely enthralled. So I downloaded the iso for Linux Mint 14 Nadia for 64 bit (and yes my machine is 64 bit).

Immediately I had problems even with the image on the installation CD. The only way I could even test LM14 was in compatibility mode. Nevertheless, it was awesome, beautiful, everything I wanted. So I clicked on the Install Linux icon, and selected for a dual boot.

However, once grub started and I selected LM14, there was a blinking cursor, then darkness, then there's this message that modules are missing, and it's unable to find dev/sda6 which is the partition where my installation is housed. So then I scoured the internet for solutions. Here's what I tried:

1.) in Grub you can select "e" and edit the command lines for Linux Mint, Boot. Instead of putting root=UUIE="a slew of characters" (or something like that) I'm supposed to put in root=dev/sda6. I tried this, and still no luck. All that happened was that the boot took forever, and served me up a slew of booting messages with respect to whether the system was finding usb connections or not, before it seized at the instafrm command line and wouldn't let me even type in a message.

2.) I opened up grub.cfg with pluma to make changes that one forum had recommended. But the file was so write-protected I couldn't do anything. In the actual comments of the grub.cfg file it warns that it's a generated file and can't be changed except by tweaking other files.

3.) SO then I put in the installation disk and start in compatibility mode again. I install the repair-boot program through terminal. I run the program. It does it's thing. Then tells me it's all fixed and I should reboot now. So I do reboot, I'm back at grub. I run LM14. Again, blinking cursor and then the message of the missing modules and the inability to find /dev/sda6.

It seems clear it just can't find my partition, even though the installation was the one who created the partition in the first place. Perhaps my windows OS is just being a jackass and thwarting any other OS installation at every which way? Also, I did some serious research on the internet and found this bug to be prevalent on all linux platforms. One writer says that one needs to replace the initrd.img file with the same file from a previous stable version. As this is my first install, of course I don't have a previous stable version to pick files from. I'm a bit demoralized with my first foray into the world of Linux and I was hoping I could poke around a distro that might be a bit more less mainstream than Ubuntu.

One last thing: One good thing about the boot-repair program was it gave me a full on report of my entire system and the actions it took. You can see it here at: http://paste2.org/p/2553971.

My guess is that this installation -especially for 64 bit - just isn't that stable. At least not for a dual boot with Windows Vista. Darn. :(
jdabbott51
Level 1
Level 1
 
Posts: 3
Joined: Sun Dec 02, 2012 10:25 pm

Linux Mint is funded by ads and donations.
 

Re: Wow. LM 14 Nadia just won't boot to save my life.

Postby slipstick on Mon Dec 03, 2012 6:50 pm

I'm a total noob at Linux, so I can't really offer a suggestion to fix your problem, but I did notice in your boot-repair listing (down at the bottom) that FlexNet was detected on your disk. I've heard that FlexNet can cause problems booting Linux, so you might get more info by doing a search on FlexNet. Also maybe some gurus here will know what to do about FlexNet, or if that is really your problem.

EDIT: I found some info on FlexNet on the Ubuntu forum:
http://ubuntuforums.org/showthread.php?t=1661254
User avatar
slipstick
Level 2
Level 2
 
Posts: 57
Joined: Sun Oct 21, 2012 9:56 pm

Re: Wow. LM 14 Nadia just won't boot to save my life.

Postby jdabbott51 on Mon Dec 03, 2012 10:54 pm

Well you're a seasoned noobie since I think your observation on the FlexNet is right on. :) The sad thing is that the work around for flexnet, and that darned data in sector 32, is a bit too precarious to go trying to erase without making me a little nervous. I did have a feeling it was something owing to this. It's like Windows dropped a pendulum in the middle of my harddrive. I guess the thing that confuses me is (and I could be wrong here) that don't most systems that retail with windows pre-installed have Flexnet? The documentation on this problem is really limited (a google search only turned up the link you provided and nothing else), whereas other grub bugs seem to have an extraneous amount of entries on the internet and this issue with FlexNet is quite a doozy of an obstacle to get past. I guess linux will have to wait until the day I order a bare bones kit and do my own computer build. Oh well . . Thanks for your reply, I appreciate it.
jdabbott51
Level 1
Level 1
 
Posts: 3
Joined: Sun Dec 02, 2012 10:25 pm

Re: UPDATE (several months later)

Postby jdabbott51 on Wed May 15, 2013 10:42 am

Just wanted to do a follow up to this, just in case another poor mad soul finds themselves with the same machine and the same predicament. Just to correct from above, FlexNet is not the problem. I figured out the problem which is due to APIC. I figured this out when trying to boot Knoppix, and the issue with APIC became evident, and there was a very simple boot cheat to get around it. On the Gateway DX2407-03 you can't disable APIC from BIOS (believe me I've tried), so . . . APIC needs to be disabled from the grub menu. When presented with the grub menu, hit "e" to edit the grub code. directly after the word "splash," add the following text:

nolapic acpi=off noapic

Now my next issue, is that I'd really like to be able to take advantage of APIC's resource allocation. Does anyone know if any of the mountains of driver updates following the successful boot of Linux Mint 14 resolve this issue? Or is there something I can do to the kernel to make it APIC friendly? Is it common for many Linux Distros to not be compatible with APIC?
jdabbott51
Level 1
Level 1
 
Posts: 3
Joined: Sun Dec 02, 2012 10:25 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 16 guests