Keyboard shortcuts not working ( mint 14 cinnamon )

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby aelfinn on Sun Dec 02, 2012 2:26 pm

aelfinn wrote:Has someone brought this to the attention of Clem or whoever and got a reply?

Anybody?
LM15 C64
Acer Aspire 1810TZ
aelfinn
Level 3
Level 3
 
Posts: 188
Joined: Thu Dec 11, 2008 2:11 pm

Linux Mint is funded by ads and donations.
 

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby goinglinux on Sun Dec 02, 2012 6:49 pm

aelfinn wrote:
aelfinn wrote:Has someone brought this to the attention of Clem or whoever and got a reply?

Anybody?

I just went to the bug at https://bugs.launchpad.net/linuxmint/+bug/1077930 and added my confirmation that this bug, originally filed against the Mint 14 Cinnamon (Nadia) release candidate, is still present in the final release. So far the importance of the bug on Launchpad has not been determined, and it has not been assigned to anyone to be fixed!
____________________
Larry Bushey
· Going Linux Podcast ·
http://goinglinux.com
Mint 17 Cinnamon Edition 64-bit · System 76 Galago UltraPro · Core i7 · 16GB RAM · 120 GB mSATA · 512 GB SSD
User avatar
goinglinux
Level 1
Level 1
 
Posts: 38
Joined: Wed May 05, 2010 9:42 am
Location: USA

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby aelfinn on Sun Dec 02, 2012 7:45 pm

goinglinux wrote:I just went to the bug at https://bugs.launchpad.net/linuxmint/+bug/1077930 and added my confirmation that this bug, originally filed against the Mint 14 Cinnamon (Nadia) release candidate, is still present in the final release. So far the importance of the bug on Launchpad has not been determined, and it has not been assigned to anyone to be fixed!

Well, now that is something I have been saying for a while: bug tracking seems to be a mess. For RCs, bugs are to be reported in the comments to the announcement post; some people will always post something worth looking at in the forums; and then there is Launchpad. I tried the latter, the bug was never assigned to anyone and never resolved in that version of Mint. In the forums, there seems to be nobody who will systematically scour posts for reliable bug reports, see to their being fixed, and post on the thread what action is being taken and whether a solution has been found. Same thing for the blog posts: There are scattered edits by Clem, which are fine as far as they go; but there needs to be a substantial response to every serious report. Otherwise people will get discouraged and not make the effort anymore, thereby ridding Mint of a potentially huge resource. And it could be fixed with some manageable but serious planning.
LM15 C64
Acer Aspire 1810TZ
aelfinn
Level 3
Level 3
 
Posts: 188
Joined: Thu Dec 11, 2008 2:11 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby electrickite on Tue Dec 04, 2012 12:34 am

I also ran into this bug. Here's a workaround until this gets resolved. It all stems from the fact that Cinnamon has tried to move the keyboard settings into its own configuration panel, but GNOME 3 changed the way these settings are stored. My solution was just to re-enable the old GNOME keyboard panel in System Settings.

First start editing a new .desktop file. (I use vi, use whatever editor you prefer)
Code: Select all
$ sudo vi /usr/share/applications/keyboard-settings.desktop


Add the folowing text to the new file and save.
Code: Select all
[Desktop Entry]
Name=Keyboard
Comment=Change keyboard settings
Exec=gnome-control-center keyboard
Icon=preferences-desktop-keyboard
Terminal=false
Type=Application
StartupNotify=true
Categories=GNOME;GTK;Settings;HardwareSettings;X-GNOME-Settings-Panel;
OnlyShowIn=GNOME;Unity;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-control-center
X-GNOME-Bugzilla-Component=keyboard
X-GNOME-Bugzilla-Version=3.4.2
X-GNOME-Settings-Panel=keyboard[Desktop Entry]
Name=Keyboard
Comment=Change keyboard settings
Exec=gnome-control-center keyboard
Icon=preferences-desktop-keyboard
Terminal=false
Type=Application
StartupNotify=true
Categories=GNOME;GTK;Settings;HardwareSettings;X-GNOME-Settings-Panel;
OnlyShowIn=GNOME;Unity;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-control-center
X-GNOME-Bugzilla-Component=keyboard
X-GNOME-Bugzilla-Version=3.4.2
X-GNOME-Settings-Panel=keyboard
# Translators: those are keywords for the keyboard control-center panel
Keywords=Shortcut;Repeat;Blink;
X-Ubuntu-Gettext-Domain=gnome-control-center-2.0
# Translators: those are keywords for the keyboard control-center panel
Keywords=Shortcut;Repeat;Blink;
X-Ubuntu-Gettext-Domain=gnome-control-center-2.0


This should create a 'Keyboard' optoion in System Tools > System Settings. Custom shortcuts added to this panel have worked for me so far!
electrickite
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 28, 2012 1:57 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby viking777 on Tue Dec 04, 2012 5:50 am

Excellent job electrickite - works perfectly. Thankyou on behalf of all us 'shortcut-less' citizens :D

Maybe you should add this workround to the bug report - it might spur them into doing something about it.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby aelfinn on Tue Dec 04, 2012 6:27 am

electrickite wrote:I also ran into this bug. Here's a workaround until this gets resolved.

Thanks for that!

Although it doesn’t seem to resolve my particular problem of trying to assign shortcuts using the Windows, or Super, key. In LM13’s Cinnamon edition, that was still possible. Or is it something about your workaround that prevents that from happening?
LM15 C64
Acer Aspire 1810TZ
aelfinn
Level 3
Level 3
 
Posts: 188
Joined: Thu Dec 11, 2008 2:11 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby colin-m on Tue Dec 04, 2012 6:33 am

I would like to add my thanks to electrickite for a great work around.

As the originator of the launchpad bug report mentioned in these comments, I hope that this bug will get sorted before the next version ol Linux Mint.
colin-m
Level 1
Level 1
 
Posts: 3
Joined: Tue Dec 04, 2012 6:16 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby captainmorgan on Tue Dec 04, 2012 11:10 am

electrickite's fix didn't work for me. Upon adding the desktop file, I didn't get anything new under Menu->System Tools->System Settings. I did get a second "keyboard" option under Menu->Preferences, but it just brings up the same dialog as System Tools->System Settings that contains things like "Brightness and Lock", etc.

Am I missing something? I even tried running "gnome-control-center keyboard" from the terminal, but it still just brings up that same "System Settings" dialog. Additionally, I get an error on the console that says
Code: Select all
** (gnome-control-center:3226): WARNING **: Could not find settings panel "keyboard"

** (gnome-control-center:3226): WARNING **: Could not load setting panel "keyboard": Unknown error
User avatar
captainmorgan
Level 1
Level 1
 
Posts: 14
Joined: Thu May 03, 2012 9:28 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby dnixx on Tue Dec 04, 2012 11:36 am

captainmorgan:

That second "Keyboard" option is the one you should launch. It contains two tabs -- "Typing" and "Shortcuts". Go to Shortcuts and select Custom Shortcuts. Then add shortcuts.

This is not the same as Cinnamon Settings -> Keyboard.

Edit: Sorry, I overlooked the last part of your message. Not sure about that one.

electrickite: Thanks!
dnixx
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 10:33 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby captainmorgan on Tue Dec 04, 2012 12:10 pm

OK, my dumb mistake. When I copied the text for the desktop file I didn't copy all the way down, just the visible part. Fixed that.

I now have the dialog you mentioned, but I'm still having trouble. When I first opened the dialog and went to the "Keyboard Shortcuts", under "Custom Shortctus" I saw the shortcuts I'd already defined in the Cinnamon dialog: "Launch Terminal" [F3] and "Launch GViM" [F4]. So, I figured I better recreate them using the new tool. I deleted those shortcuts, closed the dialog, and opened it back. At that point a shortcut had appeared under "Custom Shortcuts" that was "Launch Terminal [Ctrl-alt-t]. I don't know where this came from, but I seem to remember this used to a built-in shortcut. Lo and behold, pressing [Ctrl-alt-t] launched my terminal. So I deleted that and created my shortcuts again, the same was as before ([F3] and [F4]). No matter what I tried (restarting Cinnamon, logout-login) those shortcuts wouldn't work.

At that point I thought perhaps function keys would work, so I switched terminal back to [Ctrl-alt-t] and changed GViM to [Ctrl-alt-v]. Terminal works, but GViM does not.

Am I missing something, or does this fix only get us the ability to change shortcuts for built-in actions, not define totally custom ones?
User avatar
captainmorgan
Level 1
Level 1
 
Posts: 14
Joined: Thu May 03, 2012 9:28 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby dnixx on Tue Dec 04, 2012 12:25 pm

I can confirm that I'm able to map the F3 key to a custom action (successfully launched filezilla and gnome-terminal). I don't need to log out or restart Cinnamon.

So I'm not sure why you're still having trouble. Did you try to remove all the custom shortcuts from Cinnamon Settings as well?
dnixx
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 10:33 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby viking777 on Tue Dec 04, 2012 12:28 pm

I think you may have made a mistake with the command for gvim. Does it really have 3 capital letters in a 4 letter command? I doubt it. I don't know for sure because I have never even heard of it before right now, but it is something to look at anyway. Run the command you are using in a terminal first. Does it run from there?

There is nothing wrong with electrickite's solution, I have created several new custom shortcuts with it, they all work perfectly.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby captainmorgan on Tue Dec 04, 2012 12:36 pm

@dnixx - Thanks for the confirmation
@viking177 - I was using GViM for the display name, not the command. For the command I used "/usr/bin/gvim"

Turns out I was using the wrong one of the two "Keyboard" icons. It works now. Sorry for all the static, and great fix electrickite!
User avatar
captainmorgan
Level 1
Level 1
 
Posts: 14
Joined: Thu May 03, 2012 9:28 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby dnixx on Tue Dec 04, 2012 12:45 pm

captainmorgan: change the two instances of "Name=Keyboard" in electrickite's file to "Name=Keyboard GNOME". That way you won't select the wrong one from the menu :) (If you make this change, select the menu item that says "Keyboard GNOME" from now on.)
dnixx
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 10:33 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby lurkatron on Tue Dec 04, 2012 1:14 pm

thanks for this workaround. this was bugging me
lurkatron
Level 3
Level 3
 
Posts: 101
Joined: Tue Nov 01, 2011 2:18 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby captainmorgan on Tue Dec 04, 2012 1:30 pm

@dnixx I just thought of that after I figured out my mistake! I probably should have done that to begin with. Also, not trying to apply a work-around in the middle of work while bouncing from computer-to-computer might increase my chance of success. :oops:
User avatar
captainmorgan
Level 1
Level 1
 
Posts: 14
Joined: Thu May 03, 2012 9:28 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby norumaru on Wed Dec 05, 2012 8:26 am

For the record, and in case anyone else has the same problem as I have, a useable workaround for workspace switching is to install wmctrl (it's in software center) and set custom shortkeys. First, open a terminal and look up how wmctrl adresses your active workspaces with
Code: Select all
wmctrl -d

The first number in each line is the number you can use to steer wmctrl to the corresponding workspace. Normally it is one number smaller than the workspace number (0 for workspace 1 and so on). Then, go to keyboard settings (works under cinnamon provided settings) and create custom shortcuts that call up the following commands:
Code: Select all
wmctrl -s 0
for workspace 1,
Code: Select all
wmctrl -s 1
for workspace 2 and so forth (provided these numbers are the same on your computer) and set them to any key combinations you wish to use. Super key does work for me if I hold it down and press the other key twice instead of once, by the way.
norumaru
Level 1
Level 1
 
Posts: 21
Joined: Tue Aug 24, 2010 4:08 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby aelfinn on Wed Dec 05, 2012 4:20 pm

Sorry for repeating myself, but this problem persists depite the workaround generally working:

It doesn’t seem to resolve my particular problem of trying to assign shortcuts using the Windows, or Super, key. In LM13’s Cinnamon edition, that was still possible. Or is it something about your workaround that prevents that from happening?
LM15 C64
Acer Aspire 1810TZ
aelfinn
Level 3
Level 3
 
Posts: 188
Joined: Thu Dec 11, 2008 2:11 pm

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby captainmorgan on Fri Dec 07, 2012 3:31 pm

Looks like there is a pull request to fix this bug:

https://github.com/linuxmint/Cinnamon/pull/1405
User avatar
captainmorgan
Level 1
Level 1
 
Posts: 14
Joined: Thu May 03, 2012 9:28 am

Re: Keyboard shortcuts not working ( mint 14 cinnamon )

Postby swm on Sat Dec 08, 2012 11:47 am

Thanks for the workaround electrickite !
swm
Level 1
Level 1
 
Posts: 4
Joined: Thu May 10, 2012 8:14 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 7 guests