AppleKeyboard for Mint [RESOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

AppleKeyboard for Mint [RESOLVED]

Postby Lolinder on Mon Dec 03, 2012 5:34 pm

I've been using an apple keyboard for a while now, and I've quite liked the feel of it. The only difficulty was that the fn-key does the opposite of what it typically does on PC keyboards, allowing the f1-f9 keys to be used, rather than raising the volume or whatnot. The issue and the solution for Ubuntu are described here.

Working on the assumption that Mint was close enough to Ubuntu for it to work, I ran through that procedure, only to have my keyboard stop working when I rebooted. So I'm assuming that this is not the solution for Mint, and am wondering what is.

EDIT: As a temporary solution, the command listed on the above page did work:
Code: Select all
$ echo 2 | sudo tee /sys/module/hid_apple/parameters/fnmode


This resets when the system is rebooted, however, and would like to find a permanent solution.
Last edited by Lolinder on Wed Dec 05, 2012 6:22 pm, edited 1 time in total.
Lolinder
Level 1
Level 1
 
Posts: 9
Joined: Sun Dec 02, 2012 1:01 pm

Linux Mint is funded by ads and donations.
 

Re: AppleKeyboard for Mint

Postby AlbertP on Mon Dec 03, 2012 5:42 pm

This isn't any different from Ubuntu. It is rather an upstream Ubuntu bug instead of a Mint problem.

The command you mentioned only changes it once; to have it persist when rebooting, you can put options hid_apple fnmode in /etc/modprobe.d as described.
Note that this description is somewhat confusing. It lists 3 ways to do the same, only separated by small texts "With modprobe.d, With sysfs.conf, With rc.local". You only need to do one of them.

Note that the how-to has not been updated for Ubuntu 11.10, 12.04 or 12.10, so it may not work as described on Mint 12 and later..
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6502
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: AppleKeyboard for Mint

Postby Lolinder on Mon Dec 03, 2012 6:29 pm

AlbertP wrote:This isn't any different from Ubuntu. It is rather an upstream Ubuntu bug instead of a Mint problem.

The command you mentioned only changes it once; to have it persist when rebooting, you can put options hid_apple fnmode in /etc/modprobe.d as described.
Note that this description is somewhat confusing. It lists 3 ways to do the same, only separated by small texts "With modprobe.d, With sysfs.conf, With rc.local". You only need to do one of them.

Note that the how-to has not been updated for Ubuntu 11.10, 12.04 or 12.10, so it may not work as described on Mint 12 and later..


Well, I'd already followed these instructions:
With .conf file (Recommended)
1. Append the configuration line to the file /etc/modprobe.d/hid_apple.conf creating it if necessary:
Code: Select all
$ echo options hid_apple fnmode=2 | sudo tee -a /etc/modprobe.d/hid_apple.conf

2. Notify the hid_apple module to reload its configuration
Code: Select all
$ sudo update-initramfs -u

3. Reboot
Code: Select all
$ sudo reboot



This caused the keyboard to not work at all on reboot. I decided to figure out why before proceeding through the Ubuntu instructions.

Also: I did this on Ubuntu 12.04 and it worked fine, so the instructions are still applicable.
Lolinder
Level 1
Level 1
 
Posts: 9
Joined: Sun Dec 02, 2012 1:01 pm

Re: AppleKeyboard for Mint

Postby AlbertP on Tue Dec 04, 2012 5:24 pm

The first command did work, so it accepts the fnmode setting. Probably you made a typo which caused the hid_apple module to read a faulty option (and yes, drivers can fail to load because of options they don't understand).

You can also just use gedit to edit the file instead of using tee in terminal to add it.
Code: Select all
gksudo gedit /etc/modprobe.d/hid_apple.conf

I think this is the correct way to add the option:
Code: Select all
options hid_apple fnmode=2
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6502
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: AppleKeyboard for Mint

Postby Lolinder on Tue Dec 04, 2012 8:52 pm

I just checked the command I issued, and it was correct. Trying what you suggested, as soon as I restart.

UPDATE: it worked! Thanks!
Lolinder
Level 1
Level 1
 
Posts: 9
Joined: Sun Dec 02, 2012 1:01 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 20 guests