No sound with headphones

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

No sound with headphones

Postby Lonecricket on Mon Dec 03, 2012 3:15 pm

I have headphones that work with Windows but I've tried Ubuntu and Mint with both of them having the sound not working. I've messed around with things like alsamixer and such but I don't even know where to start now as I've searched and tried multiple things I found on Google.
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Linux Mint is funded by ads and donations.
 

Re: No sound with headphones

Postby hylke on Mon Dec 03, 2012 7:24 pm

1. Have you tried to change the settings in "Preferences" > "Sound"? It might have been silenced.
2. Your soundcard is recognised? "Administration" > "System information" > "PCI devices"
3. Maybe you need to install an additional driver? "Preferences" > "Additional drivers".

I'm a newbie myself, so if this doesn't work, don't give up and await the answer of an expert...
hylke
Level 1
Level 1
 
Posts: 5
Joined: Thu Mar 01, 2012 11:08 pm

Re: No sound with headphones

Postby Lonecricket on Tue Dec 04, 2012 11:54 am

It had 2 audio devices under PCI devices. The first one says Creative Labs SB X-FI. The second one says Advanced Micro Devices (AMD) nee ATI Juniper HDMI Audio [Radeon HD 5700 Series]. Under "Preferences" I don't have "Additional Drivers" in the menu. Also when playing something on youtube or such in volume control I can see the sound bar moving so its at least trying to work lol. How do I install snd-ctxfi driver from the terminal?
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Re: No sound with headphones

Postby Lonecricket on Tue Dec 04, 2012 7:50 pm

Here is a list of my hardware. I am trying to get my gaming headphones to work. They are plugged in to the front of the computer using the usb ports. It has 2 connections. What and which devices and hardware am I supposed to use under Preferences>Sound ? Right now the only one with more than one bar to control in alsamixer is Creative X-Fi now that I haven't been getting any help. So I have no idea where I am at with all this.

System: Host: linuxmint Kernel: 3.5.0-17-generic i686 (32 bit) Desktop: N/A Distro: Linux Mint 14 Nadia
Machine: System: Dell product: XPS 730
Mobo: Dell model: 0UU795 version: A00 Bios: Dell version: 1.0.5 date: 09/18/2008
CPU: Dual core Intel Core2 Duo CPU E8400 (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx)
Clock Speeds: 1: 3000.073 MHz 2: 3000.073 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series]
X.Org: 1.13.0 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1680x1050@60.0hz
GLX Renderer: Gallium 0.4 on AMD JUNIPER GLX Version: 2.1 Mesa 9.0
Audio: Card-1: NVIDIA MCP55 High Definition Audio driver: snd_hda_intel Sound: ALSA ver: 1.0.25
Card-2: Creative Labs SB X-Fi driver: snd_ctxfi
Card-3: Advanced Micro Devices [AMD] nee ATI Juniper HDMI Audio [Radeon HD 5700 Series] driver: snd_hda_intel
Card-4: OmniVision Monitor Webcam driver: USB Audio
Network: Card-1: NVIDIA MCP55 Ethernet driver: forcedeth
IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1e:c9:56:65:d5
Card-2: NVIDIA MCP55 Ethernet driver: forcedeth
IF: eth1 state: down mac: 00:1e:c9:56:65:d6
Drives: HDD Total Size: 500.1GB (15.9% used) 1: id: /dev/sda model: WDC_WD5000AAKS size: 500.1GB
Partition: ID: / size: 15G used: 4.2G (31%) fs: ext4
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 44.0C mobo: N/A gpu: 62.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 153 Uptime: 21 min Memory: 457.6/4032.8MB Client: Shell inxi: 1.8.4
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Re: No sound with headphones

Postby ElStellino on Tue Dec 04, 2012 8:20 pm

Have a look at my post, I had a similar problem and I solved it installing the 3.6.7 kernel
I had previously the 3.2.0, I installed then the 3.5.0-17 (same as yours) but still no joy, but 3.6.7 solved the issue.

viewtopic.php?f=90&t=117521

Have a read at the thread, there is a reply that maybe can help you, it didn't help me, though.

Or try to follow my route installing the new Kernel
Should the 3.6.7 kernel not work you can always restart the computer and in GRUB you will select Previous Versions of Linux.

There you will type in terminal:
Code: Select all
sudo apt-get purge linux-image-3.6.7*
ImageImageImageImage
Core i3 530 2.93Ghz
4Gb Ram Dual Channel.
User avatar
ElStellino
Level 1
Level 1
 
Posts: 43
Joined: Thu Nov 08, 2012 9:54 am
Location: Tenerife

Re: No sound with headphones

Postby Lonecricket on Tue Dec 04, 2012 11:16 pm

Edit: Nevermind thanks! I followed what you did and got it installed however I'm afraid my sound is still messed up from messing with it. How do I find out which device I should be using? My headphones also might not be supported as I use a gaming headset based on Windows but I tried using every day headphones that you use for an ipod and such and still no go.
Edit: I just remembered something else. The headset I'm trying to use, worked on a laptop I had installed a newer version of Ubuntu on.
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Re: No sound with headphones

Postby ElStellino on Wed Dec 05, 2012 12:01 pm

Unfortunately I wouldn't have much more to add to what hylke said already. I am a newbie also, my knowledge/experience aren't that extended yet.

I could post you what my Alsamixer shows, but I know you are using USB headphones, I don't know if you can change anything from there...
Actually, try to type in panel

Code: Select all
lsusb


and check if the headset is recognised, because you can tamper alsamixer ad infinitum but if the computer doesn't see the USB device you won't obtain anything.

I hope this helps, I'm your supporter even if I don't have a clue either, more or less :D
ImageImageImageImage
Core i3 530 2.93Ghz
4Gb Ram Dual Channel.
User avatar
ElStellino
Level 1
Level 1
 
Posts: 43
Joined: Thu Nov 08, 2012 9:54 am
Location: Tenerife

Re: No sound with headphones

Postby Jim1938 on Wed Dec 05, 2012 12:27 pm

...
I have Mint 13 xfce.
This procedure also works for other Debian based distros.

Left click on your sound applet.
Left click on "sound settings".
Mixer window opens.
At bottom Left click on "Select Controls" and
select controls you wish to be using.
Close.
Adjust volumne levels.
Quit.
Test.
Hope this works for you.
If it works, please mark your question as [SOLVED].

Jim1938
...
Wirth's law - Software is getting slower more rapidly than hardware becomes faster.
User avatar
Jim1938
Level 2
Level 2
 
Posts: 79
Joined: Thu Nov 29, 2012 8:49 pm
Location: USA

Re: No sound with headphones

Postby Lonecricket on Thu Dec 06, 2012 9:29 am

I used lsusb and I don't think its listed. I have a Turtle Beach gaming headset. This is what was in the terminal.
lsusb
Bus 001 Device 004: ID 413c:5305 Dell Computer Corp.
Bus 001 Device 005: ID 0424:2512 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 006: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
Bus 002 Device 002: ID 046d:c069 Logitech, Inc. M500 Laser Mouse
Bus 002 Device 003: ID 045e:00dd Microsoft Corp. Comfort Curve Keyboard 2000 V1.0
Bus 002 Device 004: ID 0955:000a NVidia Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 05a9:2643 OmniVision Technologies, Inc. Monitor Webcam
Bus 001 Device 009: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 010: ID 0644:0201 TEAC Corp.
Bus 001 Device 011: ID 046d:0b05 Logitech, Inc.
Bus 001 Device 012: ID 413c:8130 Dell Computer Corp.
Bus 001 Device 013: ID 046d:c718 Logitech, Inc.
Bus 001 Device 014: ID 046d:c719 Logitech, Inc.
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Re: No sound with headphones

Postby Jim1938 on Fri Dec 07, 2012 4:53 am

...
I use Mint 13 LTS on my new pc and believe it is more stable than 14.
I also believe in NOT upgrading too soon and NOT upgrading
without a very very good reason.
I'm from the "if it works, don't fix it" club.
You might want to try 13 live CD.
I tried 14 live CD and found it lacking.

I suggest that you unplug as many usb devises as you can
but leaving your headset pluged in,
reboot, and then run lsusb again.

Maybe plug the headset into a different usb port, reboot, and run lsusb again.

Then you should be able to determine whether your headset is seen by your pc.
Sometimes swapping device connections causes the pc to see devices differently.

Remember to reboot between tests.

Good luck
...
Wirth's law - Software is getting slower more rapidly than hardware becomes faster.
User avatar
Jim1938
Level 2
Level 2
 
Posts: 79
Joined: Thu Nov 29, 2012 8:49 pm
Location: USA

Re: No sound with headphones

Postby Lonecricket on Sat Dec 08, 2012 8:50 pm

I just tried using regular headphones today after the changes and still go no sound, not even feedback. I also had no sound when I had Ubuntu installed on this computer so could it be a hardware problem?
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Re: No sound with headphones

Postby Lonecricket on Sun Dec 23, 2012 3:20 am

Can anyone help me? I upgraded to Nadia and still have no sound. The sound is playing, I can see the bar moving and nothing is muted. Someone want to guide me through this?
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Re: No sound with headphones

Postby Catbuntu on Sun Dec 23, 2012 9:18 am

I had the same problem, until I found a solution. Perhaps it only works for my soundcard, but anyway, that's what I did.
Basically edit /etc/modprobe.d/alsa-base.conf with this command:
Code: Select all
 $ gksudo gedit /etc/modprobe.d/alsa-base.conf

And add this line to the bottom:
Code: Select all
  options snd-hda-intel model=auto position_fix=1 enable=yes

Hope it fixes your problems.

Catbuntu
Image
Acer Aspire 6930.
CPU→Intel Core 2 Duo @ 2,00GHz. RAM3GB. Graphics card→NVIDIA GeForce 9300M GS. O.S.→Linux Mint 14.1 «Nadia» 64-bit Cinnamon ed.
Catbuntu's Bloggie
User avatar
Catbuntu
Level 2
Level 2
 
Posts: 73
Joined: Tue Oct 23, 2012 2:37 pm
Location: Catalunya

Re: No sound with headphones

Postby Lonecricket on Sun Dec 23, 2012 10:26 am

[Solved/]That wasn't it but it's solved! The front jack wasn't working. I had already tried this but I must have had the wrong sound settings the first go 'round.
Lonecricket
Level 1
Level 1
 
Posts: 12
Joined: Sun Dec 02, 2012 8:40 pm

Re: No sound with headphones

Postby Jim1938 on Sun Dec 23, 2012 12:45 pm

...
Glad to see you found a solution and your headset now works.

Please edit your first post's subject as [SOLVED]
...
Wirth's law - Software is getting slower more rapidly than hardware becomes faster.
User avatar
Jim1938
Level 2
Level 2
 
Posts: 79
Joined: Thu Nov 29, 2012 8:49 pm
Location: USA

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], Hecubus, karlchen, niowluka and 29 guests