Can't run Lilypond once installed, help please

Questions about applications and software
Forum rules
Before you post please read this

Can't run Lilypond once installed, help please

Postby alez on Tue Dec 04, 2012 3:25 pm

Hi All,

I've installed Lilypond using the "Software Manager". This software generates a music sheet in PDF from a plain text file containing its description in a proprietary language. I was expecting that double clicking on a source file like say my_file.ly would automatically generate my_file.pdf in the same folder, much like the Windows version (port) does.

However, I get this instead:
Image

Show other applications produces this list (no "Lilipond", "GNU Lilypond", etc. there):
Image

Find applications online produces an error in two steps:
Image
Image

Somehow, the file type (MIME type?) is identified correctly (Lilypond music sheet, see 3rd pic), but I suppose maybe "Nautilus" is unaware that Lilypond is actually installed on my machine.

Indeed the application doesn't show on the list above, and also I've noticed it doesn't show on "Menu" -> "All Applications":
Image

It does show as correctly installed on the "Software Manager", though.

I'm using Mint's Cinammon variant, which I'm extremely impressed with so far.

Thanks in advance for your help.

Alex
alez
Level 1
Level 1
 
Posts: 3
Joined: Sat Nov 03, 2012 4:58 pm

Linux Mint is funded by ads and donations.
 

Re: Can't run Lilypond once installed, help please

Postby mank_in on Wed Dec 05, 2012 12:31 am

I am didn't use lilypond,
but when i am open synaptic package manager, search for lilypond, I see denemo

GNU denemo is a GUI musical score editor written in C/gtk+. It is
intended primarily as a front end to GNU Lilypond, but is adaptable to
other computer-music-related purposes as well.

maybe you need install denemo
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Can't run Lilypond once installed, help please

Postby alez on Wed Dec 05, 2012 6:14 am

Thank you very much for your post. There are a few of these WYSIWYG GUI frontends available for Linux including Frescobaldi, Denemo, MuseScore and so on, but I'm now used to the Lilypond programming language and find text entry very fast compared to GUI mouse work.

I think my problem is that this "Nautilus" or whatever it is isn't aware that Lilypond is actually installed, i.e. it looks like a generic problem rather than a Lilypond problem.
alez
Level 1
Level 1
 
Posts: 3
Joined: Sat Nov 03, 2012 4:58 pm

Re: Can't run Lilypond once installed, help please

Postby alez on Wed Dec 05, 2012 9:48 pm

I just found a pretty obvious workaround: typing the command "lilypond file.ly" on a terminal window works alright :)
alez
Level 1
Level 1
 
Posts: 3
Joined: Sat Nov 03, 2012 4:58 pm


Return to Software & Applications

Who is online

Users browsing this forum: Exabot [Bot] and 15 guests