<SOLVED> Broadcom STA wireless drivers fail to work after...

Questions about WIFI networks and devices
Forum rules
Before you post please read this

<SOLVED> Broadcom STA wireless drivers fail to work after...

Postby ergine on Thu Dec 06, 2012 8:39 am

...each reboot

I installed Linux Mint 14 (with MATE) on my HP Mini 2133 computer and had some problems with its Broadcom wireless card. I was expecting this after reading various forum posts on the matter. I fixed the problem through Menu > Control Center > Software Sources > Additional Drivers by selecting "Using Broadcom 802.11 Linux STA..." and clicking Apply Changes. After this, everything worked like a charm.

Image

The only thing is, every time I restart my computer, the wireless chip doesn't work anymore and I have to go back to Software Sources and first select "Do not use the device" (click Apply Changes) and then reselect the "Using Broadcom 802.11 Linux STA..." (and click Apply Changes). And again, everything works beautifully.

I am new to the entire Linux world and don't know where to even begin with solving this issue... so... help?
Last edited by ergine on Fri Dec 07, 2012 7:50 am, edited 1 time in total.
ergine
Level 1
Level 1
 
Posts: 6
Joined: Wed Dec 05, 2012 4:42 pm

Linux Mint is funded by ads and donations.
 

Re: Broadcom STA wireless drivers fail to work after each re

Postby kc1di on Thu Dec 06, 2012 11:34 am

Do you know which broadcom Wireless card is used in your particular machine?

If not please go to a terminal and enter the following command and post the out put here.

Code: Select all
sudo lspci

you'll have to enter your password.

Some broadcom cards don't use the STA driver.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Broadcom STA wireless drivers fail to work after each re

Postby ergine on Thu Dec 06, 2012 12:14 pm

lspci returns the following:
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11/g LP-PHY (rev 01)
ergine
Level 1
Level 1
 
Posts: 6
Joined: Wed Dec 05, 2012 4:42 pm

Re: Broadcom STA wireless drivers fail to work after each re

Postby kc1di on Thu Dec 06, 2012 1:30 pm

That should be the right driver. So not sure why it's acting up. I have the same wireless card here and don't notice any problems with it.
Sorry I can't be of more help at this time. but maybe someone else with your particular machine will come forward.
Good luck
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Broadcom STA wireless drivers fail to work after each re

Postby ergine on Thu Dec 06, 2012 1:33 pm

Hope so too. Thanks anyway.
ergine
Level 1
Level 1
 
Posts: 6
Joined: Wed Dec 05, 2012 4:42 pm

Re: Broadcom STA wireless drivers fail to work after each re

Postby TBABill on Thu Dec 06, 2012 1:52 pm

If you open a terminal and type (as root!!)
Code: Select all
gksudo gedit /etc/modules
Then add "wl" to the end of the list, without quotes of course, and save it.. After that you can either reboot or you can
Code: Select all
sudo modprobe wl
Either restarting or modprobe will enable the STA module (the actual module is wl for the STA driver).

If you ever have the wireless not working and do an lsmod in a terminal you'll see a list of active drivers. If wl isn't listed but should be, modprobe as above and see if that enables it. However, the gedit command I listed should add that module to be enabled on every restart.
TBABill
Level 6
Level 6
 
Posts: 1368
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD

Re: Broadcom STA wireless drivers fail to work after each re

Postby ergine on Thu Dec 06, 2012 3:34 pm

Yep. That did the trick. Thank you very much!

Now to go try and understand what all that actually means and why the 'wl' module wasn't automatically on the list... ,)
ergine
Level 1
Level 1
 
Posts: 6
Joined: Wed Dec 05, 2012 4:42 pm

Re: Broadcom STA wireless drivers fail to work after each re

Postby pdmurray on Thu Dec 06, 2012 6:56 pm

Hey Guys... I'm having a problem with my wireless as well. It is a HP Pavilion with a Broadcom BCM4306 802.11 b/g (rev3). I am VERY new to this and although I was quite savy in WIndows and DOS (back in the day).. I am sinking fast in deep waters trying to figure out what to do.

Do you think what you did here would be the same for me?
pdmurray
Level 1
Level 1
 
Posts: 5
Joined: Thu Dec 06, 2012 1:17 pm

Re: Broadcom STA wireless drivers fail to work after each re

Postby kc1di on Fri Dec 07, 2012 7:43 am

ergine wrote:Yep. That did the trick. Thank you very much!

Now to go try and understand what all that actually means and why the 'wl' module wasn't automatically on the list... ,)

Glad you got it sorted. When you have a moment could you mark this thread as solved- thanks ;)
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Broadcom STA wireless drivers fail to work after each re

Postby kc1di on Fri Dec 07, 2012 7:47 am

pdmurray wrote:Hey Guys... I'm having a problem with my wireless as well. It is a HP Pavilion with a Broadcom BCM4306 802.11 b/g (rev3). I am VERY new to this and although I was quite savy in WIndows and DOS (back in the day).. I am sinking fast in deep waters trying to figure out what to do.

Do you think what you did here would be the same for me?

Hi pdmurray and welcome to Mint,

You should start a new post for your problem as it's not the same card as in this post.
with that said let me see if we can help. are you using mint 14 or 13?

If it is 13 then go to control center and select additonal drivers and install the recommend driver from there. If it's 14 let me know will try to walk you through the drive install.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Broadcom STA wireless drivers fail to work after each re

Postby pdmurray on Fri Dec 07, 2012 12:32 pm

kc1di wrote:
pdmurray wrote:Hey Guys... I'm having a problem with my wireless as well. It is a HP Pavilion with a Broadcom BCM4306 802.11 b/g (rev3). I am VERY new to this and although I was quite savy in WIndows and DOS (back in the day).. I am sinking fast in deep waters trying to figure out what to do.

Do you think what you did here would be the same for me?

Hi pdmurray and welcome to Mint,

You should start a new post for your problem as it's not the same card as in this post.
with that said let me see if we can help. are you using mint 14 or 13?

If it is 13 then go to control center and select additonal drivers and install the recommend driver from there. If it's 14 let me know will try to walk you through the drive install.


Hi.. and thanks ! I wasn't sure if I should start a new thread or not.... didn't want to be doubling up on something someone else had already started..lol
I am using 14 .. and actually had someone else tell me that this particular card was notorious for being unreliable. I did start having trouble even getting it to connect with the network running WinXP before I stopped using it... although it did show that it was on .. but not connecting. Now the light which tells me the wireless is on, does not even come on.

Thanks,

Phil
pdmurray
Level 1
Level 1
 
Posts: 5
Joined: Thu Dec 06, 2012 1:17 pm

Re: <SOLVED> Broadcom STA wireless drivers fail to work afte

Postby kc1di on Fri Dec 07, 2012 4:49 pm

Hi Phil,

here is a page that may be able to help you get it going. but as you say it's known to be a bear to get going.
but take a look here anyway.
http://askubuntu.com/questions/44659/how-do-you-get-the-broadcom-bcm4306-wireless-card-working
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: <SOLVED> Broadcom STA wireless drivers fail to work afte

Postby pdmurray on Fri Dec 07, 2012 5:05 pm

Thanks so much for your help. I think what I am going to do is to replace the card that is in it with a Centrino Avanced-N 6230 WiFi Half Mini PCI-e Adapter. My understanding of this card is that there are no known issues with Linux.. and works perfectly out of the box. I tried what the links said, but had no luck keeping it up. Again, thanks so much.
pdmurray
Level 1
Level 1
 
Posts: 5
Joined: Thu Dec 06, 2012 1:17 pm

Re: <SOLVED> Broadcom STA wireless drivers fail to work afte

Postby voomie on Sun Dec 09, 2012 1:21 pm

I had the same exact problem and this did the trick. This has been one of the most troublesome versions of mint I have delt with and I hope I am getting to the end of the list of problems soon. I dont want to change distros.
voomie
Level 1
Level 1
 
Posts: 11
Joined: Mon Nov 07, 2011 1:19 am

Re: <SOLVED> Broadcom STA wireless drivers fail to work afte

Postby owichsnarc on Wed Mar 27, 2013 4:45 pm

worked for me /etc/modules
modprobe

beautiful
owichsnarc
Level 1
Level 1
 
Posts: 1
Joined: Wed Mar 27, 2013 4:30 pm

Re: <SOLVED> Broadcom STA wireless drivers fail to work afte

Postby kc1di on Wed Mar 27, 2013 5:45 pm

Glad it's solved :)
Enjoy
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 10 guests