Can't auto mount my NTFS partition

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help

Can't auto mount my NTFS partition

Postby roccop on Wed Dec 05, 2012 6:43 pm

Hi,
I'm using Mint 14 (Mate 64 bit) and I want to auto mount my NTFS partition (I have dual boot with W7) so I add the following line to /etc/fstab:
Code: Select all
UUID=3E20491C2048DD11 /media/rocco/Disco ntfs-3g defaults,windows_names 0 0


After I run
Code: Select all
mount -a
everything is ok, but when I reboot my PC I have an error and the system not finish boot:

Mount is denied because the NTFS volume is already exclusively opened, the volume may be already mounted or another software may use it which [...] terminated with status 16

Usually after boot I can see my NTFS partition via filemanager, but in this case I always need to click in order to mount it. How can I solve my problem?

Thanks a lot,
Rocco
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Linux Mint is funded by ads and donations.
 

Re: Can't auto mount my NTFS partition

Postby kwisher on Wed Dec 05, 2012 7:22 pm

Here is my ntfs automount that works. I think part of your problem may be the "ntfs-3g" portion as that is not a true filesystem name. My working line was created automatically by the SolusOS installer.

UUID=1054894554892F12 /media/data ntfs defaults 0 0
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 650
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Can't auto mount my NTFS partition

Postby water spirit on Thu Dec 06, 2012 4:36 am

This is what I do, my NTFS data partition on this computer is sda10 and named Storage. Just add this line to fstab and when you reboot the partition is mounted.

# Mount media/Storage
/dev/sda10 /media/Storage ntfs-3g defaults,locale=en_US.utf8 0 0

You can change this (en_US.utf8 0 0) locale to suit yours, if you wish.
Change sda10 to match with your partition. Change Storage to match your name or label.
No need to run any commands. Works on most distro's.
Image
Image
water spirit
Level 2
Level 2
 
Posts: 84
Joined: Sun Aug 01, 2010 12:32 am
Location: Queensland

Re: Can't auto mount my NTFS partition

Postby altair4 on Thu Dec 06, 2012 7:45 am

UUID=3E20491C2048DD11 /media/rocco/Disco ntfs-3g defaults,windows_names 0 0

I would have added a few more options to the list but there is nothing wrong with that line in fstab except the mount point. Ubuntu 12.10 introduced a new way of mounting partitions that places the temporary mount point for partitions mounted manually through the filemanager to /media/$USER/LABEL with permissions on /media/$USER determined by Access Control Lists. You need to change the mountpoint to something outside of this process:

[1] Verify that the UUID you are using is correct:
Code: Select all
sudo blkid -c /dev/null

[2] Create your own permanent mountpoint:
Code: Select all
sudo mkdir /media/Disco

[3] If your partition is currently mounted unmount it:
Code: Select all
sudo umount /media/rocco/Disco

[4] Change the line in fstab to this:
UUID=3E20491C2048DD11 /media/Disco ntfs-3g defaults,windows_names 0 0

[5] Remount with this:
Code: Select all
sudo mount -a


As a somewhat irrelevant side note
: ntfs and ntfs-3g are the same thing in Debian since one points to the other:
ls -l /sbin/mount.ntfs
lrwxrwxrwx 1 root root 13 Apr 30 13:57 /sbin/mount.ntfs -> mount.ntfs-3g

Either one will work in fstab
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6286
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't auto mount my NTFS partition

Postby roccop on Fri Dec 07, 2012 6:16 am

Sorry, but after rebbot I have always the same error message:
Mount is denied because the NTFS volume is already exclusively opened, the volume may be already mounted or another software may use it which [...] terminated with status 16

How can I know who is keeping busy my NTFS partition? :(
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Re: Can't auto mount my NTFS partition

Postby altair4 on Fri Dec 07, 2012 7:03 am

After you boot into your machine post the output of the following commands:
Code: Select all
sudo blkid -c /dev/null

Code: Select all
mount

Code: Select all
sudo parted -l

Code: Select all
cat /etc/fstab
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6286
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't auto mount my NTFS partition

Postby roccop on Fri Dec 07, 2012 10:57 am

These are output after boot ("original" status of my Linux)
Code: Select all
sudo blkid -c /dev/null
/dev/sda1: LABEL="System" UUID="1274AF5174AF367F" TYPE="ntfs"
/dev/sda2: LABEL="WINDOWS 7" UUID="6EA4F6F5A4F6BEA1" TYPE="ntfs"
/dev/sda4: LABEL="HDDRECOVERY" UUID="6CA42C56A42C24D4" TYPE="ntfs"
/dev/sda5: LABEL="Disco" UUID="3E20491C2048DD11" TYPE="ntfs"
/dev/sda6: UUID="ef11e42f-59a4-4211-b2c7-4577d1546c2a" TYPE="ext4"
/dev/sda7: UUID="7ee9f61e-d304-46fd-aff6-77a5af81cd8a" TYPE="swap"
/dev/sda8: UUID="7eace6d8-d1b8-4602-b6b0-4c03b8d92569" TYPE="ext4"

Code: Select all
rocco@Toshiba-L855 ~ $ mount
/dev/sda8 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /tmp type tmpfs (rw,size=1g)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda6 on /boot type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/rocco/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=rocco)

Code: Select all
rocco@Toshiba-L855 ~ $ sudo parted -l
Modello: ATA Hitachi HTS54757 (scsi)
Disco /dev/sda: 750GB
Dimensione del settore (logica/fisica): 512B/4096B
Tabella delle partizioni: msdos

Numero  Inizio  Fine    Dimensione  Tipo      File system     Flag
 1      1049kB  1574MB  1573MB      primary   ntfs            avvio, diag
 2      1574MB  169GB   168GB       primary   ntfs
 3      169GB   733GB   564GB       extended                  lba
 5      169GB   701GB   532GB       logical   ntfs
 6      701GB   701GB   511MB       logical   ext4
 7      701GB   708GB   6655MB      logical   linux-swap(v1)
 8      708GB   733GB   25,0GB      logical   ext4
 4      733GB   750GB   17,0GB      primary   ntfs            nascosta

Code: Select all
rocco@Toshiba-L855 ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda8 during installation
UUID=7eace6d8-d1b8-4602-b6b0-4c03b8d92569 /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda6 during installation
UUID=ef11e42f-59a4-4211-b2c7-4577d1546c2a /boot           ext4    defaults        0       2
# swap was on /dev/sda7 during installation
UUID=7ee9f61e-d304-46fd-aff6-77a5af81cd8a none            swap    sw              0       0
# mount /tmp on RAM
tmpfs /tmp tmpfs size=1g 0 0
# mount /media/rocco/Disco on /dev/sda5
#UUID=3E20491C2048DD11 /media/Disco ntfs-3g defaults,windows_names 0 0
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Re: Can't auto mount my NTFS partition

Postby altair4 on Fri Dec 07, 2012 12:06 pm

I haven't forgotten about you. It's just that at the moment I don't see anything wrong with what you are attempting to do so I'm obviously missing something.

I don't suppose that the Win7 part of this dual boot is hibernating instead of being completely logged off from?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6286
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't auto mount my NTFS partition

Postby roccop on Fri Dec 07, 2012 1:02 pm

Before with Mint 13 these steps work fine, now using Mint 14 I have problems (I completelly re-installed my system like a new installation).
Using fuser can help me? If yes, please send me the right code.
Just one thing, this is not the only problem I have with Mint 14. See my other post viewtopic.php?f=47&t=119063
But I don't know if this can help you to understand my NTFS problem... it seems that somthing run in background for both problems... :(
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Re: Can't auto mount my NTFS partition

Postby water spirit on Sat Dec 08, 2012 10:36 pm

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=b6a0b1e5-6bf2-4c7d-ae23-d5f65124e309 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda9 during installation
UUID=ffa56f5b-5ecd-4b47-8e08-1c13460b8536 none            swap    sw              0       0
# Mount media/Storage
/dev/sda10 /media/Storage ntfs-3g defaults,locale=en_US.utf8 0 0


Works perfectly Mint 14.
Image
Image
water spirit
Level 2
Level 2
 
Posts: 84
Joined: Sun Aug 01, 2010 12:32 am
Location: Queensland

Re: Can't auto mount my NTFS partition

Postby roccop on Sun Dec 09, 2012 3:58 am

Also using your command line I always have the following message after reboot:

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.


THE PROBLEM IS who keep busy my NTFS partition!
Who know how to run a command to reconize the process that use first my NTFS patition?
Could be Windows 7 to keep busy the partition?

FYI
I tried the following test:
- edit /etc/fstab and add the right command line
- manually delete NTFS mount point
- reboot the system

(obviously) I had the error and system ask me to jump my NTFS mount line
when the system was up my NTFS partition was already mounted!!! F**CK
OBVIOUSLY this is not the solution... :(
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Re: Can't auto mount my NTFS partition

Postby altair4 on Sun Dec 09, 2012 9:38 am

THE PROBLEM IS who keep busy my NTFS partition!
Who know how to run a command to reconize the process that use first my NTFS patition?

The command "mount" will show you what, where, and how all your partitions are mounted. You should do that immediately after you login to see where or if this ntfs partition is mounted. But you did that already and it is not mounted. Just in case there is something wrong with the mount command itself post the output of this command:
Code: Select all
cat /proc/mounts

Could be Windows 7 to keep busy the partition?

That's why I asked you earlier if you logged out of the Win7 machine completely or if it was hibernating. If it's hibernating it may have locked the partition for some reason.

Try another experiment:

** Don't have any reference to this ntfs partition in fstab.
** Reboot the system
** After login immediately run the "mount" command to see if it's mounting by itself somehow - but don't go into Nautilus or Nemo or whatever the File manager is called in Mate.
** If "mount" says it is mounted where is it mounted?
** If "mount" says it's not mounted then open a terminal and run the following command:
Code: Select all
/usr/bin/udisks --mount /dev/disk/by-uuid/3E20491C2048DD11

What should happen is that it will mount to /media/rocco/.... and automatically open up the file manager to that location - or give you an error message.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6286
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't auto mount my NTFS partition

Postby roccop on Mon Dec 10, 2012 4:36 pm

Windows 7 is normally shut down...
This is what I did:

system was "clear" nothing has been modified.
reboot of the system
system was up and I ran just only the following commands:

Code: Select all
rocco@Toshiba-L855 ~ $ mount
/dev/sda8 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /tmp type tmpfs (rw,noexec,nosuid)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda6 on /boot type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/rocco/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=rocco)


Code: Select all
rocco@Toshiba-L855 ~ $ cat /proc/mounts
rootfs / rootfs rw 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,relatime,size=3028656k,nr_inodes=757164,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /run tmpfs rw,nosuid,relatime,size=1215144k,mode=755 0 0
/dev/disk/by-uuid/7eace6d8-d1b8-4602-b6b0-4c03b8d92569 / ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
none /sys/fs/fuse/connections fusectl rw,relatime 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
tmpfs /tmp tmpfs rw,nosuid,noexec,relatime 0 0
none /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
none /run/shm tmpfs rw,nosuid,nodev,relatime 0 0
none /run/user tmpfs rw,nosuid,nodev,noexec,relatime,size=102400k,mode=755 0 0
/dev/sda6 /boot ext4 rw,relatime,stripe=4,data=ordered 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
gvfsd-fuse /run/user/rocco/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0


Code: Select all
rocco@Toshiba-L855 ~ $ /usr/bin/udisks --mount /dev/disk/by-uuid/3E20491C2048DD11
Mounted /org/freedesktop/UDisks/devices/sda5 at /media/Disco Dati_
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Re: Can't auto mount my NTFS partition

Postby altair4 on Mon Dec 10, 2012 7:12 pm

This is getting stranger and stranger.

From blkid:
/dev/sda5: LABEL="Disco" UUID="3E20491C2048DD11" TYPE="ntfs"

From the udisks mount command:
Mounted /org/freedesktop/UDisks/devices/sda5 at /media/Disco Dati_


Given the new rules it should have mounted to /media/rocco/Disco. Even with the old rules it would have mounted to /media/Disco. I don't know where this "Disco Dati" is coming from but the underscore at the end means that there is a folder named "Diso Dati" already present under /media.

If you do a:
Code: Select all
ls -al /media

Do you see a listing for "Disco Dati" and Disco Dati_" ?

I honestly don't have any idea what's going on here but I do have a question. Does /media/Disco Dati contain all the information it's supposed to have? If it does there is a way around this problem until we can figure out why your system is acting so strangely. You could put the udisks command in your autostart program list.

I don't know where it is in Mate but it usually is something like Menu > Preferences > Startup Applications. Then you would add the following:
Code: Select all
/usr/bin/udisks --mount /dev/disk/by-uuid/3E20491C2048DD11

Like this:
Disco.png
Disco.png (18.63 KiB) Viewed 5290 times


You won't have any control over the permissions anymore and you will not have the safety of the "windows_names" option but it should mount when you log into your system.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6286
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't auto mount my NTFS partition

Postby roccop on Tue Dec 11, 2012 2:22 pm

Please forget my previous post.
I repeat 2 times test and this is the correct output:
Reboot my system, immediately open terminal and run the following commands...

Code: Select all
rocco@Toshiba-L855 ~ $ mount
/dev/sda8 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /tmp type tmpfs (rw,noexec,nosuid)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda6 on /boot type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/rocco/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=rocco)

Code: Select all
rocco@Toshiba-L855 ~ $ cat /proc/mounts
rootfs / rootfs rw 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,relatime,size=3028656k,nr_inodes=757164,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /run tmpfs rw,nosuid,relatime,size=1215144k,mode=755 0 0
/dev/disk/by-uuid/7eace6d8-d1b8-4602-b6b0-4c03b8d92569 / ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
none /sys/fs/fuse/connections fusectl rw,relatime 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
tmpfs /tmp tmpfs rw,nosuid,noexec,relatime 0 0
none /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
none /run/shm tmpfs rw,nosuid,nodev,relatime 0 0
none /run/user tmpfs rw,nosuid,nodev,noexec,relatime,size=102400k,mode=755 0 0
/dev/sda6 /boot ext4 rw,relatime,stripe=4,data=ordered 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
gvfsd-fuse /run/user/rocco/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0

Code: Select all
rocco@Toshiba-L855 ~ $ /usr/bin/udisks --mount /dev/disk/by-uuid/3E20491C2048DD11
Mounted /org/freedesktop/UDisks/devices/sda5 at /media/Disco

Code: Select all
rocco@Toshiba-L855 ~ $ ls -al /media
totale 16
drwxr-xr-x   4 root  root  4096 dic 11 19:15 .
drwxr-xr-x  23 root  root  4096 dic  1 02:29 ..
drwx------   1 rocco rocco 4096 dic  9 09:57 Disco
drwxr-x---+  2 root  root  4096 dic 11 18:56 rocco

Code: Select all
rocco@Toshiba-L855 ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda8 during installation
UUID=7eace6d8-d1b8-4602-b6b0-4c03b8d92569 /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda6 during installation
UUID=ef11e42f-59a4-4211-b2c7-4577d1546c2a /boot           ext4    defaults        0       2
# swap was on /dev/sda7 during installation
UUID=7ee9f61e-d304-46fd-aff6-77a5af81cd8a none            swap    sw              0       0
# mount /tmp on RAM
#tmpfs /tmp tmpfs size=1g 0 0
tmpfs /tmp tmpfs defaults,noexec,nosuid 0 0
# mount /media/rocco/Disco Dati on /dev/sda5
#UUID=3E20491C2048DD11 /media/Disco ntfs-3g defaults,windows_names 0 0
rocco@Toshiba-L855 ~ $
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Re: Can't auto mount my NTFS partition

Postby altair4 on Tue Dec 11, 2012 3:32 pm

OK, that clears up the "disco Dati_" problem. I would still suggest putting the udisks command in your start up applications.

It's easy enough to test out. Add it to your startup applications. Then logout - not reboot. Then log back in again.

If you run the following command immediately after login do you see all your files in /media/Disco:
Code: Select all
ls -al /media/Disco
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6286
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't auto mount my NTFS partition

Postby roccop on Tue Dec 11, 2012 4:18 pm

OK your last suggestion is right. After log-in /media/Disco is automatically mounted...
WHY???
I don't understand which process starts before /etc/fstab and keep it busy? Why if I use Startup manager this is not a problem?
What does it means this?
You won't have any control over the permissions anymore and you will not have the safety of the "windows_names" option but it should mount when you log into your system.
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Re: Can't auto mount my NTFS partition

Postby altair4 on Wed Dec 12, 2012 8:24 am

What does it means this?
You won't have any control over the permissions anymore and you will not have the safety of the "windows_names" option but it should mount when you log into your system.

The udisks command is how Linux mounts a partition when you select it in the file manager. There are built in rules on how ntfs partitions are mounted when you use this default method. The default method mounts a partition somewhat like this:
UUID=3E20491C2048DD11 /media/Disco ntfs defaults,uid=1000,umask=077 0 0

You are the owner of the mounted partition ( uid=1000 ). But you are the only one that can access it ( umask=077 ). The "7"'s remove access to "group" and "others". That's what I meant when I said you will no longer have control over permissions. Linux can't change linux permissions on an NTFS partition outside of the "view" created by a mount.

It also has no idea what the "windows_names" option does. If this was just an isolated ntfs partition in all Linux machine it wouldn't matter. But this is a dual boot with an active Windows OS installed. Linux can create a file with a file name containing characters that Windows cannot interpret so when you log back into Windows that file is lost. The "windows_names" option prevents Linux from saving the file with a bad name so the issue is avoided. That's what I meant by safety. A bad choice of words in retrospect since it's not going to damage anything - Just be careful how you name files.
I don't understand which process starts before /etc/fstab and keep it busy?

That is the question that I admittedly am not smart enough to answer. The output of all the diagnostic commands I asked you to run indicate that it is not mounted before fstab is executed. I just don't know the answer.

Successfully mounted the partition using the udisks command I gave you in Startup Application is another way to mount partitions at login but it should not be necessary if everything was working correctly.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6286
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't auto mount my NTFS partition

Postby roccop on Wed Dec 12, 2012 8:41 am

OK thanks,
but is it possible to check step by step what my Linux Mint is loading during start up?
Where I can also read my warning log file and boot system log?
roccop
Level 1
Level 1
 
Posts: 16
Joined: Mon Jul 30, 2012 11:04 am

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 9 guests