[solved] can't get SAMBA network printing to work at all

Forum rules
Before you post please read this

[solved] can't get SAMBA network printing to work at all

Postby Smiff2 on Sun Dec 09, 2012 7:16 am

laptop: Mint 14 KDE RC with all updates

printer: USB printer on linux NAS, works fine from my older Mint / Ubuntu Gnome desktops.

network: simple LAN connected fine to router.

SMB4k can see all the shares including the printer ok.

Dolphin can't seem to connect to shares.

the KDE printer config seems to run fine, but the test print does nothing.

CUPS reports "idle, Rejecting Jobs, Not Shared"

have tried different drivers, variations of the path
e.g.
smb://WORKGROUP/NAS/Printer
smb://NAS/Printer
smb://IPofNAS/printer

etc. nothing makes any difference.


have tried adding user/pass in 3 ways:
like smb://user:pass@NAS/printer, which seems to work (it disappears when saving but i think this is intended behaviour).
have tried making default smb user pass.
have tried typing it in the two boxes provided in wizard.

the KDE user password is not equal to the windows network password, but this has never been a problem before, could it be? (i set the correct windows network password on the KDE laptop).

never had any trouble setting this up from Gnome, but not experienced with KDE

all samba components seem to be installed.

any ideas please? maybe i should be using something other than SAMBA to share the printer but it works fine in other linux dektops AND user needs windows printer server support.
Last edited by Smiff2 on Sun Dec 09, 2012 5:47 pm, edited 1 time in total.
Smiff2
Level 3
Level 3
 
Posts: 120
Joined: Sat Jan 16, 2010 11:53 am

Linux Mint is funded by ads and donations.
 

Re: can't get SAMBA network printing to work at all

Postby Smiff2 on Sun Dec 09, 2012 3:32 pm

seems to be same in stock Kubuntu 12.10. haven't tried 12.04 yet.
Smiff2
Level 3
Level 3
 
Posts: 120
Joined: Sat Jan 16, 2010 11:53 am

Re: can't get SAMBA network printing to work at all

Postby Smiff2 on Sun Dec 09, 2012 5:40 pm

the Browse button when adding new "windows printer via SAMBA" is greyed out.
in Gnome, i can use this button..


edit: SOLVED!
there's a button in KDE print setup marked "reject print jobs" .. and it's ticked by default. so untick it..
fantastic. wow don't even get me started, either on the ui design here, or my inability to see the option. haha. ok.
Smiff2
Level 3
Level 3
 
Posts: 120
Joined: Sat Jan 16, 2010 11:53 am


Return to KDE

Who is online

Users browsing this forum: No registered users and 2 guests