Enable Ctrl+Alt+Backspace in XFCE

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

Enable Ctrl+Alt+Backspace in XFCE

Postby maxibuntu on Sun Dec 09, 2012 10:47 am

On LMDE with UP5 and XFCE 4.8, Ctrl+Alt+Backspace does not work, even with the autostart entry enabled.

To make it work you have to pass a configration variable directly to the X-Server.

All the following commands can be run from a Terminal, like for instance gnome-terminal. You can easily select and copy a command from this page, then paste it in a terminal, and hit enter.

I have a sudo setup on LMDE, if you have an su setup like on standard Debian, use:

Code: Select all
su -


...and enter the root password, and commands.

But we will continue with the sudo version:

In a terminal, run:

Code: Select all
sudo mkdir -pv /etc/X11/xorg.conf.d


Then create a new config file:

Code: Select all
sudo gedit /etc/X11/xorg.conf.d/02-enable-ctrl-alt-baksp.conf


Copy/paste the following code and save the file:

Code: Select all
Section "ServerFlags"

    Option   "XkbOptions"   "terminate:ctrl_alt_bksp"
    Option   "DontZap"   "false"

EndSection


In the session manager of XFCE enable the "Ctrl Alt Backspace" autostart entry (don't know if this is actually required, but just to be sure).

If you don't have such an entry you can easily create it yourself. Create a new file ~/.config/autostart/ctrl-alt-bksp.desktop:

Code: Select all
gedit ~/.config/autostart/ctrl-alt-bksp.desktop


Select and copy the following code and paste it in gedit:

Code: Select all
[Desktop Entry]
Name=Ctrl Alt Backspace
Comment=Activate Ctrl+Alt+Backspace to restart the Xserver
Type=Application
TryExec=setxkbmap
Exec=setxkbmap -option terminate:ctrl_alt_bksp
StartupNotify=false
OnlyShowIn=XFCE;
Hidden=false
X-GNOME-Autostart-enabled=false


Save the file, close all your applications and log out and log back in again.

Ctrl+Alt+Backspace should work now. Be careful, if you use this key combination all running applications will be killed, and there is a chance of data corruption or unsaved changes.
maxibuntu
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 24, 2011 9:56 am
Location: Rotterdam, Netherlands

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 2 guests