How to stop Gnome 3.4 from DPMS screen blanking

Write tutorials here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

How to stop Gnome 3.4 from DPMS screen blanking

Postby maxibuntu on Sun Dec 09, 2012 10:27 am

In Gnome 3.4, by default, the screen blanks every 10 minutes or so. Maybe the Gnome developers think this is funny when you are watching a movie, but I sure don't.

I do not have the issue in XFCE.

All the following commands can be run from a Terminal, like for instance gnome-terminal. You can easily select and copy a command from this page, then paste it in a terminal, and hit enter.

I have a sudo setup on LMDE, if you have an su setup like on standard Debian, use:

Code: Select all
su -


...and enter the root password, and commands.

But we will continue with the sudo version:

To stop the screen from blanking you have to pass some configuration parameters to the X server.

In a terminal, run:

Code: Select all
sudo mkdir -pv /etc/X11/xorg.conf.d


Then create a new config file:

Code: Select all
sudo gedit /etc/X11/xorg.conf.d/01-disable-screen-blanking.conf


Copy/paste the following code and save the file:

Code: Select all
Section "ServerFlags"

    Option   "BlankTime"   "0"
    Option   "StandbyTime"   "0"
    Option   "SuspendTime"   "0"

EndSection


Close your applications and restart the X server with Ctrl+Alt+Backspace, or simply log out nad log back in again.
Last edited by maxibuntu on Sun Dec 09, 2012 11:52 am, edited 3 times in total.
maxibuntu
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 24, 2011 9:56 am
Location: Rotterdam, Netherlands

Linux Mint is funded by ads and donations.
 

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby caf4926 on Sun Dec 09, 2012 10:43 am

Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby maxibuntu on Sun Dec 09, 2012 11:02 am

Thanx, I didn't try this extension yet, but I think it only stops the screensaver via dbus. I don't know if it stops DPMS blanking. I'll check it out...
Last edited by maxibuntu on Sun Dec 09, 2012 5:00 pm, edited 3 times in total.
maxibuntu
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 24, 2011 9:56 am
Location: Rotterdam, Netherlands

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby caf4926 on Sun Dec 09, 2012 11:15 am

In Gnome 3.4, by default, the screen blanks every 10 minutes
But you should be able to change this to at least 1hr?
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby maxibuntu on Sun Dec 09, 2012 11:52 am

caf4926 wrote:
In Gnome 3.4, by default, the screen blanks every 10 minutes
But you should be able to change this to at least 1hr?


No, I tried that. Those are the settings for the screensaver. It has nothing to do with setting DPMS.
Last edited by maxibuntu on Sun Dec 09, 2012 5:01 pm, edited 1 time in total.
maxibuntu
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 24, 2011 9:56 am
Location: Rotterdam, Netherlands

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby rop75 on Sun Dec 09, 2012 12:53 pm

Well I don't know, but in my case (I am using Gnome shell 3.4) Ijust changed the settings in system settings / screen brightness and block, and I have my monitor on for an hour when I am using my laptop to watch a movie. Anyway, thanks for your how-to
User avatar
rop75
Level 2
Level 2
 
Posts: 97
Joined: Sat May 05, 2012 6:08 pm

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby maxibuntu on Sun Dec 09, 2012 4:52 pm

I wanted to test if the caffeine extension would disable the screen blanking on its own. So first I tried to get back the original screen blanking behaviour. I removed the config file in /etc/X11/xorg.conf, removed the caffeine extension, installed gnome-power-manager, set sleep time to five minutes in power management, set the screensaver to one minute, and absolutely nothing happens! I can't get the DPMS screen back! Gnome 3 seems to have really messy power management. Ah well, I'll stick with the Xorg config and deinstall the caffeine extension. As long as I can watch movies without interruption...
maxibuntu
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 24, 2011 9:56 am
Location: Rotterdam, Netherlands

[SOLVED]Re:How to stop Linux or any xorg DPMS screen blankin

Postby Ghis1964 on Tue Jan 08, 2013 9:41 pm

maxibuntu wrote:In Gnome 3.4, by default, the screen blanks every 10 minutes or so. Maybe the Gnome developers think this is funny when you are watching a movie, but I sure don't.

I do not have the issue in XFCE.

All the following commands can be run from a Terminal, like for instance gnome-terminal. You can easily select and copy a command from this page, then paste it in a terminal, and hit enter.

I have a sudo setup on LMDE, if you have an su setup like on standard Debian, use:

Code: Select all
su -


...and enter the root password, and commands.

But we will continue with the sudo version:

To stop the screen from blanking you have to pass some configuration parameters to the X server.

In a terminal, run:

Code: Select all
sudo mkdir -pv /etc/X11/xorg.conf.d


Then create a new config file:

Code: Select all
sudo gedit /etc/X11/xorg.conf.d/01-disable-screen-blanking.conf


Copy/paste the following code and save the file:

Code: Select all
Section "ServerFlags"

    Option   "BlankTime"   "0"
    Option   "StandbyTime"   "0"
    Option   "SuspendTime"   "0"

EndSection


Close your applications and restart the X server with Ctrl+Alt+Backspace, or simply log out nad log back in again.



Yes, SOLVED :)

Thanks! I should keep notes about where my notes are.
So far, this works in any xorg whither Debian, Arch, Linux, Slacks, BSDs etc (sorry, not Mi¢ro$o£t Wind%w¢)
Seeing this, I remembered doing this same FIX in Debian and ArchBang once. As now the screen is still on after 30mins so far and going (instead of 10). This old box is on AntiX. It's the only thing that can access "random hdd" that I add as slave drives in. I'm installing/reinstalling hoping OSs as a hooby on old machines just to see how far it goes. I don't even network them into each other. I care even less for gaming. And I like having something that runs when I'm stuck in the mud with the next one ahahah;) (and at 25$ a piece these oldies, it's a lot cheaper than any twin or quad-display video card)

This time I have been looking for a fix through tty's :; --> I don't see why I should have at some level up, something or codes that works to put wherever, when I have to at the user level to put a code that will counter-act that un-needed output.
Ghis1964
Level 1
Level 1
 
Posts: 2
Joined: Sun Oct 30, 2011 2:39 pm

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby tbplayer on Sun May 19, 2013 1:05 pm

maxibuntu wrote:Copy/paste the following code and save the file:

Code: Select all
Section "ServerFlags"

    Option   "BlankTime"   "0"
    Option   "StandbyTime"   "0"
    Option   "SuspendTime"   "0"

EndSection


Yup. That worked for me. Thanks.
User avatar
tbplayer
Level 1
Level 1
 
Posts: 11
Joined: Mon Apr 29, 2013 3:35 pm

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby maxibuntu on Fri Jun 07, 2013 4:34 pm

Ugh, this crap is back in XFCE 4.10. Constant screen blanking makes watching movies a nuisance.
maxibuntu
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 24, 2011 9:56 am
Location: Rotterdam, Netherlands

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby Transitman on Fri Jun 07, 2013 11:37 pm

maxibuntu wrote:Ugh, this crap is back in XFCE 4.10. Constant screen blanking makes watching movies a nuisance.



In the startup application settings, put these 2 items in and your DPMS screen blanking will go away.
Click ADD and then the following;
Code: Select all
Xset -dpms
1. Name: Xset -dpms
2. Command: xset -dpms
3. Comment: (Leave Blank)
 
Click save. If prompted, enter your password.

Xset s off
1. Name: Xset s off
2. Command: xset s off
3. Comment: (Leave Blank)

Click save.


Works under GNome, Cinnamon, XFCE, KDE, LXDE, etc.
Transitman
Level 2
Level 2
 
Posts: 98
Joined: Sun Dec 02, 2007 1:48 am

Re: How to stop Gnome 3.4 from DPMS screen blanking

Postby maxibuntu on Sun Jun 09, 2013 5:34 am

Very nice, that works.

I added both commands in an autostart entry in ~/.config/autostart/disable-dpms.desktop:

Code: Select all
[Desktop Entry]
Name=Disable DPMS
Comment=Disable DPMS screenblanking
Type=Application
Icon=preferences-desktop-screensaver
TryExec=xset
Exec=bash -c 'xset -dpms && xset s off'
Hidden=false
X-GNOME-Autostart-enabled=true


But still, it's odd that the X-server does not seem to read the configuration in /etc/X11/xorg.conf.d/* . I'm running LMDE tracking testing (jessie), so maybe it's a bug...
maxibuntu
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 24, 2011 9:56 am
Location: Rotterdam, Netherlands

Linux Mint is funded by ads and donations.
 

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 2 guests