Screen flickers, probably driver issue

Questions about hardware and drivers
Forum rules
Before you post please read this

Screen flickers, probably driver issue

Postby dtoffe on Sun Apr 29, 2012 10:19 pm

Hi,
I had Debian Stable installed and the screen looked fine, after installing Mint with either Cinnamon, Mate or Gnome, the screen flickers every few seconds. My graphics card is an NVidia GeForce 9500 GT, but don't know what drivers I have installed or where to look for it. Besides, In the System - Preferences - Monitors settings, the monitor is unknow and Detect Monitors doesn't seem to find anything.
How do I know what graphic drivers I have installed ?
Cheers,
Daniel
dtoffe
Level 1
Level 1
 
Posts: 15
Joined: Sun Apr 15, 2012 3:06 am

Linux Mint is funded by ads and donations.
 

Re: Screen flickers, probably driver issue

Postby Oscar799 on Tue May 01, 2012 12:16 pm

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8699
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Screen flickers, probably driver issue

Postby dtoffe on Sat Dec 08, 2012 11:44 pm

It seems Ubuntu detects nvidia hardware and install the proper drivers, but Mint doesn't and you must install them. Tomorrow I'll try the procedure described here and mark this thread as solved if it works.

viewtopic.php?t=82424&f=191

Daniel

dtoffe wrote:Hi,
I had Debian Stable installed and the screen looked fine, after installing Mint with either Cinnamon, Mate or Gnome, the screen flickers every few seconds. My graphics card is an NVidia GeForce 9500 GT, but don't know what drivers I have installed or where to look for it. Besides, In the System - Preferences - Monitors settings, the monitor is unknow and Detect Monitors doesn't seem to find anything.
How do I know what graphic drivers I have installed ?
Cheers,
Daniel
dtoffe
Level 1
Level 1
 
Posts: 15
Joined: Sun Apr 15, 2012 3:06 am

Re: Screen flickers, probably driver issue

Postby dtoffe on Mon Dec 10, 2012 10:52 am

After a clean Mint install I've installed nvidia-current, ran "sudo nvidia-xconfig" and rebooted. Now the screen doesn't flicker anymore, but I'm stuck with 640x480 mode.
It would be nice if the Mint installer could detect the hardware and install the proper drivers, I'll file a bug report with this issue.
I'm posting this procedure in case it's useful to someone else.

Daniel

dtoffe wrote:It seems Ubuntu detects nvidia hardware and install the proper drivers, but Mint doesn't and you must install them. Tomorrow I'll try the procedure described here and mark this thread as solved if it works.

viewtopic.php?t=82424&f=191

Daniel
dtoffe
Level 1
Level 1
 
Posts: 15
Joined: Sun Apr 15, 2012 3:06 am


Return to Hardware Support

Who is online

Users browsing this forum: cyb3rc0de and 5 guests