Disabling touchpad tap to click

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Disabling touchpad tap to click

Postby infinitefluff on Mon Dec 10, 2012 11:44 am

Okay, so I'm very new, and apologize if this is the wrong place. I've searched the forums and found somewhat similar issues, but nothing quite like this that I could tell. I'm running 14 right now, and whenever I tap on my touchpad in the lower right corner, it responds the same as a right click. This would be nice except I have big hands, and constantly brush the touchpad while typing, so I end up doing random things on accident, and it can be very frustrating. What I'm looking for is a way to disable this, so that my touchpad doesn't have any click options. As I said, I'm very new, so if it's a process, please be very clear on the steps involved. :D

Thank you ahead of time for everybody's help.
infinitefluff
Level 1
Level 1
 
Posts: 11
Joined: Sat Dec 08, 2012 2:54 am
Location: Arkansas

Linux Mint is funded by ads and donations.
 

Re: Disabling touchpad tap to click

Postby infinitefluff on Mon Dec 10, 2012 11:53 am

For those interested, I found a fix. On the Ubuntu forums, a user named VideoRoy posted this:

"For those that are interested in your runtime settings, go to Terminal and type synclient -l That is a lower case "L". You can change runtime parameters by typing syclient RTCornerButton=1 for example. This will make the right corner a Left click instead for a test. All changes revert back after logout / login or restart X server.

To remain persistent you have to put them in any file with a .conf extension in the xorg.conf.d directory."

I haven't tried the persistent fix yet, but setting both RTCornerButton=0 and RBCornerButton=0 stopped the issue for me, at least temporarily.
infinitefluff
Level 1
Level 1
 
Posts: 11
Joined: Sat Dec 08, 2012 2:54 am
Location: Arkansas

Re: Disabling touchpad tap to click

Postby infinitefluff on Mon Dec 10, 2012 12:56 pm

Persistent fix doesn't seem to work. I made a file with a .conf extension and put synclient RTCornerButton=0 and synclient RBCornerButton=0 in it. I then moved it to xorg.conf.d and restarted to test it. However, upon restart, the settings had gone back to previous. So I suppose my new question is, how can I set it so that those settings stay through restarts?
infinitefluff
Level 1
Level 1
 
Posts: 11
Joined: Sat Dec 08, 2012 2:54 am
Location: Arkansas

Re: Disabling touchpad tap to click

Postby barrieluv on Mon Dec 10, 2012 1:21 pm

Don't know what desktop you're running, but in MATE go to Menu > Preferences > Mouse > Touchpad. From there you can choose to disable the touchpad while typing.
Hope this helps.
[b]EeePC 701 Ubuntu 10.04 || HP Pavilion DV6 Linux Mint 17 Mate Edition
User avatar
barrieluv
Level 2
Level 2
 
Posts: 79
Joined: Fri Jun 19, 2009 12:20 pm
Location: West London

Re: Disabling touchpad tap to click

Postby infinitefluff on Fri Dec 14, 2012 12:10 am

barrieluv wrote:Don't know what desktop you're running, but in MATE go to Menu > Preferences > Mouse > Touchpad. From there you can choose to disable the touchpad while typing.
Hope this helps.


Thanks for the idea, but that was the first thing I tried, and for whatever reason, it didn't do anything for me.
infinitefluff
Level 1
Level 1
 
Posts: 11
Joined: Sat Dec 08, 2012 2:54 am
Location: Arkansas

Re: Disabling touchpad tap to click

Postby srq2625 on Thu Jan 10, 2013 6:13 pm

Check out mateconf-editor (System Tools > Configuration Editor). In the app desktop > mate > peripherals > touchpad

Therein, on the right, you have the options you need.
srq2625
Level 1
Level 1
 
Posts: 25
Joined: Tue Jan 08, 2013 11:35 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], flamangoes, Linuxnube and 31 guests