Problem with touchpad on Dell XPS (and Bumblebee?)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Problem with touchpad on Dell XPS (and Bumblebee?)

Postby Pjem on Tue Dec 11, 2012 12:42 pm

Hi all,
I just installed Mint 14 on my Dell XPS 15. Having both the nvidia and intel cards, I installed bumblebee3.

All went fine, but when I rebooted, I had no more control of my touchpad. I am assuming this was something that happened during the bumblebee install. Normal USB mouse works fine.

I looked around but no other problem with Dells and touchpads seems relevant to my issue.

I tried the usual incantations
sudo rmmod psmouse
sudo modprobe psmouse (with and without proto=imps)

Edit: more details:
If I do
xinput list

I do not seem to see the touchpad:

Code: Select all
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Power Button                               id=8   [slave  keyboard (3)]
    ↳ Video Bus                                  id=9   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_1.3M              id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                           id=13   [slave  keyboard (3)]
Last edited by Pjem on Tue Dec 11, 2012 1:56 pm, edited 2 times in total.
Pjem
Level 1
Level 1
 
Posts: 2
Joined: Tue Dec 11, 2012 12:33 pm

Linux Mint is funded by ads and donations.
 

Re: Problem with touchpad on Dell XPS (and Bumblebee?)

Postby Pjem on Tue Dec 11, 2012 12:45 pm

Sorry, a little more info:

Code: Select all
System:    Host: samael Kernel: 3.5.0-19-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine:   System: Dell product: XPS L521X version: A12
           Mobo: Dell model: 0880F2 version: A00 Bios: Dell version: A12 date: 09/28/2012
CPU:       Quad core Intel Core i7-3612QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
           Clock Speeds: 1: 2101.00 MHz 2: 2101.00 MHz 3: 2101.00 MHz 4: 2101.00 MHz 5: 1200.00 MHz 6: 1200.00 MHz 7: 1200.00 MHz 8: 1200.00 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GK107 [GeForce GT 640M]
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 9.0
Audio:     Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network:   Card-1: Intel Centrino Advanced-N 6235 driver: iwlwifi
           IF: wlan0 state: down mac: c4:85:08:b0:d7:b3
           Card-2: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: d4:be:d9:69:ca:70
Drives:    HDD Total Size: 782.2GB (1.1% used) 1: id: /dev/sda model: ST9750420AS size: 750.2GB
           2: id: /dev/sdb model: SAMSUNG_SSD_PM83 size: 32.0GB
Partition: ID: / size: 92G used: 5.1G (6%) fs: ext4 ID: /home size: 587G used: 2.8G (1%) fs: ext4
           ID: swap-1 size: 10.00GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 58.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 187 Uptime: 40 min Memory: 885.5/7868.8MB Client: Shell inxi: 1.8.4
Pjem
Level 1
Level 1
 
Posts: 2
Joined: Tue Dec 11, 2012 12:33 pm

Re: Problem with touchpad on Dell XPS (and Bumblebee?)

Postby anandrkris on Fri Dec 14, 2012 12:10 am

Hi Pjem,

Sorry, i dont have a solution for ur problem.
I have almost the same specs for my laptop. just curious...Were you able to get the secondary graphics card work for you?
I am not able to make HDMI display work with my Samsung TV, so was wondering whether it works for you. From googling, looks like it is because HDMI port is tied to my Nvidia graphics card.

And BTW thanks for the heads-up, i wouldn't want to risk installing bumblebee and losing my touchpad.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 871
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Problem with touchpad on Dell XPS (and Bumblebee?)

Postby anandrkris on Thu Jan 03, 2013 1:11 am

I got bumblebee installed and faced the issue of key board and tocuh apd not working but got it fixed by removing the xorg.conf file (some changes done).

Now i can play Supertuxkart with optirun. :-)
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 871
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai


Return to Hardware Support

Who is online

Users browsing this forum: xtal_01 and 18 guests