[SOLVED] Nadia on MacBook Pro - only boots in recovery mode!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

[SOLVED] Nadia on MacBook Pro - only boots in recovery mode!

Postby jommoner on Tue Dec 11, 2012 10:25 pm

Hi!

I've installed Mint 14 on my brand new MacBook Pro (this is the non-retina one as I valued the ability to dismantle the screen and replace components
if needed, to replace / upgrade the hard drive, to upgrade / replace the RAM, and add a second HDD in place of the optical drive at some stage).
This is the 9,1 (or 9,2?) model I think - it has identical specs to the Retina except that it doesn't have the Retina display, and costs $300 less (not much
less).

After several failed attempts I have a 'stable' version of Mint running. Installing the macfanctld helped; I managed to get a CPU temperature of 88 degrees
briefly before installing this :O

My problem is that I can only boot in recovery mode. I select this option, watch it go through the first 6 seconds of boot in verbose mode, then select 'continue
normal boot'. It boots fine every time in recovery mode, but just has a black screen if I try to boot the normal non-recovery option. I'm using rEFInd and GRUB2
as my bootloaders.

Would be grateful for some advice to fix this! Want to get Linux set up fully so I can use it as my main OS and only use Mac OS for compiling apps (why I got
this computer in the first place). I do have a desktop Hackintosh - an apple VM under Maya - but will do some development and all final compilation on actual
Apple hardware :D

Then I can work on 'getting proprietary drivers to work and not say 'x server failed to start', then modify the touchpad driver code to give a new option making
the touchpad closer to a 'standard' one (i would enable multitouch, ignore the bottom ?12mm of the touchpad, but when the touchpad 'clicks', if a finger is on the
bottom left side, it is a left click, and if a finger is on the bottom right side, it is a right click!. This would make it like a standard PC two-button touchpad even
though it only has one button to press!


SOLVED : ADDED 'nomodeset' to the kernel parameters. Apparently this can happen with the nouveau drivers and some nvidia cards. Now to try to install the
proprietary nvidia drivers... without trashing my install like last time!
jommoner
Level 1
Level 1
 
Posts: 10
Joined: Thu Oct 11, 2012 5:25 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: gold_finger and 18 guests