Skype 4.1 anyone?

Questions about applications and software
Forum rules
Before you post please read how to get help

Skype 4.1 anyone?

Postby ammon on Thu Nov 15, 2012 1:54 pm

Hi,
I'm trying to install new skype update.
4.0 worked perfect, but this one is multiarch and I have troubles with it.
Can anyone please help me with this step by step.
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Linux Mint is funded by ads and donations.
 

Re: Skype 4.1 anyone?

Postby jjaythomas on Thu Nov 15, 2012 6:39 pm

Not sure if same problem...
are you on a 64bit install? I know skype is actually a 32 bit program. :wink:

had to use the 'mint14rc fix (see mint's blog) on LMDE for unetbootin to work under 64bit install..

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Skype 4.1 anyone?

Postby ammon on Fri Nov 16, 2012 12:53 pm

Hi,
I did this months ago.
But it does not work, my wine is usless too.
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Re: Skype 4.1 anyone?

Postby zerozero on Fri Nov 16, 2012 1:43 pm

ammon,
what is the output of these 2 commands
Code: Select all
sudo dpkg --print-architecture

Code: Select all
sudo dpkg --print-foreign-architectures
thanks
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Skype 4.1 anyone?

Postby ammon on Sat Nov 17, 2012 12:24 pm

sudo dpkg --print-architecture
amd64

sudo dpkg --print-foreign-architectures
i386
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Re: Skype 4.1 anyone?

Postby zerozero on Sat Nov 17, 2012 2:31 pm

all is well in that department :)
do you have any specific error when trying to install 4.1?
in several sites what i read is that you should first remove the 4.0 packages and then install 4.1. might worth a try.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Skype 4.1 anyone?

Postby ammon on Sat Nov 17, 2012 8:20 pm

Yeah I know everything is ok with that.

Problem is in apt-get can not and will not install needed 32bit libs.
I've tried to get them manually, one by one. But that takes a lot of time.
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Re: Skype 4.1 anyone?

Postby SirSelim on Sun Nov 18, 2012 2:21 am

I've just gone through this myself. I recently followed ZeroZero's guide to installing wine on LMDE 64bit, so had the majority of the i386 packages. When I tried installing Skype 4.1 via GDebi package installer I was getting an an error with the libqtwebkit4:i386 package.

The solution was right here: https://support.skype.com/en/faq/FA1212 ... -linux#2.2

I'm running LMDE pointed at sid so I went for this section from the above link:

7.0+ at 64-bit

Using a terminal, enter the following command under the root and press Enter:

Code: Select all
dpkg --add-architecture i386 && apt-get update


Download and install Debian 7.0+ i386.

Important: If you have libqtwebkit4:amd64 already installed, the installation will fail due to a Debian bug. Learn more.(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676162)

To fix this, using a terminal and under root, enter the following command and press Enter:
Code: Select all
rm /usr/share/doc/libqtwebkit4/changelog.Debian.gz && apt-get -f install


I had to change slightly, to this:
Code: Select all
rm /usr/share/doc/libqtwebkit4/changelog.gz && apt-get -f install


I could now install the required package:
Code: Select all
sudo apt-get install libqtwebkit4:i386


I then went through the right click GDebi installer (right click your downloaded skype-debian_4.1.0.20-1_i386.deb file, and select 'Open with GDebi package installer') and Skype 4.1 is up and running on my LMDE system.

I'm not sure if this will be the same fix for you (are you running pointing at latest/testing/sid repos?), but there are multiple solutions at the page I linked above.

Hope this helps.
User avatar
SirSelim
Level 1
Level 1
 
Posts: 22
Joined: Thu Nov 01, 2012 5:34 pm

Re: Skype 4.1 anyone?

Postby giocid7 on Mon Nov 19, 2012 9:36 pm

SirSelim wrote:I've just gone through this myself. I recently followed ZeroZero's guide to installing wine on LMDE 64bit, so had the majority of the i386 packages. When I tried installing Skype 4.1 via GDebi package installer I was getting an an error with the libqtwebkit4:i386 package.

The solution was right here: https://support.skype.com/en/faq/FA1212 ... -linux#2.2

I'm running LMDE pointed at sid so I went for this section from the above link:

7.0+ at 64-bit

Using a terminal, enter the following command under the root and press Enter:

Code: Select all
dpkg --add-architecture i386 && apt-get update


Download and install Debian 7.0+ i386.

Important: If you have libqtwebkit4:amd64 already installed, the installation will fail due to a Debian bug. Learn more.(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676162)

To fix this, using a terminal and under root, enter the following command and press Enter:
Code: Select all
rm /usr/share/doc/libqtwebkit4/changelog.Debian.gz && apt-get -f install


I had to change slightly, to this:
Code: Select all
rm /usr/share/doc/libqtwebkit4/changelog.gz && apt-get -f install


I could now install the required package:
Code: Select all
sudo apt-get install libqtwebkit4:i386


I then went through the right click GDebi installer (right click your downloaded skype-debian_4.1.0.20-1_i386.deb file, and select 'Open with GDebi package installer') and Skype 4.1 is up and running on my LMDE system.

I'm not sure if this will be the same fix for you (are you running pointing at latest/testing/sid repos?), but there are multiple solutions at the page I linked above.

Hope this helps.


Thanks for your help! Worked like a charm!
giocid7
Level 1
Level 1
 
Posts: 2
Joined: Thu Feb 09, 2012 7:50 am

Re: Skype 4.1 anyone?

Postby SirSelim on Tue Nov 20, 2012 3:08 am

giocid7 wrote:Thanks for your help! Worked like a charm!

No worries, glad it helped. :)
User avatar
SirSelim
Level 1
Level 1
 
Posts: 22
Joined: Thu Nov 01, 2012 5:34 pm

Re: Skype 4.1 anyone?

Postby nomko on Tue Nov 20, 2012 3:50 am

Just for info: here's a good article about Skype: http://www.webupd8.org/2012/11/skype-41 ... ption.html
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
User avatar
nomko
Level 9
Level 9
 
Posts: 2920
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Skype 4.1 anyone?

Postby colonglz on Sun Dec 16, 2012 2:20 pm

Hi

Thank you, this information was very useful to me

greetings
colonglz
Level 1
Level 1
 
Posts: 1
Joined: Sun Dec 16, 2012 2:18 pm

Re: Skype 4.1 anyone?

Postby ShakeyJake on Tue Feb 05, 2013 4:37 pm

I've followed all the guides I can find, but whenever I go to install the .deb file it just open the archive manager and then closes it again almost right away. Is there any way to find out what's going wrong here. I enabled multiarch, got the correct i386 output and just to be safe have removed those files mentioned in this thread. Worth noting I get a wonky-looking output from the webkit install command.

Code: Select all
jack@jack-desktop:~$     sudo apt-get install libqtwebkit4:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  fontconfig-config krb5-locales libaudio2:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libcomerr2 libcomerr2:i386
  libcups2 libcups2:i386 libdbus-1-3 libdbus-1-3:i386 libexpat1:i386
  libffi5:i386 libfontconfig1 libfontconfig1:i386 libfreetype6:i386
  libgcrypt11:i386 libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin libgnutls26
  libgnutls26:i386 libgpg-error0 libgpg-error0:i386 libgssapi-krb5-2
  libgssapi-krb5-2:i386 libgstreamer-plugins-base0.10-0:i386
  libgstreamer0.10-0:i386 libice6:i386 libjbig0 libjbig0:i386 libjpeg8:i386
  libk5crypto3 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3 libkrb5-3:i386
  libkrb5support0 libkrb5support0:i386 liblcms1 liblcms1:i386 liblzma5
  liblzma5:i386 libmng1:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpcre3:i386
  libpng12-0:i386 libqt4-dbus libqt4-dbus:i386 libqt4-declarative
  libqt4-designer libqt4-network libqt4-network:i386 libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg
  libqt4-xml libqt4-xml:i386 libqt4-xmlpatterns libqtcore4 libqtcore4:i386
  libqtgui4 libqtgui4:i386 libqtwebkit4 libselinux1:i386 libsm6:i386
  libsqlite3-0:i386 libstdc++6 libstdc++6:i386 libtasn1-3:i386 libtiff4
  libtiff4:i386 libuuid1 libuuid1:i386 libx11-6:i386 libxau6:i386 libxcb1
  libxcb1:i386 libxcb1-dev libxdmcp6:i386 libxext6:i386 libxml2 libxml2:i386
  libxrender1:i386 libxt6:i386 qdbus:i386 zlib1g:i386
Suggested packages:
  nas:i386 rng-tools:i386 krb5-doc krb5-user krb5-doc:i386 krb5-user:i386
  libvisual-0.4-plugins:i386 gstreamer-codec-install:i386
  gnome-codec-install:i386 gstreamer0.10-tools:i386
  gstreamer0.10-plugins-base:i386 liblcms-utils liblcms-utils:i386
  libqt4-declarative-folderlistmodel libqt4-declarative-gestures
  libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer
  libqt4-dev libthai0:i386 libicu48:i386 qt4-qtconfig qt4-qtconfig:i386
  libxcb-doc
Recommended packages:
  krb5-locales:i386 xml-core:i386
The following packages will be REMOVED:
  qdbus
The following NEW packages will be installed:
  krb5-locales libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libcomerr2:i386 libcups2:i386 libdbus-1-3:i386
  libexpat1:i386 libffi5:i386 libfontconfig1:i386 libfreetype6:i386
  libgcrypt11:i386 libglib2.0-0:i386 libgnutls26:i386 libgpg-error0:i386
  libgssapi-krb5-2:i386 libgstreamer-plugins-base0.10-0:i386
  libgstreamer0.10-0:i386 libice6:i386 libjbig0 libjbig0:i386 libjpeg8:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
  liblcms1:i386 liblzma5:i386 libmng1:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpcre3:i386 libpng12-0:i386 libqt4-dbus:i386 libqt4-network:i386
  libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386
  libselinux1:i386 libsm6:i386 libsqlite3-0:i386 libstdc++6:i386
  libtasn1-3:i386 libtiff4:i386 libuuid1:i386 libx11-6:i386 libxau6:i386
  libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxml2:i386 libxrender1:i386
  libxt6:i386 qdbus:i386 zlib1g:i386
The following packages will be upgraded:
  fontconfig-config libcomerr2 libcups2 libdbus-1-3 libfontconfig1
  libglib2.0-0 libglib2.0-bin libgnutls26 libgpg-error0 libgssapi-krb5-2
  libk5crypto3 libkrb5-3 libkrb5support0 liblcms1 liblzma5 libqt4-dbus
  libqt4-declarative libqt4-designer libqt4-network libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg
  libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libqtwebkit4 libstdc++6
  libtiff4 libuuid1 libxcb1 libxcb1-dev libxml2
36 upgraded, 57 newly installed, 1 to remove and 701 not upgraded.
Need to get 0 B/56.3 MB of archives.
After this operation, 82.9 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 262930 files and directories currently installed.)
Preparing to replace libstdc++6:amd64 4.6.3-1 (using .../libstdc++6_4.7.2-4_amd64.deb) ...
Unpacking replacement libstdc++6:amd64 ...
Selecting previously unselected package libstdc++6:i386.
Unpacking libstdc++6:i386 (from .../libstdc++6_4.7.2-4_i386.deb) ...
dpkg: error: --configure needs a valid package name but 'libstdc++6' is not: ambiguous package name 'libstdc++6' with more than one installed instance

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !
E: Sub-process /usr/bin/dpkg returned an error code (2)
jack@jack-desktop:~$
Jack :)
ShakeyJake
Level 1
Level 1
 
Posts: 35
Joined: Fri Feb 26, 2010 7:35 am

Re: Skype 4.1 anyone?

Postby zerozero on Tue Feb 05, 2013 4:55 pm

Jack,
you need to tell us a bit more about the system you are trying to install skype in
36 upgraded, 57 newly installed, 1 to remove and 701 not upgraded.
what's up with this :lol:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Skype 4.1 anyone?

Postby ShakeyJake on Tue Feb 05, 2013 6:20 pm

Hah, well that's definitely new since I started trying to install skype. I could tell you loads about the system but it probably wouldn't be the right stuff. It's LMDE, 64bit with MATE. Kernel 3.2.0-3amd64. If there's something specific you'd like please let me know, I'm not being dense and obtuse on purpose, I'm just dense and obtuse. :)
Jack :)
ShakeyJake
Level 1
Level 1
 
Posts: 35
Joined: Fri Feb 26, 2010 7:35 am

Re: Skype 4.1 anyone?

Postby zerozero on Tue Feb 05, 2013 6:44 pm

heh no problem 8)
ShakeyJake wrote:It's LMDE, 64bit with MATE. Kernel 3.2.0-3amd64.
this tells me (together with the other highlight above) that your system is not updated.

1- make sure that the output of inxi -r matches this
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
    deb http://debian.linuxmint.com/latest testing main contrib non-free
    deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
    deb http://debian.linuxmint.com/latest/multimedia testing main non-free


2- update either with mintupdate or with apt update && apt dist-upgrade

3- after the update you can follow this viewtopic.php?f=190&t=122296 to a) enable multiarch and b) install skype
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Skype 4.1 anyone?

Postby ShakeyJake on Tue Feb 05, 2013 7:04 pm

Well I do like to go a while between updates. My usual train of thought is that if it ain't broke don't fix it but I suppose in this case it was broken. I shall try tomorrow as it's late here in GMT and I'll report back. Thanks zero.
Jack :)
ShakeyJake
Level 1
Level 1
 
Posts: 35
Joined: Fri Feb 26, 2010 7:35 am

Re: Skype 4.1 anyone?

Postby ShakeyJake on Thu Feb 07, 2013 1:46 pm

Sorry, still here and still stuck. Seeing as this has drifted OT I'd be happy to start a new thread if you guys would prefer. I'm still stuck unable to upgrade, system is really throwing a loop over this libstdc++6 rubbish.

Code: Select all
jack@jack-desktop:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  gs-cjk-resource libept1 libevince3-3 libgstfarsight0.10-0 librpm2 libupnp3
  linux-sound-base mint-artwork-debian
The following NEW packages will be installed:
  aptdaemon-data aptitude-common cpp-4.7 cryptsetup-bin fonts-samyak-taml
  g++-4.7 gcc-4.7 gcr gir1.2-xkl-1.0 gkbd-capplet icedtea-6-plugin kmod
  libamd2.2.0 libapt-inst1.5 libapt-pkg4.12 libasprintf0c2 libatk-adaptor-data
  libatk-bridge2.0-0 libavfilter3 libbabl-0.1-0 libblas3
  libboost-iostreams1.49.0 libcdio-cdda1 libcdio-paranoia1 libcdio13
  libclutter-imcontext-0.1-bin libcmis-0.2-0 libdevmapper-event1.02.1
  libegl1-mesa libegl1-mesa-drivers libept1.4.12 libevview3-3
  libexttextcat-data libexttextcat0 libfarstream-0.1-0 libfile-fcntllock-perl
  libgbm1 libgdata2.1-cil libgegl-0.2-0 libgmime2.6-cil libgusb2 libiso9660-8
  libitm1 libjbig0 libkmod2 liblapack3 liblensfun-data liblensfun0
  libmagickcore5 libmagickcore5-extra libmagickwand5 libmatewnck
  libmatewnck-common libmono-system-runtime-serialization4.0-cil
  libmono-system-xml-linq4.0-cil libmpg123-0 libmtdev1 libnemo-extension1
  libnewtonsoft-json4.5-cil libnspr4 libnss3 libopenvg1-mesa libopus0
  libpam-cap librpm3 librpmio3 libruby1.9.1 libsocialweb-common
  libsocialweb-service libstdc++6-4.7-dev libsystemd-daemon0 libsystemd-login0
  libumfpack5.4.0 libupnp6 libvisio-0.0-0 libvorbisidec1 libwayland0
  libwebrtc-audio-processing-0 libx264-123 libx264-129 libxcb-glx0 libyaml-0-2
  linux-headers-3.2.0-4-amd64 linux-headers-3.2.0-4-common
  linux-image-3.2.0-4-amd64 mate-keyring mate-media-common
  mate-media-gstreamer mint-debian-mirrors nemo nemo-data nemo-fileroller
  nvidia-kernel-3.2.0-4-amd64 packagekit-tools printer-driver-cjet
  python-aptdaemon.gtk3widgets python-dbus-dev python-lxml ruby-gettext
  ruby-locale ruby1.9.1 software-properties-common
The following packages have been kept back:
  nautilus-dropbox python-pyatspi2
The following packages will be upgraded:
  accountsservice alsa-base alsa-utils apache2.2-bin app-install-data apt
  apt-utils aptitude aptitude-doc-en at-spi at-spi2-core banshee
  banshee-extension-soundmenu base-files bind9-host binfmt-support binutils
  bluez brasero brasero-common bsdutils busybox bzip2 ca-certificates-java
  caja-dropbox caribou cheese-common cinnamon colord console-setup
  console-setup-linux consolekit coreutils cpp cpp-4.4 cpp-4.6 cryptsetup cups
  cups-client cups-common cups-filters cups-pk-helper cups-ppdc dbus dbus-x11
  debconf debconf-i18n debian-system-adjustments dictionaries-common dkms
  dnsutils dpkg dpkg-dev dselect e2fslibs e2fsprogs evince evince-common
  evolution-data-server-common exim4-config ffmpeg firefox firefox-l10n-en-gb
  fontconfig fontconfig-config fonts-opensymbol fonts-samyak-gujr fonts-taml
  g++ g++-4.4 g++-4.6 gcc gcc-4.4 gcc-4.4-base gcc-4.6 gcc-4.6-base
  gconf-defaults-service gconf-service gconf2 gconf2-common gdebi gdebi-core
  geoip-database gettext-base ghostscript ghostscript-cups ghostscript-x gimp
  gimp-data gir1.2-accountsservice-1.0 gir1.2-atspi-2.0 gir1.2-caribou-1.0
  gir1.2-clutter-1.0 gir1.2-evince-3.0 gir1.2-gconf-2.0
  gir1.2-gdesktopenums-3.0 gir1.2-gkbd-3.0 gir1.2-gmenu-3.0 gir1.2-gtk-2.0
  gir1.2-gtk-3.0 gir1.2-javascriptcoregtk-3.0 gir1.2-muffin-3.0
  gir1.2-networkmanager-1.0 gir1.2-panelapplet-4.0 gir1.2-rb-3.0
  gir1.2-telepathyglib-0.12 gir1.2-webkit-3.0 gnome-control-center
  gnome-control-center-data gnome-keyring gnome-menus gnome-session-bin
  gnome-session-common gnome-settings-daemon gnome-terminal
  gnome-terminal-data gnome-themes-standard gnome-user-guide gnupg gpgv
  grub-common grub-pc grub-pc-bin grub2-common gsettings-desktop-schemas
  gstreamer0.10-ffmpeg gstreamer0.10-gconf gstreamer0.10-plugins-bad
  gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly
  gstreamer0.10-pulseaudio gtk2-engines gtk2-engines-pixbuf gucharmap gvfs
  gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-libs hddtemp iceape
  iceape-chatzilla icedtea-6-jre-cacao icedtea-6-jre-jamvm icedtea-netx
  icedtea-netx-common icedtea-plugin icedtea6-plugin ifupdown imagemagick
  imagemagick-common initramfs-tools initscripts insserv iptables
  isc-dhcp-client isc-dhcp-common iso-codes kde-runtime kde-runtime-data
  kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools keyboard-configuration
  klibc-utils ksh libaccountsservice0 libaprutil1 libaprutil1-dbd-sqlite3
  libaprutil1-ldap libapt-pkg-perl libasound2 libatspi1.0-0 libatspi2.0-0
  libaudclient2 libaudiofile1 libavcodec54 libavdevice54 libavfilter2
  libavformat54 libavutil51 libbind9-80 libblas3gf libblkid1
  libbrasero-media3-1 libbrlapi0.5 libbsd0 libbz2-1.0 libcamel-1.2-33
  libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra0
  libcap2 libcap2-bin libcaribou-common libcaribou0 libcheese-gtk21 libcheese3
  libck-connector0 libclutter-1.0-0 libclutter-imcontext-0.1-0 libcolamd2.7.1
  libcomerr2 libcroco3 libcryptsetup4 libcups2 libcupscgi1 libcupsdriver1
  libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libdbus-1-3
  libdlrestrictions1 libdns81 libdpkg-perl libdvdcss2 libebackend-1.2-2
  libebook-1.2-13 libecal-1.2-11 libedata-book-1.2-13 libedata-cal-1.2-15
  libedataserver-1.2-16 libedataserverui-3.0-1 libelf1 libevdocument3-4
  libfftw3-3 libflite1 libfontconfig1 libgail-3-0 libgail-common libgail18
  libgck-1-0 libgconf-2-4 libgconf2-4 libgcr-3-1 libgdu-gtk0 libgdu0
  libgettext-ruby1.8 libgfortran3 libgif4 libgimp2.0 libgl1-mesa-dev
  libgl1-mesa-dri libgl1-mesa-dri-experimental libgl1-mesa-glx
  libgl1-nvidia-alternatives libgl1-nvidia-glx libglade2.0-cil libgladeui-1-9
  libglapi-mesa libglib2.0-0 libglib2.0-bin libglib2.0-cil libglib2.0-data
  libglibmm-2.4-1c2a libglu1-mesa libglx-nvidia-alternatives libgnome-menu-3-0
  libgnomecanvas2-0 libgnomecanvas2-common libgnutls26 libgomp1 libgpg-error0
  libgpod-common libgpod4 libgs9 libgs9-common libgssapi-krb5-2
  libgstreamer-plugins-bad0.10-0 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libgtk2.0-0 libgtk2.0-bin libgtk2.0-cil libgtk2.0-common libgtkhtml-4.0-0
  libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgtkmm-3.0-1
  libgucharmap-2-90-7 libgudev-1.0-0 libgweather-3-0 libgweather-common
  libicu48 libio-socket-ssl-perl libisc83 libisccc80 libisccfg82 libjack0
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libjs-jquery
  libk5crypto3 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5
  libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4
  libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libklibc
  libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4
  libkpathsea6 libkprintutils4 libkpty4 libkrb5-3 libkrb5support0
  libkrosscore4 libktexteditor4 liblapack3gf liblcms1 liblocale-ruby1.8
  liblua5.1-0 liblvm2app2.2 liblwres80 liblzma5 libmatepanelapplet
  libmetacity-private0a libmikmod2 libmission-control-plugins0
  libmono-cairo2.0-cil libmono-cairo4.0-cil
  libmono-compilerservices-symbolwriter4.0-cil libmono-corlib2.0-cil
  libmono-corlib4.0-cil libmono-data-tds2.0-cil libmono-data-tds4.0-cil
  libmono-i18n-west2.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil
  libmono-messaging2.0-cil libmono-posix2.0-cil libmono-posix4.0-cil
  libmono-security2.0-cil libmono-security4.0-cil libmono-sharpzip2.84-cil
  libmono-sharpzip4.84-cil libmono-simd2.0-cil libmono-sqlite2.0-cil
  libmono-sqlite4.0-cil libmono-system-configuration4.0-cil
  libmono-system-core4.0-cil libmono-system-data-linq2.0-cil
  libmono-system-data2.0-cil libmono-system-data4.0-cil
  libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil
  libmono-system-messaging2.0-cil libmono-system-security4.0-cil
  libmono-system-transactions4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web2.0-cil
  libmono-system-web4.0-cil libmono-system-xml4.0-cil libmono-system2.0-cil
  libmono-system4.0-cil libmono-wcf3.0-cil libmono-web4.0-cil libmono2.0-cil
  libmount1 libmozjs10d libmozjs185-1.0 libmtp-common libmtp-runtime libmtp9
  libmuffin0 libmysqlclient18 libnautilus-extension1a libnepomuk4
  libnepomukquery4a libnepomukutils4 libnettle4 libnm-glib-vpn1 libnm-glib4
  libnm-gtk-common libnm-gtk0 libnm-util2 libnspr4-0d libnss3-1d libnvidia-ml1
  liboauth0 libopenjpeg2 libpackagekit-glib2-14 libpam-ck-connector
  libpam-gnome-keyring libpanel-applet-4-0 libparted0debian1 libperl5.14
  libplasma3 libpostproc52 libppl-c4 libppl9 libproxy0 libpulse-mainloop-glib0
  libpulse0 libpurple-bin libpurple0 libpwl5 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support libqt4-script
  libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-xml libqt4-xmlpatterns
  libqtcore4 libqtgui4 libqtwebkit4 libquadmath0 libquvi-scripts libraptor2-0
  libreadline5 libreoffice libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-filter-mobiledev libreoffice-gnome
  libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer librhythmbox-core6 libruby
  libruby1.8 libsane libsane-common libsasl2-2 libsasl2-modules
  libsdl-mixer1.2 libservlet2.5-java libsmbclient libsocialweb-client2
  libsocialweb0 libsolid4 libspandsp2 libspectre1 libspeex1 libspeexdsp1
  libss2 libssh-4 libssh2-1 libssl1.0.0 libstdc++6-4.4-dev libstdc++6-4.6-dev
  libswresample0 libswscale2 libtag1-vanilla libtag1c2a libtagc0
  libtelepathy-glib0 libthai-data libthai0 libthreadweaver4 libtiff4
  libtracker-sparql-0.14-0 libudev0 libusb-0.1-4 libuuid-perl libuuid1
  libvcdinfo0 libvdpau1 libvlc5 libvlccore5 libwacom-common libwacom2
  libwbclient0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libwrap0 libxapian22 libxcb-composite0 libxcb-dri2-0
  libxcb-randr0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-xfixes0
  libxcb-xv0 libxcb1 libxcb1-dev libxml2 libxml2-utils libxnvctrl0 libxslt1.1
  libyelp0 linux-headers-amd64 linux-image-amd64 linux-libc-dev locales
  lsb-base lsb-release manpages manpages-dev mate-applets mate-applets-common
  mate-core mate-desktop-environment mate-media mate-notification-daemon
  mate-panel mate-panel-common mate-system-monitor mdm mesa-common-dev
  metacity metacity-common mint-common mint-mdm-themes mint-meta-codecs
  mint-translations mint-x-icons mintdesktop mintinstall mintinstall-icons
  mintmenu mintsystem mintupdate-debian modemmanager module-init-tools
  mono-2.0-gac mono-4.0-gac mono-gac mono-runtime mount mplayer muffin-common
  multiarch-support myspell-en-gb mysql-common nautilus nautilus-data
  net-tools network-manager network-manager-gnome ntfs-3g ntfsprogs
  nvidia-alternative nvidia-detect nvidia-glx nvidia-installer-cleanup
  nvidia-kernel-amd64 nvidia-kernel-common nvidia-kernel-dkms nvidia-settings
  nvidia-smi nvidia-support nvidia-vdpau-driver nvidia-xconfig
  obex-data-server openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
  openssh-client openssl os-prober oss-compat oxygencursors packagekit
  packagekit-backend-aptcc perl perl-base perl-modules phonon-backend-vlc
  pidgin pidgin-data plasma-scriptengine-javascript poppler-data
  printer-driver-all printer-driver-c2esp printer-driver-foo2zjs
  printer-driver-splix pulseaudio pulseaudio-esound-compat
  pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-module-zeroconf
  pulseaudio-utils python-apt python-apt-common python-brlapi python-dbus
  python-libxml2 python-packagekit python-paramiko python-pygame python-uno
  python-xapian python-zope.interface python3 python3-apt python3-minimal
  qdbus rhythmbox rhythmbox-data rhythmbox-plugins rpm-common rpm2cpio rsyslog
  ruby ruby-debian ruby1.8 samba samba-common samba-common-bin sane-utils
  seahorse shared-mime-info software-properties-gtk speex ssl-cert synaptic
  sysv-rc sysvinit sysvinit-utils tcpd telepathy-gabble
  telepathy-mission-control-5 thunderbird thunderbird-l10n-en-gb timidity
  timidity-daemon timidity-interfaces-extra tomboy transmission-common
  transmission-gtk ttf-dejavu ttf-dejavu-core ttf-dejavu-extra ttf-opensymbol
  ttf-tamil-fonts tzdata tzdata-java udev udisks ufraw-batch ufw
  unattended-upgrades uno-libs3 ure usb-modeswitch-data user-setup util-linux
  uuid-runtime vim-common vim-tiny vino virtualbox-guest-dkms
  virtualbox-guest-utils virtualbox-guest-x11 vlc vlc-data vlc-nox
  vlc-plugin-notify vlc-plugin-pulse w64codecs wajig whois wpasupplicant
  xkb-data xml-core xnest xserver-common xserver-xorg-core
  xserver-xorg-input-evdev xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus
  xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-nvidia xserver-xorg-video-openchrome
  xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo xsltproc xulrunner-10.0 xz-utils yelp
734 upgraded, 102 newly installed, 8 to remove and 2 not upgraded.
2 not fully installed or removed.
Need to get 0 B/857 MB of archives.
After this operation, 449 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: error: --configure needs a valid package name but 'libstdc++6' is not: ambiguous package name 'libstdc++6' with more than one installed instance

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !
E: Sub-process /usr/bin/dpkg returned an error code (2)
jack@jack-desktop:~$
Jack :)
ShakeyJake
Level 1
Level 1
 
Posts: 35
Joined: Fri Feb 26, 2010 7:35 am

Re: Skype 4.1 anyone?

Postby zerozero on Thu Feb 07, 2013 2:04 pm

do you have libstdc++6:i386 installed?

check with
Code: Select all
apt policy libstdc++6:i386
if yes what is the output of
Code: Select all
sudo apt-get -s purge libstdc++6:i386
this is only a dry-run, won't perform any removal in the system :D
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Skype 4.1 anyone?

Postby ShakeyJake on Thu Feb 07, 2013 5:13 pm

I appreciate your patience Zero. Still getting complaints though.

Code: Select all
jack@jack-desktop:~$ apt policy libstdc++6:i386
libstdc++6:i386:
  Installed: 4.7.2-4
  Candidate: 4.7.2-4
  Version table:
 *** 4.7.2-4 0
        500 http://debian.linuxmint.com/latest/ testing/main i386 Packages
        100 /var/lib/dpkg/status
jack@jack-desktop:~$ sudo apt-get -s purge libstdc++6:i386
[sudo] password for jack:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libstdc++6:i386*
0 upgraded, 0 newly installed, 1 to remove and 737 not upgraded.
2 not fully installed or removed.
Purg libstdc++6:i386 [4.7.2-4]
Conf libstdc++6 (4.7.2-4 Debian:testing [amd64])
jack@jack-desktop:~$

Last edited by ShakeyJake on Fri Feb 08, 2013 5:49 pm, edited 1 time in total.
Jack :)
ShakeyJake
Level 1
Level 1
 
Posts: 35
Joined: Fri Feb 26, 2010 7:35 am

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests