Imposible actualizar LMDE a kernel 3.6.10

Spanish Forum

Moderator: vrkalak

Imposible actualizar LMDE a kernel 3.6.10

Postby Rayeta76 on Mon Dec 17, 2012 10:36 am

Hola a todos, me es absolutamente actualizar el kernel de mi LMDE a la versión 3.6.10.

La razón que me indica es que necesita la libreria "Libc6" versión 2.14 o superior, pero no encuentro dicha librería en el synaptyc.
He probado incluso con los repos de Debian Sis, experimental etc pero dicho fichero no esta.

¿alguien a podido actualizar a dicha versión?

Gracias
Image
User avatar
Rayeta76
Level 3
Level 3
 
Posts: 141
Joined: Thu Oct 25, 2012 8:02 pm

Linux Mint is funded by ads and donations.
 

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby zerozero on Mon Dec 17, 2012 10:59 am

desde donde estás tratando de actualizar a la versión 3.6.10?
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby Rayeta76 on Mon Dec 17, 2012 11:11 am

zerozero wrote:desde donde estás tratando de actualizar a la versión 3.6.10?


Siguiendo un tutorial para Mint del forum si que he podido actualizar hasta la versión:

javier@lmde:~$ uname -r
3.3.7-030307-generic
javier@lmde:~$


Los ficheros los bajo de aqui http://kernel.ubuntu.com/~kernel-ppa/ma ... 1-quantal/
Hasta la versión que tengo instalado no ha habido problema alguno, pero con la 3.6.1 o superiores no hay forma de actualizar en LMDE.

También he empezado a intentar compilar el 3.7 descargado de aquí http://www.kernel.org/ pero eso es otra historia.
Image
User avatar
Rayeta76
Level 3
Level 3
 
Posts: 141
Joined: Thu Oct 25, 2012 8:02 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby zerozero on Mon Dec 17, 2012 11:38 am

pero ¿por qué estás usando los kernels de ubuntu in lmde :shock: :?:
que se rompa su instalación, tarde o temprano.

http://liquorix.net/ tiene la versión 3.6.0-10 ahora http://liquorix.net/debian/pool/main/l/linux-liquorix/
3.7 está disponible en aptosid repo http://debian.tu-bs.de/project/aptosid/ ... x-aptosid/ pero hay informes de muchos problemas con él
http://aptosid.com/index.php?name=PNphp ... pic&t=2502
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby Rayeta76 on Mon Dec 17, 2012 11:47 am

zerozero wrote:pero ¿por qué estás usando los kernels de ubuntu in lmde :shock: :?:
que se rompa su instalación, tarde o temprano.

http://liquorix.net/ tiene la versión 3.6.0-10 ahora http://liquorix.net/debian/pool/main/l/linux-liquorix/
3.7 está disponible en aptosid repo http://debian.tu-bs.de/project/aptosid/ ... x-aptosid/ pero hay informes de muchos problemas con él
http://aptosid.com/index.php?name=PNphp ... pic&t=2502


La inexperiencia es un gran peligro para experimentar, esa seria mi la razón. Soy muy novato en este tema.
Ose que agregando en Liquorix encontrare todos los Kernels, y si no recuerdo mas agregando su repositorio puedo hacerlo desde Synaptyc.

Gracias voy a leer lo que me has enviado.

Por fortuna el LMDE no se rompió, funciona , pero des-instalare los últimos Kernels por si acaso.

Gracias
Image
User avatar
Rayeta76
Level 3
Level 3
 
Posts: 141
Joined: Thu Oct 25, 2012 8:02 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby Rayeta76 on Mon Dec 17, 2012 12:12 pm

zerozero, gracias por tu ayuda.

Al final he instalado el repositorio de Liquorix y ahi me ha salido el kernel 3.6.0-10. Lo ha instalado y configurado y todo bien.
Linux lmde 3.6.0-10.dmz.1-liquorix-amd64 #1 ZEN SMP PREEMPT Wed Dec 12 03:35:17 UTC 2012 x86_64 GNU/Linux

Ahora desde synaptic des-instalare los kernels de Ubuntu, dejando solo los de LMDE.
Para gente como yo no estaría de mas un tuto aquí en el foro que explicara el tema de los Kernels ya que hay mucha confusión para los no iniciados como yo.
Aun así con los últimos Kernel no se soluciona un tema que me llave loco y es la instalación de ZFS- fuse y Zpool para poder trabajar desde Linux con sistema de ficheros de Open-indiana.

Solo me queda una duda y es que ahora tengo el driver noveau para la gráfica, ya que me daba muchos problemas al actualizar Kernel el privativo de Nvidia, voy a instalarlo ahora ya que ciertas aplicaciones no se ven correctamente con el Noveau, no se que pasara cuando actualice el Kernel con el driver Nvidia instalado.

Lo normal, pantalla negra.

Gracias y saludos.
Image
User avatar
Rayeta76
Level 3
Level 3
 
Posts: 141
Joined: Thu Oct 25, 2012 8:02 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby Rayeta76 on Mon Dec 17, 2012 12:22 pm

Hola de nuevo, con la versión de Kernel:
Linux lmde 3.6.0-10.dmz.1-liquorix-amd64 #1 ZEN SMP PREEMPT Wed Dec 12 03:35:17 UTC 2012 x86_64 GNU/Linux

LMDE tampoco me detecta los 4 GB de ram, por lo visto no es problema del kernel.

Lo curioso es que Win64 si que detecta los 4 Gb de RAM y LMDE no.
total used free shared buffers cached
Mem: 3009 1061 1947 0 58 413
Swap: 1999 0 1999
Image
User avatar
Rayeta76
Level 3
Level 3
 
Posts: 141
Joined: Thu Oct 25, 2012 8:02 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby zerozero on Mon Dec 17, 2012 9:37 pm

Rayeta76 wrote:Solo me queda una duda y es que ahora tengo el driver noveau para la gráfica, ya que me daba muchos problemas al actualizar Kernel el privativo de Nvidia, voy a instalarlo ahora ya que ciertas aplicaciones no se ven correctamente con el Noveau, no se que pasara cuando actualice el Kernel con el driver Nvidia instalado.

sobre esto yo recomendaría sgfxi http://smxi.org/docs/sgfxi-manual.htm (muy facil de usar)
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby Rayeta76 on Tue Dec 18, 2012 10:58 am

zerozero wrote:
Rayeta76 wrote:Solo me queda una duda y es que ahora tengo el driver noveau para la gráfica, ya que me daba muchos problemas al actualizar Kernel el privativo de Nvidia, voy a instalarlo ahora ya que ciertas aplicaciones no se ven correctamente con el Noveau, no se que pasara cuando actualice el Kernel con el driver Nvidia instalado.

sobre esto yo recomendaría sgfxi http://smxi.org/docs/sgfxi-manual.htm (muy facil de usar)


Pero con este scrip te instala los drivers privativos oficiales? Yo suelo descargar directamente de Nvidia el ultimo driver para Linux que ellos dan como estable o lo instalo de la rama experimental de Debian.
¿ es lo mismo?

Gracias
Image
User avatar
Rayeta76
Level 3
Level 3
 
Posts: 141
Joined: Thu Oct 25, 2012 8:02 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby zerozero on Tue Dec 18, 2012 8:55 pm

usted tiene las dos opciones, o bien instalar el driver de los repos o los oficiales de nvidia.
vea las opciones en el enlace que he dado anteriormente.
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Imposible actualizar LMDE a kernel 3.6.10

Postby Rayeta76 on Wed Dec 19, 2012 5:45 am

zerozero wrote:usted tiene las dos opciones, o bien instalar el driver de los repos o los oficiales de nvidia.
vea las opciones en el enlace que he dado anteriormente.


Hola zerozero,

¿ es seguro este metodo? en la pagina oficial aparece esta nota de advertencia:

Page last updated 2011-06-03)
smxi and related scripts

NOTE: this page is not maintained, please use the smxi.org resources listed below for reasonably up to date documentation.

Casi que prefiero instalar el driver Nvidia como hice desde el repositorio de Debian experimental. Porque tal vez no estoy comprendiendo bien, ¿ que diferencia hay que instale el driver Nvidia desde el repositorio de Debian experimental o desde el scrip de smxi.org? Al final cuando instale el kernel desde ficheros *.deb, no de liquorix, me pasara lo mismo de siempre que el kernel no encuentra la configuración del fichero xorg.conf y tenga que reinstalar el driver de Nvidia como se explica en este blog : http://lmde-frannoe.blogspot.com.es/201 ... -tras.html.

De hecho al compilar el kernel 3.7 para mi pc, me paso esto al instalar la nueva versión me quede sin servidor Xorg por no encontrar la configuración. Excepto con el Update Pack 6 de LMDE, ( no actualiza kernel), siempre que actualizo el kernel normalmente me quedo sin servidor gráfico.

Si con este scrip al instalar Nvidia y actualizar kerne no pasara esto, entonces si me interesa, pero si solo es para instalar el ultimo driver de Nvidia prefiero hacerlo de los repos Debian o descargando el driver de Nvidia.

Por favor corrígeme si me equivoco ya que apenas llevo 2 meses con Linux y aun soy muy novato y tengo muchas dudas, todo lo que me podáis enseñar es poco.

Muchas gracias por tu colaboración, todo comentario es poco para aprender, gracias de nuevo.
Image
User avatar
Rayeta76
Level 3
Level 3
 
Posts: 141
Joined: Thu Oct 25, 2012 8:02 pm

Linux Mint is funded by ads and donations.
 

Return to Español (Spanish)

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests