"Open in Terminal" not working for me [SOLVED]

"Open in Terminal" not working for me [SOLVED]

Postby jerkins on Wed Dec 19, 2012 11:55 am

This is a trivial thing, but it's driving me nuts...

Environment:

Linux Mint 13 (Mate)
Normal user, with admin rights

Problem:

When I right click in a directory window I get the option "Open in Terminal", but when I select this, nothing happens - no terminal window opens.
Also, if I run an executable script with the "Run in Terminal" option, I don't get a terminal window either.

I know this used to work for me a while ago...

Basically, is this a known problem, and is it easy to fix? If not known, where can I go to see if any errors have been reported by this action?

Thanks,
David
Last edited by jerkins on Wed Dec 19, 2012 4:00 pm, edited 1 time in total.
jerkins
Level 1
Level 1
 
Posts: 24
Joined: Mon Jun 01, 2009 3:55 pm

Linux Mint is funded by ads and donations.
 

Re: "Open in Terminal" not working for me

Postby Flemur on Wed Dec 19, 2012 2:59 pm

There's some enviroment variables ...

Code: Select all
$ env | grep erm
TERM=xterm
COLORTERM=gnome-terminal


...though when I "open terminal here" from a file browser, I get xfce-terminal from thunar and gnome-terminal from pcmanfm (in which you can define the terminal to open, which is by far the best way). My regular terminal is "terminator".

Try reinstalling your terminal application!
Mint 17/Xfce/fluxbox & another Mint 17/Xfce/fluxbox with jackd audio.
User avatar
Flemur
Level 5
Level 5
 
Posts: 992
Joined: Mon Aug 20, 2012 9:41 pm

Re: "Open in Terminal" not working for me

Postby jerkins on Wed Dec 19, 2012 4:00 pm

Good call!

This is my setup:
Code: Select all
david@desktop ~ $ env | grep erm
TERM=xterm
COLORTERM=mate-terminal


But when I looked in the synaptic package manager xterm wasn't installed! I have no idea where that went, as it's not something I would uninstall intentionally...

Anyway - many thanks! :)
jerkins
Level 1
Level 1
 
Posts: 24
Joined: Mon Jun 01, 2009 3:55 pm


Return to MATE

Who is online

Users browsing this forum: No registered users and 3 guests