Update 12/19/2012: Error: Can't find display

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Update 12/19/2012: Error: Can't find display

Postby cwsnyder on Thu Dec 20, 2012 9:44 am

I updated LMDE Xfce through normal Mint-update (click on shield with i in circle) last night, and since then booting normally takes me to the black screen with a blinking cursor, as does trying to start lightdm. The update 'supposedly' updated my kernel, but there was no kernel update found in GRUB. Using the fall-back single-user mode, trying to startx gives the error that no display is found. Tried this morning (Eastern Standard Time U.S.A.) with sudo apt-get update && sudo apt-get dist-upgrade. I have an update for google-chrome-beta, but the dl.google.com is not found, as well as errors during update.

Machine is DIY with a BIOStar N68S3B motherboard, nVidia GeForce 7025 graphics on motherboard, AMD Athlon II X3 processor, 8G RAM, Etronix 1701B 17" 1280x1024 monitor with an EDID which is not read properly by Linux, I am used to having to trouble-shoot video problems by myself since Ubuntu 7.10. I copied a xorg.conf file from my old computer which used a nVidia GeForce 6200 graphics card to see if that would help, no joy. I am using a USB keyboard and USB optical mouse.

Running startx as either my regular user or as root gives basically the same errors. Attached is my /var/log/Xorg.0.log file:
Code: Select all
[    19.869]
X.Org X Server 1.12.4
Release Date: 2012-08-27
[    19.869] X Protocol Version 11, Revision 0
[    19.869] Build Operating System: Linux 3.2.0-4.drm-amd64 x86_64 Debian
[    19.869] Current Operating System: Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.32-1 x86_64
[    19.869] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-amd64 root=UUID=2f4432a4-6224-4344-aa9b-d57be7eb535c ro quiet
[    19.869] Build Date: 29 November 2012  07:18:16PM
[    19.869] xorg-server 2:1.12.4-4 (Julien Cristau <jcristau@debian.org>)
[    19.869] Current version of pixman: 0.26.0
[    19.869]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    19.869] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.869] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 20 08:22:44 2012
[    19.920] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    20.000] (==) No Layout section.  Using the first Screen section.
[    20.000] (==) No screen section available. Using defaults.
[    20.000] (**) |-->Screen "Default Screen Section" (0)
[    20.000] (**) |   |-->Monitor "<default monitor>"
[    20.000] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    20.000] (==) Automatically adding devices
[    20.000] (==) Automatically enabling devices
[    20.143] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    20.143]    Entry deleted from font path.
[    20.159] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[    20.159]    Entry deleted from font path.
[    20.159] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[    20.159] (==) ModulePath set to "/usr/lib/xorg/modules"
[    20.159] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    20.159] (II) Loader magic: 0x7f82a1e44ae0
[    20.159] (II) Module ABI versions:
[    20.159]    X.Org ANSI C Emulation: 0.4
[    20.159]    X.Org Video Driver: 12.1
[    20.159]    X.Org XInput driver : 16.0
[    20.159]    X.Org Server Extension : 6.0
[    20.160] (--) PCI:*(0:0:13:0) 10de:03d6:1565:1405 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xdd000000/16777216, BIOS @ 0x????????/131072
[    20.161] (II) Open ACPI successful (/var/run/acpid.socket)
[    20.161] (II) LoadModule: "extmod"
[    20.186] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    20.202] (II) Module extmod: vendor="X.Org Foundation"
[    20.202]    compiled for 1.12.4, module version = 1.0.0
[    20.202]    Module class: X.Org Server Extension
[    20.202]    ABI class: X.Org Server Extension, version 6.0
[    20.202] (II) Loading extension SELinux
[    20.202] (II) Loading extension MIT-SCREEN-SAVER
[    20.202] (II) Loading extension XFree86-VidModeExtension
[    20.202] (II) Loading extension XFree86-DGA
[    20.202] (II) Loading extension DPMS
[    20.202] (II) Loading extension XVideo
[    20.202] (II) Loading extension XVideo-MotionCompensation
[    20.202] (II) Loading extension X-Resource
[    20.202] (II) LoadModule: "dbe"
[    20.203] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    20.238] (II) Module dbe: vendor="X.Org Foundation"
[    20.238]    compiled for 1.12.4, module version = 1.0.0
[    20.238]    Module class: X.Org Server Extension
[    20.238]    ABI class: X.Org Server Extension, version 6.0
[    20.238] (II) Loading extension DOUBLE-BUFFER
[    20.238] (II) LoadModule: "glx"
[    20.239] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    20.259] (II) Module glx: vendor="X.Org Foundation"
[    20.259]    compiled for 1.12.4, module version = 1.0.0
[    20.259]    ABI class: X.Org Server Extension, version 6.0
[    20.259] (==) AIGLX enabled
[    20.259] (II) Loading extension GLX
[    20.259] (II) LoadModule: "record"
[    20.260] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    20.261] (II) Module record: vendor="X.Org Foundation"
[    20.261]    compiled for 1.12.4, module version = 1.13.0
[    20.261]    Module class: X.Org Server Extension
[    20.261]    ABI class: X.Org Server Extension, version 6.0
[    20.261] (II) Loading extension RECORD
[    20.261] (II) LoadModule: "dri"
[    20.262] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    20.286] (II) Module dri: vendor="X.Org Foundation"
[    20.286]    compiled for 1.12.4, module version = 1.0.0
[    20.286]    ABI class: X.Org Server Extension, version 6.0
[    20.286] (II) Loading extension XFree86-DRI
[    20.286] (II) LoadModule: "dri2"
[    20.287] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    20.299] (II) Module dri2: vendor="X.Org Foundation"
[    20.299]    compiled for 1.12.4, module version = 1.2.0
[    20.299]    ABI class: X.Org Server Extension, version 6.0
[    20.299] (II) Loading extension DRI2
[    20.299] (==) Matched nouveau as autoconfigured driver 0
[    20.299] (==) Matched nv as autoconfigured driver 1
[    20.299] (==) Matched vesa as autoconfigured driver 2
[    20.299] (==) Matched fbdev as autoconfigured driver 3
[    20.299] (==) Assigned the driver to the xf86ConfigLayout
[    20.299] (II) LoadModule: "nouveau"
[    20.299] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    20.356] (II) Module nouveau: vendor="X.Org Foundation"
[    20.356]    compiled for 1.12.4, module version = 1.0.1
[    20.356]    Module class: X.Org Video Driver
[    20.356]    ABI class: X.Org Video Driver, version 12.1
[    20.356] (II) LoadModule: "nv"
[    20.376] (WW) Warning, couldn't open module nv
[    20.376] (II) UnloadModule: "nv"
[    20.376] (II) Unloading nv
[    20.376] (EE) Failed to load module "nv" (module does not exist, 0)
[    20.376] (II) LoadModule: "vesa"
[    20.377] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    20.390] (II) Module vesa: vendor="X.Org Foundation"
[    20.390]    compiled for 1.12.1, module version = 2.3.1
[    20.390]    Module class: X.Org Video Driver
[    20.390]    ABI class: X.Org Video Driver, version 12.0
[    20.390] (II) LoadModule: "fbdev"
[    20.391] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    20.423] (II) Module fbdev: vendor="X.Org Foundation"
[    20.423]    compiled for 1.12.1, module version = 0.4.2
[    20.423]    ABI class: X.Org Video Driver, version 12.0
[    20.423] (II) NOUVEAU driver Date:   Fri Jul 6 16:23:50 2012 +1000
[    20.423] (II) NOUVEAU driver for NVIDIA chipset families :
[    20.423]    RIVA TNT        (NV04)
[    20.424]    RIVA TNT2       (NV05)
[    20.424]    GeForce 256     (NV10)
[    20.424]    GeForce 2       (NV11, NV15)
[    20.424]    GeForce 4MX     (NV17, NV18)
[    20.424]    GeForce 3       (NV20)
[    20.424]    GeForce 4Ti     (NV25, NV28)
[    20.424]    GeForce FX      (NV3x)
[    20.424]    GeForce 6       (NV4x)
[    20.424]    GeForce 7       (G7x)
[    20.424]    GeForce 8       (G8x)
[    20.424]    GeForce GTX 200 (NVA0)
[    20.424]    GeForce GTX 400 (NVC0)
[    20.424] (II) VESA: driver for VESA chipsets: vesa
[    20.424] (II) FBDEV: driver for framebuffer: fbdev
[    20.424] (++) using VT number 7

[    20.425] drmOpenDevice: node name is /dev/dri/card0
[    20.425] drmOpenDevice: open result is 8, (OK)
[    20.425] drmOpenByBusid: Searching for BusID pci:0000:00:0d.0
[    20.425] drmOpenDevice: node name is /dev/dri/card0
[    20.425] drmOpenDevice: open result is 8, (OK)
[    20.425] drmOpenByBusid: drmOpenMinor returns 8
[    20.425] drmOpenByBusid: drmGetBusid reports pci:0000:00:0d.0
[    20.425] (II) [drm] nouveau interface version: 1.0.0
[    20.425] (WW) Falling back to old probe method for vesa
[    20.425] (WW) Falling back to old probe method for fbdev
[    20.425] (II) Loading sub module "fbdevhw"
[    20.425] (II) LoadModule: "fbdevhw"
[    20.426] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    20.438] (II) Module fbdevhw: vendor="X.Org Foundation"
[    20.438]    compiled for 1.12.4, module version = 0.0.2
[    20.438]    ABI class: X.Org Video Driver, version 12.1
[    20.438] (II) Loading sub module "dri"
[    20.438] (II) LoadModule: "dri"
[    20.439] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    20.439] (II) Module dri: vendor="X.Org Foundation"
[    20.439]    compiled for 1.12.4, module version = 1.0.0
[    20.439]    ABI class: X.Org Server Extension, version 6.0
[    20.439] (II) NOUVEAU(0): Loaded DRI module
[    20.439] drmOpenDevice: node name is /dev/dri/card0
[    20.439] drmOpenDevice: open result is 9, (OK)
[    20.439] drmOpenDevice: node name is /dev/dri/card0
[    20.439] drmOpenDevice: open result is 9, (OK)
[    20.439] drmOpenByBusid: Searching for BusID pci:0000:00:0d.0
[    20.439] drmOpenDevice: node name is /dev/dri/card0
[    20.439] drmOpenDevice: open result is 9, (OK)
[    20.439] drmOpenByBusid: drmOpenMinor returns 9
[    20.439] drmOpenByBusid: drmGetBusid reports pci:0000:00:0d.0
[    20.439] (II) [drm] DRM interface version 1.4
[    20.439] (II) [drm] DRM open master succeeded.
[    20.439] (--) NOUVEAU(0): Chipset: "NVIDIA NV4c"
[    20.439] (II) NOUVEAU(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    20.439] (==) NOUVEAU(0): Depth 24, (--) framebuffer bpp 32
[    20.439] (==) NOUVEAU(0): RGB weight 888
[    20.439] (==) NOUVEAU(0): Default visual is TrueColor
[    20.439] (==) NOUVEAU(0): Using HW cursor
[    20.439] (==) NOUVEAU(0): GLX sync to VBlank disabled.
[    20.439] (==) NOUVEAU(0): Page flipping enabled
[    20.439] (==) NOUVEAU(0): Swap limit set to 2 [Max allowed 2]
[    20.864] (II) NOUVEAU(0): Output VGA-1 has no monitor section
[    21.292] (II) NOUVEAU(0): EDID for output VGA-1
[    21.292] (II) NOUVEAU(0): Printing probed modes for output VGA-1
[    21.292] (II) NOUVEAU(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    21.292] (II) NOUVEAU(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    21.292] (II) NOUVEAU(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
[    21.292] (II) NOUVEAU(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz e)
[    21.292] (II) NOUVEAU(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 489 492 525 -hsync -vsync (31.5 kHz e)
[    21.292] (II) NOUVEAU(0): Output VGA-1 connected
[    21.292] (II) NOUVEAU(0): Using exact sizes for initial modes
[    21.292] (II) NOUVEAU(0): Output VGA-1 using initial mode 1024x768
[    21.292] (II) NOUVEAU(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    21.292] (--) NOUVEAU(0): Virtual size is 1024x768 (pitch 0)
[    21.292] (**) NOUVEAU(0):  Driver mode "1024x768": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz, 60.0 Hz
[    21.292] (II) NOUVEAU(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    21.292] (**) NOUVEAU(0):  Driver mode "800x600": 40.0 MHz (scaled from 0.0 MHz), 37.9 kHz, 60.3 Hz
[    21.292] (II) NOUVEAU(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    21.292] (**) NOUVEAU(0):  Driver mode "800x600": 36.0 MHz (scaled from 0.0 MHz), 35.2 kHz, 56.2 Hz
[    21.292] (II) NOUVEAU(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
[    21.292] (**) NOUVEAU(0):  Driver mode "848x480": 33.8 MHz (scaled from 0.0 MHz), 31.0 kHz, 60.0 Hz
[    21.292] (II) NOUVEAU(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz e)
[    21.292] (**) NOUVEAU(0):  Driver mode "640x480": 25.2 MHz (scaled from 0.0 MHz), 31.5 kHz, 59.9 Hz
[    21.292] (II) NOUVEAU(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 489 492 525 -hsync -vsync (31.5 kHz e)
[    21.292] (==) NOUVEAU(0): DPI set to (96, 96)
[    21.292] (II) Loading sub module "fb"
[    21.293] (II) LoadModule: "fb"
[    21.293] (II) Loading /usr/lib/xorg/modules/libfb.so
[    21.458] (II) Module fb: vendor="X.Org Foundation"
[    21.458]    compiled for 1.12.4, module version = 1.0.0
[    21.458]    ABI class: X.Org ANSI C Emulation, version 0.4
[    21.458] (II) Loading sub module "exa"
[    21.458] (II) LoadModule: "exa"
[    21.458] (II) Loading /usr/lib/xorg/modules/libexa.so
[    21.481] (II) Module exa: vendor="X.Org Foundation"
[    21.481]    compiled for 1.12.4, module version = 2.5.0
[    21.481]    ABI class: X.Org Video Driver, version 12.1
[    21.481] (II) Loading sub module "shadowfb"
[    21.481] (II) LoadModule: "shadowfb"
[    21.481] (II) Loading /usr/lib/xorg/modules/libshadowfb.so
[    21.499] (II) Module shadowfb: vendor="X.Org Foundation"
[    21.499]    compiled for 1.12.4, module version = 1.0.0
[    21.499]    ABI class: X.Org ANSI C Emulation, version 0.4
[    21.499] (II) UnloadModule: "vesa"
[    21.499] (II) Unloading vesa
[    21.499] (II) UnloadModule: "fbdev"
[    21.499] (II) Unloading fbdev
[    21.499] (II) UnloadSubModule: "fbdevhw"
[    21.499] (II) Unloading fbdevhw
[    21.499] (--) Depth 24 pixmap format is 32 bpp
[    21.500] (II) NOUVEAU(0): Opened GPU channel 1
[    21.501] (II) NOUVEAU(0): [DRI2] Setup complete
[    21.501] (II) NOUVEAU(0): [DRI2]   DRI driver: nouveau
[    21.501] (II) NOUVEAU(0): [DRI2]   VDPAU driver: nouveau
[    21.537] (II) EXA(0): Driver allocated offscreen pixmaps
[    21.537] (II) EXA(0): Driver registered support for the following operations:
[    21.537] (II)         Solid
[    21.537] (II)         Copy
[    21.537] (II)         Composite (RENDER acceleration)
[    21.537] (II)         UploadToScreen
[    21.537] (II)         DownloadFromScreen
[    21.537] (==) NOUVEAU(0): Backing store disabled
[    21.537] (==) NOUVEAU(0): Silken mouse enabled
[    21.538] (II) NOUVEAU(0): [XvMC] Associated with NV40 texture adapter.
[    21.538] (II) NOUVEAU(0): [XvMC] Extension initialized.
[    21.538] (==) NOUVEAU(0): DPMS enabled
[    21.538] (II) NOUVEAU(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    21.538] (--) RandR disabled
[    21.538] (II) Initializing built-in extension Generic Event Extension
[    21.538] (II) Initializing built-in extension SHAPE
[    21.538] (II) Initializing built-in extension MIT-SHM
[    21.538] (II) Initializing built-in extension XInputExtension
[    21.538] (II) Initializing built-in extension XTEST
[    21.538] (II) Initializing built-in extension BIG-REQUESTS
[    21.538] (II) Initializing built-in extension SYNC
[    21.538] (II) Initializing built-in extension XKEYBOARD
[    21.538] (II) Initializing built-in extension XC-MISC
[    21.538] (II) Initializing built-in extension SECURITY
[    21.538] (II) Initializing built-in extension XINERAMA
[    21.538] (II) Initializing built-in extension XFIXES
[    21.538] (II) Initializing built-in extension RENDER
[    21.538] (II) Initializing built-in extension RANDR
[    21.539] (II) Initializing built-in extension COMPOSITE
[    21.539] (II) Initializing built-in extension DAMAGE
[    21.539] (II) SELinux: Disabled on system
[    22.408] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    22.490] (II) AIGLX: enabled GLX_INTEL_swap_event
[    22.490] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    22.490] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    22.491] (II) AIGLX: Loaded and initialized nouveau
[    22.491] (II) GLX: Initialized DRI2 GL provider for screen 0
[    22.494] (II) NOUVEAU(0): NVEnterVT is called.
[    22.530] (II) NOUVEAU(0): Setting screen physical size to 270 x 203
[    22.530] resize called 1024 768
[    22.871] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[    22.871] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    22.871] (II) LoadModule: "evdev"
[    22.871] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    22.880] (II) Module evdev: vendor="X.Org Foundation"
[    22.880]    compiled for 1.12.1, module version = 2.7.0
[    22.880]    Module class: X.Org XInput Driver
[    22.880]    ABI class: X.Org XInput driver, version 16.0
[    22.880] (II) Using input driver 'evdev' for 'Power Button'
[    22.880] (**) Power Button: always reports core events
[    22.880] (**) evdev: Power Button: Device: "/dev/input/event5"
[    22.880] (--) evdev: Power Button: Vendor 0 Product 0x1
[    22.880] (--) evdev: Power Button: Found keys
[    22.880] (II) evdev: Power Button: Configuring as keyboard
[    22.880] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5/event5"
[    22.880] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    22.880] (**) Option "xkb_rules" "evdev"
[    22.880] (**) Option "xkb_model" "pc105"
[    22.880] (**) Option "xkb_layout" "us"
[    22.880] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[    22.881] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    22.881] (II) Using input driver 'evdev' for 'Power Button'
[    22.881] (**) Power Button: always reports core events
[    22.881] (**) evdev: Power Button: Device: "/dev/input/event4"
[    22.881] (--) evdev: Power Button: Vendor 0 Product 0x1
[    22.881] (--) evdev: Power Button: Found keys
[    22.881] (II) evdev: Power Button: Configuring as keyboard
[    22.881] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input4/event4"
[    22.881] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    22.881] (**) Option "xkb_rules" "evdev"
[    22.881] (**) Option "xkb_model" "pc105"
[    22.881] (**) Option "xkb_layout" "us"
[    22.881] (II) config/udev: Adding input device GASIA USB KB V11 (/dev/input/event0)
[    22.881] (**) GASIA USB KB V11: Applying InputClass "evdev keyboard catchall"
[    22.881] (II) Using input driver 'evdev' for 'GASIA USB KB V11'
[    22.881] (**) GASIA USB KB V11: always reports core events
[    22.881] (**) evdev: GASIA USB KB V11: Device: "/dev/input/event0"
[    22.881] (--) evdev: GASIA USB KB V11: Vendor 0xe8f Product 0x22
[    22.881] (--) evdev: GASIA USB KB V11: Found keys
[    22.881] (II) evdev: GASIA USB KB V11: Configuring as keyboard
[    22.881] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:02.0/usb2/2-3/2-3:1.0/input/input0/event0"
[    22.881] (II) XINPUT: Adding extended input device "GASIA USB KB V11" (type: KEYBOARD, id 8)
[    22.881] (**) Option "xkb_rules" "evdev"
[    22.881] (**) Option "xkb_model" "pc105"
[    22.881] (**) Option "xkb_layout" "us"
[    22.882] (II) config/udev: Adding input device GASIA USB KB V11 (/dev/input/event1)
[    22.882] (**) GASIA USB KB V11: Applying InputClass "evdev keyboard catchall"
[    22.882] (II) Using input driver 'evdev' for 'GASIA USB KB V11'
[    22.882] (**) GASIA USB KB V11: always reports core events
[    22.882] (**) evdev: GASIA USB KB V11: Device: "/dev/input/event1"
[    22.882] (--) evdev: GASIA USB KB V11: Vendor 0xe8f Product 0x22
[    22.882] (--) evdev: GASIA USB KB V11: Found 1 mouse buttons
[    22.882] (--) evdev: GASIA USB KB V11: Found scroll wheel(s)
[    22.882] (--) evdev: GASIA USB KB V11: Found relative axes
[    22.882] (II) evdev: GASIA USB KB V11: Forcing relative x/y axes to exist.
[    22.882] (--) evdev: GASIA USB KB V11: Found absolute axes
[    22.882] (II) evdev: GASIA USB KB V11: Forcing absolute x/y axes to exist.
[    22.882] (--) evdev: GASIA USB KB V11: Found keys
[    22.882] (II) evdev: GASIA USB KB V11: Configuring as mouse
[    22.882] (II) evdev: GASIA USB KB V11: Configuring as keyboard
[    22.882] (II) evdev: GASIA USB KB V11: Adding scrollwheel support
[    22.882] (**) evdev: GASIA USB KB V11: YAxisMapping: buttons 4 and 5
[    22.882] (**) evdev: GASIA USB KB V11: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    22.882] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:02.0/usb2/2-3/2-3:1.1/input/input1/event1"
[    22.882] (II) XINPUT: Adding extended input device "GASIA USB KB V11" (type: KEYBOARD, id 9)
[    22.882] (**) Option "xkb_rules" "evdev"
[    22.882] (**) Option "xkb_model" "pc105"
[    22.882] (**) Option "xkb_layout" "us"
[    22.883] (II) evdev: GASIA USB KB V11: initialized for relative axes.
[    22.883] (WW) evdev: GASIA USB KB V11: ignoring absolute axes.
[    22.883] (**) GASIA USB KB V11: (accel) keeping acceleration scheme 1
[    22.883] (**) GASIA USB KB V11: (accel) acceleration profile 0
[    22.883] (**) GASIA USB KB V11: (accel) acceleration factor: 2.000
[    22.883] (**) GASIA USB KB V11: (accel) acceleration threshold: 4
[    22.883] (II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/event2)
[    22.883] (**) Logitech USB Optical Mouse: Applying InputClass "evdev pointer catchall"
[    22.883] (II) Using input driver 'evdev' for 'Logitech USB Optical Mouse'
[    22.883] (**) Logitech USB Optical Mouse: always reports core events
[    22.883] (**) evdev: Logitech USB Optical Mouse: Device: "/dev/input/event2"
[    22.883] (--) evdev: Logitech USB Optical Mouse: Vendor 0x46d Product 0xc05a
[    22.883] (--) evdev: Logitech USB Optical Mouse: Found 12 mouse buttons
[    22.883] (--) evdev: Logitech USB Optical Mouse: Found scroll wheel(s)
[    22.883] (--) evdev: Logitech USB Optical Mouse: Found relative axes
[    22.883] (--) evdev: Logitech USB Optical Mouse: Found x and y relative axes
[    22.883] (II) evdev: Logitech USB Optical Mouse: Configuring as mouse
[    22.883] (II) evdev: Logitech USB Optical Mouse: Adding scrollwheel support
[    22.883] (**) evdev: Logitech USB Optical Mouse: YAxisMapping: buttons 4 and 5
[    22.883] (**) evdev: Logitech USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    22.883] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:02.0/usb2/2-4/2-4:1.0/input/input2/event2"
[    22.883] (II) XINPUT: Adding extended input device "Logitech USB Optical Mouse" (type: MOUSE, id 10)
[    22.884] (II) evdev: Logitech USB Optical Mouse: initialized for relative axes.
[    22.884] (**) Logitech USB Optical Mouse: (accel) keeping acceleration scheme 1
[    22.884] (**) Logitech USB Optical Mouse: (accel) acceleration profile 0
[    22.884] (**) Logitech USB Optical Mouse: (accel) acceleration factor: 2.000
[    22.884] (**) Logitech USB Optical Mouse: (accel) acceleration threshold: 4
[    22.885] (II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/mouse0)
[    22.885] (II) No input driver specified, ignoring this device.
[    22.885] (II) This device may have been added with another device file.
[    22.885] (II) config/udev: Adding input device PC Speaker (/dev/input/event3)
[    22.886] (II) No input driver specified, ignoring this device.
[    22.886] (II) This device may have been added with another device file.
[    24.206] resize called 1280 1024
Anything else I can supply to help fix this problem, I will.

I am presently running in my fall-back Debian Wheezy installation which I keep running and updated for just this type of problem.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Linux Mint is funded by ads and donations.
 

Re: Update 12/19/2012: Error: Can't find display

Postby PragTob on Thu Dec 20, 2012 11:00 am

Very much the same problem as far as I can tell around here... nothing starting and xserver complaining about no display to be found.

edit: oh and gnome display manager (gdm3) eats cpu like crazy (>60%)

edit2: ok my bad... update process got interrupted, installed remaining packages now it works :oops:
PragTob
Level 1
Level 1
 
Posts: 11
Joined: Sun Apr 15, 2012 3:17 pm

Re: Update 12/19/2012: Error: Can't find display

Postby cwsnyder on Thu Dec 20, 2012 12:51 pm

I also noted that I was unable to run further updates. My /etc/apt/sources.list was changed to:
Code: Select all
deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream import backport romeo
deb [arch=amd64,i386] http://mirror.metrocast.net/linuxmint-debian/latest testing main contrib non-free
deb [arch=amd64,i386] http://mirror.metrocast.net/linuxmint-debian/latest/security testing/updates main contrib non-free
deb [arch=amd64,i386] http://mirror.metrocast.net/linuxmint-debian/latest/multimedia testing main non-free
deb [arch=amd64,i386] http://download.virtualbox.org/virtualbox/debian wheezy contrib
These seem to be pointing to a non-existing mirror at mirror.metrocast.net/linuxmint-debian/ That is, the mirror.metrocast.net/linuxmint-debian folder is there, but there is no content when viewed from a browser.

/etc/apt/sources.list.bk looks very similar:
Code: Select all
deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream import backport romeo
deb [arch=amd64,i386] http://debian.linuxmint.com/latest testing main contrib non-free
deb [arch=amd64,i386] http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb [arch=amd64,i386] http://debian.linuxmint.com/latest/multimedia testing main non-free
deb [arch=amd64,i386] http://download.virtualbox.org/virtualbox/debian wheezy contrib
I am going to switch the two lists and see what happens when I update.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Update 12/19/2012: Error: Can't find display

Postby cwsnyder on Thu Dec 20, 2012 4:54 pm

For now, I am throwing in the towel. I don't feel like spending the time to update from my 201108 disk. I have a LM14 cinnamon disk which sort of works, and I will be installing that for the present. I don't blame LMDE, I blame my 'non-standard' hardware which has caused me grief in the past. :cry:
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Update 12/19/2012: Error: Can't find display

Postby zerozero on Thu Dec 20, 2012 9:43 pm

cwsnyder wrote:[ 19.869] Current Operating System: Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.32-1 x86_64

the new kernel is installed;
a X failure usually is graphical drivers: what nvidia driver you have installed for that card and how was it installed?

removing the xorg.conf and then reinstalling the driver (using the same method) won't work?
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Update 12/19/2012: Error: Can't find display

Postby barker1977 on Fri Dec 21, 2012 8:17 am

Thanks zerozero, i had the same problem and deleting xorg.conf sorted it out (after which the nvidia driver had to be compiled against the new kernel).
barker1977
Level 1
Level 1
 
Posts: 8
Joined: Wed Mar 23, 2011 7:48 am

Re: Update 12/19/2012: Error: Can't find display

Postby cwsnyder on Fri Dec 21, 2012 12:39 pm

@zerozero, I was using nvidia-current, and I removed the xorg.conf file and still was unable to get it working. I also tried nomodeset, etc. and still couldn't get anything except for the blinking cursor, which is why I went to LM14 Cinnamon. I at least have a display, although the maximum I can use is 1152x864 out of the 1280x1024 native. Also running nvidia-current. With nouveau, the display was white with yellow lettering except when in terminal or highlighted.

As I said earlier, I am used to my display not working since Ubuntu 7.10, except for usually being usable from the Live install CDs. I didn't try versions earlier because I switched from Windows XP in December 2007.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Update 12/19/2012: Error: Can't find display

Postby zerozero on Fri Dec 21, 2012 8:17 pm

that has to be a tricky hardware combination that you have there :shock: if not even the xorg.conf removal gives you a display (not even 800*600)
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Update 12/19/2012: Error: Can't find display

Postby cwsnyder on Sat Dec 22, 2012 7:47 pm

Well, I am back to LMDE Xfce with update pack 6 and video (and at native 1280x1024 resolution). All it took was downloading the April ISO, burning it, then performing all updates. Video and rest seem to be okay. Main difference I noticed this time? I log in with MDM, not lightDM. Also, I had the Google Chrome Beta installed and updated through /etc/apt/sources.list, but it isn't working now, even after an attempted re-install. If that is the only problem, I'm home free. With everybody else on the weekend internet, it took most of 24 hours (allowing for sleep time).
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Update 12/19/2012: Error: Can't find display

Postby cwsnyder on Sun Dec 23, 2012 10:03 pm

Okay, I did some looking around and thinking. The major change from before is that mdm is installed instead of lightdm. My initial install of LMDE was from GNOME 2 desktop, which I later re-installed with Xfce. This time my re-installation was over LM14 Cinnamon.

LM14 Cinnamon, I had an ~/.xinitrc file which was a shell file consisting of the following:
Code: Select all
xrandr --newmode "1280x1024"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode 'VGA-1' 1280x1024
xrandr --output 'VGA-1' --mode 1280x1024
[url]This replaced the changes which I had made to my lightdm.conf[/url] file to add those three lines to the file on my old installation of LMDE Xfce and was working fine under LMDE UP5.

I noticed when poking around that my ~/.xinitrc file under LM14 has been transformed into a ~/.xprofile name under LMDE Xfce. This has worked to set my (non-working EDID) Etronix 1701B to the correct native resolution, but I have never seen in any post about changing screen resolution on either this forum or the Ubuntu forums using a file named ~/.xprofile! :shock: :?: :o :shock:

Can anyone explain the change from ~/.xinitrc to ~/.xprofile?
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: killer de bug and 5 guests