Metacity theme problems (permissions?)

Forum rules
Before you post please read this

Metacity theme problems (permissions?)

Postby d00med on Thu Dec 20, 2012 2:39 pm

I'm trying to test a theme here in Mint 14 64bit Cinnamon edition. I made it some time ago, and updated it a bit recently. If I use the theme in ~/.themes, it works fine, but if I place the theme in /usr/share/themes and set the theme, it immediately gets overwritten with a different theme (also can't get my gtk3 theme to work at all in the root directory).

Fairly confused about it. Anyone have any idea of what could be going on?
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Linux Mint is funded by ads and donations.
 

Re: Metacity theme problems (permissions?)

Postby Hawkeye_52 on Thu Dec 20, 2012 4:44 pm

d00med wrote:I'm trying to test a theme here in Mint 14 64bit Cinnamon edition. I made it some time ago, and updated it a bit recently. If I use the theme in ~/.themes, it works fine, but if I place the theme in /usr/share/themes and set the theme, it immediately gets overwritten with a different theme (also can't get my gtk3 theme to work at all in the root directory).

Fairly confused about it. Anyone have any idea of what could be going on?

Not sure if I can help, but I am a little curious about the process you use to move your theme into /usr/share/themes, and how you go about ensuring the permissions are set correctly. Will you go over that process, step by step?

Hawkeye52
User avatar
Hawkeye_52
Level 3
Level 3
 
Posts: 148
Joined: Thu Mar 06, 2008 5:06 am
Location: USA

Re: Metacity theme problems (permissions?)

Postby d00med on Thu Dec 20, 2012 6:37 pm

Thanks for the response. I usually gksudo nemo and copy the theme folder to /usr/share/themes. I finally got the metacity theme working - it was a permission issue on several files. I don't know what happened, but the entire theme directory is a mess of mismatched permissions. Still trying to get the gtk3 theme working correctly.
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Re: Metacity theme problems (permissions?)

Postby ashtonford on Thu Dec 20, 2012 10:35 pm

Ive had problems with the same. It shouldent be such high security just to add themes. Should be a simple drag and drop into the folder. Hope someone fixes this.
User avatar
ashtonford
Level 2
Level 2
 
Posts: 79
Joined: Thu Aug 11, 2011 2:55 pm

Re: Metacity theme problems (permissions?)

Postby d00med on Fri Dec 21, 2012 1:25 pm

My gtk3 theme is fine in the home directory but is completely borked in /usr/share/themes. Spent all day yesterday trying to figure out why and still have no clue.

Here's a comparison.
Theme in root
Theme in home
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Re: Metacity theme problems (permissions?)

Postby Hawkeye_52 on Fri Dec 21, 2012 3:29 pm

d00med wrote:My gtk3 theme is fine in the home directory but is completely borked in /usr/share/themes. Spent all day yesterday trying to figure out why and still have no clue.

Here's a comparison.
Theme in root
Theme in home

OK, here's a 'try-at-your-own-risk' solution:
Open Nemo.
Select 'file system' on the Left Panel in Nemo.
Navigate to /usr/share/
Scroll down until you come to the 'themes' folder -- then right click on it.
From the options that pop up, select 'Open as Root'.
The directory /usr/share/themes should then be open, with a red ribbon at the top of the screen saying 'Elevated Privileges'.
From that screen, go to the menu at the top and select 'Edit', then 'Select All'.
At that time all the folders in /usr/share/themes should be highlighted.
If all folders are highlighted, move your cursor into the panel with all the highlighted folders, and right-click your mouse.
Select 'Properties' at the bottom of the pop up menu.
'Properties' will give you a window that has two tabs at the top -- 'Basic' and 'Permissions'.
Select the 'Permissions' tab.
You will be presented with another window that looks like the one below.
There are three sections to that window -- 'Owner', 'Group', and 'Others'.
Under the 'Owner' section 'Folder Access' should be set to 'Create and delete files', and 'File Access' should be set to 'Read and write'.
Under the 'Group' section 'Folder Access' should be set to 'Access files', and 'File Access' should be set to 'Read only'.
Under the 'Other' section 'Folder Access' should be set to 'Access files', and 'File Access' should be set to 'Read only'.
Once those options are selected, there is a button at the bottom of the screen that says 'Apply Permissions to Enclosed Files'.
Hit that button. There won't be any big fanfare, or acknowledgement of you changes, but all folders and files with /usr/share/themes should be set to the correct permissions.
Click the 'X' button at the top right hand corner of Nemo. You should have to do this to close your 'Root' session and then your 'User' session.
Now, when you go to access your 'themes', you should have all of them available to you.
If you followed these steps correctly, and you still have a problem -- call the fire department :shock:

If you try this, please post back the results.
BTW, I know there is a way to do this by use of the terminal, but I never learned the commands to handle it that way :oops:

Hawkeye52
Attachments
Themes Properties Window.png
Themes Properties Window.png (55.36 KiB) Viewed 639 times
User avatar
Hawkeye_52
Level 3
Level 3
 
Posts: 148
Joined: Thu Mar 06, 2008 5:06 am
Location: USA

Re: Metacity theme problems (permissions?)

Postby d00med on Fri Dec 21, 2012 8:17 pm

Thanks very much hawkeye. I tried it and still have the same issue with the one theme. Installing other downloaded themes doesn't have this problem though. I'm convinced that it is a permission issue, but I've adjusted the permissions quite a bit and so far it didn't help.
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Re: Metacity theme problems (permissions?)

Postby Hawkeye_52 on Sat Dec 22, 2012 5:48 pm

d00med wrote:Thanks very much hawkeye. I tried it and still have the same issue with the one theme. Installing other downloaded themes doesn't have this problem though. I'm convinced that it is a permission issue, but I've adjusted the permissions quite a bit and so far it didn't help.

Is the one you're having problems with associated with Aurora. I have found that, in some cases, Aurora will be installed from Synaptic with the wrong permissions -- Owner is 999 instead of Root. If this is it, I can give you a step-by-step to fix the one theme.

Really sorry you're having the problem. Nothing more frustrating than trying to get permissions correct...

Hawkeye52
User avatar
Hawkeye_52
Level 3
Level 3
 
Posts: 148
Joined: Thu Mar 06, 2008 5:06 am
Location: USA

Re: Metacity theme problems (permissions?)

Postby d00med on Fri Dec 28, 2012 6:35 pm

Hawkeye_52 wrote:
d00med wrote:Thanks very much hawkeye. I tried it and still have the same issue with the one theme. Installing other downloaded themes doesn't have this problem though. I'm convinced that it is a permission issue, but I've adjusted the permissions quite a bit and so far it didn't help.

Is the one you're having problems with associated with Aurora. I have found that, in some cases, Aurora will be installed from Synaptic with the wrong permissions -- Owner is 999 instead of Root. If this is it, I can give you a step-by-step to fix the one theme.

Really sorry you're having the problem. Nothing more frustrating than trying to get permissions correct...

Hawkeye52


Thanks Hawkeye. Yeah, it's a pain. It isn't Aurora, but it might be based on it.

edit: Thanks again for the assistance Hawkeye. Turns out it was the gtk.css file, located is the theme's gtk-3.0 directory. It was incomplete, possibly because it referenced another theme that wasn't installed. Not sure, but replacing it with another theme's gtk.css file (and adjusting its CSS color elements) fixed the problem.
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Linux Mint is funded by ads and donations.
 

Return to Themes, Icons, & Wallpaper

Who is online

Users browsing this forum: No registered users and 1 guest