Cinnamon on LMDE - stopped working with Update Pack 5

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Mon Dec 03, 2012 10:16 pm

Hi there!

After a couple of years I've decided to give another try to LMDE.
I thought Cinnamon would never work on this old computer because it's graphics card - an intel 82852/82855 GM/GME, does not have 3D hardware acceleration, I think.

But after installation, I tried Cinnamon and to my surprise it worked just fine!

After the 1GB update from the Update Pack 4 to 5, the installation jammed in the middle, the screen got crazy and the update window unresponsive, without activity from the HDD or the CPU.
So I logged out, logged in to MATE, ran dpkg --configure -a and finished updating, including the MATE and Cinnamon commands found in the Update Pack 5's change log. The update finished ok.

So now when I logged back in to Cinnamon, I got an error about the session lasting less than 10 seconds probably because there is no 3D hardware acceleration support, and the desktop environment that shows up seems to be Gnome 3, with one menu on the top and another one on the bottom. I assume this is some fallback mode.

I have purged and reinstalled Cinnamon, and now when I boot into Cinnamon it goes straight into that fallback mode.


So my questions are:

1) After all, does anyone knows if this graphic card supports 3D hardware acceleration or not?

2) How would it be possible for me to get Cinnamon running on this old brick? Should I stay with Update Pack 4, or is there any way I can update to Update pack 5 and work around this issue?


Once more, thank you all for your kind help!
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Linux Mint is funded by ads and donations.
 

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Tue Dec 04, 2012 10:10 am

Yes, this situation is confirmed. I've restarted from scratch and reinstalled the whole thing again, and Cinnamon 1.4(?) was working fine.
I've logged in to MATE, updated smoothly to the Update Pack 5, and Cinnamon 1.6 is now loading into Gnome 3 Fallback mode.

My two above questions remain, and I also wonder if Cinnamon 1.4 is compatible with this graphics card and Cinnamon 1.6 is not...

Any comments, folks? Thanks!
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Tue Dec 04, 2012 8:46 pm

New info:

When I freshly install LMDE Update Pack 4, I get this from the System Info:

Driver: Intel® 852GM/855GM x86/MMX/SSE2
Experience: standard


And from
inxi -Gx
Graphics: Card Intel 82852/855GM Integrated Graphics Device X.Org 1.11.4 Res: 1024x768@60.0hz
GLX Renderer Mesa DRI Intel 852GM/855GM x86/MMX/SSE2 GLX Version 1.3 Mesa 7.11.2 Direct Rendering Yes

Not sure how this answers my question about this graphics card supporting 3D acceleration...


Just for the test, I've installed Mint 14 Cinnamon, and I have an option for Cinnamon 2D, but it consumes all the CPU for just about anything. The System Info app tells me this:

Driver: Gallium 0.4 on llvmpipe (LLVM 0x301)
Experience: standard



Please note that LMDE does not give me the 2D option in MDM.


Hope this helps!
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby zerozero on Tue Dec 04, 2012 8:56 pm

Bruno, i'm shutting down for the night but does this link in any way gives you any clues
http://forums.debian.net/viewtopic.php? ... 99#p444101
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6482
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Wed Dec 05, 2012 9:40 am

Zerozero,
Thank you so much for your reply!

Well, I've got that system so much scrambled I need to start it up from scratch again and try your solution.
I'll do it when I have a moment, the 1GB 1200+ updates takes it's time...

So about the technicalities...
I would kindly ask you if you can give me detailed procedures and instructions, since I'm quite a noob regarding hardware and drivers...

- Don't know if this is relevant, but the card is a Intel 82852/855GM Integrated Graphics Device, not sure how i915 is applicable here... :?:

- The /etc/initramfs-tools is a folder and not a file, so I'm lost here... :shock:

- About the add "i915.modeset=0" to my kernel line, I have no idea on how and where to do that... :?


Once more, thanks for your help!
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Fri Dec 14, 2012 3:00 pm

Ok, so far what I have understood is that updating mint-meta-debian-cinnamon after installing UP5 is the thing that breaks it all.

Apart from this, some update of configuration is disabling all my input devices at boot, including keyboard, mouse and touchpad. Since this is a laptop, all I can do is unplug and plug back the USB mouse and then it works, but I cannot do this with the keyboard...

So, installation broken!

I'll wait for the ISO respin and then check it back again, I might be luckier that time...
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby AlbertP on Sun Dec 23, 2012 5:32 pm

i915 is not the problem, it's right to use that kernel module and you're having 3D acceleration if you have Mesa DRI Intel in your GLX Renderer. You should not disable it unless it leads to black screens or the like; hardware 3D acceleration will not work at all without it.

Computers without 3D acceleration have not been sold anymore for the past 10 years, though there exist GPUs that are too limited or have no good driver support on Linux. I don't know if Intel Extreme Graphics 2 is good enough for Cinnamon, it may well be too limited but if a working but too limited GPU is detected, you will get Gnome Classic instead of Cinnamon.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Sun Dec 23, 2012 6:33 pm

Hi, AlbertP, and thank you so much for your reply!
Well, this old brick *does* run Cinnamon. Actually I'm running it now, but not with Mint. I've installed ZorinOS and then installed Cinnamon, and it is working fine!
My think is that I really like Mint (I use it since V. 7), but since V. 10 I've been having graphic problems all the way along up to know. I've been using MATE and I enjoy it, but Caja has a few bugs that bug me on my everyday's life and Nemo has them solved, hence my think in trying Cinnamon.

I have no experience with Linux drivers, so if you could give me instructions on how to get this solved, I would really appreciate it!
How do I check if Mesa DRI Intel in enabled in my GLX Renderer? How do I enable it if I have to?
If this hardware can run Cinnamon, how can I get it to work on Mint?
It would be really good to have this working on Mint...

Thanks!
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby AlbertP on Mon Dec 24, 2012 11:53 am

With the GLX Renderer, I meant your first inxi -Gx output.

You should just be able to install Mint 14 Cinnamon on the computer if Cinnamon runs on Zorin.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Wed Dec 26, 2012 4:45 pm

I won't work! On Ubuntu based versions, Cinnamon doesn't work. I can get it to run on LMDE, but UP5 breaks it down unusable; and also on Zorin.

I've been having graphics problems since Mint 10 or 11 on this computer, since then I haven't been able to run Compiz.

As for now, running Linux Mint 14 MATE, I get this:

inxi -Gx
Graphics: Card: Intel 82852/855GM Integrated Graphics Device bus-ID: 00:02.0
X.Org: 1.13.0.902 driver: intel Resolution: 1024x768@60.0hz
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A


I've also tried the solutions from here http://forums.linuxmint.com/viewtopic.php?f=42&t=117294 but nothing is working...
So for what I've been able to understand, this is an Ubuntu upstream problem, and until they have this fixed... no 3D acceleration (and thus, Cinnamon) on this computer for me, at least using Ubuntu based versions... :oops:
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby AlbertP on Thu Dec 27, 2012 7:13 am

That Mint 14 Intel problem is already fixed, also you have no llvmpipe shown in inxi -Gx output. You're having a very different problem than the topic you linked. I understand you have tried to install a graphics driver? Because you should never see GLX Renderer N/A on a fresh Mint 14 system.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Thu Dec 27, 2012 12:00 pm

If the topic is solved in Linux Mint 14 and I`m a bit off-topic, I really don`t know... I`m walking on an unknown territory to me...

I don`t know anything about having no llvmpipe shown in inxi -Gx output. Just no idea at all about the graphics subsystem and how does it work... :roll:

I`ve booted from the Linux Mint 14 Cinnamon Edition live CD, and here are the outputs:

inxi -Gx
Graphics: Card: Intel 82852/855GM Integrated Graphics Device bus-ID: 00:02.0
X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A


glxgears is not working either...
X Error of failed request: BadAlloc (insufficient resources for operation)
Major opcode of failed request: 153 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Serial number of failed request: 28
Current serial number in output stream: 30


Any hints? Should I open a new topic for the Linux Mint 14 Cinnamon Edition (not the LMDE)?

Thanks for any hints!
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby AlbertP on Thu Dec 27, 2012 2:20 pm

It says "insufficient resources for operation", maybe your computer is short of RAM or you need to raise the video RAM in your BIOS?
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Thu Dec 27, 2012 8:05 pm

I believe this computer has 16 MB of graphics memory, shared from the 2GB of ram, and I can't allocate more to the graphics card, my BIOS gives me no control of it.

Right now I can't restart the computer, but if in the next few hours there's no update, the information presented here is the correct one.

Zorin OS runs Cinnamon without me changing the BIOS, so it shouldn't be it...

Is there any configuration on Mint to change the amount of video memory, or some program that overruns the BIOS?

Here I am again, ab - so - lute - ly clue - less... :lol:
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby AlbertP on Fri Dec 28, 2012 4:59 pm

Intel drivers for ancient 8xx haven't been maintained very well for a while; that may be related.

It could be that a kernel update that came with UP5 is related. A metapackage should not cause this problem since a metapackage doesn't contain any files by itself; you can rather compare mint-meta-debian-cinnamon with a shopping list of which packages a full Mint Debian UP5 Cinnamon installation should contain.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Fri Dec 28, 2012 7:41 pm

In theory, your words make sense, but in practical terms, I, being a noob, really don't know what packages to look for a comparison...
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Thu Jan 10, 2013 9:06 pm

AH - HA!!! Fixed it!!! At least in Ubuntu! :mrgreen:

Ok, after 2 years of breaking my head on this one, I've finally been able to enable Direct 3D rendering on Ubuntu-based OS.
Probably this might be useful for Debian, also, untested yet.I will soon test it on Debian and then I'll let you know.

So the thing was not the drivers. It was mesa! All I had to to was downgrade it from version 9 to 8 and it's working!
Zorin OS uses mesa V.8 and it works with Cinnamon, so I think this is it for these graphics cards!

Using the glxgears' output errors, I've googled around and found this post:

https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1061073


Don't forget to lock these packets' version on Synaptic and to ignore updates for them on Update Manager.
Also be careful because using apt might upgrade these packets into new non-working versions, even if you have locked versions on Synaptic and Update Manager.
For this, use sudo aptitude hold package_name.

Better save the link and keep a local copy of these files around, just in case...
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Fri Jan 11, 2013 1:12 am

No wonder it took me so long to figure this one out...
This rabbit hole goes deeper than I thought!

This is a very good post for us to understand what happens with supporting old hardware on OSS (Open Source Software). It's a free job but somebody's got to do it!

http://phoronix.com/forums/showthread.php?59632-Legacy-Mesa-Drivers-Receive-Their-Death-Sentence


This quote is awesome:
"
OSS is *NOT* a democracy, its a meritocracy - as in, those who are willing to do the actual work, get to make the decisions.
As long as no-one jumps in and offer to maintain the old drivers himself, these drivers will simply die. Period. End-of-story.

So in short, yes, unless you are willing to pitch in, you opinions don't really matter. (Nor do mine )

- Gilboa
"
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby AlbertP on Fri Jan 11, 2013 9:50 am

The Mesa driver for Intel 855 is not one of those removed legacy drivers. It uses the still existing i915 driver in both the kernel and Mesa. Only really ancient chips like 810/815 have no support anymore, but those have never been able to run Cinnamon anyway (I think 855 is the oldest one that does run Cinnamon). So this is definitely not "dropped support" but a bug in Mesa.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6517
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Cinnamon on LMDE - stopped working with Update Pack 5

Postby BrunoMiranda on Fri Jan 11, 2013 9:16 pm

AlbertP,
Thanks for your comment, and yes, it seems you're totally right about this being a bug in Mesa...

For what I've been googling around, it seems that this bug affects some people, not just me... These old Pentium 4 are hard bricks and will work forever and a day, so people are keeping them. I'm not letting this 7 years old laptop go! It has already been baptized as The Brick! :wink:
So keeping it running around would be nice. With Mesa locked on version 7 and Linux Mint 13 LTS, it seems I may be able to keep in running for at least 2017! :mrgreen:
Maybe longer with LMDE? :lol:


I've tried to find Mesa's bug reporting on Bugzilla, but I got lost since I've never done this...
Does anyone knows how can I report this bug?
Since I have no experience in this, I'd have to work with them to report the bug as accurate as possible, run some tests, etc... I will definitely need help on this one!
Where should I post or who should I contact?
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )
BrunoMiranda
Level 2
Level 2
 
Posts: 86
Joined: Thu Jun 24, 2010 2:22 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 5 guests