[SOLVED] KDE 14 Chromium Unable To Load DivX Plugin

Forums for the KDE Edition
Forum rules
Before you post please read this

[SOLVED] KDE 14 Chromium Unable To Load DivX Plugin

Postby rufong on Mon Dec 24, 2012 9:30 am

i watch a LOT of films on veehd.com
tired of waiting for LMDE UP 6 iso, so i decided to try Mint 14 KDE (kde has better tablet support? i'm still undecided).

flash is streaming within chromium, but not divx; "Could not load DivX Plug-In." in the yellow bar appearing below the bookmarks bar.
sure downloading the video files and opening them with VLC works, but why waste space on your disk when you can stream?
for info; http://code.google.com/p/gecko-mediaplayer/issues/list

opening chromium via the command line, then attempting to stream the divx file;
Code: Select all
chromium-browser

[10:10:5102767989:ERROR:webplugin_delegate_proxy.cc(379)] PluginMsg_Init returned false
[10:10:5102768286:ERROR:webplugin_impl.cc(269)] Couldn't initialize plug-in

i closed, relaunched chromium via mint menu

Code: Select all
sudo inxi -Fc 0

gives the output;
Code: Select all
System:    Host: rufong-kickinass Kernel: 3.5.0-17-generic x86_64 (64 bit) Desktop: KDE 4.9.3 Distro: Linux Mint 14 Nadia
Machine:   Mobo: ASUSTeK model: B121 version: 1.0 serial: NB-1234567890
           Bios: American Megatrends version: 205 date: 07/19/2011
CPU:       Dual core Intel Core i5 CPU U 470 (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
           Clock Speeds: 1: 666.00 MHz 2: 666.00 MHz 3: 666.00 MHz 4: 1334.00 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           X.org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) tty size: 135x28 Advanced Data: N/A for root
Audio:     Card: Intel 5 Series/3400 Series Chipset High Definition Audio driver: snd_hda_intel Sound: ALSA ver: 1.0.25
Network:   Card: Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlan0 state: up mac: 74:2f:68:82:1a:a1
Drives:    HDD Total Size: 80.0GB (6.5% used) 1: id: /dev/sda model: SanDisk_SSD_P4_6 size: 64.0GB
           2: USB id: /dev/sdb model: Card_Reader size: 15.9GB
Partition: ID: / size: 14G used: 4.2G (33%) fs: ext4 ID: /home size: 12G used: 682M (7%) fs: ext4
           ID: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 178 Uptime: 1:11 Memory: 828.0/3745.6MB Client: Shell inxi: 1.8.4


Code: Select all
apt-cache policy gecko-mediaplayer

gecko-mediaplayer:
Installed: 1.0.6-1ubuntu2
Candidate: 1.0.6-1ubuntu2
Version table:
*** 1.0.6-1ubuntu2 0
500 http://archive.ubuntu.com/ubuntu/ quantal/universe amd64 Packages
100 /var/lib/dpkg/status

latest version of gecko-mediaplayer already installed(thx clem), googled the error, forcing/locking an earlier version of gecko was a solution for some.
using the browser-plugin-vlc instead of gecko was also suggested. i thought installing non-free-codecs might resolve this, nope. removed non-free-codecs.

Code: Select all
sudo apt-get update ; sudo apt-get install browser-plugin-vlc

Code: Select all
apt-cache policy browser-plugin-vlc

browser-plugin-vlc:
Installed: 2.0.0-1
Candidate: 2.0.0-1
Version table:
*** 2.0.0-1 0
500 http://archive.ubuntu.com/ubuntu/ quantal/universe amd64 Packages
100 /var/lib/dpkg/status

with chromium open, enter in the address bar;
Code: Select all
chrome:plugins

going down the list of plugins, i disabled each listing of Gecko Media Player. VLC Web Plugin is already enabled after its installation.

voila streaming DivX!
User avatar
rufong
Level 2
Level 2
 
Posts: 60
Joined: Fri Dec 11, 2009 9:20 am

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 7 guests