Nvidia drivers installed : black screen at reboot

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Re: Nvidia drivers installed : black screen at reboot

Postby Dr.m0x on Sat Jul 23, 2011 2:39 am

Happened to me this morning while
I was converting an encrypted debian squeeze install into lmde. It seems nvidia-glx does not depend on the linux headers for your kernel. The module will not install correctly but you can only see the error in the terminal. If you install from synaptic, it will inform you the installation was successful. Once I pulled in the headers manually all was well.

Sent from my Cyanogenmod 7 phone.
Image
User avatar
Dr.m0x
Level 3
Level 3
 
Posts: 117
Joined: Thu Nov 25, 2010 4:12 am

Linux Mint is funded by ads and donations.
 

Re: Nvidia drivers installed : black screen at reboot

Postby djk on Tue Sep 20, 2011 1:53 pm

Same problem. Tried all the suggestions, no luck using LMDE 201109-64 bit. My test computer is an MSI 785GT-E63 mb, 6G RAM, 8600GTS w/512M, AMD Phenom II X6-1055 cpu. Luckily the is a test machine, so no problem.

I consider this a major problem that shouldn't be happening. I've been having the same problem ever since LMDE came out the first time. The idea of a rolling OS is nice, but I'm not going to spend a lot of time just to get it running. I've been using Mint since version 5, and have been very happy!

I just got through installing the latest Debian directly using the netinstall CD. I then installed the NVidia drivers with no problems, and upon rebooting, normal video.
djk
Level 1
Level 1
 
Posts: 10
Joined: Sun Aug 22, 2010 1:46 pm

Re: Nvidia drivers installed : black screen at reboot

Postby h2-1 on Tue Sep 27, 2011 2:09 pm

There's a lot of assumptions here about what should and should not be happening that aren't really warranted.

Mint doesn't write the nvidia driver, xorg, the kernel, or any of the other parts involved in non free driver installation.

I had a person on #smxi (irc.oftc.net) report constant issues with I believe an 8xxx series card, turned out there was some bug with the way ram was handled or something in the card that made it unusable for Linux desktops in general. I don't remember the specifics, but you can google it and see if you find the bug reports.

Any time you have issues that don't go away with video drivers, google the card number/brand plus the word linux and see if you get some bug reports. If you do, there's nothing your specific distro can do, the distro doesn't write any of the relevant code or driver. Trust me, if you had enough windows experience, you'd know that buggy video drivers aren't just a GNU/Linux problem, they are just a problem in general if you have a card or OS that isn't really well supported. (try getting xp sp3 AMD/ati driver issues resolved, I've found bugs that have existed for years, reported, and which are not only not fixed, they will never get fixed).

Rolling release requires a bit of common sense and an understanding of the core systems involved. Back in the good old smxi/sidux days, we had all these things fully integrated for almost pain free upgrades, still works but only if you use smxi/sgfxi all the way through.

But it's really not very complicated: new kernels often require latest driver, new xorg often requires latest driver, so the solution for rolling release is to always use latest driver, with a fallback / up to either latest beta/testing driver, or previous driver. ie, that's why sgfxi exists and runs the way it runs, it was developed and designed to deal specifically with the realworld issues of running rolling release, fairly cutting edge, linux desktops. amd/ati users, amd has repeatedly said they do not support rolling release, only a pre-selected group of distros, ubuntu, fedora/redhat. And even with that, there was a point when they didn't support fedora, which really annoyed the phoronix guy who ran amd/ati and fedora until he had to give up on that.

and so it goes, on and on, where it stops, nobody knows. What I do know is that users have to gain enough understanding of their systems to run a rolling release distro, if such a task is not something you want to do it, then don't run the distro, it's not like it's super hard, but it does require a bt more effort, nothing comes free.
smxi/sgfxi site (manuals, how-to's, faqs) :: script forums :: Check out inxi sys info script!
h2-1
Level 3
Level 3
 
Posts: 118
Joined: Sat Oct 16, 2010 4:02 pm

Re: Nvidia drivers installed : black screen at reboot

Postby thiagowfx on Thu Dec 27, 2012 12:27 pm

Gerd50 wrote:
Code: Select all
sudo nvidia-xconfig


Sorry for posting in a bit old thread, but I really wanted to say that this helped me instantly. I was trying :

Code: Select all
$sudo Xorg -configure


But I was always receiving the error

Code: Select all
Number of created screens does not match number of detected devices. Configuration failed.


I originally got this problem because of Steam. After installing one update from the client, the computer got crazy and shutdown itself. Next time I rebooted it, the X Server didn't start properly. Actually, the X Server didn't start after all. I got crazy too, googling for the solution, but it was hard to find. I tried some of the following:

Code: Select all
#apt-get purge nvidia-settings nvidia-settings-update nvidia-173 nvidia-173-updates nvidia-experimental-304 nvidia-current nvidia-current-updates


Or, a bit more risky,

Code: Select all
#apt-get purge nvidia*


Then, I reinstalled all of these packages again.

Code: Select all
#apt-get install nvidia-settings nvidia-settings-update nvidia-173 nvidia-173-updates nvidia-experimental-304 nvidia-current nvidia-current-updates


After that,

Code: Select all
$startx


Note that all of these commands should be issued from a TTY (a.k.a. Virtual Terminal, which you can access by pressing Ctrl+Alt+F1 (I think F2 through F6 should work, too))
But the monitor was a bit weird, I was facing this kind of problem: https://bugs.kde.org/show_bug.cgi?id=259386. (BTW, I use Linux Mint 13 KDE). Besides that, the desktop effects which used OpenGL weren't working properly.

Then, after the nvidia-xconfig command everything got back to normal. Thanks!
English is not my first language.
User avatar
thiagowfx
Level 1
Level 1
 
Posts: 3
Joined: Thu Dec 27, 2012 12:05 pm

Re: Nvidia drivers installed : black screen at reboot

Postby wazntme on Fri Dec 28, 2012 8:04 am

Can you share what commands actually worked?
User avatar
wazntme
Level 1
Level 1
 
Posts: 13
Joined: Tue Nov 13, 2012 8:39 pm

Re: Nvidia drivers installed : black screen at reboot

Postby thiagowfx on Sun Dec 30, 2012 2:42 pm

Sure. I would recommend you to do the following, just to be certain that everything will be all right.
First, log in to a virtual terminal (not a terminal emulator in the X). You should do that without starting the X server. You can do that from the GRUB menu at the boot time, selecting the "recovery mode" boot option. Sample here, look at the second option. If you don't use GRUB, you should search how to do that. After entering the recovery mode, simply resume your boot, selecting the properly option.

Next, make sure you have a internet connection and your packages are up-to-date:

Code: Select all
$sudo apt-get update && sudo apt-get upgrade


So, try the following:

Code: Select all
$sudo apt-get install --reinstall nvidia-settings nvidia-settings-update nvidia-173 nvidia-173-updates nvidia-current nvidia-current-updates

(Only install the nvidia-experimental-304 package at your own risk.)

If this operation was succesful, I would recommend you to backup your xorg.conf file so you can generate it:

Code: Select all
$sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Code: Select all
$sudo nvidia-xconfig


Look at the /etc/X11/xorg.conf file now, with (for example):

Code: Select all
$cat /etc/X11/xorg.conf | more


to see if it was generated correctly.

Next, start your X server.

Code: Select all
$startx
(I didn't need sudo for that)

If it does still not start, you can try:

Code: Select all
$sudo dpkg-reconfigure kdm


Note that kdm is for KDE. If you use Mate, Cinnamon or Gnome Desktop Environment, you should find out what option is suitable for that. I think it would be gdm or lightdm, not sure.

Try to press Ctrl+Alt+F7 to go to the X Server. If this hotkey doesn't work, restart your computer. It should work now.
English is not my first language.
User avatar
thiagowfx
Level 1
Level 1
 
Posts: 3
Joined: Thu Dec 27, 2012 12:05 pm

Previous

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests