Firefox package download failure [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Firefox package download failure [SOLVED]

Postby lthvwx2 on Thu Dec 27, 2012 10:51 pm

I wanted to reinstall Firefox, so I uninstalled it using the Software Manager and tried to install it again. That's where the problems started. Uninstall was fine, but it just wouldn't reinstall! The bar went to 16% and cut to complete (and Firefox hadn't been installed). I did a little digging online and found that uninstalling Firefox from the Package Manager (and then installing it again) could help, but that didn't work either! When I try to install the firefox package on Package Manager, I get this message:

W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... _amd64.deb
404 Not Found


W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... .1_all.deb
404 Not Found

What can I do? I'm almost considering reinstalling Linux Mint, but given the luck I've had reinstalling things so far, I'd probably break my computer!
Last edited by lthvwx2 on Fri Dec 28, 2012 11:25 am, edited 2 times in total.
lthvwx2
Level 1
Level 1
 
Posts: 3
Joined: Wed Oct 03, 2012 3:40 am

Linux Mint is funded by ads and donations.
 

Re: Firefox package download failure

Postby sheepgazer on Fri Dec 28, 2012 2:51 am

Try an install from the command line.
Open a terminal session Menu > Terminal

Clean out the current packages
Code: Select all
sudo apt-get autoclean

Install Firefox
Code: Select all
sudo apt-get install firefox
sheepgazer
Level 1
Level 1
 
Posts: 4
Joined: Sat Apr 14, 2012 11:30 pm

Re: Firefox package download failure

Postby mank_in on Fri Dec 28, 2012 8:02 am

firefox-globalmenu_16.0.1+build1-0ubuntu0.12.04.1_amd64.deb is not available in that repository . current file version is :
firefox-globalmenu_17.0.1+build1-0ubuntu0.12.04.1_amd64.deb

refresh your repository first :
Code: Select all
sudo apt-get update

or
in synaptic : hit reload button

mint update also refresh the repository
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Firefox package download failure [SOLVED]

Postby lthvwx2 on Fri Dec 28, 2012 11:29 am

Great, hit "Reload" in Synaptics and it worked a charm. Basics... :/ Thanks so much.
lthvwx2
Level 1
Level 1
 
Posts: 3
Joined: Wed Oct 03, 2012 3:40 am


Return to Newbie Questions

Who is online

Users browsing this forum: Mik3e and 18 guests