Mint 14 - Can't Browse Windows Shares - [SOLVED]

Questions about cabled networking
Forum rules
Before you post please read this

Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Wed Dec 19, 2012 7:47 am

Hi All,

Have Mint 13 (Cinnimon) running on several machines on a LAN. The LAN has a Windows domain running on it, also has non-domain Windows computers.

With Mint 13, I can install the system, open Nautilus, go to networking ... and see everything, connect to everything. I can see the Windows Domain, Windows Workgroup machines, other Linux shares, can connect, can mount. ... no issues. It just works.

The PCs I'm using are all identical notebooks. Same hardware. I have installs of Ubuntu, Debian, XBMCbuntu all running on this LAN ... they all work the same way. No issues. Can see all the Windows shares using the respective file managers ... no issues ... identical hardware.

When I install Mint 14 (Cinnimon) I can do everything except see the Windows shares. Can't see any of them. Can't connect to any of them. I can see "Windows Network" in Nemo ... but, none of the actual machines. I can see the non-windows machines and connect to them, just fine (linux-to-linux).

Tried to connect using IP rather than Netbios names. Makes no difference. Get an Network is not available error.

So, I think I have a SAMBA issue. Something to do with the new Nemo "out of the box" configuration.

Would appreciate any tips anyone might have. I really like everything about Mint 14 ... but, have to be able to share files with the Windows boxes.
Last edited by Magic-Rat on Fri Dec 21, 2012 11:12 pm, edited 1 time in total.
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Linux Mint is funded by ads and donations.
 

Re: Mint 14 - Can't Browse Windows Shares

Postby altair4 on Wed Dec 19, 2012 9:49 am

Tried to connect using IP rather than Netbios names. Makes no difference. Get an Network is not available error.

So, I think I have a SAMBA issue.

If you can't access the windows machine by ip address then it definitely appears to be a samba issue.

** You might want to make sure that the firewall isn't in the way:

Install nmap
Code: Select all
sudo apt-get install nmap

Then run the following command with the Windows ip address instead of the 192.168.0.100:
Code: Select all
sudo nmap -sS -sU -T4 192.168.0.100

You need the following ports to be open:
PORT STATE SERVICE
139/tcp open netbios-ssn
445/tcp open microsoft-ds
137/udp open netbios-ns
138/udp open|filtered netbios-dgm

Since your Mint13's have no issues it's probably not the culprit so run nmap against the Mint14 machine's ip address itself to see if it's samba parts are closed.

** The only other thing I can think of at the moment is you have a parameter setting wrong in your smb.conf. Run the following:
Code: Select all
testparm -sv | grep "encrypt passwords"

It should come back with:
encrypt passwords = Yes

If it comes back with No edit smb.conf and find the encrypt passwords line and change No to Yes
Code: Select all
encrypt passwords = Yes

And restart samba:
Code: Select all
sudo service smbd restart
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5987
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 14 - Can't Browse Windows Shares

Postby Magic-Rat on Thu Dec 20, 2012 8:45 pm

Thank you VERY much altair4.

I'm out of town with work right now and will dig into this when I get home this weekend.

Greatly appreciate your advice.

Pat
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares

Postby Magic-Rat on Fri Dec 21, 2012 11:00 pm

On the Mint 14 box with fresh install, running nmap against the Windows domain controller / file server at 192.168.1.2 ... and it looks like port 138 is not open. I get the results below ...

BUT ... when I run nmap on the Mint 13 box ... I get the exact SAME results. 138 is not open ... but on the Mint 13 box ... SAMBA works.

So, maybe port 138 doesn't need to be open?

Code: Select all
PORT     STATE SERVICE
42/tcp   open  nameserver
53/tcp   open  domain
80/tcp   open  http
88/tcp   open  kerberos-sec
135/tcp  open  msrpc
139/tcp  open  netbios-ssn
389/tcp  open  ldap
443/tcp  open  https
445/tcp  open  microsoft-ds
464/tcp  open  kpasswd5
593/tcp  open  http-rpc-epmap
636/tcp  open  ldapssl
1026/tcp open  LSA-or-nterm
1029/tcp open  ms-lsa
1050/tcp open  java-or-OTGfileshare
1052/tcp open  ddt
1060/tcp open  polestar
1068/tcp open  instl_bootc
1072/tcp open  cardax
1075/tcp open  rdrmshc
1078/tcp open  avocent-proxy
1079/tcp open  asprovatalk
1080/tcp open  socks
3268/tcp open  globalcatLDAP
3269/tcp open  globalcatLDAPssl
53/udp   open  domain
123/udp  open  ntp
137/udp  open  netbios-ns


*****

The testparm command does come back with "encrypt passwords = Yes"

Code: Select all
magic-rat@magicrat2-Latitude-E6420 ~ $ testparm -sv | grep "encrypt passwords"
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE
   encrypt passwords = Yes


*****

Went back in to Nemo ... can see the windows network, the workgroup and the domain ... but when I click on them ... no machines show up.

I get: "Unable to mount location. Failed to receive share list from server."

When I try to connect to a machine by IP or netbios name, I get "Please verify your user details".

Tried using the domain name ... and workgroup (which is the workgroup name) ... nothing works.

Dunno.
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares

Postby Magic-Rat on Fri Dec 21, 2012 11:11 pm

Ok.

I got it working with a workaround.

To get it to work:

1) Must use the IP of the machine you are trying to connect to. A netbios name will not work. I have static IPs, so this is an acceptable workaround.

2) Must use a domain name of "WORKGROUP" (all caps). This is a bit wierd because the I have a real Windows domain (not a workgroup) ... but "WORKGROUP" works. "workgroup" (lowercase) will not work. The real domain name also will not work (either upper or lower case).

Thanks again!

Pat
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Fri Dec 28, 2012 8:48 am

All,

To be clear, I was able to map the Windows network shares using the method described above as a "workaround".

I have not been able to get Nemo to properly browse the Windows network like all previous versions of Mint will do.

So, I still think there is a bug in release 14 related to this.

Pertinent facts:
- Mint 14 Nadia Cinnamon has this issue.
- Mint 14 KDE has this issue
- If I install Mint 13 Maya Cinnamon ... it all works properly
- If I install XMBCBuntu Eden ... it all works properly
- If I install Ubuntu 12.04 or 12.10 ... it all works properly
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby altair4 on Fri Dec 28, 2012 9:02 am

You might want to post the output of the following command just to make one last check to see if anything is messed up with the default smb.conf on the Mint14 machine:
Code: Select all
testparm -s


Mint14 comes from Ubuntu 12.10 and I doubt that Mint would mess around with the default samba settings but you never know. It could be a bug in the file manager but it would have to be the same bug in both nemo and dolphin, right?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5987
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby floreym2 on Mon Dec 31, 2012 5:53 pm

Exactly the same problem here trying to connect to CIFS shares on a Synology 212+. It may be a name resolution problem. I edited the hosts file (sudo gedit /etc/hosts) to add the address of the server (192.168.n.n servername.local SERVERNAME) and could then browse the nas box.

On the Synology box I found it was necessary to enable the local master browser function to make the shares visible to Linux. Since this enables the guest account with no password, deny access to guest on all shares to maintain security.

Mike
floreym2
Level 1
Level 1
 
Posts: 1
Joined: Mon Dec 31, 2012 5:36 pm

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby kwisher on Tue Jan 01, 2013 5:14 pm

Have you tried installing the package cifs-utils?
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 635
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Tue Jan 01, 2013 11:33 pm

altair4 wrote:You might want to post the output of the following command just to make one last check to see if anything is messed up with the default smb.conf on the Mint14 machine:
Code: Select all
testparm -s



On Ubuntu 12.10 with Dolphin it does work like it's supposed to (as it does with xbuntu, mint 13, debian, etc.)

Here ya go (from my Mint 14 box) ... and thanks again:

-- Pat (aka, magic-rat)

Code: Select all
brett@brett-Latitude-E6420 ~ $ testparm -s
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
   server string = %h server (Samba, Ubuntu)
   map to guest = Bad User
   obey pam restrictions = Yes
   pam password change = Yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   unix password sync = Yes
   syslog = 0
   log file = /var/log/samba/log.%m
   max log size = 1000
   dns proxy = No
   usershare allow guests = Yes
   panic action = /usr/share/samba/panic-action %d
   idmap config * : backend = tdb

[printers]
   comment = All Printers
   path = /var/spool/samba
   create mask = 0700
   printable = Yes
   print ok = Yes
   browseable = No

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printer
Last edited by Magic-Rat on Tue Jan 01, 2013 11:44 pm, edited 2 times in total.
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Tue Jan 01, 2013 11:39 pm

Just for giggles, here is a "testparm -s" result from an identical notebook on the same LAN with Mint 13 installed. The two machines are literally sitting side-by-side plugged into the same network hub.

-- Pat (aka, magic-rat)

Code: Select all
magic-rat@LinuxMintNotebook ~ $ testparm -s
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
   server string = %h server (Samba, Ubuntu)
   map to guest = Bad User
   obey pam restrictions = Yes
   pam password change = Yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   unix password sync = Yes
   syslog = 0
   log file = /var/log/samba/log.%m
   max log size = 1000
   dns proxy = No
   usershare allow guests = Yes
   panic action = /usr/share/samba/panic-action %d
   idmap config * : backend = tdb

[printers]
   comment = All Printers
   path = /var/spool/samba
   create mask = 0700
   printable = Yes
   print ok = Yes
   browseable = No

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby altair4 on Wed Jan 02, 2013 7:50 am

I was hoping to find something obviously wrong with smb.conf but that does not appear to be the case. I'm going to follow a couple of the recommendations from the Samba Checklist HowTo:

Rearragnge the order of how Samba resolves host names by adding a line right under the workgroup line in /etc/samba/smb.conf:
Code: Select all
name resolve order = bcast host lmhosts wins

This isn't really required from the client end but you might want to fix your netbios name. Samba uses the hostname as the netbios name but yours (brett-Latitude-E6420) is 4 characters too long. Rather than muck about with the hostname itself you can specify the netbios name in smb.conf by adding another line - rigtht under the name resolve order line:
Code: Select all
netbios name = brett-Lat-E6420

It doesn't have to be that exact name but it does have to be 15 characters or less in length.

Then restart samba:
Code: Select all
sudo service smbd restart
sudo service nmbd restart

You seem to have a lot of machines on your lan so wait about 5 minutes or so and then run the following command and post the output:
Code: Select all
smbtree
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5987
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Wed Jan 02, 2013 9:10 pm

Thks.

I see ... good catch on the name length.

I'm out of town again with work.

I'll be back this weekend and try it then.

Will post back then.
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Fri Jan 04, 2013 8:05 pm

HOOAH!!!!

I opened a terminal window and launched Nemo as root like this:

sudo su
<entered root password>
sudo gedit /etc/samba/smb.conf

I altered /etc/samba/smb.conf to this:

I added: "name resolve order = bcast host lmhosts wins" under the workgroup section as shown below.

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = WORKGROUP
name resolve order = bcast host lmhosts wins
.
.
.
#======================= Global Settings =======================

In the same root access terminal window, I then executed the following commands:

sudo service smbd restart
sudo service nmbd restart

... waited 5 minutes ... and my Linux Mint 14 Nemo can now browse EVERYTHING properly.

Yay!!!

Perfect.

I did not have to change the netbios name length of the client.

I shall now name a child in your honor (and have donated $100 to the cause).

Thank you so much!

This issue is now truly solved.

Pat (aka, magic-rat)
Last edited by Magic-Rat on Sat Jan 05, 2013 4:14 pm, edited 2 times in total.
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Fri Jan 04, 2013 8:08 pm

Just for informational purposes, here is the output of the "smbtree" command:

Code: Select all
WORKGROUP
   \\LINUXMINTNOTEBOO      LinuxMintNotebook server (Samba, Ubuntu)
      \\LINUXMINTNOTEBOO\Dell-5130cdn-Color-Laser   Dell 5130cdn Color Laser (9C:F3:E8)
      \\LINUXMINTNOTEBOO\IPC$              IPC Service (LinuxMintNotebook server (Samba, Ubuntu))
      \\LINUXMINTNOTEBOO\print$            Printer Drivers
   \\COLOSSUS             My Book Live Duo Personal Cloud Storage
      \\COLOSSUS\IPC$              IPC Service (My Book Live Duo Personal Cloud Storage)
      \\COLOSSUS\Public            Public Share
   \\BRETT-LATITUDE-      brett-Latitude-E6420 server (Samba, Ubuntu)
      \\BRETT-LATITUDE-\Dell-5130cdn-Color-Laser   Dell 5130cdn Color Laser (9C:F3:E8)
      \\BRETT-LATITUDE-\IPC$              IPC Service (brett-Latitude-E6420 server (Samba, Ubuntu))
      \\BRETT-LATITUDE-\print$            Printer Drivers
FLANDERSLAND
   \\SUPERCRUNCH          
   \\SUPER7               
   \\DUAL-XEON            
      \\DUAL-XEON\HPPSC140          HP PSC 1400 series
      \\DUAL-XEON\Archives          
      \\DUAL-XEON\Album             
      \\DUAL-XEON\C$                Default share
      \\DUAL-XEON\SYSVOL            Logon server share
      \\DUAL-XEON\ADMIN$            Remote Admin
      \\DUAL-XEON\Admin             
      \\DUAL-XEON\F$                Default share
      \\DUAL-XEON\Papers            
      \\DUAL-XEON\Bogus             
      \\DUAL-XEON\Bike              
      \\DUAL-XEON\G$                Default share
      \\DUAL-XEON\Songs             
      \\DUAL-XEON\CDonServer        
      \\DUAL-XEON\Kelley            
      \\DUAL-XEON\NETLOGON          Logon server share
      \\DUAL-XEON\FTP               
      \\DUAL-XEON\print$            Printer Drivers
      \\DUAL-XEON\Inetpub           
      \\DUAL-XEON\IPC$              Remote IPC
      \\DUAL-XEON\Development       
      \\DUAL-XEON\E$                Default share
      \\DUAL-XEON\Video             
   \\AESIP
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby altair4 on Sat Jan 05, 2013 8:35 am

Magic-Rat wrote:I shall now name a child in your honor (and have donated $100 to the cause).

Poor kid :lol:

What are her / his close friends going to call her / him for short, alty? And what about the school yard bullies? - "all-tear". I'd leave it alone.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5987
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby Magic-Rat on Sat Jan 05, 2013 10:57 am

:)

Ok. Thks again!
Magic-Rat
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 15, 2012 10:21 am

Re: Mint 14 - Can't Browse Windows Shares - [SOLVED]

Postby weewahz on Sun Mar 17, 2013 9:11 am

Thank you much for the solution to this! :D
weewahz
Level 1
Level 1
 
Posts: 1
Joined: Sun Mar 17, 2013 9:07 am

Linux Mint is funded by ads and donations.
 

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 6 guests