1.6.7: Desktop icons are gone, missing setting in options

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby chazdg24 on Sat Dec 22, 2012 3:24 pm

leskieurbiker wrote:It's the most annoying bug since the day I began to use Linux Mint as my main OS.

Good timing to test KDE!

KDE is my second choice on Ubuntu. KDE is annoying to set up. Lots of work involved.

Cinnamon is once again working perfectly with desktop icons showing up every time I boot up. :)
chazdg24
Level 3
Level 3
 
Posts: 141
Joined: Mon Jun 06, 2011 5:11 pm

Linux Mint is funded by ads and donations.
 

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby elwc on Mon Dec 24, 2012 6:41 am

Thankfully I'm not alone. First time my desktop icons disappeared, I played around with my nemo and it reappeared. Now it just doesn't come back without ctrl+alt+backspace

I would prefer not to remove nautilus as furiusisomount needs it to work.
Processor : 8x Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Memory : 12214MB
Operating System : Linux Mint 14 Nadia
elwc
Level 1
Level 1
 
Posts: 22
Joined: Sun Dec 09, 2012 3:07 am
Location: Malaysia

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby lunatico on Fri Dec 28, 2012 8:42 am

I've seen post here saying Nautilus is not installed by default on LM14.

I'm not sure that's true. I'm also having this problem. I recently upgraded from LM13 to 14, I did a fresh install. I installed Linux Mint 14 32-bit Cinnamon, and Nautilus is installed. Nemo is there too and is the main file manager.

I haven't found a god workaround... anyone?
User avatar
lunatico
Level 2
Level 2
 
Posts: 98
Joined: Mon Jul 20, 2009 12:00 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby leskieurbiker on Fri Dec 28, 2012 10:52 am

My workaround: reinstalling LM13, without activating backported packages updates: I'll stay with Cinnamon 1.4. Obviously, Cinnamon 1.6.7 is not ready.
I'm a Linux Mint 17 x64 Cinnamon user 99,5% of the time and very happy with it!
leskieurbiker
Level 1
Level 1
 
Posts: 23
Joined: Tue Feb 07, 2012 9:59 am

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby lunatico on Fri Dec 28, 2012 10:55 am

leskieurbiker wrote:My workaround: reinstalling LM13, without activating backported packages updates: I'll stay with Cinnamon 1.4. Obviously, Cinnamon 1.6.7 is not ready.

I wouldn't feel comfortable with that solution. 1.6.7 is better than 1.4. I think I found an easier workaround, at least it's working for me.

Simply create a script file containing:
Code: Select all
#!/bin/bash
sleep 8
nemo -n


Make it executable and add that to the startup applications.
User avatar
lunatico
Level 2
Level 2
 
Posts: 98
Joined: Mon Jul 20, 2009 12:00 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby leskieurbiker on Fri Dec 28, 2012 10:59 am

@lunatico

I really hope your solution works. I'll stay tuned to know.
Up to now, every solution people found (including me) worked for a few times only, then people come back and say: my icons are gone again. Annoying bug.
I'm a Linux Mint 17 x64 Cinnamon user 99,5% of the time and very happy with it!
leskieurbiker
Level 1
Level 1
 
Posts: 23
Joined: Tue Feb 07, 2012 9:59 am

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby lunatico on Fri Dec 28, 2012 11:01 am

leskieurbiker wrote:@lunatico

I really hope your solution works. I'll stay tuned to know.
Up to now, every solution people found (including me) worked for a few times only, then people come back and say: my icons are gone again. Annoying bug.


I've rebooted a few times and it has worked every time. I'll post again if it stops working.
User avatar
lunatico
Level 2
Level 2
 
Posts: 98
Joined: Mon Jul 20, 2009 12:00 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby chazdg24 on Fri Dec 28, 2012 8:36 pm

leskieurbiker wrote:My workaround: reinstalling LM13, without activating backported packages updates: I'll stay with Cinnamon 1.4. Obviously, Cinnamon 1.6.7 is not ready.

Sure it is, at least on Ubuntu 12.04. I wouldn't install LM 14 or 13 as I found the ATI drivers buggy. Ubuntu 12.04 seems to handle video drivers better. I don't quite understand why but I never had any luck with Mint.

Check out what I did in this thread to get 1.6.7 to work. I have Desktop Icons 90% of the time. :wink:
chazdg24
Level 3
Level 3
 
Posts: 141
Joined: Mon Jun 06, 2011 5:11 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby vargarv on Tue Jan 22, 2013 7:44 am

Hi, i have the same problem, i have a dell precision and i've solved the problem using dconf-editor org->nemo->desktop and remove the background-fade alse remove on org->gnome->nautilus->desktop the same check...
Reboot the machine and after login and after the auto change wallpaper (using wally) work perfect!!!!

I hope I have helped
Bye
(sorry for my english)
vargarv
Level 1
Level 1
 
Posts: 1
Joined: Tue Jan 22, 2013 7:39 am

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby falcon421 on Thu Jan 24, 2013 8:59 pm

Hi,

I too have the "Finding Nemo" problem :)

I have been looking into it and on boot nemo is not starting or is not staying running. You can go to menu-system tools-system monitor-processes and nemo is not there. By clicking on the files icon all you are doing is starting nemo up and then nemo takes over the desktop and all is well. You can also go to terminal and just type 'nemo' to start the process.

I tried forcing nemo to start by adding it to the auto start menu (menu-preferances-startup applications) and nemo does start on boot then but no Desktop icons! :? So nemo files starts but it does not run the desktop still. 9M of RAM instead of 16M...

So the problem is that nemo is unable to start normally on boot due to perhaps multiple reasons.

In my case I have another computer that works fine to compare the two. I think I have found it. The good computer does not have nautilus installed and the bad computer, for some reason, does... In the system auto run (File system-etc-xdg-autostart) there are two files that will control the desktop! 'nautilus-autostart.desktop' and 'nemo-autostart.desktop'... I was playing with it and on one boot nautilus came up on the desk top! :o So on boot both files are trying to control the Desktop and they are probably conflicting and shutting each other down. Thus the system boots with nobody controlling the desktop and thus no icons.

It is a bit confusing since both nemo and nautilus call themselves "Files" so it is not obvious you have two masters trying to run the show. So I am going to unistall nautilus and see if that fixes it. I just wanted to write all this before I forget what I did. But note that the Desktop handler is designed to fail off incase something goes wrong just so you don't have a dead computer or no boot issue. There may very well be other things that can shutdown nemo on boot too.

UPDATE:
Yes that fixed it all. I removed nautilus and now the icons and all boot perfectly fine. Note that I could have probably removed nemo and then nautilus whould be the desktop controller.

So be sure you don't have nautilus and nemo or any other file and destop handelers trying to run at the same time. Otherwise, they all crash on bootup. This was not a Cinnamon or nemo problem at all but it did take some hunting to find the conflict. I hope this helps others too. :)

FAST SOLUTION - Do not have nautilus and nemo both installed. They will conflict and crash eash other on bootup and the Desktop icons will not come up on boot.
falcon421
Level 1
Level 1
 
Posts: 12
Joined: Thu Jan 24, 2013 8:35 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby elwc on Thu Jan 24, 2013 10:34 pm

falcon421 wrote:FAST SOLUTION - Do not have nautilus and nemo both installed. They will conflict and crash eash other on bootup and the Desktop icons will not come up on boot.


Precisely. Uninstalled nautilus and never had problems since
Processor : 8x Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Memory : 12214MB
Operating System : Linux Mint 14 Nadia
elwc
Level 1
Level 1
 
Posts: 22
Joined: Sun Dec 09, 2012 3:07 am
Location: Malaysia

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby chazdg24 on Mon Jan 28, 2013 1:50 pm

falcon421 wrote:Hi,

In my case I have another computer that works fine to compare the two. I think I have found it. The good computer does not have nautilus installed and the bad computer, for some reason, does... In the system auto run (File system-etc-xdg-autostart) there are two files that will control the desktop! 'nautilus-autostart.desktop' and 'nemo-autostart.desktop'... I was playing with it and on one boot nautilus came up on the desk top! :o So on boot both files are trying to control the Desktop and they are probably conflicting and shutting each other down. Thus the system boots with nobody controlling the desktop and thus no icons.

After doing this, Ubuntu users still must do the following, otherwise your desktop icons will not show:

dconf-editor and go to org-gnome-desktop-background and tick "Show desktop icons". :wink:
chazdg24
Level 3
Level 3
 
Posts: 141
Joined: Mon Jun 06, 2011 5:11 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby northcamel on Wed Mar 13, 2013 7:38 am

I got the same problem.

When I want to transmit my Nexus 7 using linux mint 13. And I refer to a webpage(http://www.webupd8.org/2013/01/upgrade- ... rt-in.html) and that tell me to install Gvfs. After I install the Gvfs, the Nexus 7 still can't get mounted. So I uninstall the Gvfs.

But when I reboot my laptop, the file manager disappeared, just as you all.

I use the following method to solve this problem:

1.install gvfs
Code: Select all
sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update
sudo apt-get install gvfs


2.reinstall nemo
2.1 just type:
sudo apt-get install nemo

2.2 If you get the message:
Package nemo is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nemo' has no installation candidate

You have to add PPA of nemo. And you can choose the stable version of nemo or the nightly version.
Code: Select all
sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
sudo apt-get update
sudo apt-get install nemo


Code: Select all
sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-nightly
sudo apt-get update
sudo apt-get install nemo
northcamel
Level 1
Level 1
 
Posts: 15
Joined: Wed Dec 05, 2012 10:51 pm

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby adoreadonai on Tue Mar 26, 2013 3:41 am

This may have been answered or tried but I had the same problem today and resolved it with these methods

I had read nemo and nautilus conflict at times when both are installed. To be honest I don't know if it was installed as a dependency later or was included out of the box.

Uninstall nautilus (if using nemo):

Code: Select all
sudo apt-get remove nautilus


Install dconf-tools:

Code: Select all
sudo apt-get install dconf-tools


Open dconf Editor:

Menu > System Tools > dconf Editor

Navigate to org>gnome>desktop>background and check show-desktop-icons

Log out and log back in

Hope this helps.

Edit: After reading the first page I see these methods are mentioned. In the even anyone lands on this page from a search engine I'll leave my post :)
adoreadonai
Level 1
Level 1
 
Posts: 3
Joined: Mon Mar 25, 2013 11:23 am

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby theSeppi on Mon Aug 18, 2014 8:04 am

This still happens on my system (Qiana, Cinnamon 2.2.13, Nemo 2.2.2). No, I don't have Nautilus installed!

I found the following workaround to avoid the disappearing icons:
Add the command «/bin/sh -c "killall nemo && nemo -n&"» to the startup applications. This will kill the initially started instance of nemo and will start a new instance as an own process.

The similar solution posted above won't work, since the instance controlling the desktop is still running when starting the new one.
Linux Mint 17 Cinnamon Edition 64bit
HP ProBook 455 G1
AMD A8-4500G with Radeon HD 7580M
theSeppi
Level 1
Level 1
 
Posts: 2
Joined: Sat Jun 28, 2014 6:27 am
Location: Switzerland

Re: 1.6.7: Desktop icons are gone, missing setting in option

Postby sg1efc on Tue Aug 19, 2014 4:54 pm

theSeppi wrote:This still happens on my system (Qiana, Cinnamon 2.2.13, Nemo 2.2.2). No, I don't have Nautilus installed!

I found the following workaround to avoid the disappearing icons:
Add the command «/bin/sh -c "killall nemo && nemo -n&"» to the startup applications. This will kill the initially started instance of nemo and will start a new instance as an own process.

The similar solution posted above won't work, since the instance controlling the desktop is still running when starting the new one.


Hello theSeppi:

Thank you very much for posting this info & Thanks to everyone else who has also posted.

theSeppi: Would you please give me a bit more details about how you added the command? Specifically, exactly where and how do you add this command? Is it in the System Settings Control Center > click on "Startup Programs"? Or is it somewhere else?

Thank you very much for your help theSeppi, I greatly appreciate it. :)
sg1efc
Level 1
Level 1
 
Posts: 7
Joined: Wed Jan 23, 2013 10:52 pm

[Solved] "icons not showing up" & "right mouse click on desk

Postby sg1efc on Tue Aug 19, 2014 9:42 pm

Just figured out how to solve my particular "icons not showing up on my desktop" and the "clicking on the desktop with a right mouse click box not opening up" problems:

Open "dconf Editor" (you may have to install it if you do not currently have it) and then click on the "dconf Editor" tab at the top left corner. Then click on the "Find" option to enable "dconf Editor's" search function. Then type in:
nemo
in the search box.

Click on the initiate the word search "Next" button 4 times (it was 4 times for me at least) and this fourth search result should display the "Nemo" section in the left hand column. From this section you click on:
desktop
under the word Nemo in the left hand column. Then in the right hand column you will see:
show-desktop-icons
and simply check the "show-desktop-icons" box to have the icons display on your desktop & for the "clicking on the desktop with a right mouse click box not opening up" problem to also be restored. Note that there are other "show-desktop-icons" boxes in other areas of dconf Editor, it was just a matter of finding the Nemo one to solve my problem, LoL. :)

Note:
I am using Linux Mint Cinnamon 17.0 64bit version. :)
sg1efc
Level 1
Level 1
 
Posts: 7
Joined: Wed Jan 23, 2013 10:52 pm

Linux Mint is funded by ads and donations.
 
Previous

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 4 guests