[LMDE 64] Acrobat Reader once was available, now unavailable

Questions about applications and software
Forum rules
Before you post please read this

[LMDE 64] Acrobat Reader once was available, now unavailable

Postby Flat on Tue Oct 02, 2012 11:52 am

Hi all,

My first question on this great forum.

I'm not - strictly speaking - a Linux newbie (5 years ago, I began with Fedora, then switched to Debian and finally settled on Mint), but I'm far form being a guru :)

I use LMDE/64bits (amd64), and I've encountered a strange problem recently : Using Synaptic, I installed acroread without any problem, along with the firefox plugin - which I use a lot since for my work I have to access lots of pdf files through the web.
All was working smoothly, except that when I closed a firefox tab displaying a pdf file through the plugin, it was impossible to open new pdfs through firefox.
The acroread process was marked as "defunct", and I had to hardkill this process to get things working again.

This was a bit difficult to work with, and I thought I made an error during installation. Thus I uninstalled every acrobat-related package, cleaned everything, searched the web for possible mistakes I made, found nothing and then prepared to reinstall...

And now, Synaptic (or apt-get install) is not listing me the acroread package as available... :shock:
It indeed lists the "acroread-data", the "acroread-l10n-en" and so on, but no acroread anymore...

I didn't touch the repository list at all, it's the same than during install:
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
deb http://download.virtualbox.org/virtualbox/debian squeeze non-free

Where did I go wrong ? Where is this damn package ? :(
And BTW, if anybody has a workaround or an explanation for the "defunct acroread process phenomenon"...

Thanks for any help or hint.
François
Flat
Level 1
Level 1
 
Posts: 2
Joined: Tue Oct 02, 2012 9:46 am

Linux Mint is funded by ads and donations.
 

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Tue Oct 02, 2012 12:17 pm

acroread is provided by http://www.deb-multimedia.org/ and if you read the note
Code: Select all
01/07/2012 :
I added multi-arch support for acroread and thus I removed acroread amd64 packages.

To install new acroread packages :
dpkg --add-architecture i386
apt-get update
apt-get install acroread
and UP5 was respined on the end of that month without amd64 acroread.
see here >> viewtopic.php?f=190&t=111026 howto add multiarch
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby AbeOwitz on Tue Oct 02, 2012 4:11 pm

Alternatively, download 32bit deb from: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.1/enu/

Code: Select all
wget ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.1/enu/AdbeRdr9.5.1-1_i386linux_enu.deb
sudo dpkg --force-architecture -i AdbeRdr9.5.1-1_i386linux_enu.deb


Oddly, /usr/bin/acroread doesn't want to start, but running it from /opt does...

Code: Select all
/opt/Adobe/Reader9/bin/acroread


Might need to install the ia32 libs, not sure if 'apt-get -f install' will pull those in for you, as I've already installed the 32bit libs.
AbeOwitz
Level 1
Level 1
 
Posts: 6
Joined: Fri Aug 12, 2011 9:30 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby Flat on Wed Oct 03, 2012 4:29 am

Thanks to both of you, it is now up and running !
I didn't notice the change in the update packages, sorry. Thanks for pointing that.

The multi-arch installation went like a breeze, very cool.
I just tested the classical distribution and didn't use the adobe package.
ia32-libs were already installed, so I too don't know if it was needed by acroread.

Many thanks to you again. You rule :wink:

François

(And sorry for having first posted in the wrong location, I hadn't seen there was a specific place for LMDE64...) :oops:
Flat
Level 1
Level 1
 
Posts: 2
Joined: Tue Oct 02, 2012 9:46 am

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 4:05 pm

I don't mean to hijack this post but I am having a problem install the reader.
I am on LInux Mint Debian.
Here is the message I am getting.
Start a new post if that is necessary.
danc@danc-e535:~$ sudo dpkg --force-architecture -i AdbeRdr9.5.1-1_i386linux_enu.deb
Selecting previously unselected package adobereader-enu.
(Reading database ... 188815 files and directories currently installed.)
Unpacking adobereader-enu (from AdbeRdr9.5.1-1_i386linux_enu.deb) ...
dpkg: dependency problems prevent configuration of adobereader-enu:
adobereader-enu depends on libgtk2.0-0 (>= 2.4).

dpkg: error processing adobereader-enu (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
adobereader-enu
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 8:16 pm

Dan,
is multiarch enabled?
what's the output of
Code: Select all
dpkg --print-foreign-architectures

the reader is a multiarch package and i don't believe that the --force-architecture -i trick will result; that's one of the reasons they invented this multiarch mess (seamless installation of 32bit pkgs in 64bit systems)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 8:49 pm

danc@danc-e535:~/Documents$ dpkg --print-foreign-architectures
i386
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 9:18 pm

yep, it's multiarch :D
and now
Code: Select all
apt-cache policy acroread

Code: Select all
sudo apt-get -s install acroread
(this one only if the previous has output)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 9:51 pm

danc@danc-e535:~/Documents$ apt-cache policy acroread
N: Unable to locate package acroread
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 9:55 pm

Dan
please post your
Code: Select all
cat /etc/apt/sources.list

and
Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 10:38 pm

Code: Select all
danc@danc-e535:~/Documents$ cat /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import romeo backport
deb-src http://packages.linuxmint.com/ debian main upstream import romeo backport #Added by software-properties
deb http://mirror.metrocast.net/linuxmint-debian/latest testing main contrib non-free
deb http://mirror.metrocast.net/linuxmint-debian/latest/security testing/updates main contrib non-free
deb http://mirror.metrocast.net/linuxmint-debian/latest/multimedia testing main non-free


Code: Select all
danc@danc-e535:~/Documents$ sudo apt-get update && sudo apt-get dist-upgrade
[sudo] password for danc:
Ign http://packages.linuxmint.com debian InRelease
Hit http://mirror.metrocast.net testing InRelease       
Get:1 http://packages.linuxmint.com debian Release.gpg [197 B]                                         
Hit http://mirror.metrocast.net testing/updates InRelease                                 
Get:2 http://packages.linuxmint.com debian Release [15.6 kB]                                           
Hit http://mirror.metrocast.net testing InRelease                                       
Get:3 http://packages.linuxmint.com debian/main Sources [17.2 kB]                                                         
Hit http://mirror.metrocast.net testing/main amd64 Packages/DiffIndex                                           
Hit http://mirror.metrocast.net testing/contrib amd64 Packages/DiffIndex                             
Get:4 http://packages.linuxmint.com debian/upstream Sources [2,182 B]                                           
Hit http://mirror.metrocast.net testing/non-free amd64 Packages/DiffIndex                             
Get:5 http://packages.linuxmint.com debian/import Sources [27.1 kB]             
Hit http://mirror.metrocast.net testing/main i386 Packages/DiffIndex
Hit http://mirror.metrocast.net testing/contrib i386 Packages/DiffIndex                               
Get:6 http://packages.linuxmint.com debian/romeo Sources [1,255 B]                                               
Hit http://mirror.metrocast.net testing/non-free i386 Packages/DiffIndex                                         
Get:7 http://packages.linuxmint.com debian/backport Sources [20 B]                                               
Hit http://mirror.metrocast.net testing/contrib Translation-en/DiffIndex                                                   
Get:8 http://packages.linuxmint.com debian/main amd64 Packages [19.8 kB]                                         
Hit http://mirror.metrocast.net testing/main Translation-en/DiffIndex                   
Get:9 http://packages.linuxmint.com debian/upstream amd64 Packages [5,387 B]                                     
Hit http://mirror.metrocast.net testing/non-free Translation-en/DiffIndex                                       
Get:10 http://packages.linuxmint.com debian/import amd64 Packages [63.2 kB]     
Hit http://mirror.metrocast.net testing/updates/main amd64 Packages
Hit http://mirror.metrocast.net testing/updates/contrib amd64 Packages                   
Hit http://mirror.metrocast.net testing/updates/non-free amd64 Packages                                                   
Get:11 http://packages.linuxmint.com debian/romeo amd64 Packages [20 B]                                         
Get:12 http://packages.linuxmint.com debian/backport amd64 Packages [20 B]                                                 
Hit http://mirror.metrocast.net testing/updates/main i386 Packages                                               
Get:13 http://packages.linuxmint.com debian/main i386 Packages [19.8 kB]                                         
Hit http://mirror.metrocast.net testing/updates/contrib i386 Packages                                           
Hit http://mirror.metrocast.net testing/updates/non-free i386 Packages                                 
Get:14 http://packages.linuxmint.com debian/upstream i386 Packages [5,383 B]                                     
Get:15 http://packages.linuxmint.com debian/import i386 Packages [62.8 kB]                                                 
Hit http://mirror.metrocast.net testing/main amd64 Packages/DiffIndex                                                     
Get:16 http://packages.linuxmint.com debian/romeo i386 Packages [20 B]                                                     
Get:17 http://packages.linuxmint.com debian/backport i386 Packages [20 B]                                                 
Hit http://mirror.metrocast.net testing/non-free amd64 Packages/DiffIndex                                                 
Hit http://mirror.metrocast.net testing/main i386 Packages/DiffIndex                                                       
Hit http://mirror.metrocast.net testing/non-free i386 Packages/DiffIndex                                                   
Hit http://mirror.metrocast.net testing/main amd64 Packages                                                               
Hit http://mirror.metrocast.net testing/contrib amd64 Packages                                                             
Hit http://mirror.metrocast.net testing/non-free amd64 Packages                                                 
Hit http://mirror.metrocast.net testing/main i386 Packages                                                                 
Hit http://mirror.metrocast.net testing/contrib i386 Packages                                                             
Hit http://mirror.metrocast.net testing/non-free i386 Packages                                                             
Hit http://mirror.metrocast.net testing/contrib Translation-en                                                             
Hit http://mirror.metrocast.net testing/main Translation-en                                                               
Hit http://mirror.metrocast.net testing/non-free Translation-en                                                           
Hit http://mirror.metrocast.net testing/main amd64 Packages                                                               
Hit http://mirror.metrocast.net testing/non-free amd64 Packages                                                           
Hit http://mirror.metrocast.net testing/main i386 Packages                                                                 
Hit http://mirror.metrocast.net testing/non-free i386 Packages                                                             
Ign http://packages.linuxmint.com debian/backport Translation-en_US                                                       
Ign http://packages.linuxmint.com debian/backport Translation-en                                                 
Ign http://packages.linuxmint.com debian/import Translation-en_US                                                         
Ign http://mirror.metrocast.net testing/updates/contrib Translation-en_US                                                 
Ign http://packages.linuxmint.com debian/import Translation-en                                                   
Ign http://mirror.metrocast.net testing/updates/contrib Translation-en                                           
Ign http://packages.linuxmint.com debian/main Translation-en_US                                                 
Ign http://mirror.metrocast.net testing/updates/main Translation-en_US                                           
Ign http://packages.linuxmint.com debian/main Translation-en                                                     
Ign http://mirror.metrocast.net testing/updates/main Translation-en
Ign http://packages.linuxmint.com debian/romeo Translation-en_US               
Ign http://mirror.metrocast.net testing/updates/non-free Translation-en_US                                       
Ign http://packages.linuxmint.com debian/romeo Translation-en                                                   
Ign http://mirror.metrocast.net testing/updates/non-free Translation-en                                         
Ign http://packages.linuxmint.com debian/upstream Translation-en_US                                             
Ign http://mirror.metrocast.net testing/main Translation-en_US                                                   
Ign http://packages.linuxmint.com debian/upstream Translation-en                                                 
Ign http://mirror.metrocast.net testing/main Translation-en                     
Ign http://mirror.metrocast.net testing/non-free Translation-en_US
Ign http://mirror.metrocast.net testing/non-free Translation-en
Fetched 240 kB in 20s (11.7 kB/s)                         
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 10:51 pm

i don't get it how the policy command above gave you "unable to locate package" :shock: it is here http://mirror.metrocast.net/linuxmint-debian/latest/multimedia/pool/non-free/a/adobereader-enu/ in the pool of the mirror you're using
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 11:09 pm

zero,
You have been a great help with this however I am in a dependency hell that I am not good enough with linux to figure out.
I tried downloading the reader file from the list you had but it had a dependency file it wanted so I downloaded that file and tried to install it but it wanted the original adobe file I downloaded as its dependency.
I seem to be in some kind of dependency loop.
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 11:13 pm

:oops: no Dan you shouldn't try to download the files directly from the pool;
acroread has too many dep for you to cherry-pick each one that way; what i was trying to say is that is odd you cant find it in your repos when it is present in the mirrors you are using and you are up-to-date.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 11:15 pm

t to give an idea: here acroread wants to install 80 :!: dep
Code: Select all
The following NEW packages will be installed:
  acroread:i386 acroread-data acroread-debian-files:i386 acroread-dictionary-en
  acroread-l10n-en cups-bsd gcc-4.7-base:i386 krb5-locales libatk1.0-0:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libc6:i386
  libc6-i686:i386 libcairo2:i386 libcomerr2:i386 libcups2:i386 libdatrie1:i386
  libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386
  libdrm2:i386 libexpat1:i386 libffi5:i386 libfontconfig1:i386 libfreetype6:i386
  libgcc1:i386 libgcrypt11:i386 libgdk-pixbuf2.0-0:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386 libgtk2.0-0:i386 libidn11:i386
  libjasper1:i386 libjbig0:i386 libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 liblzma5:i386 libp11-kit0:i386 libpango1.0-0:i386
  libpciaccess0:i386 libpcre3:i386 libpixman-1-0:i386 libpng12-0:i386 libselinux1:i386
  libstdc++6:i386 libtasn1-3:i386 libthai0:i386 libtiff4:i386 libx11-6:i386
  libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb-render0:i386 libxcb-shm0:i386
  libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
  libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386 libxml2:i386
  libxrandr2:i386 libxrender1:i386 libxxf86vm1:i386 zlib1g:i386
0 upgraded, 80 newly installed, 0 to remove and 0 not upgraded.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 11:17 pm

zero,
Then do I have some sort of repository or sources glitch we need to check out.
Where do I begin to figure that out?
Thanks
Dan

Edit:
In these cases it would be cool if you could just take over my machine.
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 11:26 pm

now that you have already updated at least once your system can you try again
Code: Select all
apt-cache policy acroread

as i said (in the mirror you are using)
Code: Select all
zerozero@wine ~ $ apt-cache policy acroread
acroread:i386:
  Installed: (none)
  Candidate: 9.5.1-dmo7
  Version table:
     9.5.1-dmo7 0
        500 http://mirror.metrocast.net/linuxmint-debian/incoming/multimedia/ testing/non-free i386 Packages
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 11:29 pm

Sorry it still says it is unable to locate the package
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby zerozero on Fri Dec 28, 2012 11:30 pm

Dan
copy&paste exactly the text in the terminal here in the forum please
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [LMDE 64] Acrobat Reader once was available, now unavail

Postby dcihon on Fri Dec 28, 2012 11:33 pm

danc@danc-e535:~/Documents$ apt-cache policy acroread
N: Unable to locate package acroread
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests