another samba question [RESOLVED]

Questions about cabled networking
Forum rules
Before you post please read this

another samba question [RESOLVED]

Postby stimpe on Fri Dec 28, 2012 7:02 pm

testparm -s

Code: Select all
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Unknown parameter encountered: "server role"
Ignoring unknown parameter "server role"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[sysvol]"
Processing section "[netlogon]"
Processing section "[Video]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
        server string = %h server (Samba, LinuxMint)
        map to guest = Bad User
        obey pam restrictions = Yes
        guest account = avahi
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        username map = /etc/samba/smbusers
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        idmap config * : backend = tdb
        guest ok = Yes

[printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        print ok = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers

[sysvol]
        path = /var/lib/samba/sysvol
        read only = No

[netlogon]
        path = /var/lib/samba/sysvol/localdomain/scripts
        read only = No

[Video]
        path = /media/SERVER-BACKUP/Media/Video


net usershare info --long

Code: Select all
Ignoring unknown parameter "server role"
[Video]
path=/media/SERVER-BACKUP/Media/Video
comment=
usershare_acl=Everyone:R,
guest_ok=y



smbtree

Code: Select all
server@server-mint ~ $ smbtree
Ignoring unknown parameter "server role"
Enter server's password:

I enter the password and nothing happens for smbtree.

Im just trying to setup a basic home server. dont need users guest permission is ok.
the weird thing is i set it up fine in 2 minutes in vmware, i did the exact same thing on the real install and now im having problems :(
Last edited by stimpe on Sun Dec 30, 2012 10:56 am, edited 1 time in total.
stimpe
Level 1
Level 1
 
Posts: 30
Joined: Fri Dec 28, 2012 3:19 pm

Linux Mint is funded by ads and donations.
 

Re: another samba question

Postby altair4 on Fri Dec 28, 2012 7:18 pm

There's a couple of issues:

[1] This is more philosophical but if you only wanted a home server why deviate from the default smb.conf that comes with Mint.

[2] Your guest account:

you swithed it from the default of "nobody" to "avahi". Why create a samba user out of avahi? None of my business I suppose but if you are going to allow guests or this avahi user to access the shared folder then the Linux permissions have to accommodate that. What are the permissions of the shared folder:
Code: Select all
ls -dl /media/SERVER-BACKUP/Media/Video

[3] You re using 2 different samba methods to share the same folder. One is Classic in smb.conf and the other is a Samba usershare at /var/lib/samba/usershares. So far they seem to be in sync but be careful.

[4] No output from smbtree:

The usual suspects:

** Firewall is in the way. Turn it off to see if it's the problem.

** Name services aren't running. Find out if they are - might want to make sure samba is running as well:
Code: Select all
sudo service smbd status
sudo service nmbd status


If they aren't running start them:
Code: Select all
sudo service nmbd start
sudo service smbd start
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6129
Joined: Tue Feb 03, 2009 10:27 am

Re: another samba question

Postby stimpe on Fri Dec 28, 2012 7:46 pm

- the 'nobody' to 'avahi' i reached a low point and was trying everything, no idea what i was doing so thanks for sorting me out haha.

- i dont know what you mean by deviating from the smb.conf that comes with mint, i thought thats what i was using. when i installed mint i was in terminal, i typed "samba" and it said it wasnt installed, and told me to use apt-get samba4, so thats what i did.

Code: Select all
server@server-mint ~ $ sudo service smbd status
[sudo] password for server:
smbd start/running, process 843
server@server-mint ~ $ sudo service nmbd status
nmbd start/running, process 1568


firewall in system settings > firewall is disabled
Code: Select all
server@server-mint ~ $ ls -dl /media/SERVER-BACKUP/Media/Video
drwx------ 1 server server 0 Dec 28 16:26 /media/SERVER-BACKUP/Media/Video


i just want a simple smb.conf to allow guest users to share files on the network, so how do i remove 1 of the 2 methods im apparently using? thanks for your help bud!

*edit* i remember installing a gui for samba system-config-samba or something like that, i removed it anywho.
here are updated terminal outputs:
Code: Select all
server@server-mint ~ $ testparm -s
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Unknown parameter encountered: "server role"
Ignoring unknown parameter "server role"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[sysvol]"
Processing section "[netlogon]"
Processing section "[Video]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
        server string = %h server (Samba, LinuxMint)
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        username map = /etc/samba/smbusers
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        idmap config * : backend = tdb
        guest ok = Yes

[printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        print ok = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers

[sysvol]
        path = /var/lib/samba/sysvol
        read only = No

[netlogon]
        path = /var/lib/samba/sysvol/localdomain/scripts
        read only = No

[Video]
        path = /media/SERVER-BACKUP/Media/Video


Code: Select all
server@server-mint ~ $ net usershare info --long
Ignoring unknown parameter "server role"
[Video]
path=/media/SERVER-BACKUP/Media/Video
comment=
usershare_acl=Everyone:R,
guest_ok=y



and smbtree still doesnt show anything. also when im in Dolphin > Network > Samba shares : nothing shows up at all, shouldnt my shared folder
[Video]
path=/media/SERVER-BACKUP/Media/Video
show up there?

*another edit!!* got itviewable from my windows box, had to add this line to my smb.conf under my [Video] heading
browseable = Yes
but i dont have permission to enter the folder, how do i fix that?
stimpe
Level 1
Level 1
 
Posts: 30
Joined: Fri Dec 28, 2012 3:19 pm

Re: another samba question

Postby altair4 on Sat Dec 29, 2012 8:09 am

The first mistake was not your fault:
i dont know what you mean by deviating from the smb.conf that comes with mint, i thought thats what i was using. when i installed mint i was in terminal, i typed "samba" and it said it wasnt installed, and told me to use apt-get samba4, so thats what i did.

"samba" isn't a command that you invoke in a terminal but telling you to install samba4 was not the correct answer by the system. It's a long story but Samba4 isn't something you want to install at this point. Samba ( version 3 ) was already installed on your system.

Let's see if we can make it work with Samba4 - who knows it might work.

Edit smb.conf as root:
Code: Select all
gksu gedit /etc/samba/smb.conf

Add a line to your [global] section - right under the workgroup line:
Code: Select all
force user = server

Then restart samba:
In Samba3 the command would be the following - I don't know if they changed the service names in Samba4:
Code: Select all
sudo service smbd restart

Try this if it doesn't recognize the service smbd:
Code: Select all
sudo service samba restart


THe problem is this:
server@server-mint ~ $ ls -dl /media/SERVER-BACKUP/Media/Video
drwx------ 1 server server 0 Dec 28 16:26 /media/SERVER-BACKUP/Media/Video

THe only user that is going to get access is "server". "nobody" or "avahi" are not "server" but a "force user = server" will make them so.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6129
Joined: Tue Feb 03, 2009 10:27 am

Re: another samba question

Postby stimpe on Sat Dec 29, 2012 10:40 am

thank you for the help - I have removed samba4, and i'd like to try to get it to work with the regular samba that comes with mint as you first suggested.
stimpe
Level 1
Level 1
 
Posts: 30
Joined: Fri Dec 28, 2012 3:19 pm


Return to Ethernet

Who is online

Users browsing this forum: Exabot [Bot] and 3 guests