Slow Internet using wireless

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

Slow Internet using wireless

Postby Mart on Mon Aug 27, 2012 9:45 am

Hi, I've recently installed Linux Mint Maya on my Toshiba Satallite L30.

Using a wired connection the internet is fine, but using wireless the internet is very slow. I've used this laptop with windows 7/Vista wirelessly without a problem, and I have another laptop and desktop using Windows 7 wirelessly without a problem. So the wireless signal from the netgear router is quite good. I've got the laptop networked to the Windows machines as well, but this is also slow over wireless

Would this suggest a problem with the wireless driver?

Appreciate some help on this.
Mart
Level 1
Level 1
 
Posts: 1
Joined: Mon Aug 27, 2012 9:36 am

Linux Mint is funded by ads and donations.
 

Re: Slow Internet using wireless

Postby Oscar799 on Tue Aug 28, 2012 3:38 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8942
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Slow Internet using wireless

Postby GringoDeLobo on Thu Sep 13, 2012 4:47 pm

Have you ever figured this one out?

I am having the same problem with my HP EliteBook 8530p (Intel Corporation Ultimate N WiFi Link 5300).
GringoDeLobo
Level 1
Level 1
 
Posts: 1
Joined: Thu Sep 13, 2012 4:34 pm

Re: Slow Internet using wireless

Postby hakgu on Sat Oct 20, 2012 4:08 pm

Hi..

I'm experiencing the exact same thing. When I installed Mint 13 Maya (64-bit), downloaded Oct 12 from the official source, I thought my computer had broken, because the installation took +24 hours. Literally and seriously. Because I connected to my WLAN in order to pull down the latest versions while installing....

Today, I ran a speed-test using WLAN, which resulted in 156 kb/s downstream. The upstream failed due to timeout. I plugged in the cable - connecting it directly to the same wireless router - and re-ran the test. This time I got 16.98 Mb/s down, 1.02 Mb/s up, and 23 ms ping.

To test this, I booted the very same computer using an Ubuntu 11.04 CD that I had lying around, and ran a Wireless test achieving the same result as with Mint via the cable.

Thus I conclude that the issue is not with my router, not with my hardware, but with Linux Mint.

Funny thing is, in Ubuntu when connected to my WLAN, it says it has a 54 Mb/s connection when the same in Mint says 1 Mb/s.

..Cheers
..Håkan
hakgu
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 20, 2012 3:49 pm

Re: Slow Internet using wireless

Postby kvnsmith on Sun Nov 04, 2012 2:59 am

Hopefully someone can shed some light on this. I've found a couple of suggestions online but none have worked for me. I'm on an HP Envy 14 and the internet is doggedly slow, sometimes won't work at all. I ran Ubuntu with the same problem, Windows 7 has no problem. In a VirtualBox on the Win7 machine, it also seemed fine from what I remember though I should maybe set that up again to be sure. Anyway, it seems as though it's purely a Linux problem unless routers somehow block Linux traffic and allow Windows traffic. That seems unlikely.
kvnsmith
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 04, 2012 2:56 am

Re: Slow Internet using wireless

Postby slumdog on Sun Dec 30, 2012 3:14 pm

Hello,
I have the same problem.
Checked everything :laptop, router, signal, ISP, and the conclusion is that the Linux Mint is the problem.
I have installed Linux Mint 14.

Anyone has a resolution on this?

Thank you
slumdog
Level 1
Level 1
 
Posts: 1
Joined: Sun Dec 30, 2012 3:11 pm

Re: Slow Internet using wireless

Postby kiraitachi on Mon Mar 04, 2013 1:42 pm

Hi was having the same problems and gave with the SOLUTION:

What worked for me

Code: Select all
sudo gedit /etc/resolv.conf


After that delete the name server code in mine shows:

Code: Select all
nameserver "whatever number"
nameserver "whatever number"


The whatever number should be the OPEN DNS codes that I think it is 206.200 or something like that just google it, but anway we are going to take that off.
And go to network settings>wireless and below should say DNS.
Mines where 80.58.61.250 80.58.61.254 so what I did is put in the resolv.conf

Code: Select all
nameserver 80.58.61.250
nameserver 80.58.61.254
kiraitachi
Level 1
Level 1
 
Posts: 1
Joined: Sat Jan 23, 2010 7:17 pm

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: Clashius and 4 guests