No sound on Mint 14 Cinnamon 64 bit

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

No sound on Mint 14 Cinnamon 64 bit

Postby adambaker on Mon Dec 31, 2012 5:26 am

I just upgraded from Mint 12 to Mint 14, and I find my system without sound. Here's what I've tried so far:

Append "options snd-hda-intel model=generic" to /etc/modprobe.d/alsa-base.conf. Reboot. No joy.
Boot from live Mint 14 disc. No sound.
Boot from live Mint 12 disc. Beautiful melodies.
Install ALSA mixer like this fellow. But the mixer didn't have all the check boxes his showed, so no joy.
Remove Pulse Audio and replace it with ALSA per these instructions. Reboot. Silence remains.

Here are a few relevant lspci lines:
Code: Select all
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
04:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Barts HDMI Audio [Radeon HD 6800 Series]


Does anyone have suggestions?
Last edited by adambaker on Wed Jan 02, 2013 7:04 pm, edited 2 times in total.
adambaker
Level 1
Level 1
 
Posts: 4
Joined: Mon Dec 31, 2012 3:51 am

Linux Mint is funded by ads and donations.
 

Re: No sound on Mint 14 Cinnamon 65 bit

Postby viking777 on Mon Dec 31, 2012 6:07 am

Those new 65 bit processors are too advanced for Linux - try again in about a year or so :wink:

Alternatively have a look at the output of:

Code: Select all
amixer


If any channel has the word "off" alongside it switch it on again. Example:

Code: Select all
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 49 [56%] [-28.50dB] [off]


Shows my 'master' channel is [off].

I would switch it on and set the volume with:

Code: Select all
amixer set master 100 unmute


You may have more than one channel muted so you may need to run the command more than once. The 100 figure means the volume is turned up to 100% so if you have a particularly loud speaker system you might want to set a lower level to start with!
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: No sound on Mint 14 Cinnamon 64 bit

Postby adambaker on Mon Dec 31, 2012 6:02 pm

I don't think this is the issue. Here's my amixer output:

Code: Select all
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 3
  Mono:
  Front Left: Playback 2 [67%] [20.00dB] [on]
  Front Right: Playback 2 [67%] [20.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 132 [52%] [-24.60dB]
  Front Right: Playback 132 [52%] [-24.60dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 22 [71%] [-13.50dB] [on]
  Front Right: Playback 22 [71%] [-13.50dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 15 [48%] [6.00dB] [off]
  Front Right: Capture 15 [48%] [6.00dB] [off]


"Capture" is my microphone, and I want that one off.
adambaker
Level 1
Level 1
 
Posts: 4
Joined: Mon Dec 31, 2012 3:51 am

Re: No sound on Mint 14 Cinnamon 64 bit

Postby DS_ED on Wed Jan 02, 2013 3:12 am

Did you try connecting your headphone or any external speakers to the port? Are you getting audio through that?
DS_ED
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 02, 2013 3:08 am

Re: No sound on Mint 14 Cinnamon 64 bit

Postby adambaker on Wed Jan 02, 2013 5:55 am

Yes. For every experiment I've listed, I played several audio files listening for audio on my built-in speakers in my laptop and my headphones, with the headphones in both the HDMI and headphone jacks. I even try listening for the system noises both from startup and from adjusting the volume. And all these worked in my Mint 12 installation, and work when I run Mint 12 live from the DVD, and don't work in my Mint 14 install or from my Mint 14 live DVD.
Last edited by adambaker on Wed Jan 02, 2013 6:59 pm, edited 1 time in total.
adambaker
Level 1
Level 1
 
Posts: 4
Joined: Mon Dec 31, 2012 3:51 am

Re: No sound on Mint 14 Cinnamon 64 bit

Postby DS_ED on Wed Jan 02, 2013 8:59 am

adambaker wrote:Yes. For every experiment I've listed, I played several audio files listening for audio on my built-in speakers in my laptop and my headphones, with the headphones in both the HDMI and headphone jacks. I even try listening for the system noises both from startup and from adjusting the volume. And all these worked in my Mint 12 installation, and work when I run Mint 12 live from the DVD, and non work in my Mint 14 install or from my Mint 14 live DVD.


Then I'm not sure, I faced a different issue. In any case try the 3rd solution on this. That solved it for me.
DS_ED
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 02, 2013 3:08 am

Re: No sound on Mint 14 Cinnamon 64 bit

Postby adambaker on Sun Jan 06, 2013 1:54 am

Thank you for the suggestions.

I tried downloading Mint 13 and found the sound worked on the live boot, so I installed that one. I consider this an adequate solution for the time being, though I'd be happy to try other suggestions if I can do them on a live Mint 14 boot.
adambaker
Level 1
Level 1
 
Posts: 4
Joined: Mon Dec 31, 2012 3:51 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: discus84 and 7 guests