Mint 14 Cinnamon forgets USB is preferred sound device

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Mint 14 Cinnamon forgets USB is preferred sound device

Postby yatesco on Mon Dec 31, 2012 8:04 pm

Hi all,

I have a USB headset (microphone and speakers) and when I plug it in it is recognised. If I then go into Sound settings I can choose the headset in "Output", "Input" and "Hardware".

The problem is that if I put the computer to sleep or reboot it, Sound Settings will still list the headset but it is no longer selected, rather than default "Built-in Audio Analogue Stereo" (for example) is selected.

This has happened on Ubuntu as well, just FYI.

Any ideas on how to persist this selection? I guess it is to do with USB being hot swappable?, so how do I tell the Linux sound system (alsa/pulse?) "always use this headset when it is plugged in"?

Thanks!

P.S Wasn't sure if this should go into the hardware forum... admin, please feel free to move it if necessary
yatesco
Level 1
Level 1
 
Posts: 1
Joined: Mon Dec 31, 2012 7:58 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 4 guests