Touchpad problem: cursor jumps (Maya 64bit, MATE)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby eolith on Sat Dec 22, 2012 6:50 pm

Hello,

I have this annoying touchpad problem: I move the pointer with the touchpad. Then, at the end of the movement (i.e. when I release contact with the trackpad) the pointer makes a small jump on the screen of (seemingly) random magnitude and direction.

I have a dual boot HP Pavilion dv7 with Mint 13, MATE, 64bit, and a SynPS/2 Synaptics Touchpad. Booting with Windows 7 does not show this issue, indicating to me that the touchpad H/W is ok. Using a mouse with Mint also works completely fine.

I have searched in Linux forums, including this one, but I cannot find a solution. Any help would be welcome!

Best regards, Eolith

Edit 1: just tried Ubuntu live USB - precisely the same problem.

Edit 2: now tried Fedora - same problem. Seems like a Linux distro-only problem since Windows 7 is fine. Any suggestions? Thanks!!

Anybody out there with any suggestion? It is making the laptop very hard to use, since it won't let me click on the place I want; I have to aim 2 or 3 times before it lands on the right place. I don't want to go back to Windows! :( Thank you in advance for your help!
eolith
Level 1
Level 1
 
Posts: 5
Joined: Thu Nov 01, 2012 6:02 am

Linux Mint is funded by ads and donations.
 

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby laughfactory on Thu Dec 27, 2012 2:36 am

I have this same issue. It's extremely irritating and I'm not sure what to do about it. I'm running Mint 14.1 on an HP ENVY DV6T-7200. Everything else works great, but the pointer jumping juuuust as I go to click on something drives me batty. Can anyone offer us any assistance? Please?
laughfactory
Level 1
Level 1
 
Posts: 1
Joined: Thu Dec 27, 2012 2:33 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby eolith on Fri Dec 28, 2012 2:53 pm

I have now installed as a triple boot also Ubuntu 12.10, and made sure I have the latest updates. Precisely the same exasperating problem! For this reason, and because there is no response in this forum since initially posting this issue 19 dec, I have also asked the same question to the Ubuntu user community, check out http://ubuntuforums.org/showthread.php?t=2098397. No luck as yet though ... but I will update here when I get any progress.
eolith
Level 1
Level 1
 
Posts: 5
Joined: Thu Nov 01, 2012 6:02 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby erie88 on Wed Jan 02, 2013 8:42 am

I'm also having the same problem. The mouse jumpy as I click or right-clicking a a link, worse it'll clicking the opton right away.

Edited : Installing Gsynaptics packages seems to solves the problem. At least now I can handle the right-click.
erie88
Level 1
Level 1
 
Posts: 29
Joined: Mon Dec 31, 2012 11:24 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby eolith on Thu Jan 03, 2013 6:37 pm

Thanks for the suggestion and glad it works for you!

However installing Gsynaptics package does not resolve the issue for me. (I also understand that it is (near) obsolete for Mint and that rather gpointing-device-settings should be used...)

Anybody else have any assistance on offer? This problem drives me up the wall!

Thanks in advance.
eolith
Level 1
Level 1
 
Posts: 5
Joined: Thu Nov 01, 2012 6:02 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby erie88 on Fri Jan 04, 2013 1:30 pm

Have you tried changing the touchpad setting after you have installed the GSynaptics packages? Look in Menu - Prefrences - Mouse and Touchpad - then go to the second tab "Touchpad". You'll need to reduce or adjust the accelaration and sensitivity or whatever there "that has a bar" to the left (Slow or Low).
erie88
Level 1
Level 1
 
Posts: 29
Joined: Mon Dec 31, 2012 11:24 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby eolith on Mon Jan 07, 2013 6:47 pm

Yes, have tried that, to no avail: in my case it is not a problem of speed, or sensitivity, or acceleration. Whenever I stop moving the pointer and release my finger, regardless aforementions settings, it jumps away in an unpredictable direction for an unpredictable distance.

But thanks again for your help, I do appreciate it.
eolith
Level 1
Level 1
 
Posts: 5
Joined: Thu Nov 01, 2012 6:02 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby tgb on Mon Aug 19, 2013 11:25 am

I have this same problem as well. It's driving me crazy. Anyone have any other suggestions?

I have a Lenovo IdeaPad y410p with the SynPS/2 Synaptics Touchpad and Linux Mint 15 with Cinnamon 64-bit. Touchpad works fine in Windows 8 but hops ~10 pixels after finger is released. Reducing sensitivity doesn't seem to help. My touchpad also has the Mac-style click-by-pushing-down-the-entire-pad which is very hard to do without wiggling the cursor, though it has no problems in Windows. It also only occaisonally triggers the right-click button when pressing it down (left and right clicks are integrated into the touchpad, not separate buttons). Furthermore, it sometimes looses two-finger scrolling even though the setting is checked in the GPointing Device Settings screen and I have toggle it off-and-on to get the scrolling back. Overall this is quite frustrating!
tgb
Level 1
Level 1
 
Posts: 3
Joined: Mon Aug 19, 2013 11:18 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby tgb on Mon Aug 19, 2013 2:03 pm

I found out a bit more about my problem by reading http://forums.linuxmint.com/viewtopic.php?f=49&t=114085 and https://wiki.archlinux.org/index.php/Touchpad_Synaptics. I notice that /var/log/Xorg.0.log contains the following:

Code: Select all
[    25.891] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event12)
[    25.891] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    25.891] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    25.891] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"


So it looks like three different programs are being added to handle the TouchPad. This is despite using the suggestion from the Linux Mint forums linked above of using MatchDevicePath "/dev/input/event*" in my xorg.conf. In fact, I have exactly their suggested InputClass section in my xorg.conf now. No success.

Edit: I see now in the xorg.conf.d that 'Default clickpad buttons' shouldn't be a problem. I also went ahead and disabled the evdev touchpad catchall entry in 10-evdev.conf. This successfully gets rid of the Xorg.0.log multiple-entries 'issue' but doesn't actually change my original problems.
tgb
Level 1
Level 1
 
Posts: 3
Joined: Mon Aug 19, 2013 11:18 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby roblm on Tue Aug 20, 2013 7:36 am

Did you try working with the four touchpad properties below. The number next to each property is the default value:

Device Accel Profile 0
Device Accel Constant Deceleration 1
Device Accel Adaptive Deceleration 1
Device Accel Velocity Scaling 10

You can start with these values:

Device Accel Profile 2
Device Accel Constant Deceleration 2
Device Accel Adaptive Deceleration 2
Device Accel Velocity Scaling 10

First get the id number of your touchpad by running this command in the Terminal: xinput
Then use these xinput commands, replacing X with the touchpad id number:

xinput --set-prop X “Device Accel Profile" 2
xinput --set-prop X “Device Accel Constant Deceleration” 2
xinput --set-prop X “Device Accel Adaptive Deceleration” 2
xinput --set-prop X “Device Accel Velocity Scaling” 10

Then start testing different values. For Accel Profile, test if 3 works better.
For Constant Deceleration and Adaptive Deceleration, try increasing by 1 or 2, up to 16.
For Velocity Scaling try decreasing the value to 5, and then 1, and then increasing the value above 10 by 5 at a time up to 30.

Two other properties that can be tested are Vertical and Horizontal Hysteresis. Use these commands:

synclient VertHysteresis=50
synclient HorizHystersis=50

Then try increasing the value of each by 10, up to 80.

Check the link below for more information:
http://www.x.org/wiki/Development/Docum ... /#index2h2
User avatar
roblm
Level 4
Level 4
 
Posts: 434
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby tgb on Tue Aug 20, 2013 10:14 am

Thanks for the clear post and detailed instructions! I tried playing with these values a bit and the problem lessens in magnitude considerably if I increase Device Accel Constant Deceleration to about 10. However, in that case the pointer becomes unbearably slow for general use! It does even still jump with those settings but only moves a pixel or two so I'm not sure that increasing speed through some other parameter wouldn't just bring back the jumping problem.

The hysteresis settings do manage to cut down on the frequency of the jumps a bit but not on their magnitude. I see no change in behavior from increasing beyond 50 but setting it to that initial 50 does do some good - even huge values like 500 shows jumps.
tgb
Level 1
Level 1
 
Posts: 3
Joined: Mon Aug 19, 2013 11:18 am

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby roblm on Wed Aug 21, 2013 3:01 pm

tgb wrote:I'm not sure that increasing speed through some other parameter wouldn't just bring back the jumping problem.

You could try increasing the acceleration in System Settings > Mouse and Touchpad. One person in the link below had success doing
this (see post #7). Another increased the Velocity Scaling a lot higher (see post #6). I forgot to include this link in my first post.
It's where some of my suggestions come from:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1042069

In the link above the minimum and maximum speeds were both set to 1 by some.
synclient MinSpeed=1
synclient MaxSpeed=1

I'm wondering if changing the FingerLow property would help. When the finger pressure drops below the set value, then a release event is registered. I think the default value is about 25, so try decreasing the value:
synclient FingerLow=25

There's also the property called Jumpy Cursor Threshold. It's for stabilizing two-finger actions so I don't know if it affects one-finger actions. Lowering the value decreases the sensitivity. Replace the X with your touchpad id#.
xinput --set-prop X "Synaptics Jumpy Cursor Threshold" 250

The link below has more information on touchpad properties:
http://www.x.org/archive/X11R7.5/doc/ma ... ics.4.html
User avatar
roblm
Level 4
Level 4
 
Posts: 434
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad problem: cursor jumps (Maya 64bit, MATE)

Postby fredlb on Wed Aug 21, 2013 4:41 pm

I've had the same issue, but I managed to improve the accuracy quite a bit by setting FingerLow=9 and FingerHigh=12.
It's still there, but much less. "Mistaps" are almost gone or same as Windows 7.
fredlb
Level 1
Level 1
 
Posts: 5
Joined: Sun Aug 18, 2013 6:15 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: jmdeking and 14 guests