[SOLVED] Problems with Broadcom 4311 on Dell

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

[SOLVED] Problems with Broadcom 4311 on Dell

Postby Athena on Tue Jan 01, 2013 7:29 am

Hi all,

I probably should have posted this in Newbie Questions, since I'm new to Linux, but the question seems to be more appropriate for this forum.

So, I decided to install Linux Mint 14 Cinnamon on my Dell XPS M1330 alongside Windows Vista Home Basic (I used mint4win previously, but now I want to install Mint properly).

I use a USB thumbdrive already used twice to install Mint on my netbook and second laptop (both Dells). With these two, everything worked perfectly. This time, I cannot connect to the wireless. I tried to add a new wireless connection in Network Connections manually, but it doesn't work :( In Vista, the laptop connects to the wireless smoothly.

What can be the problem here?
Last edited by Athena on Thu Jan 03, 2013 12:40 pm, edited 1 time in total.
Chip: Dell XPS M1330, Linux Mint 14 Cinnamon + Windows Vista Home Basic
Dale: Dell Inspiron Mini 1018, Linux Mint 14 Cinnamon
Monty: Dell Inspiron N5110-2848, Linux Mint 14 Cinnamon + Windows 7 Basic
User avatar
Athena
Level 1
Level 1
 
Posts: 19
Joined: Tue Dec 25, 2012 4:59 pm
Location: St Petersburg, Russia

Linux Mint is funded by ads and donations.
 

Re: No wireless connection on Dell during installation of Mi

Postby RodMyers on Tue Jan 01, 2013 11:07 am

are you sure the wireless card is working?

if so, can you scan for your network?
RodMyers
Level 2
Level 2
 
Posts: 69
Joined: Tue Nov 29, 2011 12:54 pm

Re: No wireless connection on Dell during installation of Mi

Postby Athena on Wed Jan 02, 2013 5:26 pm

RodMyers wrote:are you sure the wireless card is working?

if so, can you scan for your network?


Everything is working fine under Vista, so I guess the hardware isn't the issue :(
Chip: Dell XPS M1330, Linux Mint 14 Cinnamon + Windows Vista Home Basic
Dale: Dell Inspiron Mini 1018, Linux Mint 14 Cinnamon
Monty: Dell Inspiron N5110-2848, Linux Mint 14 Cinnamon + Windows 7 Basic
User avatar
Athena
Level 1
Level 1
 
Posts: 19
Joined: Tue Dec 25, 2012 4:59 pm
Location: St Petersburg, Russia

Re: No wireless connection on Dell during installation of Mi

Postby Athena on Thu Jan 03, 2013 12:39 pm

Problem solved!

It was my Broadcom 4311 which was causing problems (I understand that it's a very common issue). Here's my way of solving the issue, just in case:

- First, I connected my laptop to the internet via my Android smartphone using USB tethering;
- Second, I found in the Software Manager and installed b43-fwcutter;
- Third, I found and installed firmware-b43-installer.

The hardest thing was to identify the source of the problem (here my thanks go to the Dell Linux Mailing List) and to find a way to connect the laptop to the internet. I did try to download the required tools using another laptop, but the offline installation didn't work.
Chip: Dell XPS M1330, Linux Mint 14 Cinnamon + Windows Vista Home Basic
Dale: Dell Inspiron Mini 1018, Linux Mint 14 Cinnamon
Monty: Dell Inspiron N5110-2848, Linux Mint 14 Cinnamon + Windows 7 Basic
User avatar
Athena
Level 1
Level 1
 
Posts: 19
Joined: Tue Dec 25, 2012 4:59 pm
Location: St Petersburg, Russia


Return to Wireless

Who is online

Users browsing this forum: No registered users and 8 guests