Steam on Linux- team fortress 2 black screen openGL

Anything related to gaming on Linux Mint including game discussion or questions concerning Steam or Wine.
Forum rules
Before you post please read how to get help

Steam on Linux- team fortress 2 black screen openGL

Postby pholey on Thu Dec 27, 2012 6:52 pm

Hi! Wondering if any other gamers here: I am running mint 14 and I currently have steam on Linux installed. Team fortress two is supported by Linux, however when I boot it up I get nothing but a black screen. I hear the valve intro music, and occasionally the start up music (occasionally being once) ... I googled all day yesterday, and could not find anything that worked. (Mainly the C_LANG fix and it's common others)

I'm running LM 14 32 bit
Cinnamon



I know it's not my system being incapable of running it because I run games such as skyrim on Linux all the time with medium quality. Team fortress 2 is nowhere close to that.

Any help would be greatly appreciated!!!

Also on a side note; audiosurf via steam on crossover, can't click the initial ok button.. Just a side note..
Last edited by pholey on Fri Dec 28, 2012 3:42 am, edited 1 time in total.
User avatar
pholey
Level 1
Level 1
 
Posts: 3
Joined: Thu Dec 27, 2012 6:10 pm

Linux Mint is funded by ads and donations.
 

Re: Steam on Linux- team fortress 2 black screen openGL

Postby Therion87 on Thu Dec 27, 2012 10:02 pm

Are you running Cinnamon? or MATE? Either way make sure that composting is off best way to do this is the use the Gnome Classic (No Effects) session when you login. Or you can install this http://www.webupd8.org/2012/12/better-steam-for-linux-performance-with.html. I personally perfer the latter it works great and everything runs as it should.
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: Steam on Linux- team fortress 2 black screen openGL

Postby mcoumans on Thu Jan 03, 2013 1:18 pm

Yep, works great via GnomeClassic/XFCE desktop environments, not on Cinnamon (except if you play games in windowed mode).

Steam-login didn't help either, after login I got a black screen (probably similar to the one you get when trying to play TF2 or Trine2 on a Cinnamon Desktop.
SYSTEM: Linux Mint 14 [Nadia] 64-bit [Cinnamon]
KERNEL: Linux 3.7.0-7-generic (x86_64)
PROC: AMD Phenom II X4 840
MB: Asus M5A99X-EVO
GFX: MSI Geforce GTX-660 Twin Frozer (2Gb)
Graphics: nvidia 313.09 (xorg-edgers)
X-server: 1.13.1.901
mcoumans
Level 2
Level 2
 
Posts: 52
Joined: Sat Aug 21, 2010 7:55 am

Re: Steam on Linux- team fortress 2 black screen openGL

Postby Therion87 on Thu Jan 03, 2013 1:22 pm

mcoumans wrote:Yep, works great via GnomeClassic/XFCE desktop environments, not on Cinnamon (except if you play games in windowed mode).

Steam-login didn't help either, after login I got a black screen (probably similar to the one you get when trying to play TF2 or Trine2 on a Cinnamon Desktop.

Shouldn't as the Steam Login uses xfcewm from XFCE nothing from Cinnamon. But, glad it's working for you.
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: Steam on Linux- team fortress 2 black screen openGL

Postby mcoumans on Thu Jan 03, 2013 1:56 pm

Therion87 wrote:
mcoumans wrote:Yep, works great via GnomeClassic/XFCE desktop environments, not on Cinnamon (except if you play games in windowed mode).

Steam-login didn't help either, after login I got a black screen (probably similar to the one you get when trying to play TF2 or Trine2 on a Cinnamon Desktop.

Shouldn't as the Steam Login uses xfcewm from XFCE nothing from Cinnamon. But, glad it's working for you.


Yes, I discussed the issue with Steam Login, but even though I can run steam+games on XFCE, I cannot login under SteamLogin. The issue is filed as steam bug, but I doubt it's a steam thing, more likely an issue with compositing (Compiz?).

And even though it's nice to be able to play games on steam linux, I rather play them on my "normal" desktop i.e. on Cinnamon, without the need to close all programmes, logoff and log back in.
SYSTEM: Linux Mint 14 [Nadia] 64-bit [Cinnamon]
KERNEL: Linux 3.7.0-7-generic (x86_64)
PROC: AMD Phenom II X4 840
MB: Asus M5A99X-EVO
GFX: MSI Geforce GTX-660 Twin Frozer (2Gb)
Graphics: nvidia 313.09 (xorg-edgers)
X-server: 1.13.1.901
mcoumans
Level 2
Level 2
 
Posts: 52
Joined: Sat Aug 21, 2010 7:55 am

Re: Steam on Linux- team fortress 2 black screen openGL

Postby Therion87 on Thu Jan 03, 2013 3:29 pm

mcoumans wrote:
Therion87 wrote:
mcoumans wrote:Yep, works great via GnomeClassic/XFCE desktop environments, not on Cinnamon (except if you play games in windowed mode).

Steam-login didn't help either, after login I got a black screen (probably similar to the one you get when trying to play TF2 or Trine2 on a Cinnamon Desktop.

Shouldn't as the Steam Login uses xfcewm from XFCE nothing from Cinnamon. But, glad it's working for you.


Yes, I discussed the issue with Steam Login, but even though I can run steam+games on XFCE, I cannot login under SteamLogin. The issue is filed as steam bug, but I doubt it's a steam thing, more likely an issue with compositing (Compiz?).

And even though it's nice to be able to play games on steam linux, I rather play them on my "normal" desktop i.e. on Cinnamon, without the need to close all programmes, logoff and log back in.

It's something else, not Compiz the entire point behind Steam Login, is that there is no compiz, no compisiting, no anything except the lightweight xfcewm from XFCE. We would have to review logs to see what is going on and trouble shoot it.
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: Steam on Linux- team fortress 2 black screen openGL

Postby pholey on Thu Jan 03, 2013 4:25 pm

I Got Audiosurf to work in cinnamon by the way, basically it seems that there is a calibration issue (on crossover and wine anyways) and you cannot click where you want to. (such as "ok")

all you need to do is resize your window to various sizes untill the calibration is correct, then once at the start menu, you can proceed to hit fullscreen and play normally.


i probably just saved a bunch of future google-ers time.
User avatar
pholey
Level 1
Level 1
 
Posts: 3
Joined: Thu Dec 27, 2012 6:10 pm

Re: Steam on Linux- team fortress 2 black screen openGL

Postby technowolf on Tue Feb 19, 2013 4:26 pm

Hi all,
I'm still getting a black screen (with some sound) when running TF2 in Steam for Linux.
Both the Gnome Classic (no effects) session and Steam login session give me the same black screen.
I don't think I can resize as the game is running in fullscreen and I don't know how to run it in a window.
Any other help you can give would be much appreciated. Thanks
technowolf
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 17, 2013 10:38 am

Re: Steam on Linux- team fortress 2 black screen openGL

Postby anandrkris on Fri Mar 01, 2013 12:51 am

Not sure, if this is solved.
Start steam from terminal and then open TF2 and check for any errors that crop up.
Code: Select all
steam

http://steamcommunity.com/app/221410 - Post your issues, higher chances of getting help from steam community.
http://steamcommunity.com/app/221410/di ... 071956036/ - Check this discussion.
To start TF2 in windows mode
Code: Select all
-sw -noborder
or
Code: Select all
-window
I had a similiar issue but mine is a different problem as I have Nvidia Optimus and had to install bumblebee. Since your other games are working fine, it should not be an issue with graphics card. Anyways post output of
Code: Select all
inxi -G
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 951
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Steam on Linux- team fortress 2 black screen openGL

Postby Bad Boy Bubby on Fri Mar 01, 2013 5:46 am

you could try ctrl + alt + f1 switch console and then alt + f8 switch back works for the same problem on counterstrike source

I think its to do with the opengl overlay not opening right

Bubby


ps to set windowed mode right click the game in the steam library and select launch options and put in -windowed
Running Linux Mint 17 KDE 64bit
Steam for Linux - Counterstike, Source and GO are my main games
ATI 6800 13.35 Beta Proprietary Driver
Intel i5 Processor
Bad Boy Bubby
Level 1
Level 1
 
Posts: 23
Joined: Thu Feb 21, 2013 4:02 am

Re: Steam on Linux- team fortress 2 black screen openGL

Postby technowolf on Fri Mar 01, 2013 7:14 am

Thanks anandrkris and buddy, will try those suggestions this evening.
technowolf
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 17, 2013 10:38 am

Re: Steam on Linux- team fortress 2 black screen openGL

Postby cebif on Fri Mar 22, 2013 6:33 am

Therion87 wrote:Are you running Cinnamon? or MATE? Either way make sure that composting is off best way to do this is the use the Gnome Classic (No Effects) session when you login. Or you can install this http://www.webupd8.org/2012/12/better-steam-for-linux-performance-with.html. I personally perfer the latter it works great and everything runs as it should.

I had the same black screen when running flightgear, in Mint Nate. This solves my problem also, after logging in to Gnome Classic, no effects.
cebif
Level 1
Level 1
 
Posts: 5
Joined: Thu Mar 21, 2013 11:42 pm

Re: Steam on Linux- team fortress 2 black screen openGL

Postby SlipperySausage on Mon Mar 25, 2013 5:52 am

I was getting these issues as well with CS Source. Since the latest patch it has been fixed - was something weird with Crossfire.

Try run the game with '-windowed' and see if you have the same issue, if it works then it's likely to be your DE
SlipperySausage
Level 1
Level 1
 
Posts: 3
Joined: Mon Mar 25, 2013 4:23 am

Re: Steam on Linux- team fortress 2 black screen openGL

Postby Geeklosopher on Sun Jun 30, 2013 2:38 pm

BTW I was having the same problem w/ TF2 and I set the launch options in Steam to -windowed and fixed the problem. Hope that helps someone.
Geeklosopher
Level 1
Level 1
 
Posts: 4
Joined: Sat Jun 22, 2013 1:17 am

Linux Mint is funded by ads and donations.
 

Return to Gaming on Linux Mint

Who is online

Users browsing this forum: No registered users and 2 guests