<SOLVED> Help with getting conky running :/

Forum rules
Before you post please read this

<SOLVED> Help with getting conky running :/

Postby destro777 on Sat Jan 05, 2013 2:55 pm

I have installed conky via the terminal
Code: Select all
sudo apt-get install conky-all
and I got a conky script and put it into the .conkyrc file and then opened the terminal and typed in conky and get this out put
Conky: desktop window (1000029) is subwindow of root window (14f)
Conky: window type - override
Conky: drawing to created window (0x2200001)
Conky: drawing to double buffer

I dont get any errors or anything but nothing shows on the desktop at all. I am new to linux in general (installed it christmas day) I just want to get conky working because it seems really cool.

any help would be greatly appreciated, thanks!
Oh here is my conky script incase that helps with anything

# -- Conky settings by giancarlo64.deviantart.com -- #
use_xft yes
xftfont xftfont verdana:style:bold:size=10
alignment top_right
gap_x 10
gap_y 40
xftalpha 1
update_interval 1.0
maximum_width 500
minimum_size 500 150
own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
draw_shades no
draw_outline no
draw_borders no
stippled_borders 10
# border_margin 4
border_width 1
default_shade_color 000000
default_outline_color 000000
default_color bcbcbc
use_spacer right
no_buffers yes
uppercase no

lua_load ~/clock_rings.lua
lua_draw_hook_pre clock_rings

TEXT
${image ~/Box.png 450x130 -p 0,0}
${voffset 50}${offset 125}${cpu cpu0}%
${voffset -17}${offset 193}${memperc}%
${voffset -17}${offset 255}${fs_used_perc /home}%
${voffset -17}${offset 316}${execi 60 find ~/.local/share/Trash/files -type f | wc -l}
${voffset -60}${offset 368}Today
${voffset 3}${offset 365}${font verdana:style:bold:size=25}${time %d}
${voffset -20}${offset 120}${font verdana:style:bold:size=8}Uptime: ${uptime_short}
${voffset -14}${goto 260}${font verdana:style:bold:size=8}Kernel: ${kernel}
Last edited by destro777 on Sat Jan 05, 2013 10:50 pm, edited 1 time in total.
destro777
Level 1
Level 1
 
Posts: 7
Joined: Sun Dec 30, 2012 4:44 pm

Linux Mint is funded by ads and donations.
 

Re: Help with getting conky running :/

Postby Flemur on Sat Jan 05, 2013 3:57 pm

Maybe try these in .conkyrc: you get a window w/o decorations.
#
own_window yes # no = background comes thru
own_window_class Conky
own_window_type normal
#own_window_type desktop # no titlebar
own_window_hints undecorated # ,below,sticky # ,skip_taskbar,skip_pager
#
Mint 17/Xfce/fluxbox & another Mint 17/Xfce/fluxbox
User avatar
Flemur
Level 5
Level 5
 
Posts: 869
Joined: Mon Aug 20, 2012 9:41 pm

Re: Help with getting conky running :/

Postby destro777 on Sat Jan 05, 2013 10:44 pm

Thanks Flemur!! I that got it to where it shows on the screen, what exactly did that do/what did that change from the original?
destro777
Level 1
Level 1
 
Posts: 7
Joined: Sun Dec 30, 2012 4:44 pm

Re: <SOLVED> Help with getting conky running :/

Postby homerscousin on Thu Jan 10, 2013 7:19 pm

I had some problems with Conky disappearing from the desktop when I clicked on icons etc. I experimented with many different combos in the window section. I remarked out the own_window_type _____line. That worked for me. I think that is the culprit.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.
homerscousin
Level 5
Level 5
 
Posts: 541
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)


Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 1 guest