(Solved) Mate Screensaver activation during movie

(Solved) Mate Screensaver activation during movie

Postby holadebeto on Sun Jul 01, 2012 9:11 am

When I set the computer to activate the screensaver when the computer is inactive, it shuts down when I'm watching a movie on VLC. Can't seem to get the best of both worlds, no screensaver activation during VLC and having it activate during normal computer use.

I guess I don't understand what "inactive" means exactly, cause when it's displaying a move, the computer is actively operating, right?

That wasn't sarcasm, honest. I just don't know.

Thank you
Last edited by holadebeto on Tue Jul 03, 2012 6:36 am, edited 1 time in total.
holadebeto
Level 2
Level 2
 
Posts: 70
Joined: Sun Jun 12, 2011 4:41 pm

Linux Mint is funded by ads and donations.
 

Re: Mate Screensaver activation during movie

Postby wyrdoak on Sun Jul 01, 2012 10:42 am

Create a bash script and run it while watching the movie:

Code: Select all
 #!/bin/bash
    xset -dpms;xset s off
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Mate Screensaver activation during movie

Postby holadebeto on Sun Jul 01, 2012 12:13 pm

I can do that, but it's much easier to just turn the screensaver off permanently and push the power button each time we start and stop using the monitor.

So is this a bug, or am I not seeing the process correctly? The Mate screensaver offers the election to "Activate screen saver when computer is inactive", but my computer is not inactive (when VLC or Movie Player or Gnome Movie Player is running) and the screen saver still activates. It activates when I'm streaming download music (which is good), and it activates during updates, etc.

So I'm confused (normal condition). It seems to activate under any condition except when using the keyboard or mouse. Is that what the programmers mean by "Active computer?"
holadebeto
Level 2
Level 2
 
Posts: 70
Joined: Sun Jun 12, 2011 4:41 pm

Re: Mate Screensaver activation during movie

Postby Jamesc359 on Sun Jul 01, 2012 4:06 pm

I'm assuming you're using xscreensaver? If so this is a very well known issue with it as the author has refused to provide support for the standard X API method of monitoring for user inactivity.

For Mplayer and possibly Gnome-Mplayer you can stop this by creating a .mplayer/config file in your home directory and inserting the following code into it.
Code: Select all
[default]
heartbeat-cmd="xscreensaver-command -deactivate > /dev/null"
stop-xscreensaver=yes
“Gosh, you've... really got some nice toys here.”
User avatar
Jamesc359
Level 3
Level 3
 
Posts: 116
Joined: Sun May 06, 2012 1:42 pm

Re: Mate Screensaver activation during movie

Postby holadebeto on Sun Jul 01, 2012 5:46 pm

Hello James,

Well, this may sound goofy, but I just uninstalled mate screen saver and installed xscreensaver and it doesn't activate during movies, etc., from VLC, and movie player.
xscreensaver does come up with an error, but it doesn't seem to affect the program in any way I can see. It also reliably (so far) activates while we're not using the computer just like it should.

My case appears to be solved, wish there was a solution for everyone - there sure seems to be a lot of folks with the same problem out there.



I'm using 64bit Mint 13 mate install.
holadebeto
Level 2
Level 2
 
Posts: 70
Joined: Sun Jun 12, 2011 4:41 pm

Re: Mate Screensaver activation during movie

Postby igor83 on Mon Oct 29, 2012 12:11 am

holadebeto wrote:Hello James,

Well, this may sound goofy, but I just uninstalled mate screen saver and installed xscreensaver and it doesn't activate during movies, etc., from VLC, and movie player.
xscreensaver does come up with an error, but it doesn't seem to affect the program in any way I can see. It also reliably (so far) activates while we're not using the computer just like it should.

My case appears to be solved, wish there was a solution for everyone - there sure seems to be a lot of folks with the same problem out there.

I'm using 64bit Mint 13 mate install.


Me too - 64 bit Mint 13 mate install. Same problem.

Out of all the solutions I tried, researching various tutorials and guides, the above is the only one that worked. Caffeine, gnome-screensaver, options in VLC--none of that worked. The screensaver would interrupt every show without fail. After 3 to 4 hours of trial and error and research on various web sites, I did the following. Installed x-screensaver, and a couple of screen shows that I don't think are necessary. I set the screensaver interval to 1 minute for testing purposes. The screensaver continued to interrupt videos. Then I uninstalled mate-screensaver. That did not work either, something was still going on. Then I tried rebooting, an old trick from Windows, and that worked! At last the screensaver quit interrupting movies. After installing x-screensaver and uninstalling mate-screensaver and then rebooting, the screensaver will NOT interrupt a show. It will also work during normal desktop use. However, the settings in x-screensaver are not used unless you click on screensaver settings in the Preferences menu. Then you will get the error message that holadebeto is talking about, something about can't find monitor on d:0. Then the x-screensaver settings will be active, for instance whichever variety of screensaver you select.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: (Solved) Mate Screensaver activation during movie

Postby xpander on Mon Oct 29, 2012 12:34 am

https://dl.dropbox.com/u/28788188/disablemss.tar.gz
paste the hidden folder into ur home and make sure it runs (add it to startup applications also)
so when u open one of those players in the list it wont activate the screensaver.

thatone working fine for me
Linux Gaming Videos: http://www.youtube.com/user/Xpander666?feature=mhee
-----------
Gfire - Xfire For Pidgin
User avatar
xpander
Level 3
Level 3
 
Posts: 158
Joined: Mon Sep 26, 2011 5:59 am

Re: (Solved) Mate Screensaver activation during movie

Postby igor83 on Mon Oct 29, 2012 1:50 am

xpander wrote:https://dl.dropbox.com/u/28788188/disablemss.tar.gz
paste the hidden folder into ur home and make sure it runs (add it to startup applications also)
so when u open one of those players in the list it wont activate the screensaver.

thatone working fine for me


What flavor of Linux Mint are you running?

I'm sure someone will be glad of the tip, but as for me I'm done at this point, not going to try finessing. It's a pretty ornery problem and I have a feeling if I tinker with anything it will break again.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: (Solved) Mate Screensaver activation during movie

Postby xpander on Mon Oct 29, 2012 12:12 pm

currently mint 14 nadia x64 (from the alpha repos: http://packages.linuxmint.com/list.php?release=Nadia)
but it worked well with the 13 Maya also.
Linux Gaming Videos: http://www.youtube.com/user/Xpander666?feature=mhee
-----------
Gfire - Xfire For Pidgin
User avatar
xpander
Level 3
Level 3
 
Posts: 158
Joined: Mon Sep 26, 2011 5:59 am

Re: (Solved) Mate Screensaver activation during movie

Postby igor83 on Mon Nov 05, 2012 8:08 pm

xpander wrote:currently mint 14 nadia x64 (from the alpha repos: http://packages.linuxmint.com/list.php?release=Nadia)
but it worked well with the 13 Maya also.


Yes, this works on Maya! Thank you!

I do not know why the directory is hidden by default, but I clicked on "Show Hidden Files" in the File Manager to reveal it. In order to execute a Python script in a Terminal, the syntax is ./[name of file]. Errors only display in the Terminal, not when running from the GUI. That is how I discovered the python script was aborting due to not finding its config file.

So I made a little modification. Editing disablemss.py in Pluma...
Code: Select all
sudo pluma disablemss.py

...I pressed Ctrl-H, and each instance of:
Code: Select all
homedir+'/.disablemss/disablemss.conf'

I replaced with:
Code: Select all
/home/.disablemss/disablemss.conf

...since I had dropped the folder into my /home directory as you suggested and it was not working there.

I have verified that mate-screensaver is in fact disabled when loading this wonderful little python script on the fly or during Startup. I'm glad because xscreensaver's GLSlideshow will not function correctly in Mate, so mate-screensaver offers a valuable slideshow function that I don't want to lose.

The syntax that works for me in Preferences | Startup Applications is "/home/.disablemss/disablemss.py" because I dropped the directory into /home.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: (Solved) Mate Screensaver activation during movie

Postby rewind on Tue Jan 01, 2013 11:04 am

Just curious is it possible to add the Adobe Flash Player which is working from the browsers in the config file, so it could inhibit screensaver while watching longer videos.

BTW it works flawlessly, thanks a lot for this.

P.S. Just forgot - Happy New 2013 everyone! :)
rewind
Level 1
Level 1
 
Posts: 6
Joined: Mon Dec 05, 2011 4:10 pm

Re: (Solved) Mate Screensaver activation during movie

Postby igor83 on Tue Jan 01, 2013 1:45 pm

I'd like to add that after some trial and error, I figured out how to get Xscreensaver working right at well. Xscreensaver doesn't require this excellent patch (which should be backported, IMHO), but has some issues of its own. I guess that is why KDE, Gnome, and now Mate are working on their own screensavers? I don't know, but it is possible to get Xscreensaver working well. I posted a brief tutorial on GLslideshow and Xscreensaver in the Linux Mint Community.
My desktop runs 64-bit Kubuntu 13.04, my htpc runs 64-bit Linux Mint Nadia Xfce, my answering machine runs 64-bit windows 7, and my laptop runs 64-bit Linux Mint Nadia KDE. Each seems suited to its purpose.
Image
User avatar
igor83
Level 4
Level 4
 
Posts: 317
Joined: Wed Aug 08, 2012 8:23 pm

Re: (Solved) Mate Screensaver activation during movie

Postby wolf_walker on Sat Jan 05, 2013 3:09 am

I use the applet to disable power management when needed. Click it when opening a movie.

Sent from my SCH-I535 using Tapatalk 2
wolf_walker
Level 1
Level 1
 
Posts: 15
Joined: Wed Aug 01, 2012 4:09 pm

Re: (Solved) Mate Screensaver activation during movie

Postby jaderiver on Sat Jan 05, 2013 8:27 pm

I have disabled pesky screensavers from activating during weird times by adding to the desktop panel the "Inhibit Applet" (which I personally place in the "drawer," the latter also added to my panel). Then, I can click on the Inhibit Applet and toggle between "Automatic sleep inhibited" and "Automatic sleep enabled" when needed.

jaderiver
ASUS U56E 64-bit Mint 13 MATE Maya w/Petra backported - dualboot WIN 7
Zoom #3095 dialup USB modem
jaderiver
Level 2
Level 2
 
Posts: 79
Joined: Wed Jun 27, 2012 1:43 pm
Location: Oregon Coast

Re: (Solved) Mate Screensaver activation during movie

Postby thomZz on Wed Jan 16, 2013 8:39 pm

rewind wrote:Just curious is it possible to add the Adobe Flash Player which is working from the browsers in the config file, so it could inhibit screensaver while watching longer videos.

BTW it works flawlessly, thanks a lot for this.

P.S. Just forgot - Happy New 2013 everyone! :)


Sorry fo the up, but i just found that if you add the line :
/usr/lib/firefox/plugin-container

To the disablemss.conf file, that's gonna work.

##Take note that every web page with flash in it (banner, carousel .. all .swf) will stop the mate-screensaver too .. but it's better than nothing :).
User avatar
thomZz
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 16, 2013 8:33 pm

Linux Mint is funded by ads and donations.
 

Return to MATE

Who is online

Users browsing this forum: No registered users and 3 guests