Odd Conky window behaviour on LXDE

Forum rules
Before you post please read this

Odd Conky window behaviour on LXDE

Postby necrosmash on Tue Mar 20, 2012 6:44 pm

Hi, I'm sorry if someone has posted something similar to this in the past, but I haven't found anything definitive on these forums and was hoping to find out if I can get Conky working properly on LXDE (Mint 12).

Basically, no matter which type of window I specify in my config file for Conky, it doesn't work quite right. According to the Conky configuration page, the types of window are as follows:

- Normal
This mode works fine, since the window decorations can be hidden by right-clicking the title bar (or, I believe, through the config file itself). However, iconifying all windows via the icon on the bottom panel causes conky to vanish.

- Desktop
Doesn't vanish through iconifying everything, but does disappear if the desktop is interacted with in any way.

- Dock
Causes the default maximisation behaviour of windows to ignore the column of space used by the docked conky (screenshot), and rests over every window that the user tries to move over it.

- Panel
Indistinguishable from the "dock" mode (to me, anyway).

- Override
Conky doesn't display at all.


Has anyone ever gotten Conky to work properly on LXDE? Any help whatsoever would be greatly appreciated. Cheers :)
necrosmash
Level 1
Level 1
 
Posts: 5
Joined: Wed Aug 04, 2010 7:44 am

Linux Mint is funded by ads and donations.
 

Re: Odd Conky window behaviour on LXDE

Postby Habitual on Tue Mar 20, 2012 6:53 pm

Define "doesn't work quite right" and post the conkrc file that you are using please.
What's a landing but a take off in reverse?
User avatar
Habitual
Level 8
Level 8
 
Posts: 2213
Joined: Sun Nov 21, 2010 8:31 pm
Location: LM17Q-Xfce

Re: Odd Conky window behaviour on LXDE

Postby necrosmash on Tue Mar 20, 2012 7:01 pm

Hi, the problems I'm having are all listed in my first post. My conky config is more or less the default file, I'm quite certain that the only changes I made were to the alignment (I set it to top_right) and the own_window_type value.

Code: Select all
# Conky, a system monitor, based on torsmo
#
# Any original torsmo code is licensed under the BSD license
#
# All code written since the fork of torsmo is licensed under the GPL
#
# Please see COPYING for details
#
# Copyright (c) 2004, Hannu Saransaari and Lauri Hakkarainen
# Copyright (c) 2005-2010 Brenden Matthews, Philip Kovacs, et. al. (see AUTHORS)
# All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
# You should have received a copy of the GNU General Public License
# along with this program.  If not, see <http://www.gnu.org/licenses/>.
#

alignment top_right
background no
border_width 1
cpu_avg_samples 2
default_color white
default_outline_color white
default_shade_color white
draw_borders no
draw_graph_borders yes
draw_outline no
draw_shades no
use_xft yes
xftfont DejaVu Sans Mono:size=12
gap_x 5
gap_y 60
minimum_size 5 5
net_avg_samples 2
no_buffers yes
out_to_console no
out_to_stderr no
extra_newline no
own_window yes
own_window_class Conky
own_window_type desktop
stippled_borders 0
update_interval 1.0
uppercase no
use_spacer none
show_graph_scale no
show_graph_range no

TEXT
${scroll 16 $nodename - $sysname $kernel on $machine | }
$hr
${color grey}Uptime:$color $uptime
${color grey}Frequency (in MHz):$color $freq
${color grey}Frequency (in GHz):$color $freq_g
${color grey}RAM Usage:$color $mem/$memmax - $memperc% ${membar 4}
${color grey}Swap Usage:$color $swap/$swapmax - $swapperc% ${swapbar 4}
${color grey}CPU Usage:$color $cpu% ${cpubar 4}
${color grey}Processes:$color $processes  ${color grey}Running:$color $running_processes
$hr
${color grey}File systems:
 / $color${fs_used /}/${fs_size /} ${fs_bar 6 /}
${color grey}Networking:
Up:$color ${upspeed eth0} ${color grey} - Down:$color ${downspeed eth0}
$hr
${color grey}Name              PID   CPU%   MEM%
${color lightgrey} ${top name 1} ${top pid 1} ${top cpu 1} ${top mem 1}
${color lightgrey} ${top name 2} ${top pid 2} ${top cpu 2} ${top mem 2}
${color lightgrey} ${top name 3} ${top pid 3} ${top cpu 3} ${top mem 3}
${color lightgrey} ${top name 4} ${top pid 4} ${top cpu 4} ${top mem 4}
necrosmash
Level 1
Level 1
 
Posts: 5
Joined: Wed Aug 04, 2010 7:44 am

Re: Odd Conky window behaviour on LXDE

Postby Habitual on Tue Mar 20, 2012 9:23 pm

This works here on a non-LM system.

Code: Select all
# Static and Variable Values used by Habitual

# Static Values
own_window yes
own_window_transparent yes
own_window_type override
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
use_xft yes
draw_outline no
draw_borders no
uppercase no
draw_shades no
draw_shades yes
double_buffer yes
border_width 0
text_buffer_size 2048
default_color white
update_interval 1.0

# Variable Values # These values are the ONLY thing that change from widget to widget
alignment tm
gap_x 00
gap_y 40
minimum_size 400 1
maximum_width 400

TEXT
${scroll 16 $nodename - $sysname $kernel on $machine | }
$hr
${color grey}Uptime:$color $uptime
${color grey}Frequency (in MHz):$color $freq
${color grey}Frequency (in GHz):$color $freq_g
${color grey}RAM Usage:$color $mem/$memmax - $memperc% ${membar 4}
${color grey}Swap Usage:$color $swap/$swapmax - $swapperc% ${swapbar 4}
${color grey}CPU Usage:$color $cpu% ${cpubar 4}
${color grey}Processes:$color $processes  ${color grey}Running:$color $running_processes
$hr
${color grey}File systems:
/ $color${fs_used /}/${fs_size /} ${fs_bar 6 /}
${color grey}Networking:
Up:$color ${upspeed eth0} ${color grey} - Down:$color ${downspeed eth0}
$hr
${color grey}Name  PID   CPU%   MEM%
${color lightgrey} ${top name 1} ${top pid 1} ${top cpu 1} ${top mem 1}
${color lightgrey} ${top name 2} ${top pid 2} ${top cpu 2} ${top mem 2}
${color lightgrey} ${top name 3} ${top pid 3} ${top cpu 3} ${top mem 3}
${color lightgrey} ${top name 4} ${top pid 4} ${top cpu 4} ${top mem 4}


I took everything you had above TEXT and replaced it with my own conky parameters.
I'll leave it to you to figure out where in your code you went wrong.

BTW: This is NOT an LXDE issue, it IS a conky coding issue.
The symptoms were present on my non-LM system as well, until I substituted my parameters for yours.
Works the same on my Arch Linux install also. No flakiness.

HTH.
What's a landing but a take off in reverse?
User avatar
Habitual
Level 8
Level 8
 
Posts: 2213
Joined: Sun Nov 21, 2010 8:31 pm
Location: LM17Q-Xfce

Re: Odd Conky window behaviour on LXDE

Postby necrosmash on Wed Mar 21, 2012 2:12 pm

Habitual wrote:BTW: This is NOT an LXDE issue, it IS a conky coding issue.
The symptoms were present on my non-LM system as well, until I substituted my parameters for yours.
Works the same on my Arch Linux install also. No flakiness.

I'm sorry, but I really don't think that the conky config file is the problem. My configuration was identical to the default config file (which worked fine), with the exception of two changed values. The code you provided has own_window_type set to override, so the effect is exactly the same as when I set it to override myself - Conky simply fails to show.

HOWEVER - setting own_window_type to override and then doing this:

Code: Select all
killall pcmanfm

causes Conky to work properly. I obviously have no Desktop icons, and the context menu is now Openbox's, but Conky now works 100% properly.

What, then, could I say that the problem is with? LXDE in general? Or just pcmanfm?
necrosmash
Level 1
Level 1
 
Posts: 5
Joined: Wed Aug 04, 2010 7:44 am

Re: Odd Conky window behaviour on LXDE

Postby Habitual on Wed Mar 21, 2012 3:19 pm

I had a very similar issue and I had to change a nautilus setting under Xfce...
...
Friday September 17 2010

Today I found out that if you use "own_window_type override" in your conky code and then use the Nautilus file manager, you are in a world of hurt.

I created a shortcut to bring up my Conky directory rapidly using "nautilus "/home/JJ/Documents/Conky" and ran it. Desktop blinked and xfce-panel disappeared. All Conky widgets (except one - Weather) gone and my whole life flashed before my eyes. All my work! Argh! my conky start|stop script (Thanks Bruce!) did nothing. I almost cried.

So I exited Xfce and logged back in selecting Gnome this time. Still no conky on my desktop. ps aux said it was running, as did htop. So I ran killall -9 conky and tried conky by itself. Nothing. confused, over?

Next I moved .conkyrc to conkyrc and tried conky again, aha! Progress! So I brought up my weather widget in gedit and looked at "own_window_type" and it read "own_window_type desktop", so I edited all my other widget to match that option and my hard work returned to my desktop.

Moral of the story if you use Nautilus and run conky...

own_window_type desktop
use nautilus with the --no-desktop option
...

Maybe pcmanfm has a similar option?

Anyone else?

Sorry, I didn't mean to blast LXDE or you.
I replied in haste and I apologize.

The desktop I almost "lost"...
</graphic>
Last edited by Habitual on Sat Apr 07, 2012 9:12 am, edited 1 time in total.
What's a landing but a take off in reverse?
User avatar
Habitual
Level 8
Level 8
 
Posts: 2213
Joined: Sun Nov 21, 2010 8:31 pm
Location: LM17Q-Xfce

Re: Odd Conky window behaviour on LXDE

Postby nerdtron on Sat Apr 07, 2012 5:45 am

I'm sorry, but I really don't think that the conky config file is the problem. My configuration was identical to the default config file (which worked fine), with the exception of two changed values. The code you provided has own_window_type set to override, so the effect is exactly the same as when I set it to override myself - Conky simply fails to show.

HOWEVER - setting own_window_type to override and then doing this:

Code: Select all
killall pcmanfm

causes Conky to work properly. I obviously have no Desktop icons, and the context menu is now Openbox's, but Conky now works 100% properly.

What, then, could I say that the problem is with? LXDE in general? Or just pcmanfm?


I did this too. I tried a lot of options and settings in the conkyrc file but so far this is the only option that resulted to a working conky on the LXDE desktop - but no desktop icons T_T.
Anyone successful in configuring conky in LXDE?
"I learned a lot from repeatedly breaking my system and then reinstalling. Oh, and a lot of GOOGLE searches too!"
User avatar
nerdtron
Level 4
Level 4
 
Posts: 316
Joined: Sun Jan 31, 2010 10:46 am

Re: Odd Conky window behaviour on LXDE

Postby fubs on Sat Jan 05, 2013 8:53 pm

Reviving this one, as I have exactly the same problem.

override - conky doesn't display at all
desktop - conky disappears as soon as I click the desktop

I've tried to run xfdesktop instead of pcmanfm --desktop,
with the same result.

I'm running conky with "own_window_type normal" thus far,
but beware of using the show desktop function (it disappears like any other window).

Anyone with an idea how to fix this (without killing the desktop)?
fubs
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 05, 2013 8:48 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 2 guests