How update ia32-libs & ia32-libs-gtk (transitional packets)

Questions about applications and software
Forum rules
Before you post please read this

How update ia32-libs & ia32-libs-gtk (transitional packets)

Postby hallergard on Fri Jan 04, 2013 7:54 am

Running a 64-bit system. Marking the above for update, suggests removing a dozen programs such as acroread, wine picasa & google-earth and installing many others. When accepting get the error message that they depend on the :i386 versions which are not available.
Adding i386 architecture and trying different repositories does not help:

root@DESKTOP:/# apt-get install ia32-libs-i386 ia32-libs-gtk-i386
.......
The following packages have unmet dependencies:
ia32-libs-gtk-i386:i386 : Depends: gtk2-engines-pixbuf:i386 (>= 2.20.1-2) but it is not going to be installed
Depends: gtk2-engines:i386 (>= 1:2.20.1-1) but it is not going to be installed
Depends: libcanberra-gtk-module:i386 (>= 0.24-1) but it is not going to be installed
Depends: libcanberra-gtk0:i386 (>= 0.24-1) but it is not going to be installed
Depends: libgail-common:i386 (>= 2.20.1-2) but it is not going to be installed
Depends: libgail18:i386 (>= 2.20.1-2) but it is not going to be installed
Depends: libgtk2.0-0:i386 (>= 2.20.1-2) but it is not going to be installed
Recommends: libbonobo2-0:i386 (>= 2.24.3-1) but it is not going to be installed
Recommends: libglade2-0:i386 (>= 1:2.6.4-1) but it is not going to be installed
Recommends: libgnomecanvas2-0:i386 (>= 2.30.1-1) but it is not going to be installed
Recommends: libidl0:i386 (>= 0.8.14-0.1) but it is not going to be installed
Recommends: liborbit2:i386 (>= 1:2.14.18-0.1) but it is not going to be installed
Recommends: libwmf0.2-7:i386 (>= 0.2.8.4-6.1+b1) but it is not going to be installed
ia32-libs-i386:i386 : Depends: libcups2:i386 (>= 1.4.4-7+squeeze1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What should I do to resolve this?
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am

Linux Mint is funded by ads and donations.
 

Re: How update ia32-libs & ia32-libs-gtk (transitional packe

Postby zerozero on Sun Jan 06, 2013 4:44 pm

multiarch deprecates ia32-libs.
now when you want to install a typical 32bits app (like the ones you mention above) you just install the app

here is the output showing that ia32-libs and ia32-libs-gtk are not installed in my system
Code: Select all
zerozero@deb-kde ~/Documents $ apt policy ia32-libs ia32-libs-gtk
ia32-libs:
  Installed: (none)
  Candidate: 1:0.4
  Version table:
     1:0.4 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
ia32-libs-gtk:
  Installed: (none)
  Candidate: 1:0.1
  Version table:
     1:0.1 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages

and here is the output showing the successful simulation of acroread installation
Code: Select all
 zerozero@deb-kde ~/Documents $ sudo apt-get -s install acroread
[sudo] password for zerozero:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libx264-128 most
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  acroread-data acroread-debian-files:i386 acroread-dictionary-en acroread-l10n-en cups-bsd
  gcc-4.7-base:i386 krb5-locales libatk1.0-0:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libc6:i386 libc6-i686:i386 libcairo2:i386
  libcomerr2:i386 libcups2:i386 libdatrie1:i386 libdbus-1-3:i386 libdrm-intel1:i386
  libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386 libexpat1:i386 libffi5:i386
  libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386
  libgdk-pixbuf2.0-0:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
  libglib2.0-0:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386
  libgssapi-krb5-2:i386 libgtk2.0-0:i386 libidn11:i386 libjasper1:i386 libjbig0:i386
  libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
  liblzma5:i386 libp11-kit0:i386 libpango1.0-0:i386 libpciaccess0:i386 libpcre3:i386
  libpixman-1-0:i386 libpng12-0:i386 libselinux1:i386 libstdc++6:i386 libtasn1-3:i386
  libthai0:i386 libtiff4:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386
  libxcb-render0:i386 libxcb-shm0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386
  libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386
  libxinerama1:i386 libxml2:i386 libxrandr2:i386 libxrender1:i386 libxxf86vm1:i386
  zlib1g:i386
Suggested packages:
  acroread-plugins:i386 mozilla-acroread:i386 acroread-l10n:i386 glibc-doc:i386
  locales:i386 rng-tools:i386 libglide3:i386 krb5-doc:i386 krb5-user:i386
  librsvg2-common:i386 gvfs:i386 libjasper-runtime:i386 ttf-baekmuk:i386
  ttf-arphic-gbsn00lp:i386 ttf-arphic-bsmi00lp:i386 ttf-arphic-gkai00mp:i386
  ttf-arphic-bkai00mp:i386
Recommended packages:
  cups-bsd:i386 mime-support:i386 acroread-dictionary-en:i386 acroread-dictionary:i386
  hicolor-icon-theme:i386 krb5-locales:i386 xml-core:i386
The following NEW packages will be installed:
  acroread:i386 acroread-data acroread-debian-files:i386 acroread-dictionary-en
  acroread-l10n-en cups-bsd gcc-4.7-base:i386 krb5-locales libatk1.0-0:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libc6:i386
  libc6-i686:i386 libcairo2:i386 libcomerr2:i386 libcups2:i386 libdatrie1:i386
  libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386
  libdrm2:i386 libexpat1:i386 libffi5:i386 libfontconfig1:i386 libfreetype6:i386
  libgcc1:i386 libgcrypt11:i386 libgdk-pixbuf2.0-0:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386 libgtk2.0-0:i386 libidn11:i386
  libjasper1:i386 libjbig0:i386 libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 liblzma5:i386 libp11-kit0:i386 libpango1.0-0:i386
  libpciaccess0:i386 libpcre3:i386 libpixman-1-0:i386 libpng12-0:i386 libselinux1:i386
  libstdc++6:i386 libtasn1-3:i386 libthai0:i386 libtiff4:i386 libx11-6:i386
  libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb-render0:i386 libxcb-shm0:i386
  libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
  libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386 libxml2:i386
  libxrandr2:i386 libxrender1:i386 libxxf86vm1:i386 zlib1g:i386
0 upgraded, 80 newly installed, 0 to remove and 0 not upgraded.
Inst gcc-4.7-base:i386 (4.7.2-4 Debian:testing [i386])
Inst libgcc1:i386 (1:4.7.2-4 Debian:testing [i386]) []
Inst libc6:i386 (2.13-37 Debian:testing [i386])
Inst libstdc++6:i386 (4.7.2-4 Debian:testing [i386])
Inst libcomerr2:i386 (1.42.5-1 Debian:testing [i386])
Inst liblzma5:i386 (5.1.1alpha+20120614-2 Debian:testing [i386])
Inst libselinux1:i386 (2.1.9-5 Debian:testing [i386])
Inst zlib1g:i386 (1:1.2.7.dfsg-13 Debian:testing [i386])
Inst libgpg-error0:i386 (1.10-3.1 Debian:testing [i386])
Inst libgcrypt11:i386 (1.5.0-3 Debian:testing [i386])
Inst libp11-kit0:i386 (0.12-3 Debian:testing [i386])
Inst libtasn1-3:i386 (2.13-2 Debian:testing [i386])
Inst libgnutls26:i386 (2.12.20-2 Debian:testing [i386])
Inst libkeyutils1:i386 (1.5.5-3 Debian:testing [i386])
Inst libkrb5support0:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Inst libk5crypto3:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Inst libkrb5-3:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Inst libgssapi-krb5-2:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Inst libidn11:i386 (1.25-2 Debian:testing [i386])
Inst libpcre3:i386 (1:8.30-5 Debian:testing [i386])
Inst libxml2:i386 (2.8.0+dfsg1-7 Debian:testing [i386])
Inst libffi5:i386 (3.0.10-3 Debian:testing [i386])
Inst libglib2.0-0:i386 (2.33.12+really2.32.4-3 Debian:testing [i386])
Inst libatk1.0-0:i386 (2.4.0-2 Debian:testing [i386])
Inst libavahi-common-data:i386 (0.6.31-1 Debian:testing [i386])
Inst libavahi-common3:i386 (0.6.31-1 Debian:testing [i386])
Inst libdbus-1-3:i386 (1.6.8-1 Debian:testing [i386])
Inst libavahi-client3:i386 (0.6.31-1 Debian:testing [i386])
Inst libexpat1:i386 (2.1.0-1 Debian:testing [i386])
Inst libfreetype6:i386 (2.4.9-1.1 Debian:testing [i386])
Inst libfontconfig1:i386 (2.9.0-7.1 Debian:testing [i386])
Inst libpixman-1-0:i386 (0.26.0-3 Debian:testing [i386])
Inst libpng12-0:i386 (1.2.49-1 Debian:testing [i386])
Inst libxau6:i386 (1:1.0.7-1 Debian:testing [i386])
Inst libxdmcp6:i386 (1:1.1.1-1 Debian:testing [i386])
Inst libxcb1:i386 (1.8.1-2 Debian:testing [i386])
Inst libx11-6:i386 (2:1.5.0-1 Debian:testing [i386])
Inst libxcb-render0:i386 (1.8.1-2 Debian:testing [i386])
Inst libxcb-shm0:i386 (1.8.1-2 Debian:testing [i386])
Inst libxrender1:i386 (1:0.9.7-1 Debian:testing [i386])
Inst libcairo2:i386 (1.12.2-2 Debian:testing [i386])
Inst libcups2:i386 (1.5.3-2.4 Debian:testing [i386])
Inst libdatrie1:i386 (0.2.5-3 Debian:testing [i386])
Inst libdrm2:i386 (2.4.33-3 Debian:testing [i386])
Inst libpciaccess0:i386 (0.13.1-2 Debian:testing [i386])
Inst libdrm-intel1:i386 (2.4.33-3 Debian:testing [i386])
Inst libdrm-nouveau1a:i386 (2.4.33-3 Debian:testing [i386])
Inst libdrm-radeon1:i386 (2.4.33-3 Debian:testing [i386])
Inst libjpeg8:i386 (8d-1 Debian:testing [i386])
Inst libjasper1:i386 (1.900.1-13 Debian:testing [i386])
Inst libjbig0:i386 (2.0-2 Debian:testing [i386])
Inst libtiff4:i386 (3.9.6-10 Debian:testing [i386])
Inst libgdk-pixbuf2.0-0:i386 (2.26.1-1 Debian:testing [i386])
Inst libglapi-mesa:i386 (8.0.5-3 Debian:testing [i386])
Inst libx11-xcb1:i386 (2:1.5.0-1 Debian:testing [i386])
Inst libxcb-glx0:i386 (1.8.1-2 Debian:testing [i386])
Inst libxfixes3:i386 (1:5.0-4 Debian:testing [i386])
Inst libxdamage1:i386 (1:1.1.3-2 Debian:testing [i386])
Inst libxext6:i386 (2:1.3.1-2 Debian:testing [i386])
Inst libxxf86vm1:i386 (1:1.1.2-1 Debian:testing [i386])
Inst libgl1-mesa-glx:i386 (8.0.5-3 Debian:testing [i386])
Inst libglu1-mesa:i386 (8.0.5-3 Debian:testing [i386])
Inst libthai0:i386 (0.1.18-2 Debian:testing [i386])
Inst libxft2:i386 (2.3.1-1 Debian:testing [i386])
Inst libpango1.0-0:i386 (1.30.0-1 Debian:testing [i386])
Inst libxcomposite1:i386 (1:0.4.3-2 Debian:testing [i386])
Inst libxcursor1:i386 (1:1.1.13-1 Debian:testing [i386])
Inst libxi6:i386 (2:1.6.1-1 Debian:testing [i386])
Inst libxinerama1:i386 (2:1.1.2-1 Debian:testing [i386])
Inst libxrandr2:i386 (2:1.3.2-2 Debian:testing [i386])
Inst libgtk2.0-0:i386 (2.24.10-2 Debian:testing [i386])
Conf gcc-4.7-base:i386 (4.7.2-4 Debian:testing [i386])
Conf libgcc1:i386 (1:4.7.2-4 Debian:testing [i386])
Conf libc6:i386 (2.13-37 Debian:testing [i386])
Inst libc6-i686:i386 (2.13-37 Debian:testing [i386])
Inst krb5-locales (1.10.1+dfsg-3 Debian:testing [all])
Inst acroread-l10n-en (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [all])
Inst acroread-debian-files:i386 (9.5.4 Unofficial Multimedia Packages:None/testing [i386]) []
Inst acroread-data (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [all]) []
Inst acroread:i386 (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [i386])
Inst acroread-dictionary-en (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [all])
Inst libgl1-mesa-dri:i386 (8.0.5-3 Debian:testing [i386])
Inst cups-bsd (1.5.3-2.4 Debian:testing [amd64])
Conf libstdc++6:i386 (4.7.2-4 Debian:testing [i386])
Conf libcomerr2:i386 (1.42.5-1 Debian:testing [i386])
Conf liblzma5:i386 (5.1.1alpha+20120614-2 Debian:testing [i386])
Conf libselinux1:i386 (2.1.9-5 Debian:testing [i386])
Conf zlib1g:i386 (1:1.2.7.dfsg-13 Debian:testing [i386])
Conf libgpg-error0:i386 (1.10-3.1 Debian:testing [i386])
Conf libgcrypt11:i386 (1.5.0-3 Debian:testing [i386])
Conf libp11-kit0:i386 (0.12-3 Debian:testing [i386])
Conf libtasn1-3:i386 (2.13-2 Debian:testing [i386])
Conf libgnutls26:i386 (2.12.20-2 Debian:testing [i386])
Conf libkeyutils1:i386 (1.5.5-3 Debian:testing [i386])
Conf libkrb5support0:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Conf libk5crypto3:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Conf libkrb5-3:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Conf libgssapi-krb5-2:i386 (1.10.1+dfsg-3 Debian:testing [i386])
Conf libidn11:i386 (1.25-2 Debian:testing [i386])
Conf libpcre3:i386 (1:8.30-5 Debian:testing [i386])
Conf libxml2:i386 (2.8.0+dfsg1-7 Debian:testing [i386])
Conf libffi5:i386 (3.0.10-3 Debian:testing [i386])
Conf libglib2.0-0:i386 (2.33.12+really2.32.4-3 Debian:testing [i386])
Conf libatk1.0-0:i386 (2.4.0-2 Debian:testing [i386])
Conf libavahi-common-data:i386 (0.6.31-1 Debian:testing [i386])
Conf libavahi-common3:i386 (0.6.31-1 Debian:testing [i386])
Conf libdbus-1-3:i386 (1.6.8-1 Debian:testing [i386])
Conf libavahi-client3:i386 (0.6.31-1 Debian:testing [i386])
Conf libexpat1:i386 (2.1.0-1 Debian:testing [i386])
Conf libfreetype6:i386 (2.4.9-1.1 Debian:testing [i386])
Conf libfontconfig1:i386 (2.9.0-7.1 Debian:testing [i386])
Conf libpixman-1-0:i386 (0.26.0-3 Debian:testing [i386])
Conf libpng12-0:i386 (1.2.49-1 Debian:testing [i386])
Conf libxau6:i386 (1:1.0.7-1 Debian:testing [i386])
Conf libxdmcp6:i386 (1:1.1.1-1 Debian:testing [i386])
Conf libxcb1:i386 (1.8.1-2 Debian:testing [i386])
Conf libx11-6:i386 (2:1.5.0-1 Debian:testing [i386])
Conf libxcb-render0:i386 (1.8.1-2 Debian:testing [i386])
Conf libxcb-shm0:i386 (1.8.1-2 Debian:testing [i386])
Conf libxrender1:i386 (1:0.9.7-1 Debian:testing [i386])
Conf libcairo2:i386 (1.12.2-2 Debian:testing [i386])
Conf libcups2:i386 (1.5.3-2.4 Debian:testing [i386])
Conf libdatrie1:i386 (0.2.5-3 Debian:testing [i386])
Conf libdrm2:i386 (2.4.33-3 Debian:testing [i386])
Conf libpciaccess0:i386 (0.13.1-2 Debian:testing [i386])
Conf libdrm-intel1:i386 (2.4.33-3 Debian:testing [i386])
Conf libdrm-nouveau1a:i386 (2.4.33-3 Debian:testing [i386])
Conf libdrm-radeon1:i386 (2.4.33-3 Debian:testing [i386])
Conf libjpeg8:i386 (8d-1 Debian:testing [i386])
Conf libjasper1:i386 (1.900.1-13 Debian:testing [i386])
Conf libjbig0:i386 (2.0-2 Debian:testing [i386])
Conf libtiff4:i386 (3.9.6-10 Debian:testing [i386])
Conf libgdk-pixbuf2.0-0:i386 (2.26.1-1 Debian:testing [i386])
Conf libglapi-mesa:i386 (8.0.5-3 Debian:testing [i386])
Conf libx11-xcb1:i386 (2:1.5.0-1 Debian:testing [i386])
Conf libxcb-glx0:i386 (1.8.1-2 Debian:testing [i386])
Conf libxfixes3:i386 (1:5.0-4 Debian:testing [i386])
Conf libxdamage1:i386 (1:1.1.3-2 Debian:testing [i386])
Conf libxext6:i386 (2:1.3.1-2 Debian:testing [i386])
Conf libxxf86vm1:i386 (1:1.1.2-1 Debian:testing [i386])
Conf libgl1-mesa-glx:i386 (8.0.5-3 Debian:testing [i386])
Conf libglu1-mesa:i386 (8.0.5-3 Debian:testing [i386])
Conf libthai0:i386 (0.1.18-2 Debian:testing [i386])
Conf libxft2:i386 (2.3.1-1 Debian:testing [i386])
Conf libpango1.0-0:i386 (1.30.0-1 Debian:testing [i386])
Conf libxcomposite1:i386 (1:0.4.3-2 Debian:testing [i386])
Conf libxcursor1:i386 (1:1.1.13-1 Debian:testing [i386])
Conf libxi6:i386 (2:1.6.1-1 Debian:testing [i386])
Conf libxinerama1:i386 (2:1.1.2-1 Debian:testing [i386])
Conf libxrandr2:i386 (2:1.3.2-2 Debian:testing [i386])
Conf libgtk2.0-0:i386 (2.24.10-2 Debian:testing [i386])
Conf libc6-i686:i386 (2.13-37 Debian:testing [i386])
Conf krb5-locales (1.10.1+dfsg-3 Debian:testing [all])
Conf acroread-l10n-en (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [all])
Conf acroread-data (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [all])
Conf acroread-debian-files:i386 (9.5.4 Unofficial Multimedia Packages:None/testing [i386])
Conf acroread:i386 (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [i386])
Conf acroread-dictionary-en (9.5.1-dmo7 Unofficial Multimedia Packages:None/testing [all])
Conf libgl1-mesa-dri:i386 (8.0.5-3 Debian:testing [i386])
Conf cups-bsd (1.5.3-2.4 Debian:testing [amd64])
zerozero@deb-kde ~/Documents $
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Re: How update ia32-libs & ia32-libs-gtk (transitional packe

Postby hallergard on Sun Jan 06, 2013 4:48 pm

Marking ia32-libs and ia32-libs-gtk for update in Synaptic gives lists of some files to be removed and many files to be updated. Okaying gives error message to the effect that this cannot be done. So first I removed all programs suggested to be removed: wine, acroread, picasa, googleearth,python-gnome2, python-pyorbit and system-config-printer. Again marked ia32-libs and ia32-libs-gtk for update which gave a new list for files to be removed. And again and again. Then installed with apt-get those suggested to be installed, using :i386. Marking ia32-libs and ia32-libs-gtk again and no suggestions, so I deleted these files and hoped for everything being okay.

Reinstalled wine1.4:i386 without problems, but got stuck on acroread which gave an error message re libcups2. Undeleted libcups2 and then installed libcups2 i386 and amd64 using the same version. Now I could install acroread. (noted that libgtk2.0-0 had been updated - which I think might have been the problem all along). Have not yet assessed the damage done to other programs.
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am

Re: How update ia32-libs & ia32-libs-gtk (transitional packe

Postby zerozero on Sun Jan 06, 2013 4:59 pm

you don't need ia32-libs (see my post above)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Re: How update ia32-libs & ia32-libs-gtk (transitional packe

Postby hallergard on Sun Jan 06, 2013 6:03 pm

Our posts crossed. Yes, you are right. Thanks!
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am

Re: How update ia32-libs & ia32-libs-gtk (transitional packe

Postby hallergard on Mon Jan 07, 2013 9:36 am

Yes, it is easier to just delete ia32-libs and ia32-libs-gtk and take it from there after installing the i386 architecture. I actually did this in December, but got stuck with
apt-get install acroread:i386
E: Package 'acroread:i386' has no installation candidate
and after downloading it myself
dpkg: dependency problems prevent configuration of adobereader-enu:
adobereader-enu depends on libgtk2.0-0 (>= 2.4)
I gave up then as I also had some other problems like the browsers with libpango. Since then I became aware of zerozero's suggestion in thread 113872:
Code: Select all
mint-choose-debian-mirror
apt-get update && apt-get dist-upgrade
This got me a bit further. I now went back and followed zerozero's suggestion by just deleting ia32-libs and ia32-libs-gtk and taking it from there. Alas not all the way. Cutting a long story short:

In August I had problems with my Kodak printer and then installed cups from SID or Experimental, think is was version 1.5.3-4:amd64. Now this blocked installing libcups2:i386 (ver 1.5.3-2.4) needed for libgtk2.0-0:386, which was needed for adobereader-enu:i386 which in turn was needed for acroread:i386. So after uninstalling libcups2-1.5.23-4:amd64 it was possible to install acroread. Then re-installed wine (and had to reinstall pulse for some reason), but was not able to re-install picasa and googleearth. By copying /opt/google/picasa and /opt/google/earth from my Kubuntu partition they are working again "incognito". Still have AdobeAir to sort out.
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am

Re: How update ia32-libs & ia32-libs-gtk (transitional packe

Postby caerolle on Mon Jan 07, 2013 11:23 am

I use ia32-multiarch to run 32-bit programs. Now even this says it is transitional, so I am not surprised the older ia32's are not working.
caerolle
Level 3
Level 3
 
Posts: 143
Joined: Sun Aug 26, 2012 3:50 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests