Has Mint 12 already hit EOL, or is my Apt borked?

Questions about the project and the distribution - obviously no support questions here please

Has Mint 12 already hit EOL, or is my Apt borked?

Postby KevinM1 on Wed Jan 02, 2013 10:07 pm

I can't seem to connect to either the Lisa or Ubuntu Oneiric repos via Apt. The dotdeb repo works fine, however. Was Lisa stealth killed before the announced April cutoff, or is my Apt having a problem? I double-checked to make sure the old universe/multiverse bug wasn't the culprit.
KevinM1
Level 1
Level 1
 
Posts: 34
Joined: Tue Dec 15, 2009 1:16 pm

Linux Mint is funded by ads and donations.
 

Re: Has Mint 12 already hit EOL, or is my Apt borked?

Postby caf4926 on Wed Jan 02, 2013 11:23 pm

EOL for 12 is April 2013
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1746
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Has Mint 12 already hit EOL, or is my Apt borked?

Postby cwwgateway on Thu Jan 03, 2013 8:56 pm

Yeah, if there is any problem, I doubt it's on Mint/Ubuntu's end, especially considering the Mint repos stay up for a small amount of time after the EOL. If either were to stop support early, then they would have notified users somehow.

Edit: I would reboot to see what happens, but otherwise, could you provide the output of putting the following into a terminal:
Code: Select all
inxi -r
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: Has Mint 12 already hit EOL, or is my Apt borked?

Postby KevinM1 on Sun Jan 06, 2013 12:03 pm

cwwgateway wrote:Yeah, if there is any problem, I doubt it's on Mint/Ubuntu's end, especially considering the Mint repos stay up for a small amount of time after the EOL. If either were to stop support early, then they would have notified users somehow.

Edit: I would reboot to see what happens, but otherwise, could you provide the output of putting the following into a terminal:
Code: Select all
inxi -r


Sorry for the delay, in response. Haven't had a chance to go onn my dev machine until now.

Output:

Code: Select all
$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ lisa upstream import main
           deb http://archive.ubuntu.com/ubuntu/ oneiric main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ oneiric-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ oneiric-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ oneiric partner
           deb http://packages.medibuntu.org/ oneiric free non-free
           deb http://packages.dotdeb.org squeeze all
           deb-src http://packages.dotdeb.org squeeze all
           deb http://packages.dotdeb.org squeeze-php54 all
           deb-src http://packages.dotdeb.org squeeze-php54 all


EDIT: Here are the errors I receive after running apt-get update:

Code: Select all
Err http://packages.linuxmint.com lisa/upstream amd64 Packages
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/import amd64 Packages
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/main amd64 Packages
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/upstream i386 Packages
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/import i386 Packages
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/main i386 Packages
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/import Translation-en_US
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/import Translation-en
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/main Translation-en_US
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/main Translation-en
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/upstream Translation-en_US
  Unable to connect to packages.linuxmint.com:http:
Err http://packages.linuxmint.com lisa/upstream Translation-en
  Unable to connect to packages.linuxmint.com:http:
Fetched 17.9 kB in 3min 37s (82 B/s)
W: Failed to fetch http://packages.linuxmint.com/dists/lisa/upstream/binary-amd64/Packages  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/import/binary-amd64/Packages  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/main/binary-amd64/Packages  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/upstream/binary-i386/Packages  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/import/binary-i386/Packages  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/main/binary-i386/Packages  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/import/i18n/Translation-en_US  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/import/i18n/Translation-en  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/main/i18n/Translation-en_US  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/main/i18n/Translation-en  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/upstream/i18n/Translation-en_US  Unable to connect to packages.linuxmint.com:http:

W: Failed to fetch http://packages.linuxmint.com/dists/lisa/upstream/i18n/Translation-en  Unable to connect to packages.linuxmint.com:http:

E: Some index files failed to download. They have been ignored, or old ones used instead.
KevinM1
Level 1
Level 1
 
Posts: 34
Joined: Tue Dec 15, 2009 1:16 pm

Re: Has Mint 12 already hit EOL, or is my Apt borked?

Postby abnvolk on Sun Jan 06, 2013 12:51 pm

Sometimes the main Mint server is quite slow and make apt fail to download, so you should choose a mirror. Go to Software Sources -> Download from -> Select best server, and it will choose the fastest server for you :)
abnvolk
Level 4
Level 4
 
Posts: 495
Joined: Thu May 10, 2012 11:05 am

Re: Has Mint 12 already hit EOL, or is my Apt borked?

Postby cwwgateway on Sun Jan 06, 2013 3:06 pm

Yes, if it is only the mint repos that aren't working (which is what it appears to be), then it is simply that they are down (they have been very pressed since the release of LMDE UP 6).
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: Has Mint 12 already hit EOL, or is my Apt borked?

Postby karlchen on Sun Jan 06, 2013 5:40 pm

Hello, KevinM1.

In addition to what has already been explained in this thread, let me add:

I can confirm that searching for updates and installing them on Mint 12 "Lisa" still works fine. All you have to do is replace the main server (packages.linuxmint.com) by a mirror server close to your geographical location.
abnvolk has explained how to so a few posts above mine.
Ever since I replaced packages.linuxmint.com by a local mirror around XMas, no more connection errors have occurred.

With respect to the upcoming EOL, it is noticeable that the development of Mint 12 has significantly slowed down. Updates have become scarce. Lisa's days are running out ...

So, the answers to your questions that you asked in your thread title are:
+ Lisa is still alive. (Has been confirmed before.)
+ Your apt packages or configuration are very likely not borked.

Kind regards,
Karl
Image
Enlightened by Lucid Lynx, enchanted by Maya, impressed by Petra.
User avatar
karlchen
Level 9
Level 9
 
Posts: 2520
Joined: Sat Dec 31, 2011 7:21 am

Linux Mint is funded by ads and donations.
 

Return to Non-technical Questions

Who is online

Users browsing this forum: cobratek and 5 guests