Difficulties with Nvida CUDA driver MINT13 MATE Kernel 3.6.6

Questions about applications and software
Forum rules
Before you post please read this

Difficulties with Nvida CUDA driver MINT13 MATE Kernel 3.6.6

Postby lemitech on Mon Jan 07, 2013 10:15 am

Hello everybody,

please excuse my quiet bad English :? .

Today I faced several problems with the nvidia grafic-driver, after updating and rebooting my workstation. The actually "installed" driver version is 310 in combination with the CUDA toolkits. Everything worked fine until today. After a hardware reboot I didn't got any kind of login-screen anymore. By looking on the display LED's I saw that there is no signal from the grafic-card. We faced a similar problem in the past so I connected one of my displays via the DVI-link (two equal displays are connected via display-port). The display connected via DVI is now working without any problems.

In the past there have been some problems with the display configuration so I've had to reconfigure the displays via the driver-mangament tool (X Server Settings). But when I opened the manager today, I received the following message:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.


When I try to run the xconfig as root, terminal responds me with a message that he can't find the nvidia-xconfig. So I tried to reconfigure the kernel via nvidia-kernel-dkms but with the same result, the terminal can't find the command. I also tried to reinstall the appropriate pakages via apt-get what lead to the following:

apt install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package nvidia-glx is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source



After searching in several boards I couldn't find a working solution. I hope anybody can help me, because I fear that a "simple" re-install of the driver will cause more problems than it solves.

System description:
Fujitsu R570-2 Workstation (Dual Xenon, Nvidia Quadro 4800)
Mint 13 MATE with updated Kernel (Version 3.6.6) and MATE 1.4
Nvidia CUDA driver kit 310


Thank you all
lemitech
Level 1
Level 1
 
Posts: 1
Joined: Mon Jan 07, 2013 9:48 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: emtea and 19 guests