Debian Plymouth Manager - Help needed

Questions about applications and software
Forum rules
Before you post please read this

Re: Debian Plymouth Manager - Help needed

Postby cwwgateway on Sun Jan 06, 2013 3:05 pm

Schoelje wrote:
cwwgateway wrote:I tested DPM on my laptop which is using bumblebee for hybrid graphics. The plymouth theme worked fine, but for some reason dpm got stuck with something to do with the intel driver, and I had to close dpm to get it to finish running update-grub, and the initramfs stuff.

You had to close DPM, but DPM finished none the less?

Yes. After closing DPM (clicking the "x"), in the terminal it ran update-grub and whatever the command is for updating initramfs.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Linux Mint is funded by ads and donations.
 

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Sun Jan 06, 2013 3:32 pm

cwwgateway wrote:Yes. After closing DPM (clicking the "x"), in the terminal it ran update-grub and whatever the command is for updating initramfs.

As if it was waiting for user input...

Could you check something for me?
Code: Select all
sudo apt-get install debconf-utils
sudo debconf-get-selections | grep intel > debconf-intel.seed

and post here whatever is written to debconf-intel.seed.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby jjaythomas on Tue Jan 08, 2013 2:18 am

using beta lmde-xfce

joy theme seem to lock if try in800-600 res (need force quit 'DPM' and retart others seem to not work at all or only certain listed resolutions (upstream problem?)

other themes seem to install but I must force-quit window and restart 'DPM' to use theme. Can't backtrack from install to theme mode (make sense :roll: )

J.Jay
P.S. solar, spacefun, mint-xfce(default) seem to always work. :)
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Tue Jan 08, 2013 3:27 am

jjaythomas wrote:P.S. solar, spacefun, mint-xfce(default) seem to always work. :)

Unfortunately, it's always trial and error with these themes. I think they were created a while ago and weren't thoroughly tested.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby jjaythomas on Tue Jan 08, 2013 6:56 pm

Thin the grub mode looks a little bare

Could their be option to change grub background and the grub timeout. Their both a easy changes/edits of config 'grub' file?

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Tue Jan 08, 2013 7:08 pm

jjaythomas wrote:Thin the grub mode looks a little bare

Could their be option to change grub background and the grub timeout. Their both a easy changes/edits of config 'grub' file?

J.Jay


Programmatically they are easy changes, but because I am the only developer at the moment working on DPM (or DDM for that matter) It doesn't have my highest priority. Let's say, it's on my wish-list. Just as improving DDM, a complete rework of live-installer, adapting Alacarte, re-designing LMDE KDE and LMDE Xfce, build a site that suits the OS's, find one or more SP's to host a repository and iso's, spend quality time with my family and friends, and so on, and so on.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby jjaythomas on Tue Jan 08, 2013 7:18 pm

Programmatically they are easy changes, but because I am the only developer at the moment working on DPM (or DDM for that matter) It doesn't have my highest priority. Let's say, it's on my wish-list. Just as improving DDM, a complete rework of live-installer, adapting Alacarte, re-designing LMDE KDE and LMDE Xfce, build a site that suits the OS's, find one or more SP's to host a repository and iso's, spend quality time with my family and friends, and so on, and so on.

Totally understand...
Just like to thank you for everything
wish I could do more beside testing and pointing out obvious things but I not a programer (or IT anything) Im a factory working(semi retired) 'OLDFART, :lol:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Tue Jan 08, 2013 7:25 pm

semi-retired...sounds good
old fart...know the feeling
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby jjaythomas on Tue Jan 08, 2013 7:48 pm

semi-retired...sounds good
old fart...know the feeling
:lol: :mrgreen:
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Debian Plymouth Manager - Help needed

Postby dcihon on Sat Jan 12, 2013 10:46 am

Schoelje,
Trying to run dpm on this machine for the first time.
Not working attached is my log file.
The forum wouldn't let me attach a .log file so I had to rename it .doc
Thanks
Dan
Attachments
dpm.doc
(2.12 KiB) Downloaded 42 times
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Sat Jan 12, 2013 11:23 am

dcihon wrote:Schoelje,
Trying to run dpm on this machine for the first time.
Not working attached is my log file.
The forum wouldn't let me attach a .log file so I had to rename it .doc
Thanks
Dan


In the log file you can see the following line:
Neither grub nor burg found in /etc/default

Can you verify there is a grub or burg file in /etc/default?
DPM needs grub or burg to configure Plymouth.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby dcihon on Sat Jan 12, 2013 12:01 pm

Doesn't look like it.
How do I get it?
Code: Select all
dcihon@dcihon-linux-mint-debian:/etc/default$ ls
acpid         bluetooth      cron        devpts         halt     intel-microcode      nss       pulseaudio    samba              useradd
alsa          bsdmainutils   cryptdisks  dirmngr        hddtemp  kdm.d                ntfs-3g   rcS           saned              winbind
alsa-base     cacerts        cups        exim4          hdparm   keyboard             numlockx  rcS.dpkg-old  speech-dispatcher
anacron       console-setup  dbus        google-chrome  htdig    locale               openvpn   rsync         tmpfs
avahi-daemon  crda           debsums     gpsd           hwclock  logitechmediaserver  portmap   rsyslog       ufw
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Sat Jan 12, 2013 12:51 pm

dcihon wrote:Doesn't look like it.
How do I get it?
Code: Select all
dcihon@dcihon-linux-mint-debian:/etc/default$ ls
acpid         bluetooth      cron        devpts         halt     intel-microcode      nss       pulseaudio    samba              useradd
alsa          bsdmainutils   cryptdisks  dirmngr        hddtemp  kdm.d                ntfs-3g   rcS           saned              winbind
alsa-base     cacerts        cups        exim4          hdparm   keyboard             numlockx  rcS.dpkg-old  speech-dispatcher
anacron       console-setup  dbus        google-chrome  htdig    locale               openvpn   rsync         tmpfs
avahi-daemon  crda           debsums     gpsd           hwclock  logitechmediaserver  portmap   rsyslog       ufw


Code: Select all
sudo apt-get install grub

This should create an initial /etc/default/grub file
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby dcihon on Sat Jan 12, 2013 1:08 pm

I did this but I don't understand and it doesn't look like it did what you wanted it to do:
Code: Select all
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get install grub
[sudo] password for dcihon:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'grub-legacy' instead of 'grub'
Suggested packages:
  grub-legacy-doc multiboot mdadm
The following NEW packages will be installed:
  grub-legacy
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 925 kB of archives.
After this operation, 1,874 kB of additional disk space will be used.
Get:1 http://http.us.debian.org/debian/ unstable/main grub-legacy amd64 0.97-66.1 [925 kB]
Fetched 925 kB in 1s (694 kB/s)     
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Selecting previously unselected package grub-legacy.
(Reading database ... 309626 files and directories currently installed.)
Unpacking grub-legacy (from .../grub-legacy_0.97-66.1_amd64.deb) ...
Processing triggers for man-db ...
Setting up grub-legacy (0.97-66.1) ...
dcihon@dcihon-linux-mint-debian:/etc/default$ ls
acpid         bluetooth      cron        devpts         halt     intel-microcode      nss       pulseaudio    samba              useradd
alsa          bsdmainutils   cryptdisks  dirmngr        hddtemp  kdm.d                ntfs-3g   rcS           saned              winbind
alsa-base     cacerts        cups        exim4          hdparm   keyboard             numlockx  rcS.dpkg-old  speech-dispatcher
anacron       console-setup  dbus        google-chrome  htdig    locale               openvpn   rsync         tmpfs
avahi-daemon  crda           debsums     gpsd           hwclock  logitechmediaserver  portmap   rsyslog       ufw
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Sat Jan 12, 2013 1:57 pm

I don't understand why it's installing grub-legacy instead of grub2.
I see that you're running liquorix.
DPM has only been tested with Linux Mint and Ubuntu and all with standard settings.

What are you running?
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby dcihon on Sat Jan 12, 2013 2:00 pm

System: Host: dcihon-linux-mint-debian Kernel: 3.6.0-4.dmz.1-liquorix-amd64 x86_64 (64 bit)
Desktop: KDE 4.8.4 Distro: LinuxMint 1 debian
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Sat Jan 12, 2013 2:10 pm

dcihon wrote:System: Host: dcihon-linux-mint-debian Kernel: 3.6.0-4.dmz.1-liquorix-amd64 x86_64 (64 bit)
Desktop: KDE 4.8.4 Distro: LinuxMint 1 debian


LinuxMint 1 debian should already have grub installed (with /etc/default/grub).

Could you return the output of:
Code: Select all
apt search grub | grep ^i
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby dcihon on Sat Jan 12, 2013 2:12 pm

dcihon@dcihon-linux-mint-debian:/etc/default$ apt search grub | grep ^i
i grub-common - GRand Unified Bootloader (common files)
i grub-legacy - GRand Unified Bootloader (Legacy version)
i grub-pc-bin - GRand Unified Bootloader, version 2 (PC/BI
i grub2-theme-mint - Grub2 theme for Linux Mint
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: Debian Plymouth Manager - Help needed

Postby Schoelje on Sat Jan 12, 2013 2:20 pm

Mine looks like this:
Code: Select all
apt search grub | grep ^i
i   grub                            - GRand Unified Bootloader (dummy package) 
i   grub-common                     - GRand Unified Bootloader (common files)   
i   grub-pc                         - GRand Unified Bootloader, version 2 (PC/BI
i   grub-pc-bin                     - GRand Unified Bootloader, version 2 (PC/BI
i   grub2-common                    - GRand Unified Bootloader (common files for
iB  grub2-theme-lmdekde             - Grub2 theme for LMDE KDE 


Try this:
Code: Select all
sudo apt-get purge grub-legacy
sudo apt-get install grub2-common

and to be sure:
Code: Select all
sudo grub-update

Now, check if /etc/default/grub exists
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: Debian Plymouth Manager - Help needed

Postby dcihon on Sat Jan 12, 2013 2:39 pm

Looks like I may have things not installed correctly:
I've included everything I did:
Code: Select all
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get purge grub-legacy
[sudo] password for dcihon:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  grub-legacy*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 1,874 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 309673 files and directories currently installed.)
Removing grub-legacy ...
Purging configuration files for grub-legacy ...
Processing triggers for man-db ...
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get install grub2-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 grub2-common : Depends: grub-common (= 1.99-26)
E: Unable to correct problems, you have held broken packages.
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get install ^C
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get install grub2-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 grub2-common : Depends: grub-common (= 1.99-26)
E: Unable to correct problems, you have held broken packages.
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get install grub-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
grub-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get purge grub-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  grub-common* grub-pc-bin*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 8,180 kB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get purge grub2-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'grub2-common' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get purge grub-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  grub-common* grub-pc-bin*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 8,180 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 309625 files and directories currently installed.)
Removing grub-pc-bin ...
Removing grub-common ...
Purging configuration files for grub-common ...
Processing triggers for man-db ...
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get install grub2-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  grub-common
Suggested packages:
  multiboot-doc grub-emu xorriso
The following NEW packages will be installed:
  grub-common grub2-common
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,648 kB of archives.
After this operation, 5,632 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://http.us.debian.org/debian/ unstable/main grub-common amd64 1.99-26 [1,553 kB]
Get:2 http://http.us.debian.org/debian/ unstable/main grub2-common amd64 1.99-26 [94.3 kB]
Fetched 1,648 kB in 2s (691 kB/s)     
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
serious bugs of grub-common (-> 1.99-26) <marked as done in some version>
 #686351 - /usr/sbin/grub-probe: grub-probe : erreur :  no such disk. (Fixed: os-prober/1.57 grub2/2.00-7)
   Merged with: 673573 680084
Summary:
 grub-common(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...] y
Selecting previously unselected package grub-common.
(Reading database ... 309330 files and directories currently installed.)
Unpacking grub-common (from .../grub-common_1.99-26_amd64.deb) ...
Selecting previously unselected package grub2-common.
Unpacking grub2-common (from .../grub2-common_1.99-26_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for install-info ...
Setting up grub-common (1.99-26) ...
Setting up grub2-common (1.99-26) ...
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo grub-update
sudo: grub-update: command not found
dcihon@dcihon-linux-mint-debian:/etc/default$ sudo apt-get install grub-update
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package grub-update
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Software & Applications

Who is online

Users browsing this forum: chadwilliam1 and 14 guests